Pagina 2 di 2 PrimoPrimo 12
Mostra risultati da 11 a 17 di 17

Discussione: avvio automatico con systemd (ex initscript)

  1. #11
    Data registrazione
    Jan 2010
    Sesso
    Uomo
    Messaggi
    17,013
    Grazie dati 
    4,802
    Grazie ricevuti 
    2,588
    Ringraziato in
    2,187 post

    Riferimento: avvio automatico con systemd (ex initscript)

    Ma devo inventarlo il pid?
    Perché quello di "in.proftpd" cambia ogni volta.
    Comunque non sta già funzionando, perché finché non lo butto su a mano, "ftp://localhost" non risponde.
    «Nessuna quantità di esperimenti potrà dimostrare che ho ragione;
    un unico esperimento potrà dimostrare che ho sbagliato.
    » (A. Einstein)

    Rispondi citando Rispondi citando Il mio PC

  2. # ADS
    Google Adsense Circuito Adsense
    Data registrazione
    da sempre
    Messaggi
    molti
     
  3. #12
    Data registrazione
    Jan 2010
    Sesso
    Uomo
    Località
    Nel mondo degli svarioni
    Messaggi
    1,403
    Grazie dati 
    149
    Grazie ricevuti 
    471
    Ringraziato in
    421 post

    Riferimento: avvio automatico con systemd (ex initscript)

    Il pidfile, non il pid è un file (solitamente in /run) in cui il demone scrive il proprio pid, così sai dove andarlo a cercare. Dovresti trovare un riferimento nel file di configurazione.

    Alla peggio nel service file lo lanci con -n e Type=simple, anche se è una porcata.

    Rispondi citando Rispondi citando Il mio PC

  4. #13
    Data registrazione
    Jan 2010
    Sesso
    Uomo
    Messaggi
    17,013
    Grazie dati 
    4,802
    Grazie ricevuti 
    2,588
    Ringraziato in
    2,187 post

    Riferimento: avvio automatico con systemd (ex initscript)

    Ho visto che i pidfile in /run sono semplicemente file di testo con un pid scritto dentro.
    Ho inserito quell'opzione nel service e poi ho creato il file a cui punta con nano.

    Però non cambia nulla, tra l'altro mi sa che il processo non sale proprio, ho lanciato su un altro terminale un while che fa `ps -A | grep ftp` a ripetizione e poi provato ad avviare il servizio e non sputa niente. (altrimenti avviandolo a mano lo sputa appena parte).

    Domani provo con il Type.

    «Nessuna quantità di esperimenti potrà dimostrare che ho ragione;
    un unico esperimento potrà dimostrare che ho sbagliato.
    » (A. Einstein)

    Rispondi citando Rispondi citando Il mio PC

  5. #14
    Data registrazione
    Jan 2010
    Sesso
    Uomo
    Messaggi
    17,013
    Grazie dati 
    4,802
    Grazie ricevuti 
    2,588
    Ringraziato in
    2,187 post

    Riferimento: avvio automatico con systemd (ex initscript)



    Alla peggio nel service file lo lanci con -n e Type=simple, anche se è una porcata.
    Ho provato, pare che funzioni, dopo vedo se parte anche allo start-up.

    Che problemi potrei avere rispetto all'uso classico con il demone?
    «Nessuna quantità di esperimenti potrà dimostrare che ho ragione;
    un unico esperimento potrà dimostrare che ho sbagliato.
    » (A. Einstein)

    Rispondi citando Rispondi citando Il mio PC

  6. #15
    Data registrazione
    Jan 2010
    Sesso
    Uomo
    Località
    Nel mondo degli svarioni
    Messaggi
    1,403
    Grazie dati 
    149
    Grazie ricevuti 
    471
    Ringraziato in
    421 post

    Riferimento: avvio automatico con systemd (ex initscript)

    Nessuno, sono modi diversi per fare la stessa cosa. Di solito i demoni si usano con type=forking (il fatto che non fosse specificato il type effettivamente poteva essere la causa del problema )

    Rispondi citando Rispondi citando Il mio PC

  7. #16
    Data registrazione
    Jan 2010
    Sesso
    Uomo
    Messaggi
    17,013
    Grazie dati 
    4,802
    Grazie ricevuti 
    2,588
    Ringraziato in
    2,187 post

    Riferimento: avvio automatico con systemd (ex initscript)



    Allora perché hai detto che è una "porcata"?
    «Nessuna quantità di esperimenti potrà dimostrare che ho ragione;
    un unico esperimento potrà dimostrare che ho sbagliato.
    » (A. Einstein)

    Rispondi citando Rispondi citando Il mio PC

  8. #17
    Data registrazione
    Jan 2010
    Sesso
    Uomo
    Località
    Nel mondo degli svarioni
    Messaggi
    1,403
    Grazie dati 
    149
    Grazie ricevuti 
    471
    Ringraziato in
    421 post

    Riferimento: avvio automatico con systemd (ex initscript)

    Perché non si è mai visto un demone che non va in background da solo

    Rispondi citando Rispondi citando Il mio PC

Segnalibri

Regole di scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •  
Cookies:direttiva 2009/136/CE (E-Privacy)

Il sito utilizza cookies propri e di terze parti per maggiori informazioni faq - Termini di servizio - Cookies
Il forum non puo' funzionare senza l'uso dei cookies pertanto l'uso della community è vincolato dall'accettazione degli stessi, nel caso contrario siete pregati di lasciare la community, proseguendo la navigazione acconsenti all’uso dei cookie