Pagina 1 di 2 12 UltimoUltimo
Mostra risultati da 1 a 10 di 20

Discussione: Non sale xorg

  1. #1
    Data registrazione
    Jan 2010
    Sesso
    Uomo
    Messaggi
    17,013
    Grazie dati 
    4,802
    Grazie ricevuti 
    2,588
    Ringraziato in
    2,187 post

    Non sale xorg



    Sarà un caso, ma è la seconda volta in cosa? un mese?

    Oggi volevo avviare ubuntu e mi ritrovo con il login da tty... evvai!! Vado di startx e mi ritrovo con una sfilza di errori che non posso neanche vedere tutti, tranne il riferimento al log di xorg, che a sua volta fa riferimento al systemlog.

    Allego quindi i due log, sperando che voi sappiate cavarci qualcosa, mentre l'output di startx è più lungo dello schermo, e non risulta possibile ridirezionarlo in un file di testo.
    Sicuramente ci sarà qualche sistema tipo il /p di win, ma non lo conosco.
    File allegati File allegati
    «Nessuna quantità di esperimenti potrà dimostrare che ho ragione;
    un unico esperimento potrà dimostrare che ho sbagliato.
    » (A. Einstein)

    Rispondi citando Rispondi citando Il mio PC

  2. # ADS
    Google Adsense Circuito Adsense
    Data registrazione
    da sempre
    Messaggi
    molti
     
  3. #2
    Data registrazione
    Jan 2010
    Sesso
    Uomo
    Località
    /dev/null
    Messaggi
    830
    Grazie dati 
    132
    Grazie ricevuti 
    426
    Ringraziato in
    341 post

    Riferimento: Non sale xorg

    Sarà un caso, ma è la seconda volta in cosa? un mese?
    No, che Xorg dia problemi è cosa comune

    Comunque sembra quasi che manchino i pacchetti dei driver e abbiano aggiornato il kernel senza aggiornare i driver nvidia. Prova a reinstallarli.

    Rispondi citando Rispondi citando

  4. #3
    Data registrazione
    Jan 2010
    Sesso
    Uomo
    Messaggi
    17,013
    Grazie dati 
    4,802
    Grazie ricevuti 
    2,588
    Ringraziato in
    2,187 post

    Riferimento: Non sale xorg



    In effetti il pacchetto mancava... non solo quello però.
    Dopo aver provato ad installare nvidia current non ha risolto, però avendo intravisto degli errori in fase di installazione ho provato a levarlo per vedere se riuscivo a leggerli... a questo punto insieme alla rimozione del driver mi ha trovato tutta una sfilza di pacchetti da installare e dopo di che startx è partito con i noveau (o quelli che sono)... salvo essersi loggato come root...

    Codice:
    Only registered members can view code.
    Ora vedo che fa dopo il riavvio... però sarebbe meglio se funzionassero i driver nvidia (così non posso neanche settare a 2mpx)... tra i disponibili vedo ancora i current, i 173 (che mi pare davano problemi) e gli experimentals.

    -------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

    edit:
    ora arriva alla schermata di log-in, però non fa il log-in automatico e una volta inserita la password da alcuni errori talmente veloci da non poter essere letti e torna alla schermata di log-in.
    Ultima modifica di Andy86; 11-04-13 alle 18: 39.
    «Nessuna quantità di esperimenti potrà dimostrare che ho ragione;
    un unico esperimento potrà dimostrare che ho sbagliato.
    » (A. Einstein)

    Rispondi citando Rispondi citando Il mio PC

  5. #4
    Data registrazione
    Jan 2010
    Sesso
    Uomo
    Messaggi
    17,013
    Grazie dati 
    4,802
    Grazie ricevuti 
    2,588
    Ringraziato in
    2,187 post

    Riferimento: Non sale xorg



    Avevo sottovalutato il fatto che partendo dallo startx mi si era loggato come root... c'era un bell'elenco di file con il proprietario cambiato, una bella passata di chown e via... interfaccia grafica ripartita, salvo essersi volatilizzato il profilo di firefox... (meno male che c'è sync).

    Ora però c'è da provare a rimettere il driver nvidia... e se poi da ancora lo stesso problema?
    «Nessuna quantità di esperimenti potrà dimostrare che ho ragione;
    un unico esperimento potrà dimostrare che ho sbagliato.
    » (A. Einstein)

    Rispondi citando Rispondi citando Il mio PC

  6. #5
    Data registrazione
    Jan 2010
    Sesso
    Uomo
    Località
    Nel mondo degli svarioni
    Messaggi
    1,403
    Grazie dati 
    149
    Grazie ricevuti 
    471
    Ringraziato in
    421 post

    Riferimento: Non sale xorg

    Se dà lo stesso problema li rimuovi e riparti con i nouveau

    Rispondi citando Rispondi citando Il mio PC

  7. #6
    Data registrazione
    Jan 2010
    Sesso
    Uomo
    Messaggi
    17,013
    Grazie dati 
    4,802
    Grazie ricevuti 
    2,588
    Ringraziato in
    2,187 post

    Riferimento: Non sale xorg



    Non se ne installa neanche una versione:

    Codice:
    Only registered members can view code.
    I noveau non rallentano la ventola... non la sopporto più....
    «Nessuna quantità di esperimenti potrà dimostrare che ho ragione;
    un unico esperimento potrà dimostrare che ho sbagliato.
    » (A. Einstein)

    Rispondi citando Rispondi citando Il mio PC

  8. #7
    Data registrazione
    Jan 2010
    Sesso
    Uomo
    Località
    Nel mondo degli svarioni
    Messaggi
    1,403
    Grazie dati 
    149
    Grazie ricevuti 
    471
    Ringraziato in
    421 post

    Riferimento: Non sale xorg

    Installali a mano dal sito, almeno se esce qualche errore lo vediamo. Qui non si vede nulla di sensato, a parte le sbrodolate del programma di ricerca drivers.

    Rispondi citando Rispondi citando Il mio PC

  9. #8
    Data registrazione
    Jan 2010
    Sesso
    Uomo
    Messaggi
    17,013
    Grazie dati 
    4,802
    Grazie ricevuti 
    2,588
    Ringraziato in
    2,187 post

    Riferimento: Non sale xorg

    In che senso "dal sito"? Non basta apt-get?
    «Nessuna quantità di esperimenti potrà dimostrare che ho ragione;
    un unico esperimento potrà dimostrare che ho sbagliato.
    » (A. Einstein)

    Rispondi citando Rispondi citando Il mio PC

  10. #9
    Data registrazione
    Jan 2010
    Sesso
    Uomo
    Località
    Nel mondo degli svarioni
    Messaggi
    1,403
    Grazie dati 
    149
    Grazie ricevuti 
    471
    Ringraziato in
    421 post

    Riferimento: Non sale xorg

    Citazione Originariamente scritto da Andy86 Vedi messaggio
    In che senso "dal sito"? Non basta apt-get?
    Apt-get ti porta una versione già impacchettata e pronta all'uso dei drivers che trovi sul sito nvidia.
    Naturalmente dato che vanno impaccati e testati quelli pacchettizzati sono più vecchi.

    Rispondi citando Rispondi citando Il mio PC

  11. #10
    Data registrazione
    Jan 2010
    Sesso
    Uomo
    Messaggi
    17,013
    Grazie dati 
    4,802
    Grazie ricevuti 
    2,588
    Ringraziato in
    2,187 post

    Riferimento: Non sale xorg

    Allora... ho scaricato dal sito il driver più nuovo che c'era, è un file .run, ma il terminale si ostina a dirmi "command not found".
    Il bello è che se lo lancio senza sudo lo vede, ma mi dice permesso negato, anche da root (sudo -s), mentre se lo lancio con il sudo davanti è sempre "command not found".
    «Nessuna quantità di esperimenti potrà dimostrare che ho ragione;
    un unico esperimento potrà dimostrare che ho sbagliato.
    » (A. Einstein)

    Rispondi citando Rispondi citando Il mio PC

Segnalibri

Regole di scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •  
Cookies:direttiva 2009/136/CE (E-Privacy)

Il sito utilizza cookies propri e di terze parti per maggiori informazioni faq - Termini di servizio - Cookies
Il forum non puo' funzionare senza l'uso dei cookies pertanto l'uso della community è vincolato dall'accettazione degli stessi, nel caso contrario siete pregati di lasciare la community, proseguendo la navigazione acconsenti all’uso dei cookie