Pagina 1 di 2 12 UltimoUltimo
Mostra risultati da 1 a 10 di 12

Discussione: Ci sono pacchetti danneggiati bloccati.

  1. #1
    Data registrazione
    Jan 2010
    Sesso
    Uomo
    Messaggi
    17,013
    Grazie dati 
    4,802
    Grazie ricevuti 
    2,588
    Ringraziato in
    2,187 post

    Ci sono pacchetti danneggiati bloccati.

    Prima volta che mi capita. Che significa che sono "bloccati"?

    Tra l'altro thunderbird era già installato e funzionante. Dopo nuovo avvio di kde improvvisamente non funziona più, mostra solo una finestra bianca. Cerco di capire il problema, e questo è ciò che ottengo:

    Codice:
    Only registered members can view code.
    Codice:
    Only registered members can view code.
    Codice:
    Only registered members can view code.
    Codice:
    Only registered members can view code.
    :
    «Nessuna quantità di esperimenti potrà dimostrare che ho ragione;
    un unico esperimento potrà dimostrare che ho sbagliato.
    » (A. Einstein)

    Rispondi citando Rispondi citando Il mio PC

  2. # ADS
    Google Adsense Circuito Adsense
    Data registrazione
    da sempre
    Messaggi
    molti
     
  3. #2
    Data registrazione
    Jan 2010
    Sesso
    Uomo
    Località
    Nel mondo degli svarioni
    Messaggi
    1,403
    Grazie dati 
    149
    Grazie ricevuti 
    471
    Ringraziato in
    421 post

    Riferimento: Ci sono pacchetti danneggiati bloccati.

    Questo è un evidente caso di problemi nei repository posta i tuoi.

    Rispondi citando Rispondi citando Il mio PC

  4. #3
    Data registrazione
    Jan 2010
    Sesso
    Uomo
    Messaggi
    17,013
    Grazie dati 
    4,802
    Grazie ricevuti 
    2,588
    Ringraziato in
    2,187 post

    Riferimento: Ci sono pacchetti danneggiati bloccati.



    Da prima a dopo l'errore non ho cambiato niente. Questo il sources.list:

    Codice:
    Only registered members can view code.
    La sources.list.d attualmente è vuota.
    «Nessuna quantità di esperimenti potrà dimostrare che ho ragione;
    un unico esperimento potrà dimostrare che ho sbagliato.
    » (A. Einstein)

    Rispondi citando Rispondi citando Il mio PC

  5. #4
    Data registrazione
    Jan 2010
    Sesso
    Uomo
    Località
    /dev/null
    Messaggi
    830
    Grazie dati 
    132
    Grazie ricevuti 
    426
    Ringraziato in
    341 post

    Riferimento: Ci sono pacchetti danneggiati bloccati.

    Hai imbrogliato .
    Rischi problemi del genere a tentare di far andare ppa per maverick su altre versioni di Ubuntu.

    Devi usare firefox unstable insieme a Thundebird unstable, sicuramente loro hanno i pacchetti con le dipendenze per Oneiric.

    A occhio dovrebbe funzionare con queste modifiche:

    Codice:
    Only registered members can view code.
    Vedi se c'è il ppa per LibreOffice.

    Rispondi citando Rispondi citando

  6. #5
    Data registrazione
    Jan 2010
    Sesso
    Uomo
    Messaggi
    17,013
    Grazie dati 
    4,802
    Grazie ricevuti 
    2,588
    Ringraziato in
    2,187 post

    Riferimento: Ci sono pacchetti danneggiati bloccati.



    Il fatto è che io non voglio usare le versioni instabili (beta), ma semplicemente avere l'ultima stabile (9 - 10).

    Prima con maverick nei repo canonical c'era ancora la tre, per cui misi quelli ufficiali mozilla.

    Ora non capisco perché i repo-stable arrivano fino alla natty: non è che per caso è oneric ad essere ancora beta?
    E comunque prima thunderbird andava, quindi prima le dipendenze le aveva installate: non mi sembra affatto logico che tutto d'un tratto senza cambiare niente non possa farlo più.

    E poi "ci sono pacchetti danneggiati" qualcosa vorrà dire, no?


    ps1: Se mettessi quelli per "natty", che è sempre versione 11?

    ps2: i repo si possono verificare anche dal browser: Index of /mozillateam/firefox-stable/ubuntu/dists
    Ultima modifica di Andy86; 04-02-12 alle 12: 52.
    «Nessuna quantità di esperimenti potrà dimostrare che ho ragione;
    un unico esperimento potrà dimostrare che ho sbagliato.
    » (A. Einstein)

    Rispondi citando Rispondi citando Il mio PC

  7. #6
    Data registrazione
    Jan 2010
    Sesso
    Uomo
    Località
    /dev/null
    Messaggi
    830
    Grazie dati 
    132
    Grazie ricevuti 
    426
    Ringraziato in
    341 post

    Riferimento: Ci sono pacchetti danneggiati bloccati.

    Ora non capisco perché i repo-stable arrivano fino alla natty: non è che per caso è oneric ad essere ancora beta?
    Magari semplicemente Oneiric non fornisce alcune versioni più vecchie delle librerie che sono necessarie per la stable, quindi invece di modificare la stable rendono disponibile la beta.
    E comunque prima thunderbird andava, quindi prima le dipendenze le aveva installate: non mi sembra affatto logico che tutto d'un tratto senza cambiare niente non possa farlo più.
    Magari hanno aggiornato dei pacchetti a versioni che Thunderbird non supporta:

    pacchetti X e Y
    X chiede libK versione <=2
    Y chiede libK versione >=2
    se aggiornano libK alla versione 2.1, il pacchetto X non funziona più

    È uno dei problemi di Debian generalmente, che si risolve col Pinning. Gentoo se non ricordo male risolve con eselect.
    ps1: Se mettessi quelli per "natty", che è sempre versione 11?
    Se non scassa dipendenze funziona. A parte che ho perso il conto delle versioni tra Maveric, Natty, Oneiric etc. Quindi non so nemmeno a che versione ti riferisci
    ps2: i repo si possono verificare anche dal browser:
    Infatti ho fatto così
    E poi "ci sono pacchetti danneggiati" qualcosa vorrà dire, no?
    Probabilmente chiedono dipendenze non presenti nel repo. Ma è veramente molto che non uso distro Debian-based per dirti con sicurezza.

    Ma davvero non c'è Thunderbird, Firefox e OpenOffice nei repo di Ubuntu?

    Rispondi citando Rispondi citando

  8. #7
    Data registrazione
    Jan 2010
    Sesso
    Uomo
    Località
    Nel mondo degli svarioni
    Messaggi
    1,403
    Grazie dati 
    149
    Grazie ricevuti 
    471
    Ringraziato in
    421 post

    Riferimento: Ci sono pacchetti danneggiati bloccati.

    Citazione Originariamente scritto da K.a.o.s. Vedi messaggio
    È uno dei problemi di Debian generalmente, che si risolve col Pinning. Gentoo se non ricordo male risolve con eselect.
    No, con revdep-rebuild. Su gentoo quando si aggiornano le librerie vengono ricompilati tutti i pacchi per farli linkare alle nuove librerie e poi si rimuovono le vecchie.

    Ma davvero non c'è Thunderbird, Firefox e OpenOffice nei repo di Ubuntu?
    Openoffice no perché c'è libreoffice. Gli altri due so per certo che ci sono.

    Rispondi citando Rispondi citando Il mio PC

  9. #8
    Data registrazione
    Jan 2010
    Sesso
    Uomo
    Messaggi
    17,013
    Grazie dati 
    4,802
    Grazie ricevuti 
    2,588
    Ringraziato in
    2,187 post

    Riferimento: Ci sono pacchetti danneggiati bloccati.



    Ma davvero non c'è Thunderbird, Firefox e OpenOffice nei repo di Ubuntu?
    Ci sono, ma non sono aggiornati. Almeno con maverick arrivavano fino all'ultima 3.xx.

    Open office me lo sono portato dietro con il backup e non ricordo perché lo misi...

    A parte che ho perso il conto delle versioni tra Maveric, Natty, Oneiric etc. Quindi non so nemmeno a che versione ti riferisci
    Ci vado in palla anch'io. . Comunque: Maverick = 10.10, Natty = 11.04, Oneiric = 11.10, Precise = immagino 12.04.
    «Nessuna quantità di esperimenti potrà dimostrare che ho ragione;
    un unico esperimento potrà dimostrare che ho sbagliato.
    » (A. Einstein)

    Rispondi citando Rispondi citando Il mio PC

  10. #9
    Data registrazione
    Jan 2010
    Sesso
    Uomo
    Località
    /dev/null
    Messaggi
    830
    Grazie dati 
    132
    Grazie ricevuti 
    426
    Ringraziato in
    341 post

    Riferimento: Ci sono pacchetti danneggiati bloccati.

    No, con revdep-rebuild. Su gentoo quando si aggiornano le librerie vengono ricompilati tutti i pacchi per farli linkare alle nuove librerie e poi si rimuovono le vecchie.
    Giusto, ricordavo male
    Ci sono, ma non sono aggiornati. Almeno con maverick arrivavano fino all'ultima 3.xx.
    Ubuntu è fatta così

    Rispondi citando Rispondi citando

  11. #10
    Data registrazione
    Jan 2010
    Sesso
    Uomo
    Messaggi
    17,013
    Grazie dati 
    4,802
    Grazie ricevuti 
    2,588
    Ringraziato in
    2,187 post

    Riferimento: Ci sono pacchetti danneggiati bloccati.



    Sembra non sia un problema mio... https://bugs.launchpad.net/ubuntu/+s...fy/+bug/859223

    Secondo voi se la metto a mano cercandola su packages.ubuntu.com scasso qualcosa?
    «Nessuna quantità di esperimenti potrà dimostrare che ho ragione;
    un unico esperimento potrà dimostrare che ho sbagliato.
    » (A. Einstein)

    Rispondi citando Rispondi citando Il mio PC

Segnalibri

Regole di scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •  
Cookies:direttiva 2009/136/CE (E-Privacy)

Il sito utilizza cookies propri e di terze parti per maggiori informazioni faq - Termini di servizio - Cookies
Il forum non puo' funzionare senza l'uso dei cookies pertanto l'uso della community è vincolato dall'accettazione degli stessi, nel caso contrario siete pregati di lasciare la community, proseguendo la navigazione acconsenti all’uso dei cookie