Pagina 1 di 2 12 UltimoUltimo
Mostra risultati da 1 a 10 di 17

Discussione: Problema conversione da ogg vorbis in avi

  1. #1
    Data registrazione
    Jan 2010
    Sesso
    Uomo
    Messaggi
    17,013
    Grazie dati 
    4,802
    Grazie ricevuti 
    2,588
    Ringraziato in
    2,187 post

    Problema conversione da ogg vorbis in avi



    Poiché il desktop recoder di ubuntu salva solo in ogg vorbis, ho necessità di riconvertire eventuali filmati in avi, per una maggiore compatibilità.

    Però c'è un problema stranissimo, quando effettuo la conversione con xmediarecode, passando dal ogg in 1920x all'avi in 720x, sembra che io sia passato ad un 320x, tipo cellulare: appare sgranatissimo.

    Se faccio la stessa cosa con un avi creato su win con cam studio, sempre in 1920x, la conversione avviene correttamente e la perdita di qualità non si nota neanche un po'.

    Stessa cosa se lo converto in mpg (2 o ts), sempre lasciando il bitrate predefinito di 2000, che mi sembra anche eccessivo per un xvid (4000 per l'mpg), e il metodo di scalatura bicubic nel modificare la risoluzione.

    È normale 'sta cosa? È un problema di compatibilità tra gli avi e gli ogg vorbis? È xmr che ha problemi con questo tipo di codec?

    «Nessuna quantità di esperimenti potrà dimostrare che ho ragione;
    un unico esperimento potrà dimostrare che ho sbagliato.
    » (A. Einstein)

    Rispondi citando Rispondi citando Il mio PC

  2. # ADS
    Google Adsense Circuito Adsense
    Data registrazione
    da sempre
    Messaggi
    molti
     
  3. #2
    Data registrazione
    Jan 2010
    Sesso
    Uomo
    Località
    Veridian III
    Messaggi
    1,740
    Grazie dati 
    419
    Grazie ricevuti 
    856
    Ringraziato in
    620 post

    Riferimento: Problema conversione da ogg vorbis in avi

    Ma il video degli ogg qual'è? Ogg di solito è l'audio, ad esempio i vecchi OGM erano spesso xvid/divx ma con audio ogg e non mp3.
    Cioè anche con Camstudio riduci la risoluzione a 720x? Magari se posti una schermata di Mediainfo vediamo che tipo di file è esattamente. Dai anche un'occhiata al bitrate finale che ti mette xmedia con quei video che risultano sgranati, visto che comunque basta un bitrate molto inferiore a 720x rispetto un HD, non vorrei che lo abbia però calato troppo..

    Rispondi citando Rispondi citando

  4. #3
    Data registrazione
    Feb 2010
    Località
    NCC1701
    Messaggi
    3,822
    Grazie dati 
    1,307
    Grazie ricevuti 
    1,323
    Ringraziato in
    996 post

    Riferimento: Problema conversione da ogg vorbis in avi

    Anche io sapevo che Vorbis Ogg era un audio encoding. Posta le info chieste da Kirk perché anche io non saprei aiutarti visto anche che non ho a che fare con questi file quasi mai.

    Rispondi citando Rispondi citando Il mio PC

  5. #4
    Data registrazione
    Jan 2010
    Sesso
    Uomo
    Messaggi
    17,013
    Grazie dati 
    4,802
    Grazie ricevuti 
    2,588
    Ringraziato in
    2,187 post

    Riferimento: Problema conversione da ogg vorbis in avi



    Ovviamente il video è in ogg theora.
    Però l'estensione è in .ogv, e mi sono confuso.

    Comunque questa è l'analisi di uno di quei file con media info:

    Codice:
    Only registered members can view code.
    Mentre questo è quello di una conversione:

    Codice:
    Only registered members can view code.
    In effetti il bitrate viene visto di mille e qualcosa, nonostante in xrm fosse impostato di 2000.

    Comunque non mi sembra che 1000 di bit rate su un 720 x si debbano vedere così... per assurdo un xvid preso dal mulo a risoluzione minore si vede meglio.

    Allego i due video dell'esempio (2 minuti di desktop con questa discussione aperta), così vediamo se sono io incontetabile o se davvero non si vede come dovrebbe.

    e
    File allegati File allegati
    Ultima modifica di Andy86; 30-11-11 alle 21: 47.
    «Nessuna quantità di esperimenti potrà dimostrare che ho ragione;
    un unico esperimento potrà dimostrare che ho sbagliato.
    » (A. Einstein)

    Rispondi citando Rispondi citando Il mio PC

  6. #5
    Data registrazione
    Feb 2010
    Località
    NCC1701
    Messaggi
    3,822
    Grazie dati 
    1,307
    Grazie ricevuti 
    1,323
    Ringraziato in
    996 post

    Riferimento: Problema conversione da ogg vorbis in avi

    Sbaglio o sono un po' più di 6 secondi? Comunque da 1920x1072 a 712x400 (questo vedo) la riduzione mi sembra abbastanza grossa.

    Rispondi citando Rispondi citando Il mio PC

  7. #6
    Data registrazione
    Jan 2010
    Sesso
    Uomo
    Messaggi
    17,013
    Grazie dati 
    4,802
    Grazie ricevuti 
    2,588
    Ringraziato in
    2,187 post

    Riferimento: Problema conversione da ogg vorbis in avi



    E chi ha mai parlato di 6 secondi?

    Lo so che la risoluzione è grossa, però se tu guardi un normale video a 720x:



    E fai caso alle scritte dei menù del programma, queste si vedono molto meglio rispetto a quelle del risultato della mia conversione, che non si legge nulla.
    «Nessuna quantità di esperimenti potrà dimostrare che ho ragione;
    un unico esperimento potrà dimostrare che ho sbagliato.
    » (A. Einstein)

    Rispondi citando Rispondi citando Il mio PC

  8. #7
    Data registrazione
    Feb 2010
    Località
    NCC1701
    Messaggi
    3,822
    Grazie dati 
    1,307
    Grazie ricevuti 
    1,323
    Ringraziato in
    996 post

    Riferimento: Problema conversione da ogg vorbis in avi

    E' che dicevi
    2 minuti di desktop con questa discussione aperta
    e a me risultano (vedendo i tuoi file allegati) di 6 secondi e 252ms. Potresti fare una conversione in AVI lasciando 1920x1072, e lavorare poi con il file avi Xvid + lame mp3 forse più versatile. E' possibile che il video in questione era su un desktop già a 720 e non 1920? Scusa ma non l'ho visto tutto, magari lo dice.

    Rispondi citando Rispondi citando Il mio PC

  9. #8
    Data registrazione
    Jan 2010
    Sesso
    Uomo
    Messaggi
    1,155
    Grazie dati 
    206
    Grazie ricevuti 
    673
    Ringraziato in
    401 post

    Riferimento: Problema conversione da ogg vorbis in avi

    Ciao.

    Il video che hai postato non può fare testo dato che il file caricato è almeno 720p e non 720x, lo vedi sia dalle opzioni di riproduzione che dalla scritta youtubeHD.
    Secondo me la conversione che ottieni è sufficiente, considera che diminuisci la risoluzione a quasi un terzo e sicuramene non hai usato nessun tipo di miglioramento dell'immagine tipo la nitidezza.
    L'unica prova che puoi fare è cambiare il modo di ridimensionamento da bicubico a lanczos (se il pc ce la fa) o bilineare...

    Rispondi citando Rispondi citando

  10. #9
    Data registrazione
    Feb 2010
    Località
    NCC1701
    Messaggi
    3,822
    Grazie dati 
    1,307
    Grazie ricevuti 
    1,323
    Ringraziato in
    996 post

    Riferimento: Problema conversione da ogg vorbis in avi

    Vero... non penso mai al fatto che sia su YT. Mi sembra comunque che sia 1280x720 o sbaglio?

    Rispondi citando Rispondi citando Il mio PC

  11. #10
    Data registrazione
    Jan 2010
    Sesso
    Uomo
    Messaggi
    17,013
    Grazie dati 
    4,802
    Grazie ricevuti 
    2,588
    Ringraziato in
    2,187 post

    Riferimento: Problema conversione da ogg vorbis in avi



    Avete ragione entrambe. Il fatto è che stasera sono cotto (dopo aver faticato tutto il giorno) quindi vi rispondo l'ultima volta e poi buonanotte per davvero.

    Comunque sono convinto che un video a 720x preso da internet si veda molto meglio che quelli.
    Anche quando faccio il cambio risoluzione da avi ad avi il risultato è decente.
    Se registro una presentazione con delle foto, alla conversione sgrana tutto. Se lo faccio da avi ad avi non sgrana per niente.

    Domani proverò i consigli del metodo scalatura e del passaggio in stessa risoluzione e poi scalatura in seconda conversione.

    Non mi stupirei se ogg comprimesse talmente bene da non riuscire a decomprimere...
    «Nessuna quantità di esperimenti potrà dimostrare che ho ragione;
    un unico esperimento potrà dimostrare che ho sbagliato.
    » (A. Einstein)

    Rispondi citando Rispondi citando Il mio PC

Segnalibri

Regole di scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •  
Cookies:direttiva 2009/136/CE (E-Privacy)

Il sito utilizza cookies propri e di terze parti per maggiori informazioni faq - Termini di servizio - Cookies
Il forum non puo' funzionare senza l'uso dei cookies pertanto l'uso della community è vincolato dall'accettazione degli stessi, nel caso contrario siete pregati di lasciare la community, proseguendo la navigazione acconsenti all’uso dei cookie