Mostra risultati da 1 a 2 di 2

Discussione: [GUIDA] Connessione ad internet con LG GW520 Intouch

  1. #1
    Data registrazione
    Apr 2010
    Sesso
    Uomo
    Località
    Torino
    Messaggi
    241
    Grazie dati 
    71
    Grazie ricevuti 
    37
    Ringraziato in
    35 post

    [GUIDA] Connessione ad internet con LG GW520 Intouch

    Dopo diverso tempo di tentavi infruttuosi con persino tentativi di connessione via bluetooth oggi sono riuscito finalmente ad utilizzare questo cellulare (quasi comprato apposta).

    Di cosa abbiamo bisogno?
    Naturalmente del cellulare in questione (il procedimento dovrebbe essere valido, pari pari anche per il cookie)
    cavo usb
    La nostra distro preferita
    Usb_modeswitch
    Programma per la connessione (io mi sono fermato a network manager visto che andava, ma credo sia possibile anche con Kppp e wvdial o quant'altro; al momento non pare funzionare con Vodafone Mobile Connect, appena posso provo con UMTSmon)

    1) Ricaviamo i vendorId e productId del telefono impostato come modem. Per farlo ho avuto bisogno di windows e dopo aver trovato il telefono ho guardato nei dettagli hardware. Purtroppo non ricordo esattamente la il nome della scheda da cui lo ho visto, ma smanettando un po' si trova. Per me erano idvendor=1004 idproduct=6000.
    Il problema è che linux lo vede come cd e ha come idproduct 607f. (i propri si possono verificare col comando lsusb)

    2) Installiamo usb_modeswitch. Io lo avevo nei repo quindi mi è bastato un
    Codice:
    Only registered members can view code.
    In alternativa è possibile anche compilarselo da sorgenti.

    3) Tra i file di configurazione di usb_modeswitch c'era uno che pensavo potesse già pronto ma non avveniva lo switch. Sul forum di usb_modeswitch un ragazzo tentava di utilizzare il cookie e ho voluto provare i suoi valori (visto che il uso id product del modem coincideva col mio). Ho quindi modificato il file nel percorso /etc/usb_modeswitch.d; si può anche creare un nuovo file inserendo il testo seguente:
    Codice:
    Only registered members can view code.
    Nel mio caso lo ho salvato nel percorso /etc/usb_modeswitch.d/1004:607f

    4) Ora proviamo a vedere se funziona e diamo il comando
    Codice:
    Only registered members can view code.
    e vediamo cosa succede. Se tutto è andato a buon fine dovremmo ricevere un messaggio che ci dice che è avvenuto lo switch. Verifichiamo anche con lsusb

    5) Ora possiamo connetterci. Io ho utilizzato network manager.

    Problemi: lo switch ha per ora successo solo se una volta connesso il cellulare viene riconosciuto come cd. Se il cd non viene riconosciuto, non avviene lo switch nonostante l'idproduct sia lo stesso. Nel mio caso avviene solo alla prima connessione del cellulare dopo un riavvio.
    Per non dare il comando usb_modeswitch a tutti gli avvii credo si possa creare una regola per udev da inserire nella cartella /etc/udev/rules.d però non lo ho ancora fatto e non so neanche la sintassi corretta di una eventuale regola.

    Credo sia tutto. Appena mi trovo ad usare linux modifico la parte 1 e indico esattamente come scoprire gli id della periferica.
    Nel caso di errori non esitate a farmeli notare
    Ultima modifica di mich; 14-07-10 alle 08: 38.

    Rispondi citando Rispondi citando Il mio PC

  2. # ADS
    Google Adsense Circuito Adsense
    Data registrazione
    da sempre
    Località
    mondo google
    Messaggi
    molti
     
  3. #2
    Data registrazione
    Apr 2010
    Sesso
    Uomo
    Località
    Torino
    Messaggi
    241
    Grazie dati 
    71
    Grazie ricevuti 
    37
    Ringraziato in
    35 post

    Riferimento: [GUIDA] Connessione ad internet con LG GW520 Intouch

    E' sparito il tasto modifica....

    Ho fatto alcune prove.
    Con UMTSmon il telefono è riconosciuto, ma non si connette assolutamente (però potrebbe dipendere da impostazioni sbagliate in umtsmon perché non si connette neanche con la chiavetta dando però un errore diverso)
    La cosa più negativa è che purtroppo il sistema sembra restare connesso ma rimaniamo senza movimenti di rete dopo circa un minuto di connessione.
    Ho provato sia con tim che con tre, assegnando i dns in automatico o quelli di google ed il risultato è lo stesso.

    Nuovo tentativo utilizzando l'ultimo firmware nobrand (ho pensato che potesse essere un problema del software del telefono visti alcuni bug che presenta il firmware tim) ma blocco anche qui.
    Ultima prova utilizzando la scheda tre con il firmware no brand (l'ultime tentativo tim l'ho fatto utilizzando l'apn wap, quindi potrebbe dipendere anche da quello)
    Ultima modifica di mich; 16-07-10 alle 15: 42.

    Rispondi citando Rispondi citando Il mio PC

Segnalibri

Regole di scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •  
Cookies:direttiva 2009/136/CE (E-Privacy)

Il sito utilizza cookies propri e di terze parti per maggiori informazioni faq - Termini di servizio - Cookies
Il forum non puo' funzionare senza l'uso dei cookies pertanto l'uso della community è vincolato dall'accettazione degli stessi, nel caso contrario siete pregati di lasciare la community, proseguendo la navigazione acconsenti all’uso dei cookie