PDA

Visualizza versione completa : Non riesco ad installare nessuna distro Linux



LadyHawke
26-02-10, 15: 07
Premessa, unica e inconfutabile, è che di Linux non ci capisco nulla, ma l'ho sempre installato, partizionato, e apportato misere modifiche a qualche file di configurazione scimmiottando ciò che trovavo in rete.
Ma è la prima volta questa che mi capita di non riuscire ad installare nessuna distro su uno specifico PC :shock

Ho un "vecchio" notebook mutilato del display (che era rotto, quindi l'ho tolto): è un Asus M2430C, Intel Centrino a 1400 con 1256Mb di Ram con video condiviso, HDD da 20Gb sostituito all'originale, wifi, lan, 1394 etc etc, che fino a due giorni fa (ovvero finchè non ho tentato l'installazione di Linux) faceva girare normalmente XP.
Volendo recuperare una licenza, e volendo provare a trasformare il "piccoletto" in un Web Server, la scelta era caduta su Ubuntu Server + LAMP, ma non c'è stato verso, così ho provato anche Ubuntu normale e Kubuntu, anche la versione 9.04 ma nulla; ho pensato che ci fosse un problema con le derivate Debian e allora ho tentato con Mandriva e con Suse... niente da fare.

Non ho errori, semplicemente l'installazione si ferma subito dopo la schermata iniziale, generalmente con il cursore lampeggiante su schermata nera sulle Debian: ho provato diversi CD (le iso le ho masterizzate al momento) e anche un masterizzatore esterno USB...

Idee?

:bai

K.a.o.s.
26-02-10, 19: 47
Ciao :bai,

dunque, senza errori si va un po' alla cieca... ma proviamo.

Per prima cosa, potresti controllare l'integrità delle live con l'apposita opzione al boot.

Poi tra le informazioni, manca quella che credo sia la più importante :hap: la scheda video. Guardando un po' su internet, sembra che abbia montata una integrata Intel, quindi come prima possibile soluzione, consiglierei di aggiungere il parametro i915.modeset=0 al boot.

Se non funziona, ci inventiamo altro :bgg2.

pierino_89
27-02-10, 13: 13
Dunque, immagino che essendo lo schermo originale sia rotto, tu stia lavorando con uno schermo esterno. La selezione dello schermo è un argomento molto delicato e non ho mai ben capito come funzioni, comunque sul mio le immagini appaiono tutte solo sul primario a meno che io non lasci lo schermo chiuso. Poi quando si avvia il server grafico nvidia-settings abilita il twinview e li usa tutti e due.
Quindi non vorrei che effettivamente la cosa funzioni, ma che l'immagine arrivi sullo schermo sbagliato.

Dal momento che tu intendi usarlo come server ti propongo una alternativa: fai l'installazione di debian, configuri ssh e poi la gestisci da un altro pc.

Come ultima chance, se ne hai la possibilità potresti attaccare il disco a un altro pc, installarci sopra la distribuzione, configurare il server ssh e rimettere il disco dov'era.

NB: io ho detto debian, ma mettici pure ciò che vuoi. Ma non ubuntu server, ti prego. È la cosa più ridicola che mi sia mai passata fra le mani.

LadyHawke
27-02-10, 14: 38
Per prima cosa, potresti controllare l'integrità delle live con l'apposita opzione al boot.Il risultato non cambia: non esegue il controllo, riproponendo schermata nera e cursore lampeggiante su alcune distro e provocando il riavvio su altre (questo avevo dimenticato di dirlo, e cioè che su alcune distro riavvia).


consiglierei di aggiungere il parametro i915.modeset=0 al boot.Nulla di fatto, però è stato illuminante per cercare con quale maledetta combinazione di tasti avrei potuto fare lo slash (che comunque non serviva). In ogni caso ho sempre impostato dove potevo la configurazione grafica sicura

Se non funziona, ci inventiamo altro :bgg2.Mi sa che va così :bgg2


@ pierino_89

Lo schermo esterno lo vedo perchè il cursore è lì che lampeggia beffardo :cry3


fai l'installazione di debian, configuri ssh e poi la gestisci da un altro pc. Eh sì...configuri l'ssh, ma devo fare un corso accellerato prima, e comunque intendevo gestire poi con VNC il piccoletto, visto che il monitor già mi switcha gli altri due PC

potresti attaccare il disco a un altro pc, installarci sopra la distribuzione, configurare il server ssh e rimettere il disco dov'era C'est possible? :oo2

Comunque un pò avanti sono andata: mi sono ricordata che quando qualche anno fa passai un pò più tempo dietro Linux si parlava spesso di problemi con l'ACPI soprattutto con i notebook, quindi l'ho disabilitato dalle opzioni di boot e allora riesco ad installare quasi tutto regolarmente.... peccato che al primo riavvio siamo da capo con il cursore e nulla più

:bai

[EDIT] Le live funzionano

pierino_89
27-02-10, 14: 48
Nulla di fatto, però è stato illuminante per cercare con quale maledetta combinazione di tasti avrei potuto fare lo slash (che comunque non serviva). In ogni caso ho sempre impostato dove potevo la configurazione grafica sicura
Mi sa che va così :bgg2

Di predefinito la mappatura è inglese:
- -> /
' -> -
Gli altri non li so, ma in genere bastano questi. Se arrivi alla shell puoi dare

Only registered members can view code.per avere il layout italiano.
Se hai già la grafica attiva invece:

Only registered members can view code.



@ pierino_89

Lo schermo esterno lo vedo perchè il cursore è lì che lampeggia beffardo :cry3

Eh sì...configuri l'ssh, ma devo fare un corso accellerato prima, e comunque intendevo gestire poi con VNC il piccoletto, visto che il monitor già mi switcha gli altri due PC
Eh, ma tutta la gestione del LAMP è da riga di comando o via web... Per usare VNC per avviare una shell tanto vale usare ssh. Poi, a tuo gusto, ovviamente...



C'est possible? :oo2

Si può fare ben di peggio... :tong2



Comunque un pò avanti sono andata: mi sono ricordata che quando qualche anno fa passai un pò più tempo dietro Linux si parlava spesso di problemi con l'ACPI soprattutto con i notebook, quindi l'ho disabilitato dalle opzioni di boot e allora riesco ad installare quasi tutto regolarmente.... peccato che al primo riavvio siamo da capo con il cursore e nulla più
Allora sei a cavallo! Quando sei su grub, premi e. Questo ti permetterà di modificare la riga di boot. Al fondo della riga aggiungi l'opzione per disattivare acpi (noacpi) e poi premi b per fare il boot.
N.B.: questo non è permanente. Serve solo a farlo salire. Per fare in modo che sia permanente devi aggiungere l'opzione a /boot/grub/menu.lst



[EDIT] Le live funzionano
Strano, però!

K.a.o.s.
27-02-10, 14: 49
Comunque un pò avanti sono andata: mi sono ricordata che quando qualche anno fa passai un pò più tempo dietro Linux si parlava spesso di problemi con l'ACPI soprattutto con i notebook, quindi l'ho disabilitato dalle opzioni di boot e allora riesco ad installare quasi tutto regolarmente.... peccato che al primo riavvio siamo da capo con il cursore e nulla più
A questo punto allora basterebbe aggiungere: acpi=off alla riga del kernel in /boot/grub/menu.lst o grub.conf (per grub2 su Ubuntu mi sembra si modifichi poi in etc e si faccia update-grub o qualcosa del genere, in modo che il sistema generi il nuovo /boot/grub/grub.conf).

EDIT:

Anticipato :)

pierino_89
27-02-10, 14: 52
A questo punto allora basterebbe aggiungere: acpi=off alla riga del kernel in /boot/grub/menu.lst o grub.confSarebbe meglio usare #kopt, almeno non spariscono ad ogni update. Comunque appena riesce a fare il boot, vediamo com'è strutturato il suo file.



EDIT:

Anticipato :)
Quanto mi mancava :lol:

LadyHawke
27-02-10, 14: 57
Ma non ci arrivo al grub :cry3

Al boot o fatto con "e" per inserire il comando della scheda intel indicato da K.a.o.s., l'ACPI=off lo imposto con F6 ma solo all'installazione: quando hanno finito che eseguono il primo riavvo non funziona più nulla :wall

Da come si è installato mi è parso di capire che l'Ubuntu Server avrebbe richiesto parecchia riga di comando :tong2, perciò già mi ero ridirezionata sulla versione normale

:bai

[EDIT] però potrei ripartire con la live e modificare il file..

pierino_89
27-02-10, 15: 04
Ma non ci arrivo al grub :cry3

Al boot o fatto con "e" per inserire il comando della scheda intel indicato da K.a.o.s., l'ACPI=off lo imposto con F6 ma solo all'installazione: quando hanno finito che eseguono il primo riavvo non funziona più nulla :wall

Se puoi fare e, vuol dire che ci arrivi. :eye



Da come si è installato mi è parso di capire che l'Ubuntu Server avrebbe richiesto parecchia riga di comando :tong2, perciò già mi ero ridirezionata sulla versione normale

Ubuntu server esce senza server grafico. Però per installare la suite LAMP dovrai comunque specchiarti nella shell, sappilo :tong2



[EDIT] però potrei ripartire con la live e modificare il file..
Certo, puoi farlo. Fai esegui "gksudo gedit" e poi vai ad aprire il file incriminato nel disco fisso (occhio! /boot è la boot del cd live, non dell'installazione su disco).

LadyHawke
27-02-10, 22: 50
:gogo Entrata nel mio Ubuntu dalla porta principale con "e" laddove c'era il nulla (praticamente è come l'F8 di windows da premere subito dopo all'avvio), così ho potuto inserire il comando ACPI=off nel Grub

A quel punto confermo che trattandosi di Grub2 il file da modificare non è più menu.lst ma sarebbe grub.cfg: dico sarebbe perchè il file non è editabile (o meglio lo è ma non è possibile salvarlo neppure con permessi di root :boh): la procedura corretta è modificare il file /etc/default/grub e dare il comando per ricreare il grub.cfg... in pratica per i posteri:


Aprire un terminale e digitare
$ gksudo gedit --> cercare e aprire il file da shell grafica
oppure
$ sudo gedit /etc/deafult/grub che apre direttamente il file
aggiungere la riga inerente l'acpi sotto alla riga GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX_DEFAULT="acpi=off"
salvare e uscire
Dal terminale precedentemente aperto digitare il comando
sudo update-grub che ricrea il file grub.cfg

Ora però mi chiedevo (perchè non ho trovato corrispondenza nè nel file grub, nè nel file grub.d), se l'utilizzo del comando che diceva pierino (#kopt) è ancora valido, perchè se il file viene "ricompilato" e non è scrivibile non dovrebbe esserci il problema di sovrascrittura da parte di aggiornamenti :ohoh

:bai

pierino_89
28-02-10, 03: 59
Ora però mi chiedevo (perchè non ho trovato corrispondenza nè nel file grub, nè nel file grub.d), se l'utilizzo del comando che diceva pierino (#kopt) è ancora valido, perchè se il file viene "ricompilato" e non è scrivibile non dovrebbe esserci il problema di sovrascrittura da parte di aggiornamenti :ohoh

:bai

Beh, io parlavo di grub 1, a occhio e croce quello che hai fatto corrisponde alla direttiva kopt (= kernel options), che specifica una serie di opzioni da passare di default a tutti i kernel in lista.

Probabilmente il file che non riuscivi a modificare aveva l'attributo i (=immutabile) settato, oppure i permessi erano settati a -w (nota: neanche root non può scrivere su un file se non ha il permesso di scrittura).
Comunque gli aggiornamenti vanno a lanciare sempre update-grub o come si chiama quello di grub2, quindi di fatto se non cambi tu gli attributi del file l'aggiornamento lo pasticcerà comunque. Però d'altra parte gli aggiornamenti non vanno mai a cambiare le default options del kernel, quindi teoricamente la cosa non dovrebbe tangerti.