PDA

Visualizza versione completa : Video Rimane una striscia con mediaplayerHC



principe andry
19-02-10, 18: 05
Salve...
Dal titolo difficile capire di cosa parlo. Il problema si presenta come da foto:

http://img716.imageshack.us/img716/8260/immaginekn.th.jpg (http://img716.imageshack.us/i/immaginekn.jpg/)

Rimane insomma una striscia di quello che st sotto al video; che sia lo sfondo (come da foto) oppure una pagina web ecc.
L'unico programma che me lo f mediaplayerHC. Con VLC nessun problema.
Ho pensato ad un installazione andata maluccio (l'ho installato 2 volte :tong2). Disinstallo, pulisco il registro, reinstallo, e non cambia nulla.

Ho tolto i filtri esterni di coreavc, e non cambia nulla (ps: sono inutili ora questi codec? prima erano indispensabili per i file .mkv :shock).

Il problemino lo f uguale con pi video .mkv. Con i file .avi invece tutto ok...

Strano anche il fatto che nella foto non ha salvato l'immagine del video...

Grazie :bai

Kirk
19-02-10, 22: 22
Ho pensato ad un installazione andata maluccioPrima di tutto vorrei capire cosa stai usando, se parliamo di MediaClassic HC o no, perch non ho mai visto una versione ad installazione..

sono inutili ora questi codec?CoreAVC uno dei decoder pi leggeri per la visualizzazione dei filmati HD, a 1080p per intenderci, e visto che la leggerezza del decoder ci che influisce maggiormente sulla fluidit del filmato ( a parit di potenza della CPU) possono essere utili si..

Ma si usa uno o l' altro, molti hanno ffdshow (pesante per gli H264) abilitato, senza rendersene conto, e di default magari usato lui e non CoreAVC.

Il problema non il filmato ma un filtro o il player di per s mal impostato, come sempre norma consigliare la disinstallazione di eventuali pack.

principe andry
20-02-10, 12: 30
ciao kirk grazie per l'aiuto :hap
St usando questo -> click (http://mpc-hc.sourceforge.net/download-media-player-classic-hc.html)
E' un'installer, se poi c' anche la versione stand-alone non lo so :boh

Per i pack nessun problema perch non ne ho mai installato uno :tong2

Mentre scrivevo ho provato a disabilitare nei filtri interni queste 2 voci (proprio perch hai detto "di default magari usato lui e non CoreAVC"):
- H264 / AVC (DXVA)
- H264 / AVC (FFmpeg)

Ora tutto ok. Se ne attivo uno non parte il video, se attivo solo l'altro invece rimane il problemino della striscia...

Grazie Kirk mi hai illuminato :sisi
:bai

Kirk
20-02-10, 12: 56
Immagino sia ffmpeg che crea il problema, con un filtro attivato probabilmente.

E' un'installer, se poi c' anche la versione stand-alone non lo soBeh si, solitamente sempre stato no-install, come il primo di questa lista (http://sourceforge.net/projects/mpc-hc/files/).

principe andry
20-02-10, 13: 56
ciao :hap
ovviamente visto che c'ero, mi son detto "proviamo i 1080p". Quelli di cui parlavo sono da 720p.

Ecco il risultato:
- la nuova versione di VLC va benino. Si sente (invece con la 1.0.3 che avevo non c'era l'audio) ma il video un pochino lento. Insomma ci devi far caso, ma non cos attentamente. Ci sono microscatti insomma.
- mediaplayer HC non va proprio. Il video non parte. Ho provato a rimettere quelle 2 voci dette, abilitare e disabilitare i coreAVC esterni e nulla cambia.
- fatto forse insolito, ma il classico media player (quello di default con windows, la versione 9 per la precisione :tong2) f vedere tutto bene!!! Nessun microscatto e l'audio ed il video sono in sincronia...

Cos'ha mediaplayerHC? O meglio, come devo settarlo?

Grazie ancora :bai

EDIT:
mi sono accorto solo ora che il file un mwv e non mkv. Ho provato a togliere la spunta nei filtri interni sulla voce "wmv 1/2/3" ed ora vedo il video in modo ottimale.
Questi filtri interni creano pi casini che benefici a quanto pare :ghgh

Kirk
21-02-10, 23: 43
Questi filtri interni creano pi casini che benefici a quanto pareNon direi, il decoder interno del classic uno dei piu leggeri per gli H264, e dicerto WMP un macigno rispetto al classic, se poi mal settato non l' ho ancora capito, sta di fatto che su uno stesso MKV, H264 1080p, la mia CPU non va mai oltre al 60% col classic, mentre costantemente tra il 90 e 100% con WMP, e anch' esso usando CoreAVC.. almeno lasciando predefinito in opzioni-->output, anche se per i sottotitoli bisognerebbe cambiare.

principe andry
22-02-10, 13: 58
ciao..
si si, dicevo per dire :sisi

Mal settato non lo so. Io non ho modificato nulla oltre quanto detto (tolta la spunta a quei filtri ed abilitato l'esterno coreAVC). Comunque ora gli mkv 720p vanno perfettamente come il wmv 1080p.

Ho provato anche powerDVD 9. Molto carino. Lo st provando per valutare la reale utilit dell'accelerazione hardware nvidia purevideo. La percentuale di utilizzo della Gpu sempre allo 0% :shock Comunque legge tranquillamente il file wmv a 1080p
Il softw sopra citato non supporta i file mkv :shock Parecchio pesante come pecca...

Che tu sappia, una nvidia 8400gs con Intel celeron E3200 (2.4Ghz) ce la f a far vedere gli mkv 1080p?
Stavo aiutando un ragazzo ma non c' stato verso... Ha provato una 8600gt (mantenendo inalterati i software e driver) e andava bene... A me sembra strano che una 8400gs non ce la faccia...

Grazie kirk :eye
:bai

Kirk
23-02-10, 02: 48
una nvidia 8400gs con Intel celeron E3200 (2.4Ghz) ce la f a far vedere gli mkv 1080p?Si dovrebbe essere al limite ma dovrebbe farcela, almeno 1 con qualcosa di simile ce la faceva tramite Coreavc, anche se non ricordo esattamente che CPU aveva, come potenza eravam li, ma da una all' altra non detto sia lo stesso.
Il softw sopra citato non supporta i file mkvAvevo gia sentito del problema, in teoria l' ultima versione non ha problemi con l' H264 : http://www.cyberlink.com/products/powerdvd/overview_en_GB.html
non lo uso da un po' forse per il container MKV bisognerebbe dar un' occhiata ai settaggi, non so nemmeno, essendo un player che di default usa codec propri, se conta l' installazione dell' Haali media splitter, quasi sempre necessario su altri player.

tolta la spunta a quei filtri ed abilitato l'esterno coreAVCComunque se sta usando Coreavc dovrebbe comparire l' icona di questi nella tray accanto all' orologio, premesso che usato se il codec usato l' H264 e non altri formati.

principe andry
23-02-10, 12: 03
ciao :hap
Il ragazzo ha risolto comprando una gt 220, ed ora utilizza win7 che mi stava dicendo che con il media center dello stesso va benissimo... meglio per lui :tong2

powerdvd non legge proprio gli mkv. Il player non parte e non d nessun errore... Utilizza solo i codec interni in quanto non appare l'icona dell'haali media splitter nella barra, cosa che accade quando utilizzo mediapHC e wmp...
Nelle impostazioni puoi modificare poco/nulla e niente che riguarda i codec.

Giusto per smanettare un p stavo provando anche nStand media della nvidia. Anche questo per non riconosce gli mkv, per fico :ghgh Mentre con il wmv 1080p va benissimo..

Il MPC sembra essere il migliore per quelli ad alta definizione e mkv... Per gli altri uso VLC che apre pure i sassi :ghgh

Grazie dell'aiuto kirk :eye
:bai