PDA

Visualizza versione completa : Restare a kde4, possibile?



Andy86
06-11-15, 00: 47
:bai

Purtroppo chakra in questi giorni ha fatto un mega aggiornamento a plasma 5, che è una schifezza, totalmente instabile, temi e comparto grafico notevolmente peggiorato. (giuro che non scherzo se dico che sembra android).

Mi chiedevo se ci fosse la possibilità di restare ancora un po' al buon vecchio kde4, anche se ha qualche problemuccio e lo sviluppo è purtroppo fermo, in attesa che tutto si sistemi, magari cambio distro (e si, fino all'altro giorno adoravo chakra, ma ora è un disastro).

Anche vedo che un po' tutte quelle nell'ambiente arch (mi piace pacman e l'essere rolling) stanno tutte passando al plasma.

Se veramente kde è destinato a fare quella fine, mi sa che valuterò un terzo ambiente alternativo, non so come sono lxde o lxce (mi tolgano tutto ma non la libertà di scelta, altrimenti che software libero è?).

pierino_89
06-11-15, 01: 50
Su Gentoo ho mascherato tutti i pacchetti del 5, così avrò modo di pensarci quando sarà stabile :ghgh
Credo che pacman abbia qualche meccanismo simile (persino apt ce l'ha), ma devi leggerti la documentazione.

Andy86
06-11-15, 10: 49
:bai

So che c'è l'opzione di ignore-pkg per non farti avvertire di un certo pacchetto, solo che ogni volta ti ricorda che "il pacchetto è stato ignorato".

I pacchetti del 5 sarebbero quelli con la parola plasma tra parentesi?

Il problema però mi sa che sarà più legato ai pacchetti che vengono aggiornati alle QT5 o quello che è, che forse non sempre rimane la versione per il 4. Per esempio dopo aver tentato di reinstallare kde-workspace non vedo più il "gestore dei processi di sole icone". :boh
(tra l'altro quelli di chakra con l'update hanno anche accorpato alcuni repo in altri, quindi non so fino dove si estende l'opera di pulizia... :shock)

Dici che al punto in cui sono per tornare indietro devo reinstallare da una vecchia iso e poi andare di "ignore-pkg" prima di lanciare gli aggiornamenti?

pierino_89
06-11-15, 15: 21
Sì, se non hai configurazioni particolari probabilmente fai prima a partire da un'installazione pulita, così vedi facilmente quali pacchetti vanno bloccati.

Andy86
06-11-15, 15: 34
:bai

Intanto ho fatto la prova (seguendo un articolo di blog relativo ad arch) a rimuovere il gruppo kdf5, solo che poi ho dovuto rimetterlo perché altrimenti le applicazioni che sono già migrate non giravano, quindi ho bloccato solo il gruppo (plasma) e ho detto vediamo se ve va il framework5 senza il plasma.

Partire da un installazione pulita è un casino perché non ho fatto l'elenco pacchetti prima e chissà quanti e quali pacchetti ho installato e disinstallato dall'ultima.

Ora sto cercando di recuperare i plasmoidi che sono andati persi, tipo icontask e visualizzazione cartella.

Ho anche ripristinato il backup della home che avevo intelligentemente fatto appena prima dell'update, così non mi porto dietro configurazioni che rompono.

Mi sto anche chiedendo perché dolphin continua a mantenere l'aspetto del tema plasma, anche se ora tutto il resto è tornato a oxygen.

Andy86
13-11-15, 01: 08
:bai

Grazie all'arch-archive (http://ala.seblu.net/packages/) ho downgradato tutti quei pacchetti di cui non c'era più la versione kde4 nei repository, ma non riesco a capire cosa devo downgradare per tornare ad avere le notifiche di dolphin in knotify.

In pratica vorrei fare il contrario di questo utente:
[SOLVED] Changing the progress bar in Dolphin (http://ubuntuforums.org/showthread.php?t=2053206)
(tra l'altro non capisco perché ci sono così tanti utenti che vanno su kde e vogliono la notifica come su windows... e poi i developer li ascoltano pure... :tap)

La spunta nelle opzioni di knotify l'ho rimessa, ma non mi ascolta.

Cercare ho cercato, ma non sono riuscito a capire quali sono i pacchetti delegati a questa funzionalità.

Vedo che l'eseguibile di knotify4 sta nel pacchetto kde-runtime che sostituisce il pacchetto kdebase-runtime, ma un eventuale downgrade sembra scontrarsi con il fatto che il vecchio pacchetto non viene riconosciuto come dipendenza al posto del primo. :ohoh

Andy86
29-04-16, 22: 46
:bai

Come va kde5 ad oggi secondo te?
Tu hai aggiornato o sei ancora al 4?

Perché su chakra restare con gli aggiornamenti bloccati sta diventando insostenibile.
Ogni volta che aggiorno qualcosa, qualcosa si scassa.

Oggi ho provato cinnamon in partizione separata, ma poi mi sono pure accorto, non so come, di averlo a 32bit. :wall

Comunque sono sempre in crisi quando devo cambiare le cose.

Mi sa che domani provo la live di chakra aggiornata, ho visto che l'ultima è di febbraio e non più di novembre.

pierino_89
30-04-16, 02: 26
Sono sul 5 da un bel pacco di tempo ormai... Adesso è circa usabile, diciamo.

Andy86
30-04-16, 10: 49
Mmmm.... Allora oggi provo la live e vediamo.... È che ieri sul 4 non andava più la lista applicazioni e invece di provare a risolvere sono scappato.
Poi ieri sera ho visto qualche tread sul problema, ma era tardi.

Qualche tema stondato almeno adesso c'è?

EDIT

Ho individuato il pacchetto responsabile di scassare la MIME-CACHE, attraverso il log di pacman ho indivudato un "rebuilding MIME cache" dopo l'update di kdelibs, ho downgradato kdelibs ed è tornato (quasi) tutto a posto.

C'è una cosa di cui non riesco a venire a capo... non c'è più kdesu (http://www.collectiontricks.it/forum/gnu-linux/Ct6300-non-c-kdesu.html#post234207).

Meno male, perché oggi sono impegnato, quindi posso rimandare al prova di kde5 a quando avrò più tempo (e sarà più stabile :tong2).