PDA

Visualizza versione completa : [Debian 8.1]HTML5: problema di Debian o di iceweasel?



Kirk78
22-06-15, 15: 11
Su Debian 8 il browser predefinito non è firefox ma iceweasel, sempre progettato da Mozilla basato su Firefox ma con alcune cose diverse. Volevo vedere alcuni tutorial su youtube e visto che, almeno per ora, non avrei intenzione di installare quel coso di flash, ho settato il player di youtube con HTML5 (quando possibile) ma non riesco a vederne neanche uno. Gli stessi video, su altro pc con Xubuntu, in firefox, li vedo tranquillamente in html5. :triste

E' un problema di Debian 8.1 oppure di iceweasel 31.7.0 (l'ultimo che mi trovo sul repo di Debian)? Se fosse colpa del browser vedo che un pacchetto di firefox "originale" su Debian 8.1 non c'è come pacchetto, quindi forse non è completamente compatibile :boh. Si può sempre provare a decomprimere il pacchetto di firefox, firefox-38.0.5.tar.bz2, ma è un artifizio e potrebbe, suppongo, avere problemi.

Idee per vedere video html5, almeno su youtube con Debian senza troppi "magheggi" magari non compatibili in Debian 8.1? Grazie comunque dell'attenzione! :bai

EDIT nel link del player html5 di youtube dice

Che cosa supporta questo browser?
v HTMLVideoElement
v H.264
v WebM VP8

Browser supportati
Molti browser supportano video in HTML5 e il codec video H.264 o il formato WebM. Tra questi:
Google Chrome
Microsoft Internet Explorer
Firefox
Opera
Apple Safari

non è presente iceweasel, ma c'è scritto "tra questi". Non potevano certo scriverli tutti.

RISOLTO con vlc... ok diciamo che ho risolto con VLC. Certo che se c'è un modo per vederlo sul browser non sarebbe male. In attesa di eventuali vostre altre idee aspetto a mettere risolto, visto che iceweasel comunque non li vede. Diciamo a metà, per ora.

pierino_89
22-06-15, 15: 53
E' un problema di Debian 8.1 oppure di iceweasel 31.7.0 (l'ultimo che mi trovo sul repo di Debian)? Se fosse colpa del browser vedo che un pacchetto di firefox "originale" su Debian 8.1 non c'è come pacchetto, quindi forse non è completamente compatibile :boh. Si può sempre provare a decomprimere il pacchetto di firefox, firefox-38.0.5.tar.bz2, ma è un artifizio e potrebbe, suppongo, avere problemi.

No, è puramente un problema legato al software libero. Puoi tranquillamente estrarre l'archivio di firefox 38, oppure cercarlo in altri repository esterni.



Idee per vedere video html5, almeno su youtube con Debian senza troppi "magheggi" magari non compatibili in Debian 8.1? Grazie comunque dell'attenzione! :bai
Chromium dovrebbe essere nei repository, attenzione solo a non installare il gioco omonimo.

Andy86
22-06-15, 17: 17
:bai

Probabilmente ti manca una dipendenza facoltativa di firefox, se è quella l'html5 non funzionerà neanche con gli altri browser.
Nella pagina per attivare html5 su youtube c'è la spunta blu di fianco ad h264?

Se non c'è la spunta prova a vedere se sono installati gst-plugins-good e gst-libav.
All'inizio io non li avevo ed ero nella tua stessa situazione, poi ho visto "h264" tra le dipendenze facoltative di firefox e ho risolto.

Kirk78
22-06-15, 17: 48
A quanto ho capito DuckDuckGolando pare sia un problema di iceweasel + Debian. H.264, come nel mio edit sopra, è spuntato.

è puramente un problema legato al software libero
Non ho capito bene: iceweasel è di Mozilla basato su firefox. L'uno funziona, l'altro no? Sono tutti e due liberi :boh
Comunque appena chiudo iceweasel provo con il pacchetto scompattato di firefox e provare firefox e/o fireefox-bin e vi dico. Mi piaceva l'idea di usare un'altro browser, anche se basato sempre su firefox. Ma se non funzia non funzia. Si vede che hanno tolto qualcosa di più o, come dicono altri, che youtube non riconosca iceweasel come browser? Pare la stessa cosa succeda su altri siti.

Comunque è installato gir1.2-gst-plugins-base-1.0, l'unico pacchetto che all'interno la parola gst-plugins su Debian 8.

:bai

EDIT: adesso sono su firefox 38.0.5 preso dal pacchetto scompattato: i video html5 funzionano e tra l'altro, probabilmente condividendo con iceweasel anche i segnalibri e la configurazione mi sono ritrovato tutto come in iceweasel :gogo
A questo punto se mi confermate che iceweasel non vedrà mai gli html5 forse lo abbandono (peccato) e metto risolto.

pierino_89
22-06-15, 18: 35
Non ho capito bene: iceweasel è di Mozilla basato su firefox. L'uno funziona, l'altro no? Sono tutti e due liberi :boh

:nono https://it.wikipedia.org/wiki/Iceweasel
Iceweasel è "più libero", per non farla lunga.

Può essere che ci sia qualche problema di codec proprietari già inclusi in firefox che vengono invece rimossi in iceweasel. Ma non saprei da dove partire per capirci qualcosa, onestamente.

Kirk78
22-06-15, 18: 51
Non leggo wkpiede italian per via della castrazione chimica della pagina di P2P Forum Italia (http://linux.collectiontricks.it/wiki/P2P_Forum_Italia)... comunque ho notato che la differenza è che firefox ha, come plugin open, OpenH264 (http://www.openh264.org/) di Cisco.

Cisco provides this program under the terms of the BSD license
We will not pass on our MPEG-LA licensing costs for this module, and based on the current licensing environment, this will effectively make H.264 free for use on supported platforms.
Dovrebbe essere anch'esso un software libero (sicuramente aperto), ma forse Debian ha deciso di non metterlo su iceweasel :boh forse per problemi di sicurezza

Cosa è Iceweasel? Iceweasel è un fork [da Firefox] con il seguente scopo:
1. fare il backport delle risoluzioni dei problemi di sicurezza alla versione dichiarata Debian stable;
2. escludere elementi grafici e artistici con marchio registrato Mozilla (a causa del punto #1 sopra).
A parte questo i due sono praticamente identici.
Su firefox sì https://blog.mozilla.org/blog/2013/10/30/video-interoperability-on-the-web-gets-a-boost-from-ciscos-h-264-codec/

A questo punto mi preoccupo un po' per via della sicurezza (punto 1)....

:bai

pierino_89
22-06-15, 19: 18
A questo punto mi preoccupo un po' per via della sicurezza (punto 1)....

:bai



1. fare il backport delle risoluzioni dei problemi di sicurezza alla versione dichiarata Debian stable;

Se tu stai al passo col ramo principale, non c'è problema.

Kirk78
22-06-15, 19: 42
Se tu stai al passo col ramo principale, non c'è problema.
Parlavo se ci sono problemi se faccio partire firefox dal pacchetto scompattato al posto di iceweasel. Oppure mettere il plugin di firefox di openh264 su iceweasel? Probabilmente il problema è che l'h264 di iceweasel non è fatto molto bene :boh
Io ho installato la versione stable di Debian 8.1 e non ho aggiunto nessun'altro repo... non so esattamente cosa tu intenda per stare al passo :ehmm scusami se dico bestialità GNU :ghgh

:bai

pierino_89
22-06-15, 20: 27
Sto dicendo che se tu stai al passo (= aggiorni) la versione che hai scompattato, non hai problemi di sicurezza rispetto ad iceweasel.
"Backport" indica che quando nella versione corrente di firefox viene corretto un bug, questa correzione viene riportata su iceweasel, senza che vengano riportati altri aggiornamenti. Per questo le versioni non corrispondono.