PDA

Visualizza versione completa : Relinking the OSS kernel modules failed



Andy86
04-11-14, 15: 12
:bai

Visto che mi sono stufato dei problemi di alsa che rimangono anche senza pulseadio, volevo provare a mettere oss (https://wiki.archlinux.org/index.php/Open_Sound_System_%28Italiano%29), ma da errore al modulo del kernel. :boh


Only registered members can view code.
Non ho alcuna conoscenza/esperienza in fatto di kernel... help... :cry3 :thx

edit: su aur ho trovato una versione molto più aggiornata di oss (2010 vs 2006), makepkg e pacman hanno fatto il loro dovere senza storie e ora l'errore di make è sparito, ma ora mi chiede:


Only registered members can view code.

Non riesco a capire quale sarebbe questo development package che manca. :ehmm

ps: nei repo cercando i nomi suggeriti vedo questi, e sono installati entrambe:


Only registered members can view code.

pierino_89
04-11-14, 18: 57
Secondo me hai solo da perderci :ghgh Comunque, a naso stai cercando di installare moduli di una versione specifica di kernel, ma ne stai facendo girare un'altra (motivo per cui non trova le cartelle).

Andy86
04-11-14, 21: 00
:bai

Beh, l'altro sistema che avevo provato di configurare alsa per la scheda esclusiva (cioè sento solo un'applicazione per volta) non ha risolto nulla, visto che stando alla wiki di arch oss è migliore di alsa... perché non provare?
Tanto con i driver audio ci litigo dai tempi di windows. :ghgh

Comunque la vs. del kernel e quella che cerca oss sono uguali, come vedi dall'output di pacman.
Invece esplorando root ho scoperto che era un problema di standard, ed ho sistemato con un bel collegamento simbolico.

Solo che ora mi dice che alcuni moduli sono occupati:


Only registered members can view code.

E se provo a toglierli con modprobe -r, dice che non li trova:


Only registered members can view code.
Ci vorrebbe una bella modalità provvisoria. :lol:

-------------------------------------------
edit: buttando giù kde ha funzionato e caricato oss, ma, sorpresa, non è probabilmente compatibile con la mia scheda audio... gracchia di brutto.

Per cui per ora ho rinunciato e sono tornato ad alsa. (è bastato disisintallare oss e reinstallare il kernel da pacman).

pierino_89
05-11-14, 02: 41
C'è un motivo se tutti usano ALSA :ghgh
Anche se è tornato opensource, ci andrà parecchio prima di tornare "usabile".