PDA

Visualizza versione completa : Windows 7 (64bit): Windows Update non vuole funzionare !



Armandillo
02-09-14, 15: 15
:triste oggi per curiosita' ho voluto vedere se ci fossero aggiornamenti per il pc e senza preavviso m'e' apparsa la finestra come da figura:


http://images.collectiontricks.it/images/59370485692177531655.jpg

http://images.collectiontricks.it/images/62044926252847308490.jpg

Tenete presente che ho deciso di postare qui dopo circa 2 ore di vari tentativi e di letture circa questo identico problema...elenco di seguito cio' che ho fatto:

- scan con Avira
- scan con Malwarebyte's
- controllo con Hithisjack

nulla di sospetto

- 3 fixit di Microsoft dedicati a WU
- sfc /scannow per ripristino eventuali files corrotti
- 1 fixit riparatore da sito partner di Microsoft
- guida passo passo da supporter Microsoft con prompt e fixit
- almeno 4 guide di ricostruzione WU da prompt di comando come amministratore

nulla di nulla

- per finire ho ripristinato un registro che avevo backuppato e che sicuramente era funzionante ma la risposta e' ancora quella che vedete in figura :boh

Aggiungo che gli utlimi aggiornamenti sono andati a buon fine, che non ho "smanettato" anche perche' tornato da poco dalle vacanze, che non ho visto o notato stranezze in questi due giorni e che, per finire, l'unica diversita' sono state alcune connessioni Usb al pc con 2/3 cellulari e un IPad per caricare/scaricare foto e video.

Cos'altro posso fare ?
Grazie
:bai

EDIT:

continuando a cercare soluzioni ho provato a disinstallare gli ultimi aggiornamenti risalenti alla data del 14/08 ma senza risultato :triste
In rete ho letto che molti si trovano nelle mie stesse condizioni e che qualcuno ha risolto col metodo suggerito dalla Microsoft ma nel mio caso non e' servito :boh....riprovero'

Armandillo
02-09-14, 19: 16
Risolto !! :gogo

Come ulteriore tentativo ho cancellato tutto in C:\Windows\SoftwareDistribution\DataStore dopo aver backuppato il suo contenuto per prudenza.
Poi ho subito riavviato Windows Update che e' partito e dopo circa 10 minuti mi ha riproposto 11 aggiornamenti (credo quelli disinstallati in precedenza).
Li ho installati e dopo il riavvio del pc tutto e' tornato alla normalita'.

Ora rimane solo il dubbio se questo ultimo passaggio sia quello risolutivo o se l'insieme delle soluzioni provate abbia dato esito positivo :sisi

:bai

Clairvoyant
07-09-14, 10: 25
Ciao Armandillo,

probabilmente facendo quanto hai scritto nel tuo ultimo post hai già risolto, nel caso non fosse così puoi ancora provare ad usare
Windows Repair AIO (http://www.tweaking.com/content/page/windows_repair_all_in_one.html), che tra le altre cose può riparare anche Windows Update.

Lo segnalo qui anche nel caso potesse tornare utile ad altri.:hap

:bai

Armandillo
07-09-14, 13: 31
Si, ho risolto in modo definitivo e credo, ma non ne sono certissimo, di aver provato anche quell'utility che hai suggerito, o era molto simile, con esito negativo :boh
Riflettendo meglio su cio' che mi e' capitato e pensando che ho anche ripristinato un registro antecedente dovrei concludere che non era appunto un problema di registro oppure il comportamento di tutte quelle utility e fix non ha funzionato bene con il mio sistema a 64 bit.

:bai