PDA

Visualizza versione completa : netframework...



p060477
30-08-14, 19: 16
ciao!

ho win xp serv pack 3 pro ed

ed ho l'ultima vers di netframework compatibile la 4.03...
ora voglio provare un tool:
replay media catcher 5 che quando lo lancio mi dice che ho bisogno del
netframework 2.0.50727...
clicco di si e mi si apre una pagina di microsoft dove mi consiglia di installare il netframew. 3.5 serv pack 1
lo installo ma non riesce dicendo che ha riscontrato un errore..
allora trovo sul web il 2.0.50727 e lo installo..
mi esce l'errore che e' incompatibile un un netframew che ho sul pc..presuppongo con il mio ultimo 4.03...

cosa dovrei fare...??

grazie!!

Asterix
31-08-14, 10: 50
Ciao

prova a disinstallare tutti i .net e poi installarli seguendo la versione prima la .net 2 (http://www.microsoft.com/it-it/download/details.aspx?id=1639) poi la 4.5 (http://www.microsoft.com/it-it/download/details.aspx?id=42642)

Naturalmente devi fare anche gli windows update.

:bai

p060477
31-08-14, 11: 11
Ciao

prova a disinstallare tutti i .net e poi installarli seguendo la versione prima la .net 2 (http://www.microsoft.com/it-it/download/details.aspx?id=1639) poi la 4.5 (http://www.microsoft.com/it-it/download/details.aspx?id=42642)

Naturalmente devi fare anche gli windows update.

:bai

ciao e grazie!

se installassi,dopo aver disinstallato tutto come dici,
la vers 3.5 serv pack 1
e dopo la vers 4.03 ,che dovrebbe essere l'ultima compatibile con il mio xp
perche' la 4.5 non lo e',

cosa ne pensi..??
oppure e' meglio che metta la 2 e dopo la 4.03..??

grazie mille :)

Asterix
31-08-14, 11: 21
Se ti chiede la due io opterei per la due e poi la 4.

:bai

p060477
31-08-14, 11: 36
Grazie!

per 4 intendi la 4.03 che dovrebbe essere l'ultima per xp..?
io avevo scritto la 3.5 serv pack 1 perche' sul sito microsoft mi sembra di aver letto
che sia comunque un net fondamentale tant'e' che quando scrivono le istruzioni per fixxare problemi con i net framework
scrivono di disinstallare prima tutti i net come hai scritto anche tu
e dopo installare in ordine la 3.5 serv pack 1 e dopo la 4
tu cosa ne penseresti..??
ancora mille grazie!!

Asterix
31-08-14, 17: 33
Il 4 dovrebbe giÓ interpretare i programmi scritti in 3.5 Ŕ per quello che ti ho detto la 2 e poi la 4.

:bai

p060477
31-08-14, 18: 08
Grazie!!

..io mi ero basato su questo..:

"In breve, salvo condizioni particolari indicate successivamente, conviene installare nell'ordine indicato solo quanto segue a seconda del sistema operativo:

Windows XP SP3 -->
.NET Framework 3.5 SP1
.NET Framework 4.0

sembra che convenga installare comunque anche la 3.5 (con relativo service pack), in modo da garantire una buona compatibilitÓ con applicazioni meno recenti o scritte sulla 2.0.

.NET Framework 3.5 SP1 include ed installa il service pack 1 della build 3.0, il service pack 1 della 2.0, ed Ŕ retrocompatibile con le applicazioni basate sulla 2.0 standard.

In sintesi:

Con la 4.5/4.0 e la 3.5 SP1 non Ŕ necessario installare la 3.0 e la 2.0 (e relativi service pack), mentre si dovrÓ installare a parte la 1.1 SP1 in caso di applicazioni obsolete che la richiedono esplicitamente e non supportano le release successive (quasi tutte le applicazioni e i driver attuali, comunque, vanno bene con 2.0 e superiori). "