PDA

Visualizza versione completa : Firefox: lungo caricamento delle pagine web



Armandillo
13-06-14, 19: 26
:bai

Dopo essere passato a Win 7 64 bit e dopo i vari aggiornamenti di FF (ver. 30.0) ho notato che il caricamento delle pagine web e' molto lungo e talvolta interminabile.
Anche il primo avvio risulta piu' lento di qualche secondo.

Pensavo che la causa fosse l'add-on NoScript che avevo installato...niente.
Pensavo allora che fosse Avira Safety Browse anch'esso installato...niente.

Queste sono le estensioni installate:

2903

e questi i plugin:

2904

Il numero totale dei componeneti aggiuntivi rispetto a prima e' calato ma l'efficienza e' diminuita e per la prima volta IE11 e' risultato molto piu' veloce aprendo quasi all'istante :shock
Vorrei restare con FF ma se non c'e' rimedio mi tocca desistere....avete qualche idea ?

Grazie

Andy86
13-06-14, 20: 14
Quindi sei passato dalla vs. a 32 bit di FF a quella a 64bit?

Firefox l'hai avviato con un profilo pulito o con un profilo precedente?

L'hai provato in safe-mode?

Io non ho riscontrato questi problemi, ma sono su linux.

Armandillo
14-06-14, 13: 28
Quindi sei passato dalla vs. a 32 bit di FF a quella a 64bit?

Firefox l'hai avviato con un profilo pulito o con un profilo precedente?

L'hai provato in safe-mode?

Sono passato da Windows 7 32 bit a win7 64 bit.
Firefox l'ho avviato pulito ereditando solo i preferiti.
Non so cosa sia il "safe mode"

Edit:

aggiungo che la descrizione del problema descritta qui (https://support.mozilla.org/it/kb/Firefox%20non%20termina%20mai%20il%20caricamento%2 0di%20alcune%20pagine%20web) e' precisa al mio.
Preciso anche che ho controllato il pc con ogni mezzo ed e' risultato pulito.
Nel pc e' installato Java 8 update 5 (64 bit)

Andy86
14-06-14, 14: 34
:bai

La safe-mode sarebbe "aiuto -> riavvia disattivando i componenti aggiuntivi", per vedere se qualche plug-in o componente interagisce con il normale funzionamento di firefox.

Prova anche a seguire queste procedure -> https://support.mozilla.org/it/kb/I%20siti%20web%20vengono%20caricati%20con%20altri% 20programmi%20ma%20non%20con%20Firefox

Armandillo
14-06-14, 14: 56
Andy...ho provato il safe mode aprendo il forum e dopo avermi restituito la pagina iniziale di CT la "rotellina" ha continuato a girare per parecchio dopodiche' ho dovuto chiudere :boh quindi peggio di come era prima.
Preciso inoltre che stranamente le pagine che apro piu' spesso non danno quel problema, la rotellina si ferma poco dopo.
Con alcune invece gira all'infinito anche dopo che vi ho navigato all'interno...in pratica gira fino a quando non chiudo la pagina.

Andy86
14-06-14, 15: 07
Con le pagine che apri più spesso è normale che carichi più veloce perché si aiuta con la cache.
Hai provato le procedure ufficiali di mozilla che ti ho linkato?

Armandillo
14-06-14, 15: 21
Hai provato le procedure ufficiali di mozilla che ti ho linkato?

Ho applicato 2 suggerimenti in about:config ed ora faro' delle prove.

Stavo pensando se per caso l'aver lasciato la cache sul SSD invece che sul secondo harddisk (come feci con Win 32 bit) possa aver influito sulla velocita' .....pero' questo contrasterebbe con IE11 che invece viaggia piu' veloce :m:

Edit:
ho fatto delle prove ma non ho visto differenze poi ho provato un suggerimento fissando a 1024 il valore della cache e modificando la configurazione e sembra che un piccoloaumento di velocita' ci sia stato :sisi
Proseguiro' il test

Andy86
14-06-14, 16: 19
Mi pare strano, l'ssd è più veloce, dubito che quello non giustifica il rallentamento.

Prova a giocare con queste due opzioni:

browser.cache.disk.enable
browser.cache.memory.enable

La prima abilità la cache disco, la seconda la cache ram.
Puoi provare ad abilitarle alternativamente (disabilitando l'opposta) per vedere se la cache rallenta di più su ram o su disco.
Adesso che vedo io ho disabilitato la ram su disco mentre di default risultano attive tutt'edue, ma non ricordo proprio perchè lo feci. :m:

Armandillo
14-06-14, 17: 50
Prova a giocare con queste due opzioni:

browser.cache.disk.enable
browser.cache.memory.enable


Sono "true" entrambi.

Andy86
14-06-14, 17: 52
Prova a mettere la prima a false e vedi se la navigazione migliora. (di sicuro occuperà un sacco di ram).
Altrimenti prova l'opposto e fai la stessa verifica.

Armandillo
14-06-14, 18: 36
Fatto :gogo e (forse) risolto !!!!

Ho messo "browser.cache.disk.enable" = false e i siti si aprono quasi all'istante ed ho provato con qualcuno di quelli in cui la "rotellina" girava in eterno ed ora dopo poco si ferma !!!

Grazie Andy, spero di aver risolto definitivamente :sisi

Andy86
14-06-14, 18: 46
Magari l'avevo fatto anch'io per quello e l'ho dimenticato. Magari firefox ha davvero dei problemi lui con gli ssd. :boh
Comunque ricorda che in questo modo la cache va tutta in ram, quindi non stupirti se controllando la ram occupata da firefox dovessi vedere valori altissimi, magari anche 300 o 400mb, dipende proprio dalla cache.

Armandillo
14-06-14, 22: 43
Comunque ricorda che in questo modo la cache va tutta in ram, quindi non stupirti se controllando la ram occupata da firefox dovessi vedere valori altissimi, magari anche 300 o 400mb, dipende proprio dalla cache.

Grazie...se vedo che non mi crea problemi altri resto così perche' vedo che va benone :sisi

Kirk78
11-03-15, 16: 25
Aggiungo ai consigli del buon Andy86, che esiste anche browser.cache.memory.capacity che dovrebbe settare quanta ram utilizzare per la cache. Si può scegliere:

Only registered members can view code.
Non l'ho mai provato avendo su questo catorcio pochissima ram, quindi è solo una opzione che ho visto.

:bai