PDA

Visualizza versione completa : Mac Wine su mac



Andy86
17-12-13, 15: 47
:bai

Mi serve una mano perché di mac non sono tanto pratico. La vs. del mac è la 10.6.8.

Ho installato questo precompilato: WINE for Darwin and Mac OS X | Free software downloads at SourceForge.net (http://sourceforge.net/projects/darwine/)

Qualunque eseguibile faccio partire mi da errore di "java app launcher" terminato.

Se serve posso riportare il backtrace.

Non trovo le normali opzioni di wine, winecfg e quelle cose lì.

Mi togliete un po' di ruggine? :thx

Kirk78
19-12-13, 00: 30
Ciao Andy86,

anche io di mac so poco o nulla di quelli attuali (ultimi 10 anni :ehmm) ma mi sembra di capire che bisogna sapere se è un PowerPC Mac o un Intel Mac.
Inoltre vedo che bisogna vedere WinHQ, che ha anche una Wine Application Database - WineHQ - Wine Application Database (http://appdb.winehq.org/) - sopratutto se è un Intel visto che

All development now happens in WineHQ tree

Darwin pare che sia un prodotto un po' vecchiotto (2005).

Non so se può servirti questo commento

Thanks so much for the binary build of wine for Mac! I was not able to run the installer. But I found Wine.app in a hidden folder in the downloaded dmg. Drag-and-drop that app to /Applications and export /Applications/Wine.app/Contents/Resources/bin to PATH might probably be simpler than using the installer.

:bai

Andy86
19-12-13, 13: 00
:bai


Darwin pare che sia un prodotto un po' vecchiotto (2005).

Lo so che sei vecchietto e cecato, ma sta scritto proprio di fianco al download:



Last Update: 2013-08-16
Il database lo guardo sempre, anche perché wine lo utilizzo molto su linux.. http://forum.spaziogames.it/board/images/smilies/gamer.gif, però quel problema me lo fa con qualunque exe che ho provato.

Ho visto che ci sono altri precompilati, tipo winebottle, proverò anche con quello.

K.a.o.s.
20-12-13, 11: 02
C'è anche Wineskin ( link (http://wineskin.urgesoftware.com/tiki-index.php) ) che ti crea un .app che in realtà viene lanciato con Wine.

In aggiunta, se vuoi fare le cose "alla Linux" c'è HomeBrew ( link (http://brew.sh) ) che è un package manager che ti compila direttamente Wine da sorgente se vuoi :eye.

Andy86
20-12-13, 12: 22
:bai

Ieri ho provato winebottle e, almeno in parte, funziona.

Sono riuscito ad installare il programma, poi mi sono ritrovato con l'errore descritto al primo commento qui -> WineHQ - CorelDRAW 11 (http://appdb.winehq.org/objectManager.php?sClass=version&iId=1840&iTestingId=73743)

Ho visto che è dato "gold" con la vecchia versione 1.4.1, sempre dal sito di winebottle ho scaricato la 1.4 (la 1.4.1 richiedeva la 1.7 del mac), ma l'errore è rimasto.

Chissà perché quando c'è in giro un errore che colpisce una parte limitata di utenti io me lo ritrovo sempre tra i piedi... :wall

Dici che con quelli che mi hai suggerito cambia qualcosa? O magari se con homebrew riesco a compilare la 1.4.1 magari gira?

Ah, mi dovresti spiegare come si apre il terminale, perché non l'ho trovato, mi da un senso di limitatezza il mac, come se non lo potessi controllare. Vabbè, non sono abituato.
(e comunque mi devono spiegare perché hanno mappato tutti i vari "ctrl +" su "mela +" :whip)

K.a.o.s.
20-12-13, 12: 35
Ho visto che è dato "gold" con la vecchia versione 1.4.1, sempre dal sito di winebottle ho scaricato la 1.4 (la 1.4.1 richiedeva la 1.7 del mac), ma l'errore è rimasto.
La 1.7? Intendi la 10.7, ovvero Lion? Perché mi pare molto strano che Wine non supporti almeno Snow Leopard... sei sicuro?

Dici che con quelli che mi hai suggerito cambia qualcosa? O magari se con homebrew riesco a compilare la 1.4.1 magari gira?
Se un software non è compatibile con un sistema operativo, non riesci a compilarlo.


Ah, mi dovresti spiegare come si apre il terminale, perché non l'ho trovato, mi da un senso di limitatezza il mac, come se non lo potessi controllare. Vabbè, non sono abituato.O usi Spotlight, o usi lo stack "Applicazioni" o vai con il Finder in Applicazioni->Utility :eye.
Comunque fidati che è sempre così all'inizio quando cambi sistema operativo.

e comunque mi devono spiegare perché hanno mappato tutti i vari "ctrl +" su "mela +" :whipIo mi trovo molto meglio, ma è questione di gusti e abitudine. Poi ad esempio se usi il terminale e vuoi copiare qualcosa, non rischi di stoppare il processo :hap.

Andy86
20-12-13, 14: 00
La 1.7? Intendi la 10.7, ovvero Lion? Perché mi pare molto strano che Wine non supporti almeno Snow Leopard... sei sicuro?

Si, volevo dire la 10.7, non si è battuto lo zero. Ma infatti winebottle gira con la 1.6 e la 1.7.8 di wine; secondo me è il precompilato che è stato compilato per la 10.7, e sulla 10.6 non tornano le dipendenze. :m:

Anche perché sul link per il download c'è scritto anche "snowleopard", però quando apro quella specie di disco virtuale sull'applicazione appare un bel divieto e mi dice che richiede la vs. 10.7.

K.a.o.s.
20-12-13, 14: 19
e sulla 10.6 non tornano le dipendenze. :m:
La questione delle dipendenze è un po' diversa su Mac rispetto a Linux, non sono sicurissimo sia proprio la causa del problema in questo caso.


Anche perché sul link per il download c'è scritto anche "snowleopard", però quando apro quella specie di disco virtuale sull'applicazione appare un bel divieto e mi dice che richiede la vs. 10.7.


Sia con la versione in sviluppo che la stabile?

Andy86
20-12-13, 20: 22
:bai

Guarda che non c'è uno sviluppo per ogni versione, sono già quelle versioni, 1.7 per quella in sviluppo, 1.6 quella stabile, quindi la 1.4 è old-stable.
Pensavo ad un problema di chi ha compilato proprio perché è un paradosso che vada la 1.6 e non la 1.4 :boh

Comunque devo anche pensare all'ipotesi che il problema non sia la versione di wine ma qualcosa che gli va installato dentro.

K.a.o.s.
20-12-13, 22: 07
Guarda che non c'è uno sviluppo per ogni versione, sono già quelle versioni, 1.7 per quella in sviluppo, 1.6 quella stabile, quindi la 1.4 è old-stable.No mai io intendevo che magari la versione in sviluppo di WineBottler è stata compilata male, mentre quella stabile invece funziona :eye.


Comunque devo anche pensare all'ipotesi che il problema non sia la versione di wine ma qualcosa che gli va installato dentro.

Fai conto che in genere il divieto compare quando l'architettura è sbagliata o problemi del genere. Se mancasse qualche componente sarebbe andato in crash all'avvio o poco dopo, mentre quello è un controllo a livello molto superficiale.

Andy86
20-12-13, 22: 48
Infatti la seconda affermazione si riferisce al crash che avviene all'avvio del programma.
Il divieto ce l'ho solo con la 1.4.1, mentre la 1.4.0, la 1.7 e la 1.6 vanno e poi vanno in crash, come dicevo, con l'errore riportato nel primo di commento che si legge su winehq.
Per questo anch'io pensavo ad un problema di compilazione di quella versione.

K.a.o.s.
21-12-13, 15: 03
Avevo capito male la vicenda allora :hap.
Non ho molta esperienza con gli errori di Java. Controlla però che sia installato (in genere te lo chiede se installarlo se non lo è già) e la versione sia quella giusta (appunto, la 7 è incompatibile con la 6).

Andy86
21-12-13, 15: 22
:bai

Ma no, il problema non è più quello con cui ho aperto la discussione, è cambiato facendo prove. L'errore di java lo dava con darwine. Con winebottle invece è partito il setup, si è installato, e poi crashava all'avvio con questo errore:


Only registered members can view code.

Il trace dump credo sia uguale a quello riportato nei commenti del sito di wine (linkato prima) visto che anche l'errore è uguale.

--------------------------------

Comunque il sito di java dice che java 7 non c'è per il 10.6, mentre il java 6 s'installa con gli aggiornamenti di sistema e non c'è ne sono.

K.a.o.s.
21-12-13, 15: 37
Dato che su Mac (e Linux) non ci sono le .dll sembra più un problema di compatibilità/mancanza di rispettive dll. Magari se l'aggiungi a mano funziona :boh.