PDA

Visualizza versione completa : Wordpress NextGen Gallery problemi



provaprova
09-11-13, 10: 29
Ciao a tutti

sto avendo dei problemi con NextGen Gallery in Wordpress.

Praticamente delle vecchie gallerie è possibile vedere le immagini quando clicco sulla thumbnail, ma non le thumbnail.

Inoltre, quando creo una nuova galleria, il sito mi dice che le foto sono state caricate, ma tramite filezilla vedo che la cartella è vuota.

C'è un'altra cosa: le vecchie cartelle hanno permessi 777 e lo stesso proprietario, c'è anche la dicitura flcdmpe.
Ma la nuova galleria ha un proprietario diverso e la dicitura fle e non riesco a modificare nessun valore.

Sono davvero in grande difficoltà, anche perchè non riesco a trovare eventuali alternative a questo plugin e a me le gallerie servono molto.

Asterix
09-11-13, 11: 34
Ciao

premetto che non conosco bene il plugin

Praticamente delle vecchie gallerie è possibile vedere le immagini quando clicco sulla thumbnail, ma non le thumbnail

hai provato a ricreare le Thumbnails delle gallerie? vai in manage galleries -> seleziona la galleria e poi nel menù a tendina seleziona la voce Create new Thumbnails e poi premi sul tasto apply

Per il nome proprietario diverso non te lo so spiegare, ma se non riesci tramite ftp e se hai l'accesso tramite ssh prova da riga di comando.

:bai

provaprova
09-11-13, 11: 42
No, purtroppo non funziona.

Anche aggiornando le thumbnail.

E tramite ftp non riesco a modificare i valori della cartella.

Praticamente le thumb vecchie non si vedono, solo cliccando sulle foto, mentre le nuove gallerie non funzionano

Asterix
10-11-13, 10: 51
Ciao

hai già provato a cambiare i permessi dal cpanel, l'altra alternativa che vedo è quella di chiedere al tuo provider se tramite root forzano il proprietario e i permessi di quelle cartelle.

:bai

provaprova
10-11-13, 14: 42
Dato che negli ultimi tempi ci sono stati diversi problemi con i permessi di cartella,
dovrei, d'accordo con il mio provider, resettare tutto il sito, eliminare file e database, per fare un'installazione da 0

provaprova
23-11-14, 20: 15
Chiedo scusa se approfitto di questo up della conversazione.

Ho un altro problema con nextgen.

Purtroppo, quando clicco su una foto, non si apre il box (credo che si chiami fancybox), ma si apre l'immagine (quindi per tornare al sito bisogna cliccare su tasto indietro)

Kirk78
26-11-14, 18: 49
Prova a chiedere al provider se ha fatto dei cambiamenti da quanto hai riscontrato il problema. Oppure lo hai sempre riscontrato? Per tenere sottocchio i cambiamenti io mi salvo i risultati del phpinfo() ogni settimana / mese e scopro alle volte che ci sono stati dei cambiamenti a mia insaputa. Sei hai un hosting condiviso questo può succedere perché il provider deve ottimizzare per più utenti sullo stesso spazio.

Inoltre, questo è fondamentale, hai per caso aggiunto altri plugin o aggiornato Wordpress o dei suoi plugin poco prima che avvenissero i problemi con NextGen Gallery?

Anche io non conosco quel plugin (suppongo sia questo (https://wordpress.org/plugins/nextgen-gallery/))
Che versione dl plugin hai? L'ultima disponibile vedo è la V2.0.66.33 e che negli ultimi mesi vedo parecchi cambiamenti anche repentini.
E che versione di Wordpress?

Ricorda di farti sempre dei backup dal pannello di controllo (che sia cpanel o plesk o altro) sia del database oltre che dei file, sopratutto se devi aggiornare o aggiungere plugin. Consiglio inoltre di fare un'operazione alla volta perché altrimenti è difficile sapere quale operazione ha dato problema / errore e sarai costretto a disattivare piano piano tutti i plugin.


Backup Before Upgrading
Please consider backing up your site (both server files & MySQL Database) whenever updating plugins.

Ultimo consiglio: fai le prove prima offline! Anche se dovresti simulare esattamente le caratteristiche del tuo hosting... altrimenti poi online potrebbe non funzionare lo stesso.

:bai

EDIT - dal sito ufficiale:
What are the common errors in NextGEN Gallery? (http://www.nextgen-gallery.com/common-errors/)
What are the requirements to run NextGEN Gallery? (http://www.nextgen-gallery.com/requirements/)

provaprova
27-11-14, 15: 33
Ho le ultime versioni di entrambi.

DIciamo che è qualche settimana che ho questi problemi.
Provo a cancellare tutte le foto e il plugin e a ripristinare tutto manualmente

Kirk78
27-11-14, 16: 20
Ti consiglio vivamente i backup.
Se ce l'hai da qualche settimana dovresti ricordare cosa hai fatto prima dell'inizio dei guai. Questo ti aiuterà per il debug.
Facci sapere! :bai

Asterix
29-11-14, 07: 18
Ciao un'altra prova è quella di installare tutto in locale e fare una prova con wp e il solo plugin e vedere se funziona tutto, potrebbe essere anche una non compatibilità con un'altro plugin aggiornato di recente.

:bai

Kirk78
29-11-14, 11: 48
Esatto era infatti, in breve, l'ultimo mio consiglio

Ultimo consiglio: fai le prove prima offline! Anche se dovresti simulare esattamente le caratteristiche del tuo hosting... altrimenti poi online potrebbe non funzionare lo stesso.
Il problema è che da hosting a locale bisognerebbe, come detto, simulare esattamente le caratteristiche dell'hosting, visto che alcune variabili, moduli installati o addirittura versioni di PHP, Apache o php se sono diverse potrebbero far uscire errori diversi.
Facci sapere se hai risolto e, cortesemente, condividere come :fleurs

:bai