PDA

Visualizza versione completa : Dolphin non si accorge che la copia del file è terminata



Andy86
23-09-13, 21: 25
:bai

Ultimamente quando faccio copia e incolla di un file devo fare stop a mano quando ha finito perché sembra non accorgersene.

Cioè, arriva a questo punto e si ferma lì in attesa perenne:

http://images.collectiontricks.it/images/92072909840604076983.png

Ah, cosa fastidiosa lo fa anche quando devo copiare più file, finisce il primo file e non comincia con il secondo se non faccio stop e poi riprendo saltando i file già copiati.

pierino_89
23-09-13, 22: 05
A me in genere si "addormenta" quando copio in rete, ma dopo un po' si riprende sempre. Non credo che sia un comportamento molto sano quello di "stopparlo", rischi che ti perda pezzi di file.

Andy86
23-09-13, 23: 14
Allora potrebbe essere un problema della copia su chiavetta/drive esterno? :m:

Pezzi di file non ne perde, perché il file è già copiato tutto, lo apro prima di stopparlo, non è nemmeno in uso.

Se aspetto che si riprende da solo ci mette una vita in più a finire la copia. :sisi

pierino_89
23-09-13, 23: 32
Non saprei dirti. Hai provato a lanciare "sync" a mano al termine della copia?

Andy86
23-09-13, 23: 39
La prossima volta provo. :thx

Andy86
07-10-13, 00: 14
:bai

Niente da fare neanche con sync. Rimane bloccato anche lui finché dolphin non si sveglia. :wall

pierino_89
07-10-13, 00: 24
Allora il problema non è di kde, ma del kernel o addirittura hardware. Anche perché "sync" chiama la system call omonima e basta, a livello più basso non si può andare.

Andy86
07-10-13, 13: 29
:boh

Il Kernel ho il 3.10.10-3 :m:

Ora non ricordo se lo facesse anche con il pc vecchio.

La butto lì... potrebbe essere un problema dell'hub?

pierino_89
07-10-13, 13: 44
Assolutamente sì... Prova a toglierlo e vedi se fa la stessa cosa.

Andy86
28-10-13, 17: 01
Forse è davvero l'hub... oggi non stava connesso il cellulare, così mi sono ricordato di provare senza hub, e non ha fatto il problema. :m:
Mi dispiace d'aver comprato una cinesata, ma se è davvero quello... meglio.

Andy86
31-10-13, 19: 26
Di peggio in male... ora non si smontano più le chiavette, anche senza hub, dopo aver terminato a mano la copia, anche forzando con sudo umount, non si smonta, con lsof non risulta nessun file in uso, ma non si smonta, e se la tolgo senza smontarla il file appena copiato risulta corrotto, mentre prima di toglierla risultava interamente visibile.

L'unica soluzione è stata quella di riavviare, in modo che spegnendosi è riuscito a smontarla bene.

Stessa storia con due chiavette diverse. :boh

pierino_89
01-11-13, 19: 59
E col comando sync che fa?

Andy86
01-11-13, 20: 06
Faceva la stessa storia solita. Comando sync bloccato. Oggi invece tutto normale. :boh

Ah, però quando non da problemi non provo sync... non so se magari il suo di comportamento resta lo stesso. :m:

Andy86
16-11-13, 21: 18
:bai

Oggi problema della copia infinita anche senza hub in mezzo.

Comincio a pensare che sia un problema del filesystem fat, magari solo di alcune chiavette, devo vedere se lo fa sempre con la stessa, anche perché ho scoperto che quando fa il problema che non si smonta si può risolvere con "dosfsck /dev/sdax -aw", corregge un po' di errori e poi dopo si smonta benissimo. :sisi

Ci sto facendo caso adesso che forse la sd del cellulare ha smesso dopo che la ho formattata, che poi non ha neanche più dato problemi di perdita file per strada come prima, avrebbe senso. :m:

Kirk78
17-11-13, 17: 46
A me il problema lo fa anche quando copio da registratore multimediale (firmware linux based) a pendrive USB. Per farla "rifunzionare" devo ogni tanto fare il check della penna (che sia su linux o win) o formattarla. Intanto, per me, è solo una pendrive "temporanea".

Su slax (liveCd) questo problema non l'ho mai avuto da HDD a USB, finisce sempre la copia, anche mi accorgo che l'ultima parte dell'ultimo file ci mette più tempo dei precedenti file :boh ma attendo buono buono e completa l'operazione. Su slax tra l'altro posso anche copiare più cartelle contemporaneamente da HDD a USB anche se non ha finito la copia precedente. Alle volte mi da errore quando copio alcuni tipi di file windows... ma quello è colpa di win non certo di linux!

Io non uso mai, però, hub usb.

Fortuna che il buon pierino_89 mi ha insegnato che esisteva la (I) per vedere le operazioni che stava effettuando altrimenti non mi accorgevo quando finisce.

:bai

Andy86
17-11-13, 18: 44
Su slax tra l'altro posso anche copiare più cartelle contemporaneamente da HDD a USB anche se non ha finito la copia precedente.

Si, però se copi dallo stesso hdd alla fine rallenta perché deve saltare continuamente tra un file e l'altro, e i tempi di accesso degli hdd, si sa, sono proverbiali. Invece mettendo in pausa tutto tranne una e riprendendone una per volta man mano che una finisce ci mette meno tempo. :sisi

Andy86
08-12-13, 17: 05
:bai

Oggi ho aperto un'altra discussione qui http://www.collectiontricks.it/forum/hardware-reti/Ct5484-strano-problema-file-system-fat.html, poi mi sono reso conto che forse sto inseguendo lo stesso problema. :ehmm:wall

Ho fatto la prova a montare con async... non sembra che cambi molto.

pierino_89
08-12-13, 17: 35
Async è il comportamento predefinito... Semmai dovresti usare sync. Dopo leggo l'altra discussione.

Andy86
08-12-13, 20: 47
Ah, con sync si che va davvero lento... :ghgh
Si vede che prima è andato lento per la solita storia.
Stavo provando anche con un altra chiavetta... ha fatto lo stesso il problema, che siano proprio i file grossi? :boh

pierino_89
08-12-13, 20: 57
Beh, le chiavette di solito non sono un razzo, se non hanno super certificazioni è normale che vadano lente.

Andy86
08-12-13, 21: 23
È una verbatim. Con async raggiunge anche i 50mb/s per secondo.
Con sync sta sui 250kb/s. :shock

Ora mi è venuto in mente che alcune chiavette di default avevano un flag attivato, mi pare LBA, ho provato a metterlo e alla prima prova (montata default) è andata a razzo, salvo poi bloccarsi alla fine... seconda prova invece solo 4mb/s... :boh

Ho provato con dd, per vedere se dal terminale mi dava un errore di qualche tipo, non ha detto niente, ma una volta che il file era copiato per intero (ed apribile) il comando non è terminato subito, ma dopo un po', come al solito.

pierino_89
08-12-13, 21: 43
È una verbatim. Con async raggiunge anche i 50mb/s per secondo.
Con sync sta sui 250kb/s. :shock

Per forza, con async non lo scrive davvero. La velocità reale è sempre quella con sync. Ci sono alcune chiavette che hanno un comportamento così brutale che non scrivono assolutamente NIENTE finché non vengono smontate. E sembrano un razzo, fino a quando non devi toglierle :ghgh



Ora mi è venuto in mente che alcune chiavette di default avevano un flag attivato, mi pare LBA, ho provato a metterlo e alla prima prova (montata default) è andata a razzo, salvo poi bloccarsi alla fine... seconda prova invece solo 4mb/s... :boh

Un flag de che? LBA è roba dei vecchi hard disk che si metteva nel bios, non mi sembra molto correlato :tong2

Andy86
08-12-13, 23: 32
Allora magari è per quello che non finisce la copia... sta ancora scrivendo. :bsh

Adesso sta ancora ricopiando il backup, ci sta mettendo una vita... domani provo il sync con questa chiavetta perché mi sono accorto che prima l'ho provato su un altra chiavetta di ben altra marca (maxell, quale?!?, maxell, mai sentita prima).