PDA

Visualizza versione completa : Hard Disk esterno... funziona su Ubuntu ma non su Windows



DeST
11-03-13, 20: 36
Salve a tutti,
non so se il problema sia software o hardware... spero di aver scelto la sezione adatta
ho un HD esterno [box multimediale S-tech Hard Disk Maxtor da 500gb] che si comporta in maniera strana, riproduce correttamente il contenuto e funziona correttamente come unità di memoria sul mio notebook con Ubuntu, ma non ne vuole sapere di funzionare con Windows XP sp3 che ho sul fisso

Ecco le operazioni che ho già provato:
Non lo collegavo al pc da un paio di anni, appena collegato alla porta usb windows indica il messaggio della periferica riconosciuta e driver correttamente installati ma non spunta nulla in risorse del computer e appena provo ad aprire un programma o il gestore periferiche si blocca inesorabilmente il sistema costringendomi a riavviare forzatamente...
Collego quindi l'HD al mio notebook con Ubuntu e il tutto funziona perfettamente, salvo quindi i dati importanti sul portatile e con gparted formatto l'HD sperando così di risolvere i problemi su windows (fat32 è il formato richiesto dal box multimediale)

Collego l'HD appena formattato a windows, ma... stessi problemi. Penso che possano essere le porte usb visto che uso le frontali del case, ma provando quelle dirette sulla scheda madre... non lo vedono proprio, come se non collegassi nulla.
Immaginando che il problema possa essere il box multimediale, estraggo l'hd dal box e lo collego direttamente al pc con un adattatore sata->usb al computer... Nulla è cambiato stessi problemi come in partenza...

Quale può essere il problema?? è possibile che ubuntu non crei correttamente il filesystem fat32?
come mi consigliate di procedere?

Grazie :bai

Pegaso
11-03-13, 21: 24
Hai provato a collegarlo a un altro pc che monti Windows?

DeST
12-03-13, 18: 27
ho provato a collegare l'hd al pc di una mia amica con windows xp e lo ha riconosciuto... quindi il problema è il pc fisso! :/
Premetto che agli albori dell'acquisto dell'hd lo usavo principalmente sul pc fisso che ora non vuole riconoscerlo... ho provato a ripulire i driver installati con drivercleanup, ma collegando l'hd ricevo sempre i stessi risultati (installazione dei driver corretta ma niente in rirorse del computer)

Quale sarà la causa del problema??

Pegaso
12-03-13, 20: 56
Non saprei che altro suggerire perchè quello che pensavo (la pulizia dei driver) lo hai già fatto. :-(
Io avevo avuto un problema che non mi riconosceva la penna usb http://www.collectiontricks.it/forum/software/Ct4740-penna-usb-non-visualizzata.html ma il tuo problema è che non ti permette nemmeno di arrivare alla gestione periferiche e questo è molto strano.

Armandillo
12-03-13, 23: 17
In rete ho letto che il problema potrebbe essere la mancata assegnazione di lettera di unita' e che per risolvere dovresti digitare in Start_Esegui_ diskmgmt.msc
All'interno della finestra poi cercare l'harddisk esterno e vedere se ha una lettera assegnata o se questa e' gia' presente.
Nel caso fosse presente rimuovere il doppione e poi darne una diversa.Nel caso non fosse presente, aggiungerla.

:bai

Andy86
12-03-13, 23: 35
dovresti digitare in Start_Esegui_ diskmgmt.msc

Che poi sarebbe uguale che fare click destro su risorse del computer -> gestione -> gestione disco. :ghgh

Indubbiamente sapere i nomi a memoria ti risparmia tempo. :hap

Comunque i sintomi corrispondono abbastanza... sapendo anche che alle volte windows tenta di memorizzare i device rimovibili per assegnarvi a sua volta la stessa lettera (in modo che, teoricamente, se uno crea dei collegamenti, questi restano), ma tra il dire e il fare c'è di mezzo... microsoft, e questo comportamento finisce spesso per generare conflitti e conseguenti device fantasmi. :sisi

Armandillo
13-03-13, 00: 00
Mi chiedevo se avviando la console di ripristino dal cd di Xp potesse visualizzare quell'harddisk :m:

Andy86
13-03-13, 13: 30
La console di ripristino visualizza solo hdd dove siano presenti installazioni di windows da essa riconosciute. :ghgh :boh

calaf
13-03-13, 18: 45
E' un 3,5" o 2,5" ? Si vede da: Start> Strumenti di amministrazione> Gestione computer> Gestione disco?
Con cosa lo hai riformattato? Hai controllato nel Bios sia disabilitato qualcosa nella sezione di boot?

Armandillo
13-03-13, 19: 45
La console di ripristino visualizza solo hdd dove siano presenti installazioni di windows da essa riconosciute. :ghgh :boh

Per la precisione la console non puo' essere utilizzata per unita' rimovibili, ma per ogni harddisk anche se non e' installato un sistema operativo.

Andy86
13-03-13, 21: 12
:bai

Si, beh, solo che poi quando la attivi ti chiede di selezionare un installazione di windows sulla quale eseguire le riparazioni, e non mi pare di ricordare un comando per elencare i dischi presenti. :m: :boh

DeST
14-03-13, 12: 02
allora l'HD è un 3.5"
ho provato a collegare nuovamente l'hd per poi aprire la console di gestione periferiche sia da risorse del computer che dal comando in esegui, ma il pc si blocca appena cerco di aprirli... non facendo funzionare nemmeno ctrl-alt-canc
ho provato a mantenere la finestra della gestione periferiche aperta per poi collegare l'hd ma quando cerca di aggiornare le informazioni nuovamente si blocca... e sono costretto a riavviare dal pulsante queste prove le ho fatte con tutte le porte usb frontali (sono 3)
sulle porte della scheda madre (4) invece non c'è la benchè minima reazione del sistema al collegamento dell'hd come se non facessi nulla... le porte però funzionano perchè le uso anche per stampante, chiavetta wifi e webcam :(

Andy86
14-03-13, 14: 12
:bai

A questo punto proviamo a far pulizia direttamente dal registro di sistema, almeno quello non dovrebbe bloccarsi.

Vai su HKLM//System//CurrentControlSet//MountedDevices dovrebbero esserci tutta una serie di voci che iniziano per \??\, cerca tutte quelle che nel nome hanno RemovableMedia o qualcosa che possa assomigliare al tuo hdd, e cancellale.

Attento a non cancellare le voci che iniziano per \??\Volume perché potresti cancellare i riferimenti alle unità disco interne o alla partizione di sistema.

Controlla anche se tra i vari \DosDevice\X: ci sono delle lettere doppie, e casomai cambiale o toglile.
Queste sono le lettere "occupate" dai vari dispositivi, se ne togli alcuni dispositivi al successivo avvio rimarrano senza lettera, se le cambi (sempre dopo aver riavviato) i dispositivi cambieranno lettera di conseguenza.

Armandillo
14-03-13, 18: 01
Si, beh, solo che poi quando la attivi ti chiede di selezionare un installazione di windows sulla quale eseguire le riparazioni, e non mi pare di ricordare un comando per elencare i dischi presenti. :m: :boh

Breve OT....scusate.

Diskpart consente di gestire partizioni su volumi di disco rigido. L'opzione /add consente la creazione di una nuova partizione. L'opzione /delete consente di eliminare una partizione esistente. La variabile periferica è il nome della periferica per una nuova partizione, ad esempio \periferica\discorigido0. La variabile unità è la lettera di unità di una partizione da eliminare, ad esempio D. La variabile partizione è il nome basato sulla partizione della partizione da eliminare, ad esempio \periferica\discorigido0\partizione1 e può essere utilizzata al posto della variabile unità. La variabile dimensione è la dimensione in megabyte di una nuova partizione.

Format consente di formattare un disco. L'opzione /q consente di eseguire una formattazione rapida. L'opzione /fs consente di specificare il file system.




Map consente di visualizzare i mapping delle periferiche correntemente attive. Includere l'opzione arc per specificare l'utilizzo di percorsi ARC (Advanced RISC Computing), ovvero il formato per Boot.ini, anziché di percorsi di periferiche di Windows.

Andy86
14-03-13, 18: 20
:bai

Ma diskpart non era di win98? :m:

DeST
15-03-13, 12: 09
bè l'utility che ho usato prima di collegare l'hd (drivercleanup) non fa altro che rimuovere tutte le voci di registro che si riferiscono ai dispositivi rimovibili... praticamente la stessa operazione che hai descritto ma automatica... infatti mi trovo solo le chiavi dell'hd e del masterizzatore...

secondo voi se faccio una passata con sfc /scannow potrei risolvere il problema??
la cosa strana è che il pc funziona benissimo in tutto il resto ma questo hd non lo vuole proprio vedere!!

DeST
24-03-13, 23: 24
ho letto di un metodo per risolvere problemi con le porte usb... praticamente ho completamente disinstallato tutti gli hub usb di sistema e i driver usb della scheda madre (dalla gestione periferiche in modalità provvisoria), per poi reinstallare il tutto dopo il riavvio del sistema in seguito alle singole richieste del plug-n-play
Inutile dire che non è praticamente cambiato nulla, ho però scoperto che una delle 4 porte usb della scheda madre (l'unica libera, praticamente quella che non reagiva con l'hd esterno) sembra non funzionare con nessun dispositivo nemmeno con una pendrive... :/
i problemi invece di diminuire aumentano... :cry3 appena posso proverò una live ubuntu per escludere possibili problemi hardware

Andy86
24-03-13, 23: 52
ho però scoperto che una delle 4 porte usb della scheda madre (l'unica libera, praticamente quella che non reagiva con l'hd esterno) sembra non funzionare con nessun dispositivo nemmeno con una pendrive... :/

Ma a questo punto hai provato l'hdd in un altra porta?

:notte:

Armandillo
25-03-13, 00: 05
:bai

Non so se potra' esserti utile....... ma dopo aver installato un ssd e averci messo il SO (Seven) ho dovuto fargli riconoscere l'harddsik esterno usb che usavo come magazzino e che conteneva una precedente immagine completa di sistema, quello che avevo prima.
Ebbene l'harddsik si bloccava dopo una eterna lettura dei files che ivi erano stati copiati :triste
Quindi sono stato costretto ad usare un altro pc con Xp per poterlo leggere.
L'ho fatto e con Xp tutto filava liscio e leggeva anche molto veloce.
Allora ho pensato bene di cancellare ogni voce attinente Seven compresa l'immagine di backup....ha cancellato tutto ma non l'immagine :cry3
Quindi mi sono deciso ad adoperare una distro Linux con la quale ho potuto eliminare tutto :sisi
Ho quindi ricollegato l'harddisk a Seven che ha cominciato a leggerlo ma sempre lentamente e qui mi sono accorto di una cartella ".Trash" che prima non c'era e che probabilmente era stata creata dalla distro Linux :m:

Dopo vari tentativi (ho provato anche con Killbox) sono riuscito ad eliminarla forzando le autorizzazioni per l'amministratore di sistema ed infatti, dopo, l'harddisk si leggeva e si legge correttamente e senza sbavature.

Ti ho raccontato questo perche' probabilmente il tuo problema potrebbe dipendere dalla formattazione eseguita con GParted anche se vale sempre la legge che dice che..."se due computer sono assemblati esattamente con gli stessi componenti ed hanno gli stessi SO e gli stessi programmi e sono adoperati dalla medesima persona, nello stesso modo, nello stesso luogo, non e' detto che un problema uguale abbia una eguale soluzione..." :ghgh

Buona fortuna :bai

DeST
25-03-13, 00: 15
Inizialmente avevo già pensato ad un possibile problema con gparted, ma visto che su un altro pc con xp funziona bene l'ho escluso... inoltre ho riformattato l'hd con il sistema Windows che lo riconosceva escludendo del tutto questa possibilità...ma senza risolvere il problema

L'hd per ora purtroppo non posso provarlo su un altra porta perché l'ho usato vicino ad una smart tv che lo ha formattato in un file system sicuramente non gestibile fa Windows, appena potrò usare il pc della mia amica per riportare l'hd in fat32 effettueró le dovute prove...