PDA

Visualizza versione completa : Applicativi Nuovo plug-in pdf integrato in firefox... pessima impressione. Si può disattivare?



Andy86
04-03-13, 21: 52
:bai

Come anticipato dal buon Kirk78 nella discussione degli aggiornamenti, dopo che firefox si è aggiornato all'ultima vs., sia per win che per kde, si è portato dietro un visualizzatore pdf integrato che si è sostituito sia a okular, sia a foxit reader senza chiedere, nemmeno funzionasse meglio.

La prima impressione che ho avuto è stata di essere tornato ad acrobat reader... :shock
Con i pdf grossi non è per niente fluido ed è lento e scattoso a caricare le pagine. :boh

Come se non bastasse su linux mi sballa pure i caratteri, i pdf appaiono come se fossero scritti in cinese o roba del genere.

Ma il problema più grosso è che sembra non esserci modo di tornare alla situazione iniziale, questa funzione non è presente tra i plug-in, e solo selezionabile nella finestra delle associazioni dei file, ma se associo un altro programma il file viene scaricato e non più visualizzato all'interno del browser. :furious

wrongway
05-03-13, 07: 28
:bai
prova a vedere qui (support.mozilla.org/it/kb/Aprire i documenti PDF con Firefox) (da "Verificare le impostazioni dell'applicazione" in poi)

Kirk78
05-03-13, 18: 21
Il link specifico per la versione 19 è https://support.mozilla.org/it/kb/Aprire%20i%20documenti%20PDF%20con%20Firefox#os=wi nxp&browser=fx19

https://support.cdn.mozilla.net/media/uploads/gallery/images/2012-01-26-11-41-09-c0a131.png

Adesso non ho la 19 sottomano ma se non erro dovrebbe essere su Strumenti -> Opzioni -> Applicazioni -> Adobe Acrobat Document io ho messo chiedi ogni volta, ma puoi scegliere quello che vuoi (sulla 18).

:bai

Andy86
05-03-13, 22: 27
:bai

A me usa le impostazioni di "pdf (portable document format)", ho messo okular, ma continua a scaricare il pdf per aprirlo con okular invece di visualizzarlo nel browser, ho seguito tutte le istruzioni del link, ma la storia non cambia. :boh

Domani (tempo permettendo) proverò su win, vediamo se foxit reader riesce ad imporsi su FF.

Kirk78
05-03-13, 22: 35
Prova a mettere "Chiedi ogni volta" sulle opzioni e facci sapere. Ma il tipo di contenuto dovrebbe essere Adobe Acrobat Document non so cosa sia il portable document format ma forse è l'indicazione su linux. :boh
Non ho sottomano linux, sorry. :bai

Andy86
05-03-13, 22: 54
:bai

Ti chiedi cos'è il Portable Document Format? Prova a leggere le iniziali. :tong2

Nel link indicato da wrong si legge chiaramente:



Cercare la voce Portable Document Format (PDF) nell'elenco e fare clic per selezionarlo.


Comunque ho provato con quello indicato da te, ma non cambia nulla, continua a rispettare quello che c'è in "** (PDF)".

Kirk78
06-03-13, 00: 25
Come dicevo è probabile che sia la dizione per linux :bleh ma l'immagine che ho inserito è quella presa da Mozilla per la versione 19.x.
Non capisco cosa vuol dire

quello che c'è in "** (PDF)".
puoi postare l'immagine di opzioni -> applicazioni come da figura presa dal sito Mozilla per la versione 19.x (il link di wwong specifico per la versione 19)?
Domani magari ci do uno sguardo :notte:

:bai

Andy86
06-03-13, 14: 38
Come dicevo è probabile che sia la dizione per linux :bleh

No. È la dizione di Adobe. :ghgh

Infatti in win ho appena risolto mettendo:

2410

:tong2

Kirk78
06-03-13, 16: 56
Come appunto ti avevo detto io :sisi, difatti puoi scegliere ciò che vuoi. Anche io ho Foxit Reader (predefinito) ma prefersco scaricarli e poi vederli o comunque decido io scegliendo "Chiedi ogni volta".
Su linux non funziona la stessa cosa? Comunque io non ho installato Adobe e mi mette con il nome Adobe (anche se con l'icona di Foxit reader) esattamente come sul sito di Mozilla http://images.collectiontricks.it/images/78344308939899464600.jpg (http://images.collectiontricks.it/) :boh

:bai

Andy86
06-03-13, 17: 12
No. Tu avevi detto sotto "adobe acrobat document", io invece le scelte di foxit reader li vedo sotto "portable document pdf", sotto Adobe c'è solo chiedi ogni volta, ma non mi ha mai chiesto. Poi comunque adobe reader sono anni che non lo uso più. :boh


Il Portable Document Format, comunemente abbreviato PDF, è un formato di file basato su un linguaggio di descrizione di pagina sviluppato da Adobe Systems nel 1993 [...]

Comunque sotto linux non vedo la possibilità di usare okular in firefox, continua a scaricare il .pdf per poi aprirlo esternamente.

Kirk78
08-03-13, 19: 25
Ancora questa non-fonte wkp :tong2. Comunque da win mi aspetto che ci siano queste stranezze tra un pc ed un'altro perché io come PDF non ho nulla solo Adobe... che tra l'altro non ho più installato da parecchio :boh

Non ho idea cosa sia ma ho trovato https://github.com/afrimberger/okularplugin ... non mi prendo responabilità però perché non l'ho mai provato e non ho sottomano la macchina linux :ehmm

:bai

P.S. Ah, dimenticavo Foxit Reader Plugin 2.2.1.530 and below è stato bloccato per la tua protezione (https://addons.mozilla.org/it/firefox/blocked/p250) non so quale versione hai. Io ho la 2.2.3.111 che non ha problemi.

Andy86
09-03-13, 12: 26
:bai

Mi hai dato l'idea giusta... ho cercato okular tra i pacchetti disponibili per l'installazione e ho trovato kpartsplugin.

Non so se era quello che c'era anche prima, se si non capisco perché sia sia rimosso in automatico, comunque viene visto da firefox ed apre i pdf in okular.

La stranezza di turno è che kpartsplugin si è impostato come predefinito su adobe acrobat document, ma naturalmente non funzionava, così ho dovuto impostarlo per pdf.:boh


ha dimenticavo

:znc


non so quale versione hai. Io ho la 2.2.3.111 che non ha problemi.

Penso di avere aggiornato pure io... comunque poi verifico. :sisi

Kirk78
09-03-13, 14: 18
Sono contento che ti ho dato l'idea per risolvere :sisi, mi innorvesiscono i problemi irrisolti :triste

Importante, è che pochi lo pensano, è fondamentale aggiornare anche Foxit Reader: non è che se non utilizzate quel pesante Adobe Reader non è necessario aggiornare anche Foxit. I problemi di sciurezza dei PDF è noto... sopratutto su win :eye

:bai


ha dimenticavo
Intendevo Ah, dimenticavo :tong2 mi scusi Professore non lo farò più :lol: è il cane che mi ha mangiato i compiti ... e gli occhiali :ghgh

Andy86
09-03-13, 15: 55
:bai


comunque poi verifico. :sisi

Verificato, ho anch'io l'ultima. :hap

ps: comunque correggi quella citazione, così sembra che l'ho scritto io. :whip

Kirk78
09-03-13, 17: 23
ps: comunque correggi quella citazione, così sembra che l'ho scritto io. http://www.collectiontricks.it/images/smilies/whip.gif

L'ho scritto nel commento, mi sembrava doveroso :fleurs

Oggi alle 14: 21. Motivo: Foxit - correzione per Andy86 :-)

Lo so che tu sei bravo anche sui plugin, ma è meglio dirlo a tutti. Metterò una nota anche sul thread sugli aggiornamenti del Firefox (attuale 19.0.2).

:bai