PDA

Visualizza versione completa : Non sale KDE (in dmesg errore di udev)



Andy86
24-02-13, 17: 32
:bai

Improvvisamente non sale più kde, ieri funzionava tutto bene, oggi avvio, fa il suo bel caricamento grafico con i 4 pallini e poi invece del load di kde appare il tty.

La prima cosa che mi è venuta in mente è stata guardare il log di sistema, e che ci trovo?
Un bell'errore di udev...

http://images.collectiontricks.it/images/05733028626538473669.jpg

pierino_89
24-02-13, 17: 56
Posta /var/log/Xorg.0.log, tanto se non sale la grafica è un problema di X a priori. Poi vediamo perché udev si è offeso :ghgh

Andy86
24-02-13, 18: 57
Però lo apro da win che se no a riportare tutto non me la cavo più...

Edit: Anzi, te lo allego perché se no mi sballa i ritorni a capo... :ghgh

K.a.o.s.
24-02-13, 20: 38
Prova a rinominare i file
.xinitrc nelle home (root e il tuo utente) in .xinitrc.old

Andy86
24-02-13, 23: 32
:bai

Sembra che io non abbia quei file. :boh

pierino_89
25-02-13, 01: 44
Hai provato ad avviare gdm/gdm3? A vedere il log sembrerebbe che non abbia neanche provato ad avviare X.

@Kaos: .xinitrc vale solo quando lanci "startx", non quando usi un display manager. A meno che non sia in /etc/X11 :eye

Andy86
25-02-13, 13: 51
:bai

Gnome neanche c'è l'ho più installato, però ho dato:

http://images.collectiontricks.it/images/53191928385477980344.png

(Si vede che non sono capace di far foto? :triste, purtroppo alcuni comandi non permettono di essere ridirezionatati su file di testo.)

Pare che si sia disinstallato X... :shock

Ora che faccio?

K.a.o.s.
25-02-13, 14: 04
Pare che si sia disinstallato X... :shock

Ora che faccio?Reinstallalo :ghgh in genere c'è un metapacchetto che ti rimette tutto. Probabilmente si è tolto con qualche disinstallazione.

Andy86
25-02-13, 14: 31
Non è che mi potreste dire come si chiama questo metapacchetto?
Io ci ho provato, ma non ho concluso nulla. :ehmm

pierino_89
25-02-13, 14: 51
Suppongo si chiami xorg-server, o qualcosa del genere.

Andy86
25-02-13, 15: 50
:thx, a xorg non ci avevo pensato.

sudo apt-get install xorg ha risolto.
Mancavano ben nove pacchetti di xorg (:shock) e la loro installazione ha richiesto la rimozione del kernel 3.2.0.37... :m: :boh

K.a.o.s.
25-02-13, 17: 51
Avevi tolto qualcosa con autoremove? Spesso è lui la causa.

PS: no ma poi Ubuntu mi dicono che è stabile -.-

pierino_89
25-02-13, 18: 03
Avevi tolto qualcosa con autoremove? Spesso è lui la causa.
Fosse deborphan capirei, ma autoremove che ti tolga il server X... La scimmia delle dipendenze è in ferie? :ghgh



PS: no ma poi Ubuntu mi dicono che è stabile -.-
:lol: non dirlo a me che ho dovuto reinstallare un server ubuntu (stavolta con debian) neanche un mese fa.

Andy86
25-02-13, 20: 59
:bai

No, niente autoremove. Ho solo fatto gli aggiornamenti che mi ha segnalato l'updater grafico. Ultimamente si aggiorna qualcosa praticamente ogni giorno.

Non vorrei fosse quel kernel che si è aggiornato a causare la rimozione di xorg... e spiegherebbe perché è stato contrassegnato come da rimuovere... o no?

K.a.o.s.
26-02-13, 01: 19
Se un pacchetto del kernel rimuove Xorg allora sono veramente... "Furbi"
Prova a guardare i log di apt.

In ogni caso, immaginate un utente comune... queste cose non devono proprio accadere.

Andy86
26-02-13, 19: 44
:bai

Questo è ciò che credo riguardi gli aggiornamenti di sabato, ovvero la sessione prima del patatrack:


Only registered members can view code.

Sembra che sia stato "mezzo-installato"... che significa?