PDA

Visualizza versione completa : SD del nokia perde i permessi di scrittura



Andy86
29-07-12, 20: 00
:bai

Da ieri succede una cosa strana... quando sto copiando dei file dal pc sulla sd del nokia collegato in archiviazione di massa, e quindi montata come un disco esterno, dopo un po' di tempo perde i permessi di scrittura, le voci "crea" e "incolla" di dolphin diventano in grigetto, viene finito di essere scritto ciò che è già in scrittura e poi il file dopo viene rifiutato.

Apparentemente non ha alcun senso logico... c'è qualche prova che posso fare per identificare la causa del problema?

pierino_89
29-07-12, 21: 52
Secondo me si pianta qualcosa e la rimonta in sola lettura. Controlla con "mount -l" se è così, o se effettivamente per qualche motivo cambi la proprietà dei file.

Andy86
30-07-12, 15: 02
:bai

Rimane in rw anche dopo che i comandi passano in grigetto. Sembra impedisca il secondo tentativo dopo un errore di scrittura.
Ma perché si verifica l'errore su di una sd? :boh

/dev/sdb1 on /media/186B-0AF8 type vfat (rw,nosuid,nodev,uid=1000,gid=1000,shortname=mixed ,dmask=0077,utf8=1,showexec,uhelper=udisks)

pierino_89
30-07-12, 16: 11
:bai

Rimane in rw anche dopo che i comandi passano in grigetto. Sembra impedisca il secondo tentativo dopo un errore di scrittura.

Prova a fare uno spostamento da terminale dopo che si incarta, magari ci dà qualche errore sensato.



Ma perché si verifica l'errore su di una sd? :boh

Blocchi danneggiati, filesystem corrotto (con fat basta che smonti male due o tre volte il disco e addio), problemi con il lettore di sd, ecc...



/dev/sdb1 on /media/186B-0AF8 type vfat (rw,nosuid,nodev,uid=1000,gid=1000,shortname=mixed ,dmask=0077,utf8=1,showexec,uhelper=udisks)
Da qua sembra che i permessi siano giusti e i proprietari pure. Ed è in rw. A sto punto penso che otterremo un fantastico generico "IO error" :ghgh

Andy86
30-07-12, 17: 37
:bai

Il terminale dice semplicemente ciò che dice dolphin, ovvero:

andre@lepre:/media/186B-0AF8$ mkdir prova
mkdir: impossibile creare la directory "prova": File system in sola lettura

ciò nonostante stando a mount -l il filesystem è ancora in rw. :boh

pierino_89
30-07-12, 19: 10
Lancia "dmesg | tail" quando succede il blocco.

Andy86
30-07-12, 20: 02
:bai

Eccolo là... ma che significa? :ohoh

andre@lepre:~$ dmesg | tail
[ 1833.467597] sd 6:0:0:0: [sdb] No Caching mode page present
[ 1833.467601] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[ 1833.469845] sd 6:0:0:0: [sdb] No Caching mode page present
[ 1833.469850] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[ 1833.867198] sdb: sdb1
[ 1833.869971] sd 6:0:0:0: [sdb] No Caching mode page present
[ 1833.869976] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[ 1833.869980] sd 6:0:0:0: [sdb] Attached SCSI removable disk
[ 1871.280601] FAT-fs (sdb1): error, fat_get_cluster: invalid cluster chain (i_pos 0)
[ 1871.280606] FAT-fs (sdb1): Filesystem has been set read-only

pierino_89
30-07-12, 20: 23
Zac, è proprio un problema di file system :ghgh.
Ora non so cosa voglia dire di preciso, però direi di fargli un bel check (e magari riformattare la scheda).

Andy86
30-07-12, 20: 46
Risultato del check:


Only registered members can view code.

Ora sembra funzionare bene, ed è anche più veloce nel montaggio. :sisi

Andy86
04-08-12, 19: 53
:bai

Invece non avevo notato le ultime due righe:

Leaving file system unchanged. /dev/sdb1: 1818 files, 891723/1935671 cluster

Però ho risolto definitivamente con lo scandisk da windows, che ha corretto tutto senza fermarsi.
Ora quel problema là non succede più. :sisi