PDA

Visualizza versione completa : Windows XP xp si riavvia continuamente



poniboy
17-03-12, 16: 03
ciao a tutti
era un pò troppo tempo che ero tranquillo :-)
mi sta capitando una cosa strana, avvio xp, dopo che appare la finestra classica di xp, dove c'è il cursore che carica il os, prima di apparire la finestra dove inserisco user e psw ecco che si riavvia, e questo in continuazione.
tanto per curiosità ho provato ad entrare in mod. provvisoria, ma si blocca del tutto e devo riavviare manualmente. avete idea di cosa posso fare?
grazie!

Andy86
17-03-12, 17: 27
:bai

Risposta praticamente pronta: cominciare col seguire questa guida -> http://www.collectiontricks.it/forum/guide-hardware-reti/Ct1149-diagnosi-dei-crash-sistema-schermata-blu-riavvii-indesiderati.html e fornire più informazioni possibili sull'errore, ricordandoti che non possiamo guardare dentro il tuo pc. :eye

Forse poi possiamo darti qualche indicazione in più. :sisi

poniboy
17-03-12, 17: 33
ciao Andy


Only registered members can view HTML code.

magari ci potessi andare...non posso accedere a nulla, dopo la schermata nera con il logo di xp, e il cursore che cammina ecco che parte il riavvio, non entra nemmeno dentro al sistema, come faccio ad andare in pannello?
o mi sono perso qualcosa?

ops.. ho capito come disattivare il riavvio automatico premendo il magico tasto f8
adesso succede che dopo la schermata classica con il logo di xp, appare la schermata nera, con la freccia del mouse che si trasforma subito in clessidra, e da li non si schioda più
stavo quasi pensando di provare ad entrare con una live di linux e cercare cio che chiede la guida che mi hai postato, perchè diversamente non so cos'altro fare


mi sa che è peggio del previsto. ho provato ad entrare con knoppix e si blocca con questa schermata:

1901

calaf
17-03-12, 20: 44
Si legge male.
Ad occhio e croce pare sia danneggiato l'MBR (Master Boot Record). Prima d'ora non avevi avuto alcun sintomo di malfunzionamento attribuibile al disco rigido?
Schermate blu di decesso (BSOD = blue screen of death); Riavvii lentissimi, Riavvii con la comparsa di (cito a memori) controllo disco C:\ premere un tasto per evitarla, ecc.?

Andy86
17-03-12, 21: 26
:bai

In effetti si legge pochissimo. Però mi sembra strano che una live si blocchi in avvio per un problema al disco rigido: dovrebbe ignorarlo.

Io propenderei più per un problema alla ram, quando il sistema arriva a scrivere nella zona danneggiata salta tutto.

Una volta all'avvio del cdlive c'era la possibilità di fare direttamente il memory test senza avviare la live, se non c'è l'hai prova a scaricare una live più vecchia, sempre che hai un pc per farlo, tipo la 9, e vedi se riesci a fare il test. :sisi

poniboy
17-03-12, 23: 40
Si legge male.
Ad occhio e croce pare sia danneggiato l'MBR (Master Boot Record). Prima d'ora non avevi avuto alcun sintomo di malfunzionamento attribuibile al disco rigido?
Schermate blu di decesso (BSOD = blue screen of death); Riavvii lentissimi, Riavvii con la comparsa di (cito a memori) controllo disco C:\ premere un tasto per evitarla, ecc.?

il pc a dire il vero non è mio ma di mio fratello, comunque mi dice che grossi fastidi sembra di non ricordarli, se non un rallentamento enorme nel navigare, e difficoltà a scaricare la posta.

per quanto riguarda il test della memory, sto scaricando ubuntu 9.04, per provare a vedere se riesco ad entrare, e prima farò il test che propone andy.
ci aggiorniamo a domani. non me ne fregherebbe nemmeno nulla se dovessi formattare, ma prima devo recuperare un pò di roba, e ho paura che non sia nemmeno la formattazione il problema. speriamo bene.

Andy86
17-03-12, 23: 53
:bai

Facci sapere, se non partono nemmeno le live e vedi che non è da cambiare la ram, per recuperare i dati non ti resta che attaccare l'hdd ad un altro pc, e nel frattempo vedere se funziona bene. :sisi

poniboy
18-03-12, 10: 43
:bai

Facci sapere, se non partono nemmeno le live e vedi che non è da cambiare la ram, per recuperare i dati non ti resta che attaccare l'hdd ad un altro pc, e nel frattempo vedere se funziona bene. :sisi

ho provato con la 6 e la 7 alternate, ma ho poi visto, (non ricordavo) che non si possono provare ma solo installare, e ho lasciato stare. poi ho provato con la 8.04 e la 9.04 desktop e si piantavano appena davo qualche comando, sia che fosse la prova, sia che fosse il test della memoria. ho solo più da provare con la 10.04 desktop, che sta masterizzando adesso e poi non so più cosa fare.
ti/vi aggiorno!

Andy86
18-03-12, 11: 09
:bai

Quante schedine di ram hai? Casomai potresti provare a toglierne una per volta (prima togli la corrente!!), per vedere se quando togli quella bruciata (sempre che il problema sia quello) riparte tutto bene. Anche questo è un modo per capire. :sisi

cydonia
18-03-12, 12: 43
l'errore di knoppix e' il classico errore di una iso corrotta o masterizzata male, dovresti controllare la firma digitale md5 della iso e masterizzare a bassa velocita'
a parte questo con la live di ubuntu all'avvio premi f6 e nelle opzioni del grub togli lo splash,cosi' da vedere dove si blocca,ma e' sempre lo stesso computer dell'altra volta (http://www.collectiontricks.it/forum/gnu-linux/Ct2708-ubuntu-10-04-strana-schermata-allavvio.html)?
:bai

poniboy
18-03-12, 13: 00
1904

non l'ho ancora scoperchiato per vedere quanta ram ha, intanto allego l'unico minidump che ho trovato
fermi tutti, adesso sono riuscito ad entrare in prova con la 10.04 cosa faccio?
ciao Cyd come va? :-) non è quello dell'altra volta . che memoria che hai complimenti :-)
anche se quello dell'altra volta continua a fare lo stesso problema riesco a conviverci, più avanti ti spiegherò, adesso però cominciamo con il risolvere il problema su questo. :-)
premesso che ho trovato l'immagine del disco c di questo computer, fatta con acronis a suo tempo, per cui al limite, potrò provare a ripristinare, ma se riusciamo a salvarlo preferisco. attendo vs istruzioni

Andy86
18-03-12, 16: 42
:bai

Questa è l'analisi del minidump:


Only registered members can view code.

Sembra che il problema sia effettivamente correlato alla ram o al processore -> Cause generali degli errori STOP 0x0000007F (http://support.microsoft.com/kb/137539/it).

Per eseguire il ramtest dalle live dalla 10.04 in su, premi ESC all'avvio del cd, e partirà il menù classico. :sisi

poniboy
18-03-12, 17: 50
ok, lanciato il memtest, ma siccome è la prima volta, cosa devo fare? mi sembra una procedura piuttosto lunga a vedere dalla percentuale di avanzamento. alla fine, devo fare una foto alla schermata e postarla?
ipotizziamo che sia un problema di ram o di processore, mi devo preoccupare? vuol dire che non risolverei il problema con la formattazione, piuttosto che il ripristino dell'immagine giusto?

Andy86
18-03-12, 18: 26
:bai

Se è un problema di ram, bisogna cambiare la ram danneggiata, non si scappa. :sisi

Se il memtest rileverà degli errori comincerai a vedere delle righe in rosso.

Immagine da google images come esempio:
http://farm3.static.flickr.com/2367/2211603622_8e5a11555b_o.jpg

Come vedi qui segnala due errori, puoi anche leggere il totale sotto la scritta errors nella riga appena sopra. :sisi

poniboy
18-03-12, 18: 36
mi sa che non è la ram
allego immagine dopo che ha finito, poi ha ricominciato da capo.

1905

cosa posso controllare adesso?

poniboy
19-03-12, 09: 27
oh oh! mi devo spaventare che non leggo più nessuno:shock:triste

Andy86
19-03-12, 13: 08
:bai

Fai un controllo del disco, così ci togliamo il dubbio. Se ci dici marca e modello ti aiutiamo a cercare l'utility ufficiale per il controllo da dos, sempre che esiste. :sisi

poniboy
19-03-12, 19: 09
devo smontarlo per vedere o posso risalirci diversamente? sempre tramite ubunto però, è l'unico modo in cui sono dentro per ora

Andy86
19-03-12, 19: 23
:bai

Da un terminale dai:


Only registered members can view code.

Genererà il file di testo 'lshw.txt' nella home, con parecchie informazioni sul tuo pc, vediamo se c'è quella che ti serve.

Armandillo
19-03-12, 19: 33
:bai

Se non sbaglio hai parlato di poter formattare quindi deduco che possiedi il cd di Xp....giusto ?
Se e' così puoi tranquillamente partire con quello e sovrascrivere i files di sistema....perderai gli aggiornamenti ma non i tuoi dati.
In alternativa, se puoi, smonta l'harddisk, collegalo ad altro pc come secondario e fai uno scandisk o meglio un chkdsk /p per correggere eventiali errori.

Se poi il MBR fosse corrotto, con il cd di Xp puoi ricrearlo (qualche virus potrebbe averlo danneggiato) senza perdere i tuoi dati.

Andy86
19-03-12, 19: 36
Io avevo capito che avesse soltanto l'immagine di sistema, non il disco con la console di ripristino.

Comunque aggiungo che il chkdsk si può fare direttamente dal cd di xp, e che per fare un ripristino ottimale dei files di sistema è opportuno un predate della cartella "windows" eseguibile da ubuntu, altrimenti alcuni file non verrebbero sostituiti e si creerebbe una situazione instabile. :sisi

poniboy
19-03-12, 20: 35
e che per fare un ripristino ottimale dei files di sistema è opportuno un predate della cartella "windows" eseguibile da ubuntu, altrimenti alcuni file non verrebbero sostituiti e si creerebbe una situazione instabile. :sisi

questa non so come fare a farla. puoi spegarmi

qui sotto il risultato del comando che mi hai detto

1931

si, ho sia l'immagine che il cd di xp
ma la cosa più pratica a sto punto qual'è? stacco il disco(che se non ho letto male è un maxtor) e faccio il check, (ma mi dovete spiegare come :shock perchè non lo so) oppure parto subito con il cd di xp a fare il resto?

Andy86
19-03-12, 20: 50
:bai

Se hai l'immagine da ripristinare è più pratica quella che l'altro sistema. Quindi al limite procedi con quella.

Per il disco, si tratta di un MAXTOR STM325031, marca famosa per guastarsi spesso, anche se vedo che ha cambiato nome in seagate, e infatti di recente ho fatto un intervento per un disco seagate che appena comprato già funzionava male... ora ho capito perchè... :ghgh

Comunque... scaricati questa iso -> http://www.seagate.com/staticfiles/support/seatools/SeaToolsDOS220EURO.144.ISO e masterizzala su di un cd, quindi avvia con quello invece che con ubuntu e vedi se ti corregge qualcosa.

Il programma non lo conosco quindi non ti so guidare, ma dovrebbe essere abbastanza semplice.

poniboy
19-03-12, 20: 56
facciamo così, siccome ho pensato che ci sono molti programmi che all'inizio non c'erano, se posso evitare preferirei non dover reinstallare tutto. a sto punto uso il tool a cui mi mandi e poi però proverei a recuperare come avete detto poco sopra, ma siccome sono arrugginito, una volta entrato con il cd di xp, che devo scegliere/fare?

poniboy
19-03-12, 21: 13
il tool non ha dato errori. ora sono entrato con il cd di xp, ma come ripeto sono arrugginito
cosa faccio?

1932

Andy86
19-03-12, 21: 35
:bai

Prima rientra con ubuntu, installa mucommander (http://www.mucommander.com/download/mucommander_0.8.5_all.deb), naviga con esso fino alla cartella windows, pulsante destro, cambia data, metti una data molto indietro, es. 1997 (ho sparato anche troppo, ma va bene), assicurati che sia spuntato di cambiare le sotto cartelle e conferma.

Quando ha finito ritorna alla schermata del cd di windows, dai invio e quando ti dice di premere mi pare R per ripristinare un installazione esistente, premila. Scegli l'installazione ed avvia il ripristino.

Mi raccomando, il cambia data è importante perché se per esempio ripristini su sp3 con il cd sp2 poi potresti avere un sacco di malfunzionamenti. Io ne so qualcosa. :sisi

poniboy
19-03-12, 21: 57
porca mucca. abbi pazienza. ma sono ancora più arrugginito con ubuntu
una volta scaricato come lo lancio? anche perchè devo scaricarlo su un pc e poi portarlo nell'altro, in quanto sul pc difettoso non ho la possibilità di connettermi

Andy86
19-03-12, 21: 59
:bai

Dovrebbe già essere impostato di predefinito per aprirsi con qualcosa tipo "package installer" o con il software center, quindi ci clicchi sopra e parte l'installazione.

È un .deb, quindi lo trasferisci con qualunque supporto, che la live sicuramente vede. :sisi

poniboy
19-03-12, 22: 16
dunque lo installa con l'installatore pacchetti Gdebi, ma quando finisce con cosa lo apro? è questo che non capisco/ricordo:shock

Andy86
19-03-12, 22: 20
Dovrebbe comparire un collegamento da qualche parte... se hanno dimenticato di metterlo lo apri dal terminale, semplicemente scrivendo "mucommander". :sisi

poniboy
19-03-12, 22: 30
poniboy@poniboy-desktop:~$ mucommander
Error: cannot find java VM.
poniboy@poniboy-desktop:~$


come vedi è quello che ho fatto

:ohoh

Andy86
19-03-12, 22: 52
:bai

Ahia, l'avevo dimenticato... è scritto in java che da un paio di distro non è più inclusa...

Allora facciamo con un altro sistema, senza MU, fai il CD nella dir windows che devi tentare di aggiustare, e poi dai questo comando:


Only registered members can view code.

Tutti i file della directory in cui esegui il comando avranno come data ultima modifica: 21/02/97.

Dopo di che torna al punto due del post di prima. :sisi

poniboy
19-03-12, 22: 58
:bai

fai il CD nella dir windows che devi tentare di aggiustare, e poi dai questo comando:


Only registered members can view code.




Tutti i file della directory in cui esegui il comando avranno come data ultima modifica: 21/02/97.
una volta dentro non basta dare il comando da terminale una volta sola?

scusami che significa fai il cd nella dir windows?
vediamo se ho capito, entro con ubuntu nel xp avariato, apro il terminale e do il comando che mi dici tu, dopodichè esco, rientro con il cd di xp e via con il tasto r
ho capito bene?

Andy86
19-03-12, 23: 14
Quasi bene.

Il soggetto della frase era la dir windows, non i file.

Cioè esegui il comando in una dir, e tutti i file contenuti in quella dir cambiano data. :sisi

Fare il CD (call dir) significa raggiungere la dirirectory col terminale.

Quindi dovresti dare: "cd /media/nomepartizionediwindows/windows/".

Se non riesci a trovarla, raggiungila con il normale gestore dei file (nautilus), e quando sei dentro fai "pulsante destro -> apri nel terminale qui" e dovresti esserci in automatico, verifica di leggere qualcosa tipo:

poniboy@poniboy-desktop:/media/nomepartizionediwindows/windows/$

E dai il comando che ho detto prima.

:notte:

poniboy
20-03-12, 07: 35
:shockperdonami ma sono de coccio ma sto provando e il nome della partizione dove c'è windows è il disco c ovvero la partizione sda1
solo che mi risponde " File o directory non esistente"
se invece entro da "risorse" sul fyle system che mi interessa, ovvero quello dove c'è windows col tasto destro non mi da l'opzione "apri nel terminale qui"
scusa ancora, ma forse sono io che non ho capito:shock
vado al lavoro, ti rileggo stasera
per ora :bai

cydonia
20-03-12, 08: 45
il mount point in questo caso la partizione di windows in /media e' presente solo se prima viene montata.
apri nel terminale e' presente solo se prima hai installato il pacchetto nautilus-open-terminal e riavviato nautilus con
nautilus -q
:bai

poniboy
20-03-12, 13: 18
il mount point in questo caso la partizione di windows in /media e' presente solo se prima viene montata.
apri nel terminale e' presente solo se prima hai installato il pacchetto nautilus-open-terminal e riavviato nautilus con
nautilus -q
:bai

aspetta, io la prova l'ho fatta prima sul mio pc che è in dual, perchè volevo provare. e la partizione di win, ovvero il famoso disco c (e anche il d) c'è sempre stata. o faccio io un errore di interpretazione?

Andy86
20-03-12, 13: 36
:bai

A, B, C e D in linux non esistono, le partizioni si indentificano con sdaX e si montano in cartelle tipo /MEDIA/UUID (che è il seriale della partizione).

Per farti capire il concetto di "montaggio": hai presente quando in win si monta una iso con un programma di masterizzazione, per vederla come se fosse nel lettore?

Il concetto è lo stesso, tu monti una partizione in una posizione per interagire con essa. :sisi

Il pacchetto indicato da cidonia, se devi portarlo in un altro pc senza rete, lo puoi prendere da qui -> http://packages.ubuntu.com/search?keywords=nautilus-open-terminal&searchon=names&suite=all&section=all, scegli quello per la tua distro.

poniboy
20-03-12, 19: 18
allora, adesso ho scaricato il pacchetto che mi dici, l'ho portato sull'altro pc
l'ho lanciato. da "risorse" sono andato nella partizione interessata, tasto dx, e ora c'era l'opzione apri nel terminale, ho dato "nautilus -q"
e ho dato il comando che mi hai detto
vedi foto
è giusto?1935
1936

ora posso andare con il disco di windows e vedere se si sistemano le cose senza perdere nulla?

Andy86
20-03-12, 20: 57
:bai

Mi sembra che sia giusto. Prendi un file a caso nella cartella windows, tasto destro, proprietà e vedi se la data ultima modifica è cambiata al 1997, se è così procedi pure col disco di windows. :sisi

poniboy
20-03-12, 21: 12
confermo e l'accendo :bgg2
ora c'è qualcosa che mi sfugge
che devo fare?

1938

non so cosa devo digitare:shock

Andy86
20-03-12, 21: 23
:bai

Hai saltato un passaggio, da lì serve per i parametri dos, avresti dovuto dare invio quando ti chiedeva se vuoi installare windows, e poi alla schermata successiva premere R e scegliere l'installazione di windows esistente. :sisi

Per uscire da quella situazione digita "exit" senza virgolette, e dai invio.

poniboy
20-03-12, 21: 29
ehm....volevo veder se eri attento.....:bgg2
sta lavorando. incrociole dita :bgg2
a frappè.
anche perchè se poi funzionasse vorrei ancora un consiglio per una cosa che ho in mente per evitare di fare sto lavoro se risuccedesse.

Andy86
20-03-12, 21: 33
ehm....volevo veder se eri attento.....:bgg2

Io?? :bgg2

Tienici aggiornati. Per altre domande siamo qui.

poniboy
20-03-12, 23: 28
stavo scherzando naturalmente :bgg2
visto che ci siamo e che sto aspettando che il pc finisca, mi porto avanti con il lavoro e ti dico cosa vorrei fare. prima di tutto, (sempre che alla fine di tutto, il pc sia guarito) farò una nuova imagine per sicurezza, in modo da avere in futuro tutti i programmi che ha installati ad oggi. seconda cosa, vorei fare un dual boot con ubuntu, come nel mio pc, in maniera tale che se risuccedesse una cosa del genere, posso accedere direttamente dal pc, senza lanciare un cd live. che ne pensi/pensate?
vorrei dedicare un piccolo spazio a ubuntu. al momento il pc è diviso (su xp) con 46 gb di disco c, e 130 circa di disco d dove ci sono documenti ecc.
vorrei partizionare il d e dedicare una decina di gb a ubuntu (io sono fermo alla 10.04, meglio che ne scarico l'ultima x questo pc?)
prima cosa vorrei sapere se secondo te/voi può essere una buona idea, secondo, se mi date una mano a ricordare come partizionare in fase di installazione, perchè è ormai un annetto che non combino più nulla e ho dimenticato molte cose di lnux (se è per questo anche di windows :ghgh)

--- Post unito in modo automatico ---

ho paura che ci sia qualche problema
è quasi un'ora che è fermo su "l'installazione dovrebbe terminare tra 39 minuti"
vado a nanna ci aggiorniamo a domani:cry3

poniboy
21-03-12, 07: 07
infatti un'ora fa sono venuto a vedere ed era sempre fermo a 39 minuti. ho rifatto tutto da capo, ed ora che sto andando via è di nuovo fermo sul 39 minuti:cry3
avete idea di cosa posso/devo fare?

cydonia
21-03-12, 07: 24
ciao @poniboy parlo da profano piu' che altro perche' e' un sistema chiuso e non si fa conoscere,quello che vedo e' che si blocca in qualche punto dell'istallazione,fatto un controllo se mi ricordo di coerenza con il checkdisk di windows? per verificare se ci sono settori danneggiati,oppure non so se ci sia in windows un utility interna per verificare l'integrita' dei file di sistema? visto che non e' un'istallazione da zero,riguardando l'errore iniziale parlando sempre da profano ntfs.sys non e' quel file che si preoccupa del filesystem di windows?che sia' corrotto? di guide ne ho viste per sostituirlo visto che mi sempre che facilmente si corrompe,chiaramente quello che dico predilo come viene...
:bai

Andy86
21-03-12, 18: 32
:bai

A questo punto direi che siamo davanti ad un errore fisico del disco. :sisi

Evidentemente l'ntfs.sys si pianta proprio in fase di lettura file system, perché non ci riesce, e se fosse corrotto verrebbe sostituito in fase di ripristino, infatti in questa fase vengono usati i driver presi dal cd, non quelli in fase di sostituzione. :sisi

Per quanto riguarda il chkdsk, viene fatto in automatico quando si avvia un ripristino o un installazione, e se non ha corretto errori, significa che l'errore non è solo nel file system... :sisi

A questo punto non ho ben capito se intendi C e D come partizioni o come due dischi separati... se sono due dischi separati proverei a fare un immagine dell'installazione sull'altro disco, che magari è sano, e renderla avviabile, quindi se parte lasciarla lì ed eliminare il disco malato. :sisi

poniboy
21-03-12, 20: 12
ciao ragazzi. non ho capito molto bene quello che avete detto, ma solo per ignoranza mia in materia, ci mancherebbe, voi siete decisamente preparati. detto questo, non credo di aver ben capito il da farsi, mi pare che Andy stia ventilando l'idea di un guaio fisico del disco. ma come mai allora da ubuntu riesco ad entrarci? è normale?
C e D sono due partizioni all'interno dello stesso disco del pc. ho solo un disco in questo pc. a suo tempo avevo diviso, e in C misi il OS e in D i vari dati, foto, musica che nel tempo mio fratello avrebbe avuto bisogno di metterci. a sto punto, cosa devo fare? mi viene il dubbio a sto punto che nemmeno formattando risolverei il problema. però quando ho fatto il memtest non ha dato problemi, su ubuntu ho visto che c'è una diciamo opzione che è in >sistema>amministrazione>test del sistema. potrebbe servire a qualcosa?

Andy86
21-03-12, 22: 54
:bai



ma come mai allora da ubuntu riesco ad entrarci? è normale?

Ubuntu è molto più stabile di Win, quindi se il guasto non è serio finisce per leggere comunque i dati.
Però è anche vero che se c'è un errore grave nel filesystem, ntfsprogs dovrebbe rifiutarsi di montare la partizione per evitare guai. :m:



mi viene il dubbio a sto punto che nemmeno formattando risolverei il problema.

Credo che se si blocca durante il ripristino, si bloccherà anche durante l'installazione dopo la formattazione, alla fine il "soft" che esegue le operazioni è lo stesso. :sisi



su ubuntu ho visto che c'è una diciamo opzione che è in >sistema>amministrazione>test del sistema. potrebbe servire a qualcosa?

Potrebbe. Diciamo che sarebbe più per testare la compatibiltà di ubuntu con la tua piattaforma. Però dovesse bloccarsi durante un test sappiamo che hai problemi. :sisi

poniboy
21-03-12, 23: 32
problemi sembra non rilevarne. a sto punto cosa posso fare?:triste

poniboy
22-03-12, 06: 45
help!:triste

Armandillo
22-03-12, 07: 53
:bai

Ho visto che sei ad un punto morto....ma non ti scoraggiare, probabilmente c'e' stato un passaggio non corretto....ripeto la procedura col disco di Xp:

1 - Avvio del boot con il cd di Xp
2 - Ad inizio dell'installazione ti verra' chiesto di utilizzare la "console di ripristino"....ignora e premi Invio.
3 - Premi F8
4 - Nella schermata successiva (prompt) seleziona l'installazione presente sull'harddisk e premi "R"
5 - Da questo momento se tutto e' andato per il verso giusto iniziera' la reinstallazione con la copia dei files di windows

Buona fortuna

poniboy
22-03-12, 18: 24
ciao. è quello che ho fatto, ma come puoi leggere nel post più indietro, mi si pianta quando mancano 39 minuti, e da li non si muove più. è per questo che non so cosa fare.
domanda/e ho pensato ad alcuni post fa dove Andy mi diceva che se avevo 2 dischi potevo fare un'immagine del primo e ribaltarla sul secondo, posso usare acronis a questo punto? faccio l'immagine del disco, la salvo su un hd esterno che ho, compro un altro disco nuovo, lo monto e ci ficco su l'immagine. potrebbe funzionare?
oppure, non potrebbe essersi preso qualche virus l'mbr? oppure non potrebbe essere un problema di alimentatore, che stenta? o addirittura il processore? posso fare dei controlli su tutte ste cose? come?

Armandillo
22-03-12, 18: 40
Per il virus puoi rimediare con un "cd rescue" (Avira/F-prot o altri) e controllare l'harddisk.
La cosa piu' semplice e' avviare una live di Linux, copiare i dati che ti interessano e passarli all'harddisk esterno e poi riformattare il disco che non va....io almeno farei così.

Trasferire l'immagine non mi risulta si possa fare :bohe comunque anche fosse trasferiresti una immagine "danneggiata" quindi non funzionante....a che pro ?

Mi rendo conto che reinstallare tutto d'accapo e' una noia e una perdita di tempo ma se vuoi risolvere e fino ad ora non ci sei riuscito, non ti rimane altro.

:bai

Andy86
22-03-12, 19: 42
posso fare dei controlli su tutte ste cose? come?

Per l'alimentatore non corrispondono i sintomi: se fosse riscontreresti dei blackout, non delle bosd. :sisi
Per il processore non ti so aiutare, non so se siano possibili guasti lievi, se fosse bruciato si fermerebbe al caricamento del bios. :sisi

Su internet ho trovato una marea di cause per il tuo problema, ma nessuna sicura.
Sugli articoli di microsoft questo codice errore si ferma a windows 2000. :boh

Sommando i problemi in scrittura durante l'installazione e l'impossibilità di accedere in modalità provvisoria, giungo alla conclusione che il problema è hardware, e probabilmente (imho) del disco. Ma posso sbagliarmi.


non ti rimane altro.

Non sono convinto. Secondo me se riscontra un blocco nel ripristino, poi lo riscontra anche nella reinstallazione, poiché alla fine il programma è lo stesso, con la differenza che nel caso del ripristino non viene prima eseguito il software.

Il predate che ho suggerito risolve i problemi software nella sovrascrittura, quindi in teoria rimane quello hardware. :sisi


Trasferire l'immagine non mi risulta si possa fare :boh

Io ho provato con ddrescue e funziona, basta fare una copia raw della partizione su un altro disco e poi impostare il flag di boot alla nuova partizione (es. con parted e relative interfacce grafiche) ed impostare il disco come dispositivo di boot. :sisi


trasferiresti una immagine "danneggiata" quindi non funzionante....a che pro ?

Prendo per buona l'ipotesi che il problema sia hardware, quindi lo stato dei file è ok ed al limite va a posto con un chkdsk.
Chiaro che facendo una fotografia del software ti porti dietro solo i problemi software e non quelli hardware.

poniboy
22-03-12, 20: 23
Io ho provato con ddrescue e funziona, basta fare una copia raw della partizione su un altro disco e poi impostare il flag di boot alla nuova partizione (es. con parted e relative interfacce grafiche) ed impostare il disco come dispositivo di boot. :sisi.

mi spieghi in dettaglio come fare? tirando le somme a quanto pare il disco è danneggiato ed evidentemente irrecuperabile. a questo punto non mi resta che cambiarlo. ma se io faccio l'immagine con acronis, cambio il disco e metto un disco nuovo secondo te non funziona?
al limite perso per perso, posso provare a ripristinare l'immagine del disco come era in origine su questo che fa i capricci, così vediamo subito se il disco è da "buttare" che ne dite?

Andy86
22-03-12, 20: 50
:bai

Può essere una prova, però prima fatti l'immagine attuale (anche con acronis se vuoi/riesci), così se le cose vanno storte la puoi ripristinare sul disco nuovo. :sisi

cydonia
23-03-12, 06: 35
non saprei aiutarti in ambito proprietario perche' da come vedi non si fa conoscere ne farti confusione piu' di quanto non ne hai gia',pero' precedentemente hai detto che le altre dist. live si bloccano, sarebbe da capire dove,la live in caso di un malfunzionamento hardware grave si bloccherebbe ne piu' ne meno di altri sistemi,ora questa si e' avviata , ha fatto fatica nel farlo?puo' essere anche che le altre live si blocchino nella rilevazione hardware di qualche componente(ethernet forse problema che cera in passato non totalmente risolto ) questa invece prosegue.Hai fatto fatica a montare la partione di windows?,prova prima i suggerimenti proposti,quando hai tempo posta l'output del comando dmesg dalla live.
:bai

poniboy
23-03-12, 08: 56
non so se può essere importante, ma mi dice mio fratello, che gli capitava ogni tanto una schermata con scritto "andando in off" e poi si piantava, lo riavviava e lui tornava a funzionare. può essere utile?

Kirk78
23-03-12, 21: 02
Ciao. Ho cercato di leggere velocemente un po' tutta la discussione, quindi perdonatemi se magari dico cose già dette.
Io farei un controllo disco da liveCD con testdisk che mi sembra sia il miglior tool "generico" che si possa avere su una liveCD.
Non ho ben capito esattamente quale è il disco che hai perché, come detto mi sembra dal buon Andy86, ci sono delle liveCD specifiche del produttore per controllare il disco da loro prodotto.

Questo perché abbiamo visto, se non erro, che la ram dovrebbe essere a posto. L'unica cosa in più sarebbe vedere se per caso ci sia un blocco per via della temperatura della CPU. Si possono vedere o da una liveCD oppure semplicemente andando in BIOS e vedere le temperature lasciando accesso il PC per parecchio tempo e vedere se e quanto sale la temperatura e se si blocca anche in BIOS.

Auguri comunque e, tempo permettendo, siamo quì ad aiutarti.

P.S. "andando in off" non so cosa voglia dire sinceramente

:bai

Andy86
23-03-12, 21: 37
:bai

"Andando in off" mi fa venire in mente un messaggio del monitor, quando non riceve segnale dalla scheda video per un po', ma se non erro stiamo parlando di un portatile, che ha il monitor integrato, quindi niente risparmio energetico. :m:

poniboy
26-03-12, 12: 27
ciao e scusate il ritardo, ma ho approfittato del bel tempo per andar via 2 giorni :sisi
il pc non è un portatile, ma un fisso. questo giusto per chiarire di cosa parliamo.:bgg2
dunque, al mio ritorno ieri sera ho fatto una prova. ho cambiato l'hd e ci ho sbattuto su l'immagine che avevo fatto 2 anni fa quando ho dato il pc a mio fratello. alla fine del ripristino dell'immagine, riavvio e............funziona. ho di nuovo tutto a posto, con alcuni programmi da reinstallare, ma il grosso è fatto.
conclusione, non so come ne perchè, ma di fatto potremmo tranquillamente dire che l'hd precedente ha avuto qualche problema, anche se il sw consigliatomi da Andy per controllarlo non ha riscontrato errori.
ripeto, non so quale può essere stato l'errore, ma a questo punto direi che la cosa è conclusa, anche se mi piacerebbe capire il problema. vorrei provare ad usare il disco "fallato" come disco dati, ma non so come fare il collegamento
è un sata. il principale ha 2 connettori uno più stretto e uno più largo.
come devo collegare questo hd? e poi devo gestire qualcosa a livello bios?
grazie

Andy86
26-03-12, 13: 09
:bai

Ti servono i connettori giusti. Se uno è sata e uno ata non li puoi collegare sullo stesso cavo, ti serve un cavetto rosso per ogni sata ed un cavo grigio largo per gli ata. L'attacco lo trovi sulla mobo, è grosso per gli ata, ed è rosso per i sata, non puoi sbagliare. :sisi

Per la corrente devi cercare un cavo tra quelli che partono dall'alimentatore uguale a quello che hai già collegato all'altro hd, di solito sono vicini (a ipsilon, Y), e dovrebbero arrivarci senza aggiunte. Se necessario invertili per farli arrivare bene tutti e due.

La rilevazione del bios dovrebbe essere automatica, tuttalpiù devi correggere l'ordine di boot per evitare rallentamenti inutili in fase di caricamento. :sisi

Kirk78
26-03-12, 20: 29
Non ricordo quale software hai usato per i test (mi sono perso sorry :ehmm), ma per sapere se era un problema grave io ti consiglio di testare il disco con la liveCD del produttore del disco. Questo perché nel caso fosse un problema hardware grave io NON lo monterei internamente ma su un box USB, altrimenti rischi che ti si blocchi il sistema.... e si ricomincia, mentre se è una periferica USB al massimo ti da un errore di periferica non trovata.

Nel caso non abbia errori hardware gravi, allora vuol dire che era un problema software del sistema operativo.... vai a capire quale...

:bai

poniboy
26-03-12, 22: 29
effettivamente è meglio che lo lascio esterno al pc. si sa mai.
il tool per controllare il disco comunque lo avevo usato e non aveva restituito errori. boh!
Andy scusa ma che differenza c'è tra sata e ata? come lo capisco?

Kirk78
26-03-12, 22: 40
Sata = Serial Ata, Ata di solito è un'altro nome per Ide (non seriale). Hanno gli attacchi anche diversi.
Quale è il nome del tool? Comunque dovrebbe esserci anche la liveCD del tool del produttore.
:bai

poniboy
26-03-12, 23: 05
si infatti ho usato la live cd, ma problemi non ne aveva rilevati. comunque sia, lo archivio e fine della fiera. a sto punto direi che non mi resta altro che ringraziare tutti voi per il prezioso aiuto e la pazienza:bai

Kirk78
27-03-12, 01: 43
Insomma, come alle volte avviene, questa è un'altra discussione che dovrebbe avere l'indicazione non-risolto-per-stanchezza o comunque in "attesa" eventuale di riprendere il problema (da te ovviamente) se vuoi ricaricare per prova il sistema.

Ci si scrive in giro!

:bai

poniboy
27-03-12, 22: 05
Insomma, come alle volte avviene, questa è un'altra discussione che dovrebbe avere l'indicazione non-risolto-per-stanchezza o comunque in "attesa" eventuale di riprendere il problema (da te ovviamente) se vuoi ricaricare per prova il sistema.

Ci si scrive in giro!

:bai

a dire la verità, c'è qualcosa di strano. ormai ho gettato la spugna, ma prima ho fatto 2 prove. la prima è quella di formattare e reinstallare xp sul disco incriminato. risultato, ha funzionato.
la seconda, ho provato a rimettere l'immagine che avevo creato a suo tempo sempre sull'hd incriminato, e mi restituiva come errore una schermata nera all'avvio in cui diceva che mancava un file .dll di cui ora non ricordo il nome. poi invece la stessa immagine l'ho messa sull'hd nuovo e ha funzionato. qualcuno sa dare una spiegazione?:ehmm

Andy86
28-03-12, 19: 16
:bai

Direi che il disco a volte si perde i pezzi (come quasi tutti gli ex maxtor d'altronde), quindi una volta riesce a installare bene e la seconda no.

Se ti può consolare altre persone con un ex maxtor avevano gli stessi sintomi. :sisi

poniboy
28-03-12, 20: 46
va bene grazie mille e direi che possiamo ritenere chiusa la discussione, che dite?