PDA

Visualizza versione completa : Kubuntu non vede più lo scanner ma ubuntu lo vedeva.



Andy86
13-02-12, 18: 51
:bai

Non capisco perché kunbuntu non riesce più a vedere lo scanner della lexmark x1100.

Su gnome lo vedeva da subito e sono anche riuscito a far funzionare la stampa tramite il driver della z600, da qualche parte ci sono anche i deb precompilati che spero di ritrovare. :sisi

Ora ho provato anche a mettere il programma di gnome, simple-scan, ma non lo vede neppure lui.

Cercando un po' in giro ho trovato la guida ufficiale ed installato libsane-extras, ma niente, non funziona lo stesso. :boh

Poi ho trovato il seguente comando, che lo vede... :


Only registered members can view code.

E allora perché i programmi no?

cydonia
14-02-12, 05: 27
dai un sguardo qui' (https://help.ubuntu.com/community/HardwareSupportComponentsPrinters/LexmarkPrinters#Lexmark_Z600_Series_Printers)
:bai

Andy86
14-02-12, 12: 33
:bai

Quella è la procedura che ho seguito per far funzionare la stampante, ed era ok.

Ma lo scanner su gnome lo ha rilevato prima ancora di fare od installare qualunque cosa, mentre qui su kde non lo vede, eppure è sempre lo stesso.

cydonia
15-02-12, 06: 18
dai :

Only registered members can view code.
per verificare se tra device visualizzati con sane-find-scanner effettivamente esiste,e viene visto:

Only registered members can view code.

poi installa il frontend xsane

Only registered members can view code.
avvialo e se esiste lo scanner tra quelli sopra, dovrebbe chiederti all'avvio di sceglierlo.
:bai

Andy86
15-02-12, 21: 12
:bai

Niente da fare:


Only registered members can view code.

ps: con xane non ho installato i raccomandati, perché ce n'erano un po' che iniziavano per 'g'. :ohoh

cydonia
15-02-12, 21: 44
qui' (http://forum.ubuntu-it.org/index.php/topic,151771.0.html) hanno risolto il problema dello scanner della tua stampante ,seguendo questa (http://wiki.ubuntu-it.org/Hardware/StampantiScanner/LexmarkX1250#Configurazione_dello_scanner) guida(parte che riguarda lo scanner)
p.s leggi quel thread
:bai

Andy86
15-02-12, 23: 00
:bai

Ho seguito thread e guida, ma dopo il make non vengono visti ne "checkinstall" ne "makeinstall". :boh

L'output che ha generato il make è chilometrico. Non me lo aspettavo e non l'ho ridirezionato su file, perciò gran parte è rimasta fuori dal terminale, che dopo il passaggio non ho più impostato su nessun limite. :ops:

cydonia
16-02-12, 06: 28
pulisci i sorgenti con:

Only registered members can view code.
e poi fai il redirect cosi':

Only registered members can view code.
:bai

Andy86
16-02-12, 16: 33
:bai

Ecco fatto. :hap

cydonia
16-02-12, 20: 39
apparte qualche warning il make e' andato liscio anche perche' " 2>&1" redirigie lo stdout e stderr,errori nell'output non ce ne sono,quando dai il make install cosa esce? versione di kubuntu?
:bai
edit se stai usando la 11.10 ti metto a disposizione il sorgente che ho compilato .deb
http://anyhub.net/file/5JDk-libsane_1.0.18-4-1_i386.deb

Andy86
16-02-12, 22: 16
:bai

Ora make install lo vede. Che strano. :boh

Comunque dopo il make ho installato anche il tuo pacchetto, ma non cambia nulla, ancora lo scanner non viene visto.

Non vorrei fosse semplicemente qualche pacchetto incluso in gnome e non in kde, perché a me sembra proprio di non aver installato nulla per scannerizzare sotto ubuntu: ho aperto simple scan ed ho scannerizzato. :m:

cydonia
17-02-12, 05: 10
ok.facciamo una cosa pulita rimuovi il .deb installato con synaptic o altro frontend di apt che hai ,rimuovi anche il pacchetto installato dai sorgenti cosi',nel Makefile dei sorgenti e' predisposta la procedura per l'uninstall dunque,vai nella directory e dai:

Only registered members can view code.
installa il libsane aggiornato della 11.10, installa libsane-extras
con lo scanner/stampante collegata identifica l'idvendor e l'idproduct(come da guida) con:

Only registered members can view code.
edita/crea(verifica) se non esiste 025_libsane-extras.rules:
verifica:

Only registered members can view code.
se non esiste la crei, semplicemente i tutti e due i casi usando l'editor di default,kate in kubuntu o gedit(ubuntu) :

Only registered members can view code.
e inserisci l'idvendor e l'idproduct presi da lsusb:

Only registered members can view code.
riavvia o scollega e ricollega lo scanner dall'usb
:bai2

Andy86
17-02-12, 16: 58
:bai

Stavolta sembra non sia previsto:


Only registered members can view code.

Il file là della guida lo avevo fatto (non esisteva), ed ho inserito, appunto, le cose rilevate, non penso di aver sbagliato:


Only registered members can view code.

Io fra queste ho scelto la seconda (007c). :m:

cydonia
17-02-12, 19: 16
Only registered members can view code.
unistall certamente non esiste ,ma ho scritto uninstall:hap
:bai

Andy86
17-02-12, 19: 30
:ops:

Allora, disinstallato e reinstallato libsane e libsane-extras, scollegato e ricollegato lo scanner, ma ancora non ci siamo:


Only registered members can view code.

sane-find-scanner è come sopra. :boh

EDIT:

Il file delle rules si è automaticamente rinominato in "z60_libsane-extras.rules", lo ho lasciato ma ho anche ricreato il doppione con il nome di prima: risultato medesimo. :boh

cydonia
17-02-12, 19: 57
stavo guardando questa discussione (http://ubuntuforums.org/showthread.php?t=1745031)che dopo l'uprade a natty in questo caso non vedeva piu' lo scanner,in uno dei post punta a questa discussione (https://bugs.launchpad.net/ubuntu/+source/xsane/+bug/774475?comments=all) su launchpad e molti hanno risolto con la procedura di questo utente Ashley Hooper (https://bugs.launchpad.net/ubuntu/+source/xsane/+bug/774475/comments/4):



Only registered members can view code.
chiaramante da disinstallare le versioni di libsane e libsane-extras della distro eliminare la regola che hai creato,sinceramente non e' il massimo installare i pacchetti di un'altra distro anche se Debian...prova
:bai

Andy86
17-02-12, 20: 29
:bai

Fatto... ma niente da fare. Casomai vedo dopo che ho riavviato. :sisi

Andy86
21-02-12, 00: 44
:bai

Davvero più nessuna idea?

Mi sta troppo scomodo che non funzioni più... e fa anche una brutta figura con gli utonti che ancora non sono completamente convinti... :bgg2

ps: questo mi può essere utile? http://www.sane-project.org/man/sane-lexmark.5.html :m:

cydonia
21-02-12, 06: 42
veramente aspettavo che riaviassi il computer,comunque:
hai installato quei pacchetti?
posta l'output di:

Only registered members can view code.
vedi se e' commentata la riga che riguarda la lexmark in /etc/sane.d/dll.conf
cancella le regole di libsane create in

Only registered members can view code.
veranno ricreate all'inseriemento della stampante ma con le conf dei nuovi pacchetti
:bai

Andy86
21-02-12, 12: 56
:bai


veramente aspettavo che riaviassi il computer


:ops: Avevi detto che bastava staccare e riattaccare...



hai installato quei pacchetti?

Disinstallato completamente le vecchie versioni e reinstallato dal deb.

Il pin l'ho fatto direttamente dal gestore aggiornamenti di kubuntu.


Only registered members can view code.


vedi se e' commentata la riga che riguarda la lexmark in /etc/sane.d/dll.conf

.... non c'è più... :shock

Forse è stato rimosso col purge, non so... però prima c'era... perché all'inizio avevo guardato e la riga non era commentata. :sisi


cancella le regole di libsane

Già fatto, non sono state ricreate. :boh

cydonia
26-02-12, 07: 25
scusa dell'assenza.


vedi se e' commentata la riga che riguarda la lexmark in /etc/sane.d/dll.conf .... non c'è più... :shock


Forse è stato rimosso col purge, non so... però prima c'era... perché all'inizio avevo guardato e la riga non era commentata. :sisi


cancella le regole di libsane


Già fatto, non sono state ricreate. :boh
gia' provato a reiserire lexmark in quel file di configurazione ,e ricreare a mano quella regola?
:bai

Andy86
12-03-12, 18: 20
:bai

Niente da fare, non funziona.

Ho provato un paio di soluzioni trovate su internet


Only registered members can view code.

E l'aggiunta delle regole in:


Only registered members can view code.

Ma continua a dire "no sane device found". :boh