PDA

Visualizza versione completa : Ci sono pacchetti danneggiati bloccati.



Andy86
03-02-12, 22: 35
Prima volta che mi capita. Che significa che sono "bloccati"? :confused:

Tra l'altro thunderbird era già installato e funzionante. Dopo nuovo avvio di kde improvvisamente non funziona più, mostra solo una finestra bianca. Cerco di capire il problema, e questo è ciò che ottengo:


Only registered members can view code.


Only registered members can view code.


Only registered members can view code.


Only registered members can view code.

:thx:

pierino_89
03-02-12, 23: 20
Questo è un evidente caso di problemi nei repository :tong2 posta i tuoi.

Andy86
04-02-12, 00: 35
:bai

Da prima a dopo l'errore non ho cambiato niente. Questo il sources.list:


Only registered members can view code.

La sources.list.d attualmente è vuota.

K.a.o.s.
04-02-12, 02: 05
Hai imbrogliato :tong2.
Rischi problemi del genere a tentare di far andare ppa per maverick su altre versioni di Ubuntu.

Devi usare firefox unstable insieme a Thundebird unstable, sicuramente loro hanno i pacchetti con le dipendenze per Oneiric.

A occhio dovrebbe funzionare con queste modifiche:


Only registered members can view code.

Vedi se c'è il ppa per LibreOffice.

Andy86
04-02-12, 12: 49
:bai

Il fatto è che io non voglio usare le versioni instabili (beta), ma semplicemente avere l'ultima stabile (9 - 10).

Prima con maverick nei repo canonical c'era ancora la tre, per cui misi quelli ufficiali mozilla.

Ora non capisco perché i repo-stable arrivano fino alla natty: non è che per caso è oneric ad essere ancora beta? :ohoh
E comunque prima thunderbird andava, quindi prima le dipendenze le aveva installate: non mi sembra affatto logico che tutto d'un tratto senza cambiare niente non possa farlo più. :bsh

E poi "ci sono pacchetti danneggiati" qualcosa vorrà dire, no? :m:


ps1: Se mettessi quelli per "natty", che è sempre versione 11?

ps2: i repo si possono verificare anche dal browser: Index of /mozillateam/firefox-stable/ubuntu/dists (http://ppa.launchpad.net/mozillateam/firefox-stable/ubuntu/dists/)

K.a.o.s.
04-02-12, 13: 56
Ora non capisco perché i repo-stable arrivano fino alla natty: non è che per caso è oneric ad essere ancora beta? :ohoh
Magari semplicemente Oneiric non fornisce alcune versioni più vecchie delle librerie che sono necessarie per la stable, quindi invece di modificare la stable rendono disponibile la beta.

E comunque prima thunderbird andava, quindi prima le dipendenze le aveva installate: non mi sembra affatto logico che tutto d'un tratto senza cambiare niente non possa farlo più. :bshMagari hanno aggiornato dei pacchetti a versioni che Thunderbird non supporta:

pacchetti X e Y
X chiede libK versione <=2
Y chiede libK versione >=2
se aggiornano libK alla versione 2.1, il pacchetto X non funziona più

È uno dei problemi di Debian generalmente, che si risolve col Pinning. Gentoo se non ricordo male risolve con eselect.

ps1: Se mettessi quelli per "natty", che è sempre versione 11?
Se non scassa dipendenze funziona. A parte che ho perso il conto delle versioni tra Maveric, Natty, Oneiric etc. Quindi non so nemmeno a che versione ti riferisci :ghgh

ps2: i repo si possono verificare anche dal browser:Infatti ho fatto così :tong2

E poi "ci sono pacchetti danneggiati" qualcosa vorrà dire, no? :m:Probabilmente chiedono dipendenze non presenti nel repo. Ma è veramente molto che non uso distro Debian-based per dirti con sicurezza.

Ma davvero non c'è Thunderbird, Firefox e OpenOffice nei repo di Ubuntu?

pierino_89
04-02-12, 15: 03
È uno dei problemi di Debian generalmente, che si risolve col Pinning. Gentoo se non ricordo male risolve con eselect.

No, con revdep-rebuild. Su gentoo quando si aggiornano le librerie vengono ricompilati tutti i pacchi per farli linkare alle nuove librerie e poi si rimuovono le vecchie.



Ma davvero non c'è Thunderbird, Firefox e OpenOffice nei repo di Ubuntu?
Openoffice no perché c'è libreoffice. Gli altri due so per certo che ci sono.

Andy86
04-02-12, 15: 08
:bai


Ma davvero non c'è Thunderbird, Firefox e OpenOffice nei repo di Ubuntu?

Ci sono, ma non sono aggiornati. Almeno con maverick arrivavano fino all'ultima 3.xx. :sisi

Open office me lo sono portato dietro con il backup e non ricordo perché lo misi... :m:


A parte che ho perso il conto delle versioni tra Maveric, Natty, Oneiric etc. Quindi non so nemmeno a che versione ti riferisci :ghgh

Ci vado in palla anch'io. :wall. Comunque: Maverick = 10.10, Natty = 11.04, Oneiric = 11.10, Precise = immagino 12.04. :sisi

K.a.o.s.
04-02-12, 15: 30
No, con revdep-rebuild. Su gentoo quando si aggiornano le librerie vengono ricompilati tutti i pacchi per farli linkare alle nuove librerie e poi si rimuovono le vecchie.Giusto, ricordavo male :eye

Ci sono, ma non sono aggiornati. Almeno con maverick arrivavano fino all'ultima 3.xx. :sisi
Ubuntu è fatta così :bsh

Andy86
04-02-12, 16: 23
:bai

Sembra non sia un problema mio... https://bugs.launchpad.net/ubuntu/+source/libnotify/+bug/859223

Secondo voi se la metto a mano cercandola su packages.ubuntu.com scasso qualcosa? :m:

pierino_89
04-02-12, 19: 32
No, mal che vada sul lungo termine rimarrà lì inutilizzata.

Andy86
04-02-12, 19: 45
:bai

Grazie. Fatto. Funziona. :thx