PDA

Visualizza versione completa : Reti e Connessioni Problema assegnazione indirizzi ip in rete locale



Ricky
13-01-12, 10: 29
Salve a tutti

La mia rete di casa è così composta:

- 1 router con access point wireless
- 2 pc Windows 7 collegati wireless
- 1 mac collegato in wireless
- 1 pc Windows 7 collegato con ethernet tramite adattatore Powerline (quelli che fanno passare il segnale nei fili della corrente elettrica)

Il router è configurato per fare da server DHCP dall'indirizzo 192.168.0.2 (il 192.168.0.1 è il gateway) fino a 192.168.0.254.

Il problema è che così configurato, se io imposto sui pc o sul mac nelle impostazioni ipv4 "assegna indirizzo ip automaticamente" a volte ho dei problemi a collegarmi. Allora sui pc imposto un indirizzo statico (es. 192.168.0.15) e allora mi si connettono.

Ecco un log di errore tipico di quando provo a connettermi via wireless:


Only registered members can view code.

Cosa può essere?

Asterix
13-01-12, 13: 52
I problemi potrebbero essere svariati ora mi vengono alla mente:

un conflitto di ip
una mancata risposta del server dhcp in modo rapido
il pc client si avvii prima del server dhcp
l'ip richiesto non è stato preventivamente rilasciato dal server dhcp, se non ricordo male il server associa l'ip al mac address in modo tale da riassegnare il medesimo ip se questo si ripresenti all'interno di un lasso di tempo prestabilito

Io normalmente consiglio di assegnare ip statici ai pc fissi, ad es. da 192.168.0.2 a 192.168.0.100 ed attivare il dhcp per gli apparati mobili, naturalmente con questa configurazione il server dhcp deve essere impostato a dovere in modo tale da assegnare il range di ip da 192.168.0.101 a 192.168.0.254

:bai

Ricky
13-01-12, 21: 32
un conflitto di ip

Si, a volte mi dà anche questo messaggio, ma non capisco: il DHCP non dovrebbe assegnare al pc che si connette il primo indirizzo libero?


Io normalmente consiglio di assegnare ip statici ai pc fissi

Purtroppo io non ne ho: il più fisso è quello collegato col Powerline. Ma avevo provato ad assegnare ai miei 4 pc di casa ip statici, ma a volte non si connettevano.

Che sia il router Netgear (pure nuovo) che non funzia a dovere??

Kirk78
17-01-12, 12: 59
Ciao Ricky :bai.
Concordo con Asterix sugli IP fissi. Io ho tutte le macchine attaccate con i powerline, per via di interferenze, ma con il DHCP ogni tanto mi inseriva un IP già assegnato e quindi mi "butta fuori" un'altra macchina (conflitto IP).
Allora ho optato per gli IP fissi e tutto è filato alla perfezione.

ma a volte non si connettevano.
Quì bisogna vedere se il problema è dovuto al wireless oppure all'IP.

Puoi sempre fare 2 configurazioni alternative per i portatili, una per la tua rete e una per l'esterno.
Sul router puoi comunque sempre assegnare te un IP ad un determinato MAC-Address e anche dare un'occhiata al log per vedere anche da lì se c'è qualche conflitto.
:bai

Ricky
28-01-12, 16: 02
Allora

ho attivato il DHCP per gli indirizzi dal 192.168.0.100 al 192.168.0.254, invece che dal .0 al .100 e i problemi sembrano essersi risolti. Per adesso non ho impostato nessun ip statico, ma non escludo di farlo in seguito.

Kirk78
30-01-12, 15: 58
Forse c'era un IP che andava nella prima parte.... comunque prima di mettere il risolto, attendiamo un (bel) po' di tempo, e poi ci fai sapere.
:bai