PDA

Visualizza versione completa : Windows Vista/ 7 Abilitare la cache di scrittura del disco



LadyHawke
24-10-09, 21: 51
Abilitando la cache di scrittura del disco si aumentano le performance del disco fisso e conseguentemente di tutto il Sistema: per contro c'è il rischio di perdita di dati nel caso di interruzione improvvisa dell'energia elettrica; tale situazione non può però verificarsi nel caso si utilizzi un Gruppo di Continuità (UPS) e nel caso di Notebook con la batteria inserita.

Di norma la cache del disco è già abilitata, ma costa poco verificare, approfittando per spuntare anche l'altra opzione presente nella finestra di gestione:

Start --> tasto destro su Computer --> Proprietà --> Gestione Dispositivi nel menù a sinistra
Espandere la voce Unità Disco e selezionare il Disco Fisso al quale abilitare la cache -->Proprietà -->Criteri-->
Mettere la spunta a "Attiva cache in scrittura sul dispositivo" e solo se disponete di UPS o notebook con batteria funzionante a Disattiva scaricamento buffer cache in scrittura..."


http://www.collectiontricks.it/imagesbox/collection/icone/ct.png

ARAGORN II
01-11-09, 21: 55
Mi chiedevo, esattamente cosa provoca l'attivazione della cache su disco? E perchè un'interruzione di corrente potrebbe determinare la perdita di dati? Nel senso, che tipo di dati vengono memorizzati?

Grazie! :)

:bai

LadyHawke
01-11-09, 23: 05
Ciao Aragorn,

l'attivazione della cache come vedi è a discrezione dell'utente: ogni disco fisso ha sempre una sua cache di svariati Mb chiamata anche buffer di memoria (nei dischi attuali si va dagli 8 ai 32MB): tramite la procedura che ho postato si istruisce il S.O. ad utilizzare o no quella cache.

La cache è una memoria tampone: serve a far si che il disco reperisca più velocemente dei dati, sia che debba passarli in elaborazione sia che debba solo caricarli; generalmente si tratta di dati usati di recente che sono molto più veloci da riprendere nella cache che facendo spostare la testina del disco su e giù :hap, e la resa migliore si ha quando i dati sono contigui.

Quindi va da se che stiamo parlando di qualsiasi tipo di dati, e poichè la cache è una memoria Ram (quindi volatile e non fisica), nel caso di interruzione di corrente purtroppo non rimane nulla di quanto vi stava transitando

:bai

ARAGORN II
02-11-09, 09: 59
Grazie mille Lady, sei stata estremamente chiara! :) Era proprio quello che mi serviva sapere.
Ho appena controllato e su Windows 7 è attivata di default, mentre su Vista no; proverò quindi ad attivarla anche per quest'ultimo.

:bai

Syryo_skz
06-01-12, 10: 37
Ciao a tutti, in particolare a colei ha aperto questo thread
le cui delucidazioni per me sono al momento importantissime.

Da ieri ho per la prima volta un problema grande quanto 'na casa!

Sul mio PC (con OS Win XP) ho 5 HD, tutti Sata2.
In particolare, 3 su 5 sono adibiti:
(G: ) ai files temporanei ed alla cartella Incoming di un P2P -> 500Gb
(M:) tutti i films dalla "A" alla "L" -> 1Tb
(N:) tutti i films dalla "M" alla "Z" -> 1Tb
Una volta completati, i files vengono spostati al rispettivo HDD e rspettiva Cartella (in Share, ovviamente).

Ieri, stavo cercando di spostare 4 files da (G:) in (M:) ma continuamente ho un errore con tanto di baloon giallo sulla status-bar ed icona-triangolino giallo con punto esclamativo:
"errore scrittura rimandata non riuscita impossibile salvare".

L'HDD è nuovo, lo uso con soddisfazione da circa 1 anno (mi pare), l'intera macchina ha funzionato correttamente fino a ieri sera, non è stata spostata, sballottolata o simili.
Leggere i files sull'HDD incriminato è possibile, spostare da una cartella ad un'altra NELLO STESSO HDD è possibile.
Unica operazione impossibilitatami è la suddetta.

Il Quick-Test WD Diagnostics è passato OK,
Il Quick-Scan degli errori con HD Tune è Ok,
Se provo a copiare usando TeraCopy, allo 0,1% si blocca con log "Impossibile effettuare la richiesta a causa di un errore della periferica I/O
Sono nel panico!
anche fare uno Scandisk è stato impossibile (in 6h è restato fermo allo stesso punto della fase 4 ed ho dovuto forzare la chiusura) ed usare un SW come Partition Wizard per effettuare un controllo disco, mi da continuamente errori del tipo descritto per lo spostamento files.

Oggi, tra le tante cose, ho provato a disabilitare la cache sull'HDD (M:) e, dopo il riavvio, è stato finalmente possibile lo spostamento dei dati.
A questo punto mi chiedo: PERCHE'?
Per Circa un anno la cache è stata attiva e non mi ha dato problemi l'HDD. Poi, di punto in bianco, succede questo.
É qualcosa di preoccupante?

grazie!

LadyHawke
06-01-12, 14: 16
Ciao Syryo_skz e :welcome: su CT

Su due piedi mi vengono in mente due cose: per qualche motivo la cache era piena, e quindi si sarebbe potuto ottenere un effetto contrario ad un miglioramento delle performance, o il disco M: inizia ad avere dei problemi che non sono stati rilevati dal QuickScan di HDTune (test piuttosto blando e non affidabile).
Per la prima verifica potresti riattivare la cache e riprovare a copiare gli stessi files.
Pe il secondo test verificherei intanto se è attivato nel Bios lo S.M.A.R.T. per il controllo fisico degli hard disk, poi farei dei test più approfonditi con HDTune, ovvero il Benchmark con successivo controllo nell'Health per vedere se ci sono valori allertati in giallo: dipendentemente da quelli successivamente potresti fare anche un ErrorScan approfondito, ma per come esponi il problema non credo ci siano settori danneggiati, o meglio, forse ce ne sono ma il disco potrebbe essere ancora in grado di sostituirli con i suoi di riserva, per cui potresti avere qualche problema ma il disco risulterebbe ancora buono: lo S.M.A.R.T. potrebbe però essere in grado di rilevare anche queste anomalie.

:bai

Syryo_skz
03-03-12, 09: 44
Ciao!
dunque, a distanza di tempo posso dirti che, disabilitando la cache e riavviando WinXP il problema si era risolto solo utilizzando TeraByte Copy, il chè era tutt'altro che fastidioso:eye ...
Due giorni fa, però, il problema mi si è ripresentato senza remore. Ho provato a far partire no scandisk con chkdsk M: /F /R ma dopo 31 ore ero appena al 37% !!! Estenuante!
Ho disabilitato SMART dal bios e riaviato in modalità provvisoria con prompt dei comandi e facendo lo stesso scandisk: nulla. stessa lentezza (ho aspettato 10 min, non ho altre 31ore...:ohoh ) ora sono in WinXP con WD Diagnostics facendo un Extended Test ma a quanto pare mancano 70 ore!!!:cry3 Considerando che lo step successivo dovrebbe essere HD Tune, è mai possibile che debba restare una settimana senza usare il PC per 2 test del cavolo?:triste

Non so che pesci pigliare (ed il bello è che non è nemmeno un buon momento per aquistare un nuovo HDD :cry3)

LadyHawke
03-03-12, 22: 04
Ciao Syryo_skz,
la butto lì, ma se esegui il test Benckmark di HD Tune non vorrei che tu ti ritrovassi il transfer rate molto vicino allo 0.... dai un'occhiata e facci sapere

:bai

Syryo_skz
04-03-12, 16: 41
Ciao Syryo_skz,
la butto lì, ma se esegui il test Benckmark di HD Tune non vorrei che tu ti ritrovassi il transfer rate molto vicino allo 0.... dai un'occhiata e facci sapere

:bai

quindi dici di chiudere il test western digital per cui, attualmente, mancano 41 ore? :ohoh

LadyHawke
04-03-12, 21: 56
Assolutamente si: nessun test ha questi tempi assurdi, vuol dire che c'è qualcosa che non va e secondo me è da ricercare nella lentezza del disco.

:bai

Syryo_skz
05-03-12, 22: 07
Ho fatto il Benchmark...
effettivamente, già a confronto con un secondo, l'HDD del primo screenshot ha risultanti pessimi :shock
1888
1889

Quanto mi devo preoccupare?:cry3

LadyHawke
06-03-12, 19: 35
Quanto mi devo preoccupare?:cry3
Abbastanza: il disco potrebbe continuare così per un periodo indefinito (ovvero non completamente guasto ma comunque da urlo), come potrebbe peggiorare le sue condizioni fino alla paralisi (come e quando lo decide lui)

:bai

Syryo_skz
07-03-12, 09: 34
:shock eh?|?
quindi sarebbe solo da buttare e sostituire?
Ma ha appena 2 anni!:cry3

LadyHawke
07-03-12, 11: 13
Mi spiace, la qualità degli hard disk è sempre più bassa....controlla bene che non sia ancora in garanzia e per scrupolo prova a cambiare la porta sata sul quale è collegato e rifare il test

:bai

Syryo_skz
07-03-12, 15: 08
Mi spiace, la qualità degli hard disk è sempre più bassa....controlla bene che non sia ancora in garanzia purtroppo l'ho preso su eBay (nuovo e sigillato) e quindi non posso appellarmi a nulla senza scontrino :(


e per scrupolo prova a cambiare la porta sata sul quale è collegato e rifare il test :bai
ci proverò... nel frattempo(ammesso che non si riavvii ancora il PC), attendo l'esito dell'error scan e ti/vi faccio sapere ... :S

Syryo_skz
10-03-12, 18: 05
Ecco il risultato dei lunghissimi test:
http://img267.imageshack.us/img267/3959/hd1errorscan.th.png (http://imageshack.us/photo/my-images/267/hd1errorscan.png/) http://img21.imageshack.us/img21/8049/hd1health.th.png (http://imageshack.us/photo/my-images/21/hd1health.png/)
devo supporre che è tutto ok?:shock


I tempi dilatati sono dovuti al fatto che quasi sicuramente il disco è passato dalla modalità Ultra DMA (anche se SATA di solito la modalità indicata è quella) alla modalità PIO Mode.
In effetti è così.
provo a fare una disinstallazione via SW e riavvio.
Poi Ti/Vi faccio sapere ;)

EDIT:

disinstallato-riavviato-installato-riavviato.
me lo sono ri-trovato in UDMA ma non appena ho provato a fare un copia-incolla,
ho ottenuto di nuovo lo stesso errore
http://img72.imageshack.us/img72/9026/hd1errorecopia.png (http://imageshack.us/photo/my-images/72/hd1errorecopia.png/)

Uploaded with ImageShack.us (http://imageshack.us)
ed l'HDD è tornato in PIO Mode :wall