PDA

Visualizza versione completa : Vista - Voglio disinstallare Shark007 video codec pack... problema con una chiave



Kirk78
23-05-11, 22: 34
Ciao a tutti!

Per poter risolvere un'altro problema mi hanno consigliato di disinstallare un cavolo di Codeck Pack chiamato Shark007 (http://shark007.net/vistacodecpackage.html) che non vuole proprio disinstallarsi in Svista.
NON INSTALLATELO

Ho creato temporaneamente anche un Super admin, ma si blocca il tutto (anche regedit) perché nessuno riesce ad accedere alla voce di registro:

HKEY_LOCAL_MACHINE\Software\Microsoft\MediaPlayer\ MLS

sia l'uninstall (tab help del tool di configurazione) sia anche provando a leggere semplicemente la voce con regedit (o anche la versione 32) eseguita come amministratore da super-admin.


Impossibile aprire MLS. Un errore impedisce l'apertura della chiave. Dettagli: Accesso negatoIn realtà, ho appena notato, che non riesce ad entrare in nessuna sotto cartella di

HKEY_LOCAL_MACHINE\Software\Microsoft\MediaPlayer\

Vedo solamente 8 voci di registro (che posso anche modificare) ma tutte le sotto cartelle: accesso negato!

Che mi dite? Io sto :wall

Revo, consigliato dal buon Andy86, non saprei come farlo partire, visto che è una voce del loro tool di configurazione. E poi se non riesco neanche a leggere quelle cartelle dal regedit, non credo che Revo ci riesca!

:thx :bai

AGGIORNAMENTO: ho fatto l'esportazione del registro e vedo che ci sono 2 cartelle con dati: Services e ShimInclusionList. In queste sotto voci posso tranquillamente entrare. le altre non sono neanche uscite in esportazione....

Ho trovato un "esempio" di cosa potrebbe esserci nella voce MLS/Extensions

Only registered members can view code.

Qualcuno con un problema diverso aveva



Remove HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MediaPlayer\ Setup\wmp.dll
Remove HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MediaPlayer\ Setup\wmploc.dll
Remove HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MediaPlayer\ Setup\\wmplayer.exe

Ma io non posso accedere a quelle voci....

Provato anche Modify the codec installation e poi Remove. Si apre il Windows installer e poi si blocca sempre allo stesso posto.

1273

Kirk
23-05-11, 23: 57
Di reinstallarlo sopra (per poi disinstallarlo) hai provato?

non credo che Revo ci riesca!Che cosa dice Revo, lo stesso del suo unistall?


Ho trovato un "esempio" di cosa potrebbe esserci nella voce MLS/ExtensionsSi, piu' o meno, io ne ho molte meno e posso modificarle e farne cio' che voglio, e come sai ho Vista, sinceramente penso che tu con quella ciofeca di pack te ne ritroveresti probabilmente molte di piu', soprattutto se è stato usato wmp spesso..
Ma..non capisco pero', cioè il pack non si disinstalla per quelle voci presenti??

Kirk78
24-05-11, 00: 26
Vai di revounistaller, selezioni il setup con il modo mirino, dopo che si è chiuso con l'errore, prosegui con la procedura, cancella tutto quello che revo trova e ciao-ciao pack.
Allora ho messo mirino. Ho fatto modifica codec -> Rimuovi e ora ho la finestra di errore dove posso fare solo [OK] quando è che devo cliccare sul mirino prima o dopo l'OK?
Non ho capito esattamente cosa il caro Andy dice con "prosegui con la procedura".
Se lo faccio prima mi dice: Nessun risultato! Provare ad indicare un'altra finestra etc etc
Se sposto il mirino sulla finestra errore mi dice di disinstallare Windows Installer :shock (msixec.exe): dove lo piazzo il mirino? E' un codec... lo metto su setting32.exe in
Programmi -> VideoCodecPack -> Tools -> Settings32.exe?

:bai

Kirk
24-05-11, 04: 58
Se non lo trova credo non lo puoi disinstallare cosi', io proverei di reinstallarlo, se riesce poi puoi fare piazza pulita.. per certi softwares in passato ho dovuto far cosi' o niente.

Andy86
24-05-11, 13: 12
:bai

Allora, per la chiave io (con xp) riesco a vederla. Non ho capito se hai provato anche a eseguire regedit (regedit.exe) con permessi di amministrazione. Magari prova anche a cercarlo in system32 ed eseguirlo con pulsante destro -> esegui come admin. :sisi
Altrimenti prova anche a copiare in un file di testo queste righe:


Only registered members can view code.E salvarle con estensione ".reg", quindi eseguirle. :sisi (Questo dimostra quanto sia facile creare un malware per windows... :triste).


Se sposto il mirino sulla finestra errore mi dice di disinstallare Windows Installer :shock (msixec.exe): dove lo piazzo il mirino? E' un codec... lo metto su setting32.exe in
Programmi -> VideoCodecPack -> Tools -> Settings32.exe?Si, esatto. O comunque prova su qualunque file relativo al programma (file, non finestra, altrimenti riconosce il gestore finestre) e speri che ti riconosca il codec pack.
Altrimenti pulizia totale cancellando a mano le finestre e poi pulizia del registro, magari con due pulitori.



Non ho capito esattamente cosa il caro Andy dice con "prosegui con la procedura".Questo valeva nel caso revo ti mostrava l'icona per l'unistaller nell'elenco applicazioni. Quando davi OK all'errore, poi invece di chiudere la finestra di revo, aspettavi che usciva avanti e lo davi. Avevo anche messo un paio di immagini di là. :sisi

Kirk78
24-05-11, 15: 27
Ciao.
@Andy86: ho visto le immagini (grazie), ma ovviamente lì c'era l'uninstaller di SAS o, come da tua cortese figura, il link al programma stesso. Quì si tratta di codec-pack quindi non c'è un vero e proprio programma ma, appunto, dei codec che al massimo vanno settati. Ho paura che disinstallando con Revo semplicemente il configuratore di codec... mi disinistalli solo quello e quindi sarebbe ancora più difficile disinstallarlo ... senza neanche un menù di disinstallazione. Questo è il mio dubbio che mi ha fatto, per ora, non fare questa prova con Revo. Anche Kirk ha i miei stessi dubbi.
Se in questa macchina avessi la licenza di XP non stavo con questi problemi. E' che con Svista è tutto :aargh
Ho fatto sia Prompt di comando (come amministratore) e sia regedit che la versione a 32. Ho anche creato temporaneamente un super admin con il comando

Only registered members can view code.e anche da lì comunque non funzionano tutti e 2. Proverò anche da modalità provvisoria...

@Kirk: indovina un po'... lor signori dicono di ... disinstallare (per sicurezza :furious) prima la precedente versione .... il cane che si mangia la coda. Potrei provare a fare quella on-line tramite il programma, sperando che poi il problema non si raddoppi :wall è lentissimo il download. Ma tento prima questa....

Lo sapete... a me viene un fortissimo sospetto: che quella zozzeria di windows media player ia diventato un super sudo administrator con poter di vita e di morte sulle sulle sue maledette sotto cartelle di registro....
Vi avevo detto che alcuni aggiornamenti (http://www.collectiontricks.it/forum/software/Ct3216-windows-vista-service-pack-2-si.html#post82494) non li ho fatti. Si parla genericamente anche di compatibilità, grafica e ... video.
Poi immagino ci sia anche il nuovo media player e il nuovo explore 9.... :wall
Se concludo scriverò un libro: come arpionare e squartare 007 squali!
:bai

EDIT: Ho notato che in ProgramData\VistaCodecs\{bla bla bla}\ c'è un Vista Codec Packages.msi ...
P.S. sul loro forum il programmatore dice di non utilizzare assolutamente i pulitori di registro. Io per ora non li uso...

AGGIORNAMENTO: la reinstallazione mi da un errore su ... una query SQL :shock ma cosa c'entra ora una query SQL?

Only registered members can view code.

Andy86
24-05-11, 21: 11
Ho paura che disinstallando con Revo semplicemente il configuratore di codec... mi disinistalli solo quello e quindi sarebbe ancora più difficile disinstallarlo ... Quando in revo fai la cancellazione ti fa vedere esattamente che cosa va a cancellare, quindi ti puoi rendere conto se toglie solo file config o anche dei codec in %systemroot%/system32. Comunque non mi è mai capitato che mi togliesse solo una parte di un programma. Più volte mi sono capitati setup corrotti che non volevano saperne di svolgere il loro compito, e in tutti i casi revo (mirino o no) mi ha risolto il problema con un bel "seleziona tutti i risultati - cancella". :sisi

Perché suggeriscano di non utilizzare pulitori di registro non lo so, ma se il suggerimento è onesto mi vien da pensare che sia riferito al "prima dell'installazione", perché potrebbe rimuovere i riferimenti alla presenza del pack lasciando residui in system32. :m:

Comunque non ho capito se hai provato col file .reg che ho suggerito sopra. :confused:

Kirk78
24-05-11, 21: 26
Ciao Andy86 :bai
Volevo prima provare con Revo come da primo consiglio. Visto che adesso su Pannello di Controllo -> Programmi e funzionalità ci trovo anche Vista Codec Packages il mirino lo posso trascinare direttamente lì oppure sul C:\ProgramData\VistaCodecs\{bla bla bla}\Vista Codec Packages.msi ?

Sul Pannello di Controllo dice nessun risultato. Se apro il setting mi dice: Disinstalla o rimuovi VistaCodecs Setting Application.

In modalità "normale" vedo i programmi installati (con Vista Codec Packages) e mi da la possibilità di


Disinstalla
Disinstalla forzato
Rimuovi
.
.
Apri le chiavi di registro... (interessante)

Ho visto anche che c'è il modo Uninstaller (Disinstallatore) .. che poi è quella "normale" :ghgh

:bai

Andy86
24-05-11, 21: 51
In modalità "normale" vedo i programmi installati (con Vista Codec Packages)

Se adesso riesci a vederlo in modalità normale il mirino non ti serve più. E sei già a metà dell'opera. Quindi comincerei con un disinstalla, per poi eseguire la pulizia di revo anche se il setup si chiude, come detto prima.

Disinstalla forzato -> mai visto e non sembra neanche menzionato nel manuale. :boh

Rimuovi -> Attenzione: È come il cancella voce di ccleaner, rimuove la voce dall'elenco e basta. Quindi non farlo.

Kirk78
24-05-11, 21: 55
Ok. procedo. Comunque leggo che

Disinstalla forzato: tale voce compare solo su alcune applicazioni.Per info, nelle chiavi registro (tranne ovviamente quella che non riesce a leggere) trovo tra le altre

Only registered members can view code.[Disinstallatore] Sicuri di voler disinstallare il programma selezionato? Vista Codec Package [ciumbia :ok:] [no]

Selezionare Metodo di Disinstallazione:


Incorporta (l'italiano no è ?)
Sicura - include il metodo Incorporato ed esegue ulteriori scansioni nel Registro e nel Disco fisso per ricercare voci rimaste e sicure da eliminare. Metodo più veloce.
Moderata (default)
Avanzata


Provo Incorporta (a incorporta :ghgh) e se non funziona Sicura ... per andare sul sicuro?
Che dite?

Kirk
24-05-11, 23: 56
e se non funziona Sicura ... per andare sul sicuro?
Che dite?Io con la moderata non ho mai avuto problemi, a dir la verità me ne infischio del fatto che consigliano di non pulire il registro ulteriormente e ci ripasso con altro (Regseeker, solo voci verdi), trattandosi di codec io ci andrei giu' pesante, si devono sradicare completamente o sono come l' erba cattiva, poi ritornano :ghgh

Se non ti senti sicuro comunque fai almeno la sicura, con la prima voce credo cerchi troppo poco le voci rimaste..

Kirk78
25-05-11, 00: 27
Ok.
[1] Creazione punto di ripristino :ok:
[2] Analisi dati dell'appliczione prima dell'installazione :ok:
[3] Avvio dell'installatore dell'applicazione per un disinstallazione predefinita -> Si apre il disinstallatore -> Rimuovi -> Rimuovi ... rimozione ... il solito ERRORE... ma allora ditelo...
... e ora? Ma Revo in pratica non ha fatto nulla di diverso da quello che avevo fatto io in precedenza....
Ovviamente sono fermo prima del:
[4] Premere il tasto "Avanti" per avviare la scansione dei file rimasti, delle cartelle e delle voci del registro una volta terminata la disinsallazione dell'applicazione
:furious :wall

Ho premuto [OK] sull'errore solito ... ripristino del sistema alla situazione precedente ... La procedura guidata è stata interrotta prima che Vista Codec.... -> Fine

NON ho ancora premuto Avanti per la fase [4] perché NON ha fatto la disinstallazione... e ora? Martello? :bsh
Faccio Annulla o Indietro ? Se faccio Avanti ho timore che cancelli voci e cartelle senza che sia stato disinstallato: oppure Revo funziona così?
Il programmatore Shark consiglia l'antico pulitore che dava gratuitamente Microsoft, anche se so per certo che non c'è più nei siti Microsoft....

AAAAAAAAAAAAAARGH

EDIT: Il programmatore Shark007 ha messo un link (non su Microsoft che l'ha ritirato dai loro siti) del vecchio tool di Microsoft (versione 7.2) e ha detto di installarlo di selezionare "(All Users) Vista Codec Package" e fare Remove... e dopo reinstallare i nuovi codec ... che dite provo?

Oppure mi consigliate di fare la prova sul Registry consigliata (http://www.collectiontricks.it/forum/multimedia-grafica/Ct3284-vista-voglio-disinstallare-shark007-video-codec-pack-problema-chiave.html#post83915) dal buon Andy86?

Kirk
25-05-11, 13: 31
Ti vedo titubante, prova con uno o con l' altro, quel pack lo devi sradicare, non ho mai usato il tool della microzozz pero'.. importante è che tenti qualsiasi forma possibile per togliere quel "male".
Al limite ci sono sempre gli innumerevoli punti di ripristino di Vista..

E la prossima tira le orecchie alla sorellina prima di installare certa roba :ghgh

Kirk78
25-05-11, 17: 47
Ho i miei dubbi perché non conosco Svista, se era XP avrei risolto dopo 2.1 secondi netti... ne sono certo. Io lo usai una volta e mi fece più danni che altro. Ovviamente mi fido più di voi che del programmatore del pako, e poi lui continua a fare riferimento, inizialmente, al vecchio link microsoft. Poi qualcuno gli ha accennato che non esisteva e ne ha dato uno su majorkìgeeks... Tra l'altro l'ultima revision dello scorso anno doveva essere la 7.6 e il link fa riferimento alla 7.2 (Windows Installer Clean Up Application 2.05.0001) poi però è, appunto, stata ritirata (http://support.microsoft.com/kb/290301). Chi dice che perché dava fastidio a quell'altra roba di Office 2007, chi dice invece per colpa del marketing perché volevano far pagare gli interventi tecnici spot anche telefonici :boh chi dice che avevano ingaggiato un team di terze parti per creare i Microsoft Fix It.
Posso anche capire che sia io che lei lo scorso anno (quando è avvenuto il fattaccio) eravamo impegnati con figli e nipoti, oltre che il grave problema di salute di famiglia che avevamo, ma comunque :bsh fatto :ghgh

Mi ero dimenticato della mia auto proposta di disinstallarlo in provvisoria: ...

Il servizio Windows Installer non è accessibile in modalità provvisoria :furious

Andy86
25-05-11, 18: 15
:bai Rientro adesso.


NON ho ancora premuto Avanti per la fase [4] perché NON ha fatto la disinstallazione... e ora? Martello? :bsh
Faccio Annulla o Indietro ? Se faccio Avanti ho timore che cancelli voci e cartelle senza che sia stato disinstallato: oppure Revo funziona così?

Era proprio ciò che intendevo prima. Anche se il setup termina con l'errore, revo unistaller riesce comunque a sradicare tutte le cartelle e le chiavi di registro rimaste, quindi equivale a disinstallare. Anzi, meglio. :sisi
Quindi premi Avanti, e magari dai anche una scansione avanzata, così leva tutto. Ps: incorporata esegue solo il setup dell'applicazione, senza effettuare altre ricerche.

Kirk78
25-05-11, 18: 32
Grazie Andy86 :bai
Riavvio in normale e ci provo subito. Visto che tu riesci ad entrare in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MediaPlayer\ MLS mi dici che cosa c'è dentro?
Ovviamente neanche in provvisoria riesce ad entrare in quella voce, e neanche a creare una nuova chiave con il tasto destro.
Ecco quelle che riesco ad esportare:

Only registered members can view code.
Ovviamente è gradito anche sapere dagli altri cosa c'è dentro anche con sistemi diversi, così magari le confrontiamo. Dopo posto anche tutte le voci che ha trovato Revo.

Questa è l'ìimmagine di Revo comunque
1276

:bai

Andy86
25-05-11, 18: 51
Eccoti accontentato:

http://img200.imageshack.us/img200/6576/hkmlmsmpmls.png (http://imageshack.us/photo/my-images/200/hkmlmsmpmls.png/)

Ma non chiedermi che significhi.

Kirk78
25-05-11, 18: 58
Grazie sempre DOC! E nella sola MLS?

Andy86
25-05-11, 19: 00
Niente. Solo quella chiave che ho evidenziato.

Kirk78
25-05-11, 19: 09
Revo ha trovato 24 voci in

Only registered members can view code.
Mi sembrano 23 però è un dettaglio ma forse è indicata anche la cartella come voce.

Non ho ancora fatto Avanti per una vostra valutazione.

Andy86
25-05-11, 19: 17
:bai

Quelli sono tutti i valori contenuti nella chiave
Only registered members can view code.ovvero quella chiave che contiene tutte le informazioni utili a windows per visualizzare il programma nell'elenco applicazioni, nulla più.

Cancella pure tutto.

Kirk
25-05-11, 19: 47
Visto che tu riesci ad entrare in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MediaPlayer\ MLS mi dici che cosa c'è dentro?Quella lista dipende poi ovviamente da pc e pc e a cosa c'è installato, io ho molte meno voci, forse perche' WMP mi son scordato di averlo sul pc?? :ghgh

http://img585.imageshack.us/img585/1801/vociregistro.jpg (http://imageshack.us/photo/my-images/585/vociregistro.jpg/)

Kirk78
25-05-11, 20: 29
Grazie Kirk! E anche tu immagino che non hai nulla nella semplice voce MLS?

forse perche' WMP mi son scordato di averlo sul pc?? :ghgh
Concordo! Nel mio di PC l'ultima volta che l'ho aperto.... mi sa che non l'ho mai aperto :ghgh
Tra poco vi dico cosa ha fatto Revo con la "Sicura" e vi dico se ho tolto sta "roba". Ovviamente seleziono [:ok:] solamente l'ultima cartella (quella con i codici del software) e l'unica tra l'altro che è in grassetto. :bai

EDIT: ovviamente prima faccio Cancella e poi Avanti

Kirk
25-05-11, 20: 47
E anche tu immagino che non hai nulla nella semplice voce MLS?Esatto, solo un predefinito non impostato :hap

Kirk78
25-05-11, 20: 52
E che sia per quello, ovverosia che gli manca la voce predefinito anche se non impostato....
Comunque prima faccio Cancella e poi Avanti -> mi ha trovato 291 elementi tutte in Program Files\VistaCodecPack seleziono tutto e Cancella -> Terminato e mi chiede se voglio cercare ulteriori voci andare Indietro. Faccio TERMINATO.

Poi riavvierò la macchina. Penso che comunque rimarrà nel Pannello di controllo.

Modalità sicura per ora... eventualmente se non va posso in seguito provare una più profonda no? Intanto se resta nel Pannello immagino che posso riavviare la disinstallazione non farà alcuni passaggi già fatti, ma potrà fare altro: CORRETTO?

Poi, come suggerito dal buon Kirk, meglio che installo l'ultima versione del packo e poi disinstallo "normalmente"? GRAZIE!

:bai

Kirk78
27-05-11, 08: 18
Ciao. Allora, come detto ho fatto la disinstallazione "sicura" di Revo e mi ha cancellato le voci di registro dell'Uninstaller e i file dentro la cartella di installazione.

Come mi aspettavo il nome Vista Codec Package è rimasto nella lista anche di Revo.

Ovviamente le sottocartelle in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MediaPlayer\ che non riuscivo ad aprire continuano ad avere Accesso Negato, ma anche queso me lo aspettavo.

Se faccio apro chiavi registro da Revo adesso mi fa vedere quelle in
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Installer\UserData\S-1-5-18\Products\EC08 bla bla bla\InstallProperties
dove mi sembra ci siano scritte le medesime cose che c'erano nella "Uninstall" tranne
[SPOILER=Mi sembra unica differenza]LocalPackage = C:\Windows\Installer\b1422.msi[/QUOTE]
che dovrebbe indicare la copia dell'installer originale e altre 3 voci che non mi sembra vogliano dire molto.

Quindi: mi conviene provare a installare adesso la nuova versione del codec e poi disinstallarlo oppure cosa (fare anche una disinstallazione più profonda con Revo)?

Ma sopratutto: in che maniera vedo se hanno veramente disinstallato il packo? Ho scaricato VD e ho visto che nella sessione compression ci sono

Only registered members can view code.Che mi sembra siano quelli che vedevo da Windows Media Player -> Informazioni. Quindi praticamente non ha fatto nulla Revo... Forse per i codec in Svista si deve fare in altra maniera....

Ho provato a vedere adesso cosa mi diceva WMP per confrontare ache i decoder e questa volta mi dice:
Windows Media Player 11 per Windows Vista - Scegliere le impostazioni iniziali per Windows Media Player :shock ma vuoi vedere che a forsa di guardare quella cavolo di cartella con accesso negato, era proprio perché WMP aveva semplicemente perso la trebisonda :ghgh, come avevo "subodorato"?
L'uniche differenze fatte dopo erano il nuovo shockwave e il java che mancava... che però non vedo cosa c'entrano con i setting di WMP 11!

Sono in dubbio se fare Impostazioni personalizzate e vedere se questa volta posso leggere MLS e compagni. Se si mi verrebbe anche l'idea di tornare al punto di ripristino precedente creato da Revo, rifare le personalizzazioni di WMP e poi provare la disinstallazione classica.


OPINIONI SUL DA FARE?


Accidenti a Svista!
:bai

Andy86
27-05-11, 12: 29
Intanto se resta nel Pannello immagino che posso riavviare la disinstallazione non farà alcuni passaggi già fatti, ma potrà fare altro: CORRETTO?Ma... mi sembrava di aver risposto ieri... è sparito il mio post o me lo sono sognato? :boh :confused:

Comunque: nel pannello non dovrebbe rimanere, perché quelle voci che hai citato prima, che revo ha cancellato, sono proprio quelle che servono a windows per visualizzare l'applicazione nell'elenco di quelle presenti. Sono voci che l'applicazione stessa mette quando vuole farsi trovare. :sisi
Se non ha pulito abbastanza, per poter rifare la scansione con revo, devi, come diceva kirk, reinstallarlo e ri-rimuoverlo. :sisi



Come mi aspettavo il nome Vista Codec Package è rimasto nella lista anche di Revo. [...] Se faccio apro chiavi registro da Revo adesso mi fa vedere quelle in [...] E sei sicuro di aver rimosso (facendo seleziona tutto e poi cancella) le voci che ti ha indicato revo?
Per caso ti ha chiesto di riavviare per completare la rimozione delle voci di registro? Se così fosse, penso ad un problema di permessi, (con revo su xp non mi mai successa 'sta cosa, anche disinstallando codec), e ti consiglio di provare ad eseguire revo con i permessi di amministrazione, poi rifai la scansione approfondita, che tanto non danneggia niente. :sisi

Kirk78
27-05-11, 13: 14
E sei sicuro di aver rimosso (facendo seleziona tutto e poi cancella) le voci che ti ha indicato revo?
Assolutamente si, infatti non ci sono le voci uninstall ne i 291 file nella directory di installazione. Non mi ha chiesto di riavviare. Ho chiaramente avviato Revo con tasto destro e avvia come amministratore.... ma pare che non abbia disinstallato quasi nulla (o nulla in realtà visto che i codec sono rimasti).
Comunque in realtà, visto che Revo non ha fatto la disinstallazione, a questo punto posso anche riprovare a rifarla da Revo un po' più approfondita...

Se c'era XP non vi chiedevo neanche aiuto, potevo addirittura farlo ad occhi chiusi. E con sto Svista che c'è la complicazione che non conosco...

Per Windows Media Play 11 (in Svista) che mi dici/dite? E' strano che mi abbia chiesto le impostazione... è come se non avesse completato l'installazione e forse per quello che alcune voci non erano accessibili.

P.S. non c'era il tuo post, sono stato sveglio quasi fino alle 1... :boh

:bai

Kirk
27-05-11, 14: 06
Quindi praticamente non ha fatto nulla RevoPerche' hai quelle voci in VD? A parte l' xvid le avresti lo stesso anche senza pack, dunque non è vero che non hai tolto niente, col pack ne avresti di piu' immagino..
Credo anch'io che è una questione di permessi, non mi sembra che il tuo account li abbia pienamente, e potrebbe capitare lo stesso con altri software, perche' come detto, quelel chiavi le devi vedere, anche su Vista.

Prova a smanettare nelle proprietà e nelle autorizzazioni di cartelle e files, comunque ti avevo suggerito di andarci giu' pesante senza timori, altrimenti a forza di prove e riprove tra un mese ancora non lo hai pienamente sradicato.

P.s. WMP di per se' lo ignorerei, non è lui che ti lascia residui di un pack.

Guarda l' immagine sotto, togli Lagarith, ffdshow, xvid e techsmith, gli altri sono di default installati col sistema operativo col pack non c'entrano niente:
http://img571.imageshack.us/img571/8353/clipboard01ji.jpg (http://imageshack.us/photo/my-images/571/clipboard01ji.jpg/)

Kirk78
27-05-11, 14: 24
Perche' hai quelle voci in VD?
Si. E prima in Media Player Info (quando si apriva subito) mi indicava "solo":

Only registered members can view code.Che sembra gli stessi. Anche dal tool di Sysinternals vedo anche ffdshow (che di soli con VD non si vede).
Posso anche riprovare da Revo direttamente, perché intanto prende la copia dell'installer/deinstaller e ovviamente da lo stesso errore.
Ma siete sicuri che i codec si disinstallano così in Svista? In XP, bello XP...., si disinstallano in altra maniera. Ma personalmente non ho mai installato dei Packki quindi non sparei...

Come avevo detto, ho provato a leggere quella voce di registro anche da SuperAdmin da regedit, ma nulla. Come faccio a vedere le autorizzazioni in Svista?

Pensavo a WMP, magari dandogli delle preferenze di default, perché magari mi sistema la/le chiavi con accesso negato visto che trattasi di chiavi proprio MediaPlayer :boh così magari disinstallo con il suo tool...
Non vorrei che fosse proprio WMP che prende possesso di quelle chiavi e che il disinstallatore del packo debba solo vedere se in quelle chiavi aveva messo messo delle proprie voci, ma WMP prende il sopravvento e inibisce anche il disinstallatore del packo.

:bai

Kirk
27-05-11, 14: 33
che di soli con VD non si vedeSe è installato ffdshow si vede eccome, e' anche encoder non solo decoder.

Ma siete sicuri che i codec si disinstallano così in Svista?Si disinstallano alla stessa maniera che in XP, ne avro' disinstallati un centinaio.. la differenza principale tra xp e vista/seven sono i permessi, e che in questi ultimi proprio per questo è problematica la installazione dei programmini dove si lancia il file .IFO, niente piu'.
Ripeto non credo wmp sia il problema..

Come faccio a vedere le autorizzazioni in Svista?Io l'unica cosa che ho cambiato sono le autorizzazioni di certe cartelle, tramite le proprietà, per il resto non ho cambiato niente ma non ho gli stessi problemi, sapere che è passato su quel pc a distanza è dura..

Andy86
27-05-11, 14: 41
:bai

Hai provato anche ad eseguire revo (con permessi) effettuando l'accesso col net user admin? giusto per non escludere niente.

Per l'errore sulla chiave di registro hai provato questa procedura? -> click (http://www.chicchedicala.it/2009/12/30/assumere-autorizzazioni-per-le-chiavi-del-registro-di-sistema/).


In XP, bello XP...., si disinstallano in altra maniera.

"Bello" dipende dai punti di vista... Comunque io i codec sempre disinstallati così anche su xp, e revo mai sbagliato. :sisi

Kirk78
27-05-11, 15: 00
:bai

Il "super" admin l'ho disabilitato ma posso anche riabilitarlo. Ho provato a cambiare le autorizzazioni con l'utente tutte le sottovoci di MediaPlayer con Promt come amministratore -> REGEDIT e mi dice
L'editor del Registro di sistema non è stato in grado di impostare il proprietario nella chiave selezionata attualmente o nelle relative chiavi secondarie.
Non c'erano comunque nessuna autorizzazione assegnata per MediaPlayer: voci che autorizzazioni avete su \MediaPlayer?

Ho fatto comunque un po girare il cursore su tutte le voci di registro e sembrano solo quelle essere "antipatiche".... ma ora (riesco a vedere il famoso (Predefinito) non impostato alla voce MLS e anche posso "toccare" quelle altre... quasi quasi aggiungo a mano Extensions.... Questo dopo il tentativo che ho fatto adesso con Revo sicura (che non ha trovato nulla).

Guarda un po' che vitaccia con sto sistema...

Andy86
27-05-11, 15: 05
con Promt come amministratore -> REGEDIT


Ed a fare le varie operazioni con con "Promt come amministratore" eseguito dal net user admin? Cioè tutte e due le cose insieme? :m:

ps: ora le autorizzazioni non posso dirtele, perché sono su linux. :ghgh

Kirk78
27-05-11, 15: 24
Intendi Net user administrator /active:yes poi riavviare, attendere la creazione del super admin e poi provare da lì con Revo? Da super admin però non leggeva neanche MLS, cosa che adesso sembra leggerle tutte, ma non c'è la sottocartella Extensions.
Per creare a mano comunque la sottocartella Extensions in regedit è forse Valore stringa espandibile? No non è quello ... non trovo sottochiave...

Ho fatto in modo che MLS abbia l'autorizzazione sia dell'utente che dell'admin ed è apparsa Extensions, ma non leggibile (mancano diritti?)... insomma ogni passo è una passo avanti ma il totale ancora nulla...

P.S. ho provato con Revo -> avanzata e mi ha trovato 606 voci di registro! Alcune delle quali di Neroe altre ignote....

Andy86
27-05-11, 16: 21
Intendi Net user administrator /active:yes poi riavviare, attendere la creazione del super admin e poi provare da lì con Revo?

Sì, però eseguendo comunque revo (o regedit) con clik destro "esegui come admin". Magari c'è qualche doppio permesso che blocca più utenti che malware. :sisi



non trovo sottochiave...

Sotto "nuovo" dovrebbe esserci "chiave" come prima voce.


mi ha trovato 606 voci di registro! Alcune delle quali di Neroe altre ignote....

:m: Sicuro che siano di nero e non del pack che ha accoppiato qualche codec a nero? Io a questo punto rischierei di dover reinstallare nero. Imho. :sisi

Kirk
27-05-11, 17: 24
Sicuro che siano di nero e non del pack che ha accoppiato qualche codec a nero?Concordo in pieno, oltretutto Nero è già di per se' invasivo lui, non pensavo fosse installato anche Nero!!
Sempre piu' convinto che, problema di permessi a parte, il problema non è Vista, bensi' tutto quello zibaldone che c'è installato su quel portatile, e comunque non è che certi problemi non passano in xp, semplicemente lo conosci meglio, sistema diverso, ma anch'esso coi suoi difetti nonostante il sistema abbia avuto lunga vita.

Cioè se non lo si vuol usare ok, ma accanirsi e dare per disastrato un sistema a priori non risolve niente (come il chiamarlo sempre Svista :-)).

Kirk78
05-06-11, 13: 27
come il chiamarlo sempre Svista :-)
:ghgh fammi almeno divertirmi un po :ghgh comunque ho fatto tutto quello che voleva revo e ora non lo vedo più tra i programmi installati quindi, forse, dovrebbe essere stato disinstallato. Come faccio a verificare? VD vede esattamente gli stessi, compreso Xvid (Configure funziona perfettamente.....), di prima. Insomma non c'è nell'elenco ma sarà stato veramente disinstallato? Se si perché c'è ancora Xvid? .... sarà una ... svista di revo? :lol:
:bai

Kirk
05-06-11, 14: 43
Se si perché c'è ancora Xvid?Forse era stato installato in precedenza..alcuni programmi lo installano, Autogk, avisynth ecc. ecc.
Ma lui non è un problema, al limite verifica che funziona in compressione, facendo una prova veloce con VD.
Se non lo vedi (il pack) ne' dal pannello, ne' in Revo, direi che è disinstallato.