PDA

Visualizza versione completa : Che fastidio quei rumori !!!!



Armandillo
17-04-11, 13: 39
:bai


Ho installato Ubuntu 10.10 in dual-boot con Xp su un pc "muletto" (pentium 4 3 ghz) e tutto funziona a meraviglia tranne che per un rumore fastidiosissimo che proviene dal pc ogni qual volta muovo il mouse sullo schermo !!

In pratica il ronzio (si avvicina a quello di un'ape) e' contemporaneo al movimento del mouse :triste ....non solo....aprendo una qualsiasi pagina web, se in questa e' presente della pubblicita' con immagini in movimento, anche quelle provocano il ronzio in sincronia !!

Dalla rete ho appreso che potrebbe trattarsi del powersafe di Ubuntu....ho provato a seguire le istruzioni per disabilitarlo ma il "rigo" da modificare non era il medesimo e quindi ho desistito.

Ho provato anche a disabilitare la scheda audio dal sistema operativo ammutolendo gli altoparlanti...nulla !!

Prima di escludere fisicamente dal pc l'altoparlante mi sono chiesto se per caso qualcuno aveva avuto il medesimo problema e quindi...cosa potrei fare ?

Grazie

pierino_89
17-04-11, 13: 59
Non saprei... Io ho solo problemi di rumori strani quando uso flash a 64bit.

K.a.o.s.
17-04-11, 14: 21
Magari la ventola della scheda video?

Intanto prova a disattivare il pc speaker:

Only registered members can view code.
e vedere se ricompare. Non è una modifica permanente, quindi al riavvio vengono nuovamente ricaricati i moduli.

Armandillo
17-04-11, 15: 12
Niente da fare Air :triste

Ho anche disinstallato pulseaudio, ma niente

E' come se qualsiasi movimento si trasferisse alla scheda audio e comunque , con lo stesso pc, la cosa in Xp non si ripete :boh

EDIT: ho staccato il cavetto sulla mobo e non si sente piu' nulla :sisi ma la stranezza rimane e forse potrebbe riguardare i driver audio di Ubuntu che non sono compatibili :boh
comunque ritengo risolto il problema...faro' a meno dei suoni visto che e' un muletto

:bai e grazie

Kirk78
19-04-11, 17: 24
Che scheda audio è (o se integrata che mobo)? :bai

Armandillo
19-04-11, 19: 33
:bai

Il pc e' un Acer Veriton 5700 gx e Ubuntu mi dice (col programma HardInfo) che la scheda audio e' una HDA Intel mentre Xp (in dual boot con Ubuntu) mi dice che e' una Realtek High Definition Audio.

Ho provato a ricollegare il cavetto sulla mobo e il rumore si ripresenta puntuale solo con Ubuntu.

Kirk78
19-04-11, 22: 05
ho provato a seguire le istruzioni per disabilitarlo ma il "rigo" da modificare non era il medesimo e quindi ho desistito.
Quale rigo, questo:

Only registered members can view code.?

pierino_89
19-04-11, 23: 54
Per curiosità, cosa intendi per il cavetto della mobo?

Armandillo
20-04-11, 18: 15
Quale rigo, questo:

Only registered members can view code.?

No, il primo che appare in questa (http://bouhtouch.blogspot.com/2009/11/disabilitare-il-powersave-della-scheda.html) discussione.
Quel rigo a me appare diverso e quindi mi sono fermato.


Per curiosità, cosa intendi per il cavetto della mobo?

Il cavetto che parte dalla mobo (siglato "audio out") e che giunge all'altoparlante.
Il medesimo risultato l'ho ottenuto disabilitando il controller audio nel bios.

Nota: questo pc ha un altoparlante che, in assenza d'un apparato audio esterno (io ho un 2+1), non produce solo dei "bip" ma tutti i suoni.

Trovata: la scheda audio e' Azalia AC'97

:bai

Kirk78
20-04-11, 23: 23
Quel rigo a me appare diverso e quindi mi sono fermato.
Esattamente il rigo come "appare"? Postalo. E' su alsa-base.conf.
:bai

Armandillo
21-04-11, 16: 15
Esattamente il rigo come "appare"? Postalo. E' su alsa-base.conf

Quel file non c'e' :boh
L'ho cercato con "cerca file" e nelle directory ma proprio non c'e' !

Andy86
21-04-11, 16: 51
:bai

Dimentichi che sei su linux. Alcune cose se non sei root non le puoi fare.


Only registered members can view code.

pierino_89
21-04-11, 16: 54
Beh, se ci fosse stato l'avrebbe aperto in sola lettura. Non credo che sudo risolva la cosa.

Andy86
21-04-11, 17: 04
Più che sudo gli ho indicato il percorso.
Alle volte mi è capitato di non vedere dei file o cartelle (anche navigando con cd) perché non ero root. Però magari non c'entra niente. :boh

Armandillo
21-04-11, 17: 07
Only registered members can view code.

Grazie....con quel comando me lo ha aperto, eccolo:

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2

EDIT: sto cercando di risolvere il problema leggendo discussioni riguardanti l'audio e quindi anche i codec ed e' gia' la terza o quarta volta che cercando di installare da terminale alcuni pacchetti ottengo questa risposta:

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
E: Impossibile trovare il pacchetto non-free-codecs

Voglio sottolineare che la medesima risposta me l'ha data anche, per esempio, cercando di installare un file manager e il pacchetto Anomos.
Probabilmente questo non c'entra con l'audio, ma mi impedisce dei tentativi.
Cosa mi dite ?

Grazie

pierino_89
21-04-11, 17: 50
Più che sudo gli ho indicato il percorso.
Alle volte mi è capitato di non vedere dei file o cartelle (anche navigando con cd) perché non ero root. Però magari non c'entra niente. :boh

Beh dipende dai permessi dei file, in genere se non contengono password viene permessa la lettura a tutti. Soprattutto perché buona parte dei demoni girano con utenti non privilegiati.

@Armandillo: apt-get pretende che tu gli dia il nome esatto del pacchetto. Se non sai come si chiama, cercalo su synaptic e installalo da lì. Non-free-codecs è un pacchetto che non esiste, magari su qualche repo strano sì, ma quello che in realtà desideri sono i gst-plugins-bad e i gst-plugins-ugly. Poi c'è la roba del de-css per i dvd, ma non mi ricordo come si chiama.

Andy86
21-04-11, 18: 10
magari su qualche repo strano sì

Per l'esattezza si tratta del repository medibuntu (http://wiki.ubuntu-it.org/Repository/NonUfficiali/Medibuntu), e non è affatto strano, ma semplicemente non può essere incluso in ubuntu per ragioni di licenza. Il pacchetto in questione è consigliatissimo ogni qual volta si abbiano problemi con i codec open. :sisi

pierino_89
21-04-11, 18: 13
:boh che io sappia nei multiverse (o non-free?) c'è già tutto il necessario!

Armandillo
21-04-11, 18: 33
Allora....ho reinstallato pulseaudio e il gestore audio sulla barra (li avevo tolti per vedere se risolvevo il problema).

Ho collegato l'impianto 2+1 alla scheda audio e si sente correttamente ma il ronzio spostanto il mouse sullo schermo si ascolta solo dall'altoparlantino interno del pc e non dalle casse.
I suoni di Ubuntu si sentono solo se collego l'impianto.

Se tolgo l'impianto dall'altoparlante interno prosegue il ronzio e non si sente alcun suono, cosa che invece con Xp accade !!!

Conclusioni:
Ubuntu non riconosce l'altoparlante interno o comunque non puo' adoperarlo e per qualche ragione strana, invece, riproduce ogni singolo passaggio del mouse !!

Credo che una soluzione sia nel distaccare i cavetti che raggiungono l'altoparlantino ma non quelli della scheda integrata :boh

:bai

K.a.o.s.
21-04-11, 23: 28
Se il problema è disattivare l'altoparlante interno, basta togliergli il modulo. (posta lsmod)

Io controllerei anche che il volume master di alsa non sia al massimo.

@Andy86

Non usare sudo per lanciare programmi con GUI. È facile che crei problemi.

Armandillo
22-04-11, 16: 43
Se il problema è disattivare l'altoparlante interno, basta togliergli il modulo. (posta lsmod)

Io controllerei anche che il volume master di alsa non sia al massimo.

Il volume master e' al 50%.
So disattivare l'altoparlante interno ma preferirei non farlo perche' mi e' comodo quando uso Xp (ricordo che ho Xp + Ubuntu).

Ho fatto anche un'altra prova adoperando tastiera + mouse PS2 invece di quella wireless....il ronzio resta :sisi

:bai

pierino_89
22-04-11, 16: 49
Il volume master e' al 50%.
So disattivare l'altoparlante interno ma preferirei non farlo perche' mi e' comodo quando uso Xp (ricordo che ho Xp + Ubuntu).


Intendeva dire di disattivarlo su Ubuntu rimuovendone il driver. Per questo ti ha chiesto l'output di lsmod.

Armandillo
22-04-11, 16: 58
:ehmm ....ancora sono acerbo con Ubuntu !!

Comunque questo e' il risultato del comando "sudo ismod":

Module Size Used by
pppoe 9015 2
pppox 2054 1 pppoe
joydev 8767 0
hid_microsoft 2691 0
usbhid 36882 0
hid 67742 2 hid_microsoft,usbhid
binfmt_misc 6599 1
nvidia 9329739 38
snd_hda_codec_realtek 218492 1
snd_hda_intel 22235 1
snd_hda_codec 87552 2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep 5040 1 snd_hda_codec
snd_pcm 71475 2 snd_hda_intel,snd_hda_codec
snd_seq_midi 4588 0
snd_rawmidi 17783 1 snd_seq_midi
snd_seq_midi_event 6047 1 snd_seq_midi
snd_seq 47174 2 snd_seq_midi,snd_seq_midi_event
snd_timer 19067 2 snd_pcm,snd_seq
snd_seq_device 5744 3 snd_seq_midi,snd_rawmidi,snd_seq
ppdev 5556 0
intel_agp 26566 0
parport_pc 26058 1
snd 49038 11 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec, snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,sn d_seq_device
psmouse 59033 0
soundcore 880 1 snd
serio_raw 4022 0
agpgart 32011 2 nvidia,intel_agp
snd_page_alloc 7120 2 snd_hda_intel,snd_pcm
lp 7342 0
parport 31492 3 ppdev,parport_pc,lp
floppy 54311 0
tg3 123310 0

Andy86
22-04-11, 16: 58
:bai


@Andy86

Non usare sudo per lanciare programmi con GUI. È facile che crei problemi.

Ne sei sicuro?
Solo una volta, in quasi un anno di Ubuntu, sudo mi incasino pulseaudio, ma Kaos mi disse che non era colpa di sudo, ma di pulseaudio che è buggato.


So disattivare l'altoparlante interno ma preferirei non farlo perche' mi e' comodo quando uso Xp (ricordo che ho Xp + Ubuntu).

Le modifiche software fatte su di un sistema operativo non influenzano minimamente l'altro. :sisi
E poi non dicevi che volevi addirittura staccare i cavi? :boh

pierino_89
22-04-11, 17: 06
Con sudo rischi di cambiare l'owner dei file di configurazione, così rischi di trovarteli in sola lettura (e ciò non è bello). Ma in linea di massima se si tratta di solo di gedit non dovresti aver problemi.

@Armandillo: dopo guardo la lista dei moduli, sempre che non lo faccia prima Air.

K.a.o.s.
22-04-11, 18: 09
Solo una volta, in quasi un anno di Ubuntu, sudo mi incasino pulseaudio, ma Kaos mi disse che non era colpa di sudo, ma di pulseaudio che è buggato.Sono io K.a.o.s. :eye
Comunque ci sono esempi (http://www.mail-archive.com/arch@archlinux.org/msg04963.html) dove sudo ha incasinato file tipo .ICEauthority. Poi che Pulseaudio sia buggato... si sa :hap.
Hanno creato i wrapper (gksu/gksudo/kdesu) apposta per sudo.

Trovata: la scheda audio e' Azalia AC'97
È quella che vuoi usare?
Prova a dare: sudo modprobe -r snd_hda_codec_realtek
(è una modifica temporanea, con il riavvio torna tutto a posto).

Armandillo
02-05-11, 18: 46
Posto di nuovo poiche' sono intervenuti dei cambiamenti circa il medesimo problema...e spiego

Per qualche giorno non ho adoperato il pc "incriminato" e proprio ieri gia' dall'avvio quel rumore-ronzio e' divenuto un gracchiare insopportabile questa volta non collegato al movimento del mouse ma a quello (parrebbe) dell'harddisk nel momento del lavoro :shock

A quel punto ero quasi tentato di staccare la spina all'altoparlantino del case quando mi sono imbattuto in una pagina web dove un utente riportava il medesimo problema.

Nel frattempo avevo pero' gia' applicato dei cambiamenti (suggeriti da alcuni thread) a Pulseaudio ritenuto responsabile probabile.

Proseguendo la lettura ho trovato un ennesimo consiglio che ho applicato, questo:

ad Alsa-conf ho aggiunto questo rigo

"# options snd-hda-intel power_save=10 power_save_controller=N"

e dopo aver avviato il problema era sparito :sisi .......ma......sparito quello mi sono ritrovato con la scheda audio disattivata :triste

Ora la situazione e' questa:

quando avvio Ubuntu l'icona-altoparlante in alto a destra e' disattivata; quindi apro il terminale e digito il comando pulseaudio e si ricollega, pienamente funzionante.

Allora, pensando fosse un problema dell'avvio di Pulseaudio, ho aperto l'applicazione "Applicazioni d'avvio" dov'e' l'elenco di cio' che s'avvia in automatico, ma lì Pulseaudio c'e' ed e' attivo e spuntato (start-pulseaudio-x11) :boh

Ho provato a leggere qualcosa a riguardo ma le indicazioni riportano sempre al comando d'avvio che pero' e' attivo (o lo sembra).

Per me, sinceramente, va bene anche così :sisi ...l'importante era eliminare quel fracasso....se mi serve ascoltare l'audio do' il comando dal terminale e il gioco e' fatto !

Ho voluto testimoniare questo per correttezza nei confronti di chi si e' interessato e in quella degli eventuali lettori.

:bai