PDA

Visualizza versione completa : Lettore mp3 Audiokey FM e firmware



DeST
24-02-11, 15: 15
salve a tutti,
avrei bisogno di un vostro aiuto nel reperire dei driver
un amica mi ha chiesto di provare a recuperare un lettore mp3 un Packard Bell Audiokey FM da 2gb, con gparted ho recuperato la memoria ma il lettore non si accende, allora leggendo qua e la ho visto che il firmware è aggiornabile con il programma della casa.
Il prodotto sarà mooolto vecchio in quanto sul sito ufficiale non c'è il minimo riferimento a questo lettore.
Nonostante questo sulla rete ho recuperato un firmware per questo lettore l'unico problema è che su windows il lettore viene visto come SMTP3500 i cui driver non sembrano disponibili...
Sempre su internet ho scoperto che il lettore si trova in modalità Recovery e necessita di particolari driver per permettere l'aggiornamento hardware...

Morale della favola dove posso trovare il Recovery Driver per il lettore? :cry3
la periferica che riconosce windows è SMTP3500

Sto cercando sulla rete ma non trovo nulla

Andy86
25-02-11, 11: 45
:bai

1) Dubito che il lettore non si accenda per un bug del firmware. Di solito il problema è la batteria. :sisi
Per caso lo carichi solo tramite la usb? :m:

2) Ho trovato questo -> click (http://drivers.downseeker.com/download/37097/packard-bell-audiokey-max-fm-firmware-updater-3.620.297/), che sembrerebbe essere il programma ufficiale per aggiornare il firmware senza bisogno del driver.

3) Il recovery driver dovrebbere essere questo -> click (http://it.driverscollection.com/?file_cid=397976647206db618e729ad5ee8).

4) Quando windows non riconosce una periferica e si intestardisce che sia un'altra, ci sono due strade:
a) Staccare il lettore, disinstallare la falsa periferica, installare i driver a periferica sconnessa e ricollegare la periferica. (non per niente si legge spesso "non collegare la periferica finché non è stato installato il driver".) :sisi

b) Cercare la falsa periferica in gestione periferiche, scegliere aggiorna driver e specificare a manina (no ricerca automatica) il file .ini contenuto tra i file del driver.
Buona fortuna. :hap

DeST
25-02-11, 12: 29
Prima di tutto grazie dei driver erano proprio quelli che cercavo, il firmware è lo stesso che posseggo io e necessita di quei driver (almeno nel mio caso)
Grazie ai driver sono riuscito a aggiornare il firmware dell'mp3 ma continua a non accendersi (lei mi dice che usa le mini stilo ricaricabili che ricarica con un caricabatterie dedicato) Ho provato comunque a cambiare batteria ma continua a non accendersi!!

Ricapitolando "Prima il lettore si accendeva ma non riproduceva e non si riusciva ne ad aprire nel pc ne a formattare, da quando ho recuperato la memoria con gparted il lettore funziona come una pendrive ma aimè non ne vuole sapere di accendersi, nemmeno ora dopo l'aggiornamento firmware...

Andy86
25-02-11, 13: 49
:m:

Prego, però a questo punto credo che ti dovrai rivolgere all'assistenza.

Ho ipotizzato il problema della carica perché mi è successo con una periferica che non si caricasse dalla usb senza confermare il messaggio sul display. Una volta completamente scarico è stato possibile solo caricarlo dalla rete.

Hai detto che hai cambiato le batterie, quindi, se ne hai messe un paio cariche, il problema e da un'altra parte.

L'ipotesi dell'errore di scrittura, per quanto raro nelle memorie solide, ci può stare; ma in questo caso non vorrei che tu, con gparted, abbia creato una mpt non valida o un fs non compatibile con il lettore, hai verificato prima di operare? :ohoh

DeST
25-02-11, 17: 30
non vorrei che tu, con gparted, abbia creato una mpt non valida o un fs non compatibile con il lettore, hai verificato prima di operare?
Ok, ho appena realizzato di aver fatto un enorme caxxata... :wall c'è modo di rimediare?
Ricordo solo di aver visto che il filesystem era fat32..

Andy86
25-02-11, 17: 43
:bai

Se c'era solo una partizione in fat32 grossa come tutta la memoria e l'hai partizionato diversamente, prova a ripartizionalo così. :sisi

DeST
25-02-11, 19: 52
Bhè dato che era l'unica cosa che ho controllato è anche l'unica cosa che ho fatto bene...
Credo che il problema stia nel fatto che per recuperare la memoria ho dovuto ricreare con Gparted una nuova partition table, ed ho il dubbio che quella di default non sia adatta... (non ci sto capendo niente! :shock)

Andy86
25-02-11, 21: 58
:bai

Avresti dovuto guardare che partition table c'era prima di ricrearla: "visualizza -> informazioni dispositivo".

Questa causa resta sempre e solo un ipotesi, ma potresti provare a recuperare la struttura originale con Testdisk (te l'avevo già presentato in un altra discussione.). :sisi

DeST
26-02-11, 16: 46
...Testdisk...
Cavoli in materia di memorie questo programma fa davvero tutto!!
Quando l'ho usato per recuperare i dati era abbastanza intuitivo, ma ora... cosa dovrei fare??

Andy86
26-02-11, 21: 43
:bai

Allora, Questa guida -> click (http://www.vecchiomago.net/index.php?mod=read&id=1282994199), mi sembra abbastanza chiara. Seguila saltando il punto che dice di premere "p" per recuperare i file, fai la scansione approfondita e modifica le partizioni ipotizzate finché diventano tutte verdi e pensi possano corrispondere a quelle originali, quindi esegui il comando "write" come dice la guida illustrata. :sisi

Ps: Eventualmente non fossi sicuro, posta uno screen della struttura ipotizzata da testdisk, che vediamo di ragiornarci insieme. :hap

DeST
27-02-11, 12: 56
Sto usando la versione windows di testdisk, nel visualizzare i drive collegati mi sembra di vedere tre volte la pendrive (di 2GB)...1147 vbhè pensando che sono sotto windows ho scelto Drive I:
ora nella schermata successiva dove si sceglie la partition table la guida dice che il valore di default è quello corretto perchè rilevato automaticamente da TestDisk

Di default è selezionato [no partitioned media] questo vuol dire che non c'è?
Andando avanti con "none" e facendo l'analisi risulta verde...
1148

Scegliendo invece di Drive I: le voci [Disk /dev/sdf e phisical drive] la partition table è di default intel e procedendo mi visualizza un avviso1149 e poi la vede come primary bootable1150

cosa fare?

DeST
02-03-11, 10: 29
Ho una tremenda voglia di provare a tentoni tutte le funzioni del programma...
Vi prego fermatemi e ditemi cosa fare prima che bruci totalmente il lettore! :lol:

Andy86
02-03-11, 14: 48
:bai

Bruciarlo mi sembra un po' difficile, tuttalpiù lo rendi irrecuperabile... :ghgh

Comunque eviterei di fidarmi di windows e andrei con "/dev/sdf".
Dopo che hai confermato l'analisi e ti ha restituito l'elenco verde, premi "invio" (enter per continuare) quindi scegli "write", conferma, e ripeti l'analisi per vedere se ha corretto l'errore. :sisi

Per le altre funzioni, più che cancellare tutto, riscrivere l'mbr e definire a mano i parametri hardware, non mi sembra che si possa fare... se pensi che ti possa servire a qualcosa, liberissimo. :ghgh

DeST
02-03-11, 15: 53
riguardo ai parametri *=Primary Bootable P=Primary L=Logical E=extended D=Deleted
non importa che la pendrive venga vista come *=Primary Bootable?

Provando a fare write mi da partition write error!

Andy86
02-03-11, 19: 59
:bai

Quell'errore è molto strano, di solito significa che testdisk non ha i permessi in scrittura per i dischi. Su che windows sei? Per caso vista o superiore? :m:

Per la partizione avviabile credo che sia normale, visto che c'è solo quella. Comunque, se proprio ti preoccupa, puoi togliere il flag boot da gparted, "menù contestuale -> gestione flag". :sisi

DeST
04-03-11, 10: 39
Ok ho capito widows non è l'ineale... :lol:
Adesso sto usando testdisk sotto linux ed ho un nuovo errore! :ohoh
1174

Andy86
04-03-11, 12: 27
:bai

Esattamente quando te lo da quell'errore?

Dopo che premi "continua" cosa succede?

Comunque, poiché non hai dati da perdere, puoi provare a sistemare quel valore dal menù geometry.
Trovi questo menù nella stessa schermata dove trovi "analyse".

Seleziona poi la voce "head" e immetti la voce che ti suggerisce il messaggio, ovvero 255.
Poi riprova. :sisi

DeST
04-03-11, 19: 07
Esattamente quando te lo da quell'errore?
si presenta dopo analyse

Dopo che premi "continua" cosa succede?
La riga diventa verse e poi... write error

Comunque, poiché non hai dati da perdere, puoi provare a sistemare quel valore dal menù geometry. Trovi questo menù nella stessa schermata dove trovi "analyse".
Ok fatto ma adesso c'è un altro errore 1175 che non so perchè al secondo tentativo è sparito ed ora ho di nuovo il primo avviso1176

Andy86
04-03-11, 20: 44
:bai

Chiarito che, visto che non sappiamo com'era la pendrive in origine dobbiamo andare per tentativi (sempre sperando di non peggiorare le cose. :m:), direi di provare a piallare completamente la MPT e poi ripartizionare da zero.

Per cancellare usa l'opzione "delete" dal menù di testdisk, sotto "analyse"; poi la partizione la ricrei con gparted. :sisi

In alternativa devi provare a correggere (con "geometry") gli errori che man mano ti escono. I nomi mi sembrano abbastanza chiari. :sisi

DeST
05-03-11, 11: 29
Allora...
Ho subito notato una strana cosa, ogni volta che collego il lettore al pc questo mi riporta gli avvisi su numbers of heads per cylinder e number per sector anche se in precedenza li ho cambiati in geometry... tornano sempre come prima

Ho provato delete ma continua a darmi write error, è come se non riuscisse mai a scrivere sulla memoria...
Ho provato a cancellare la partizione e a ricrearla con gparted... tutto bene ma il problema non si risolve
da gparted ho usato la voce Controlla che dovrebbe controllare la correttezza dal file system ma dice errore impossibile determinare fyle system
ho eseguito anche uno scandisk (che prima non si avviava a ora si... ??)

Nulla tutto come prima il lettore funziona come pendrive ma non si avvia... :wall

Andy86
05-03-11, 11: 51
:bai

A questo punto non saprei più che cosa pensare. Forse non ti rimane che mandarlo in assistenza. Anche se non credo che c'entri, Testdisk lo hai eseguito da sudo o da home? :ohoh

Ultima spiaggia sarebbe una procedura di reset "hardware". Sul manuale non c'è niente che vi faccia riferimento? Oppure sul lettore un tastino premibile solo con una graffetta? :ohoh

Per me si è rotto qualcosa, perché l'ultima (e unica) volta che ho avuto un problema simile al tuo per sintomi (ma non avevo rifatto le partizioni), il problema era proprio la batteria, che tu hai già escluso.

DeST
05-03-11, 16: 19
Il reset hardware non è presente... l'unica cosa (che ho già fatto) e collegare il lettore al pc in recovery mode (tenendo premuto play senza batteria) e aggiornare il firmware...
La cosa strana è che il lettore si accendeva prima ma non funzionava la memoria ora è il contrario la memoria funzona ma non si accende il lettore!!

e se provassi un downgrade del firmware? Prima montava una vecchia versione la 3.620.293 ora sopre c'è la 3.620.297

Andy86
05-03-11, 16: 37
Ma non ho capito... il lettore non si è più acceso da dopo che hai fatto l'upgrade? :ohoh

Comunque a questo punto provare non ti costa niente, a parte il tempo. Io non leggo nel futuro, per cui non posso dirti se funzionerà. :bgg2

DeST
05-03-11, 20: 41
Ma non ho capito... il lettore non si è più acceso da dopo che hai fatto l'upgrade?
NO! il lettore non si è più acceso da quando ho ripristinato la memoria con Gparted...

Ora dovrò trovare QUELLA versione del firmware, su quel sito non è presente... :S