PDA

Visualizza versione completa : Problemi con differenze tra ubuntu 10.10 e ubuntu 10.04



Andy86
30-01-11, 15: 35
:bai

Per il problema descritto in altra discussione ho deciso di effettuare, forse con anticipo, l'avanzamento di versione di ubuntu, dalla 10.04 alla 10.10; Evidenti differenze nella gui, però, mi hanno lasciato alquanto perplesso...

Per cominciare:



Dov'è finita la barra dei menù? Quella con programmi - sistema - amministrazione - preferenze - ecc... ?? Io mi trovo solo le icone in fondo con ora - logout - email, e senza neanche poterle personalizzare come prima... :triste
_
Il menù in alto a sinistra col simbolo di ubuntu mi cerca le applicazioni nelle cartelle del disco... Hanno messo la gestione delle apps tipo il mac?? :shock

_
La barra a destra sarà anche comoda, ma siccome uso anche cairo-dock, che preferisco, sembra un doppione. Posso avere i lanciatori in alto come prima? :bgg2
_
Posso fare il downgrade di firefox?? La beta è anche bella, ma perde compatibilità con un sacco di estensioni... :m:


Se riuscite ad illuminarmi, :thx

pierino_89
30-01-11, 16: 14
Ma stai usando la versione netbook? A me la 10.10 desktop sembrava uguale.
Il downgrade di firefox teoricamente sì, vai nei repo della 10.04 e scarichi il .deb di firefox e lo dai in pasto a Gdebi, ma non so dirti se nella pratica possa funzionare. Inoltre cercherà di aggiornartelo ogni volta.

ginalfa
30-01-11, 16: 16
Secondo me hai smanacciato un po' troppo!:ghgh
L'applet dei menu dovrebbe essere dove è sempre stata.
Almeno la barra superiore con le altre icone a destra ce l'hai. (la barra a destra che è???)
Quindi il pannello c'è e dovrebbe essere sufficiente cliccare destro ed aggiungere l'applet.
Ora non sono in Ubuntu e non posso essere più preciso.

Andy86
30-01-11, 17: 17
:bai


Ma stai usando la versione netbook? Non so, Sono sul fisso e ho fatto solo l'upgrade, :sisi, però in effetti guardando qui (http://www.piroplastic.com/tag/ubuntu-10-10), alla mia situazione corrisponde lo screen della versione notebook... :ohoh


Secondo me hai smanacciato un po' troppo!http://www.collectiontricks.it/forum/images/smilies/ghgh.gifHo solo fatto come dice qui (http://forum.ubuntu-it.org/index.php/topic,409424.msg3207884.html#msg3207884) alla risposta 8 per risolvere il problema, poi "sudo update-manager -d" ed è partito l'avanzamento correttamente. :sisi :ohoh



la barra a destra che è???Questa:
--> Immagine rimossa: errore caricamento


Quindi il pannello c'è e dovrebbe essere sufficiente cliccare destro ed aggiungere l'applet.Come dicevo "senza neanche poterle personalizzare come prima...", ovvero, nel menù pulsante destro della barra, non ci sono più i comandi per aggiungere e rimuovere applet e lanciatori. :boh

pierino_89
30-01-11, 19: 08
si è decisamente unity, l'interfaccia dei netbook :tong2 prova a vedere se c'è qualche pacchetto relativo a gnome.

Andy86
30-01-11, 20: 04
Pacchetti relativi a gnome c'è ne sono parecchi:

http://img715.imageshack.us/img715/9726/proup1.th.png (http://img715.imageshack.us/i/proup1.png/)http://img717.imageshack.us/img717/7141/proup2.th.png (http://img717.imageshack.us/i/proup2.png/)http://img190.imageshack.us/img190/8254/proup3.th.png (http://img190.imageshack.us/i/proup3.png/)

Ma, cosa strana, i repository portano il nome natty, che secondo veloce ricerca è il nome di ubuntu 11, che neanche sapevo esistesse già... :ghgh

1083

:thx

pierino_89
30-01-11, 20: 17
Vabbè, intendevo non installati... Comunque prova a cambiare tipo di sessione da GDM prima di accedere.
Per i repo non saprei, sicuro di non aver fatto casini tu?

Andy86
30-01-11, 23: 14
Allora, da GDM posso solo mettere le impostazioni di "accesso universale", spegnere/riavviare, oppure cambiare il nome pc dal mio a qualcosa tipo "natty (for developers)" cliccandoci sopra... :ohoh


sicuro di non aver fatto casini tu?

Ormai non sono sicuro di niente, ma quello che ho fatto te lo detto: cambiamento a mano di tutte le occorrenze di "lucid" con "maverik" nel file dei repo e poi l'istruzione di aptitude, come scritto nel link. Infine sudo update-manager -d e avanzamento col tool. :sisi

Se poi è il modo sbagliato non lo so. Comunque questo ubuntu non è per niente stabile, è un continuo segnalazioni errori per programmi terminati inaspettatamente, sembra quasi di essere sotto windows... :sisi

buona :notte:

ginalfa
31-01-11, 12: 37
La 10.10 è parecchio stabile, credo quindi che nelle diverse manovre fatte prima dell'avanzamento qualche casinetto ci sia stato.
Andando a naso non era corretta la modifica dei repo per maverick, quando avevevi installata la 10.04. Il gestore pacchetti ha ssunto che fosse installata la 10.10.
Eseguendo un avanzamento da maverick (quelli erano i repo così modificati) potevi solo avanzare verso qualche beta della 11.04.

Andy86
31-01-11, 13: 45
:bai

:m:... quindi tu dici che usando quel sistema in combinazione con "update-manager -d" ho eseguito due avanzamenti? :ohoh

Adesso che faccio? Se scarico la .iso della 10.10 posso fare qualche installazione pulita senza perdere tutto? :ohoh
Esiste un qualche tipo di downgrade...

A proposito, l'avanzamento mi ha lasciato nel grub una voce "old version" con dentro i vecchi kernel... posso farci qualcosa avviando da quelli? :ohoh

:thx

___

Aggiornamento:

Ho trovato un comando per fare l'elenco dei pacchetti in modo che possa essere letto dal comando inverso e reinstallato, l'ho messo sulla sda3 e ho reinstallato da zero la 10.10 sulla sda1.

:thx

Però altra tegola: mentre si installava è mancata la corrente... :furious; Quando è tornata la corrente ho rifatto la procedura da capo, solo che ora non va più il grub: mi mostra l'elenco corretto ma non mi permette di scorrerlo. Se do "invio" dice "sinstassi errata"...

Ora sono sulla live (10.10) e sto provando a configurarlo in chroot... suggerimenti accettati... :thx

______

Ri-Aggiornamento:
Da chroot sono riuscito a mettere windows come scelta predefinita, almeno ora accedo con quello, però grub ancora non ne vuole sapere di scorrere l'elenco... la tastiera la vede, perché quando schiaccio la freccia su il countdown si blocca; però l'elenco non scorre... :boh

Non so se aprire una discussione apposta o se continuare con questo piccolissimo off-topic, visto che la 10.10 installata ancora non l'ho avviata una volta e non so se è a posto... :sisi

Dimenticavo... il setup mi ha confermato che nella sda1 avevo la 11.04... :ehmm

ginalfa
02-02-11, 10: 02
Come hai fatto la reinstallazione?
Non è che ti sei tirato dietro il vecchio filesystem, con i suoi file di configurazione di GRUB2?

Non credo che dipenda da quanto è stato scritto nel MBR, ma se vuoi puoi ripulirlo da live prima di ripetere l'installazione

Only registered members can view code. da root o con sudo, dopo aver smontato la partizione

oppure semplicemente ripristina il bootloader di win (il metodo dipende dalla versione di win) e poi procedi alla reistallazione avendo cura di riformattare la partizione extX.

Andy86
02-02-11, 18: 26
:bai


Come hai fatto la reinstallazione?
Non è che ti sei tirato dietro il vecchio filesystem, con i suoi file di configurazione di GRUB2?


:nono nono, ho messo di formattare la partizione in entrambi i tentativi. :sisi
L'unica cosa che non va nel grub è proprio la selezione, tutto il resto (terminale, opzioni, contdown, invio, ecc...) funziona. :boh



il metodo dipende dalla versione di win

In questi giorni non ho avuto tempo di fare prove. Ripristinare il Bl di win non è un problema, ma se reinstallassi semplicemente il grub da live? Non si sovrascriverebbe?:sisi

pierino_89
02-02-11, 23: 18
Lo sovrascriveresti, ma punterebbe anche al cd e non al disco rigido :tong2
Puoi farlo da chroot montando in bind /dev e /proc, e poi usando il comando update-grub.

Andy86
03-02-11, 13: 43
:bai

Si, per "reinstallarlo da live", intendevo in chroot. Ed è esattamente ciò che ho fatto seguendo un paio di guide su google.
Ora il problema grub è risolto. :thx

Però ho un problemino con la re-installazione dell'elenco pacchetti. :triste
Ho fatto il backup in un'altra partizione con:


Only registered members can view code.Poi dalla nuova installazione ho tentato il reinstall con:


Only registered members can view code.Ha scaricato diversi mb di pacchetti, ma alla fine i vecchi programmi non risultavano installati... :ohoh

Aggiornamento: ho rifatto la procedura con
Only registered members can view code. ed ha installato correttamente l'elenco pacchetti. Ora dovrebbe essere tutto a posto... :m:

Ri-Aggiornamento: fatto il danno... :wall avendo fatto l'upgrade dei pacchetti dalla 11.04 beta mi sono portato dietro anche i pacchetti non validi, perciò, nonostante in repo maverik, sono ritornato con l'interfaccia netbook e non so cos'altro perché il sistema è diventato lentissimo... peggio di vista su 512mb di ram... :triste

A passo di lumaca ho cercato di installare gnome dall'usc, ma dice che non è possibile risolvere alcune dipendenze a causa di pacchetti incompatibili. :boh
Cercherò di fare qualcosa da live, ma accetto qualunque consiglio... :sisi :thx

Tri-Aggiornamento: Smanettando da live in chroot sono riuscito a reinstallare ubuntu-desktop, ora sembra davvero tutto a posto... :sisi speriamo...