PDA

Visualizza versione completa : ubuntu 10.04 strana schermata all'avvio



poniboy
08-12-10, 13: 08
:bai riparto da qui. dopo avere cambiato scheda video (pc in dual con xp ) al boot se faccio partire xp, no problem, tutto ok,ma se faccio partire ubuntu ecco che appare sta schermata
938

se provo a far partire con un altro kernel (si dice cosi?) invece mi appare questa
939

posso risolvere? come?

poniboy
08-12-10, 18: 29
il problema è parzialmente risolto, e dico parzialmente xchè in parte persiste
allora, dopo la prima schermata che ho postato, digito exit e dopo 5-6 secondi ecco che il mio ubuntu parte!
non capisco il perchè ma sono in parte felice.
c'è una soluzione definitiva ora che sono dentro al sistema?

djdedo
09-12-10, 13: 01
Hai dei problemi con i driver della scheda video appunto. Dovresti intanto disabilitarli dalla schermata del driver ristretti che usi sul pc. Poi sarebbe utile sapere che scheda avessi prima e cosa hai montato ora

poniboy
09-12-10, 14: 08
ciao! scusa ma non ho ben capito che devo fare.


Dovresti intanto disabilitarli dalla schermata del driver ristretti che usi sul pc.
come devo fare?


Poi sarebbe utile sapere che scheda avessi prima e cosa hai montato ora

prima era integrata. adesso è una asus con chipset nvidia 9500 di preciso non lo so non c'è l'ho qui!

sotto xp, in ogni caso, no problem, è in ubuntu che mi da sto problema
attendo gentili spiegazioni:bgg2

poniboy
09-12-10, 14: 13
questa è la schermata inerente ad driver hardware

943

djdedo
09-12-10, 15: 14
La schermata dei driver ristretti è quella che hai postata per ultima. Dunque non ne sono sicuro ma credo che per quella scheda dovresti abilitare i driver 173 e disabilitare quelli che al momento sono in uso

poniboy
09-12-10, 16: 28
fatto. ma continua a darmi lo stesso problema!
e se li attivassi tutti e due che succede?

djdedo
09-12-10, 16: 45
Non li puoi attivare entrambi perchè si tratta dello stesso driver in versione differente. Un'altra cosa che puoi provare è reinstallare il kernel perchè da quello che capisco non sta trovando il modulo kernel del driver video. Quindi disabilita tutto apri il terminale e digita

Only registered members can view code.
riavvia e prova a riabilitare i driver raccomandati e vediamo che succede.

poniboy
09-12-10, 17: 31
mi dice: "operazione reinstall non valida"

ginalfa
09-12-10, 20: 23
Forse fai prima così.
Se ora hai una Nvidia e la sk sostituita era anche Nvidia è possibile che i vecchi driver creino qualche conflitto.
disattiva e disinstalla (con purge) sia i 177 che i common e riavvia.
Al riavvio dovrebbero essere caricati i driver non proprietari, ma dopo un po' l'utilità dei driver proprietari ti dovrebbe avvisare della possibilità di installare i drive Nvidia.
Scegli i raccomandati.

La cosa che non capisco è la prima schermata che dice che l'UUID di un disco è errato e non parla di moduli nvidia.

djdedo
10-12-10, 00: 14
Parla di un "missing module" ma non riesco a capire se è riferito al disco oppure è della scheda. Comunque fai come ti ha suggerito ginalfa per ripulire meglio il sistema (usa il gestore pacchetti a sto punto, non ho apt-get per dirti il comando preciso)

poniboy
10-12-10, 10: 14
Forse fai prima così.
Se ora hai una Nvidia e la sk sostituita era anche Nvidia è possibile che i vecchi driver creino qualche conflitto.
disattiva e disinstalla (con purge) sia i 177 che i common e riavvia.
Al riavvio dovrebbero essere caricati i driver non proprietari, ma dopo un po' l'utilità dei driver proprietari ti dovrebbe avvisare della possibilità di installare i drive Nvidia.
Scegli i raccomandati.

La cosa che non capisco è la prima schermata che dice che l'UUID di un disco è errato e non parla di moduli nvidia.

ciao ginalfa.
abbi pazienza, sai che con me ne serve tanta:bgg2
prima la scheda video era integrata, ora è una asus con chipset nvidia
non ho capito cosa devo fare, dammi i comandi passo passo altrimenti mi incasino!:ghgh

ginalfa
10-12-10, 12: 35
Parla di un "missing module" ma non riesco a capire se è riferito al disco oppure è della scheda. Comunque fai come ti ha suggerito ginalfa per ripulire meglio il sistema (usa il gestore pacchetti a sto punto, non ho apt-get per dirti il comando preciso)

A me pare che dopo l'aggiornamento del kernel non sia stato correttamente aggiornato initramfs, che non trova un "root device" valido e quindi non può caricare il filesystem. (gave up waiting for root device)
Il vero messaggio di errore è nell'ultima riga. (ALERT /dev/disk/ ecc. ecc.... does not exists)
Gli altri sono suggerimenti per i "common problems".
Quindi per ora quel kernel non si usa.

@ poniboy

Da qui dovrei andare a memoria e mi servono i nomi esatti dei pacchetti.
Appena vado sul sistema ubuntu ti specifico qualche comando.
Potrebbe essere utile sapere quale GPU ha la sk video, così verifichiamo quale sia il driver giusto. (173 o current)

[edit]

disattiva i driver ristretti e riavvia
poi da terminale

Only registered members can view code.
riavvia ancora in modo da favorire l'dentificazione del driver giusto da parte di jokey-gtk

se la gpu è della serie 6 o superiore dovrebbero andare bene i current

per il kernel vediamo in seguito

poniboy
10-12-10, 17: 56
fatto! ora ci sono questi! quali attivo?
956

ginalfa
10-12-10, 19: 02
per stare sicuri bisognerebbe sapere quale GPU hai.
comunque le ultime, dalla serie 6 in poi, sono supportate da current

poniboy
11-12-10, 08: 24
ho installato la seconda voce dei driver. ora che faccio? il problema all'avvio rimane:bgg2
dimenticavo, tra le varie prove, ho letto non sopiu' dove che dovevo disinstallare anche i driver noveau, e l'ho fatto, ma non è cambiato nulla:ghgh

ginalfa
11-12-10, 11: 31
quale avviso è rimasto, quello della modalità grafica ridotta?
che GPU hai?
speriamo che nei vari tentativi che hai stratificato non si sia incasinato xorg

i noveau non sono ancora affidabili e supportano solo limitatamente l'accelerazione.

poniboy
13-12-10, 08: 14
scusa il ritardo.:bgg2
resta la prima schermata, quella che finisce con initramfs
come si fa a sapere che gpu ho?

cydonia
13-12-10, 09: 24
nel primo screenshot,che parla dell'UUID dovrebbe bastare indicare direttamente il device nell'fstab(senza UUID)
.........
riconfigurare xorg entri in TTY(ctrl + alt +f1) o in una shell stoppi gdm:

Only registered members can view code. essendo deprecato avrai l'avviso, dovrebbe per compatibilita' agire ugualmente,oppure

Only registered members can view code.riconfigura xorg

Only registered members can view code.segui il wizard e scegli i generici "nv",dopo potrai fare le prove del caso(pulendo i driver proprietari)(reinstallando il kernel linux-image) ,cambiando quella stringa nell'xorg.con in "nvidia".
:bai

poniboy
13-12-10, 10: 43
sono arrivato alla riconfigurazione dell' xorg
poi ho dato sudo reboot, ma al riavvio solita schermata!
ora non ho ben capito che devo fare:bgg2

cydonia
13-12-10, 11: 09
guardando meglio l'immagine effettivamente sembra piu' un problema di moduli.
comunque intendevo il reconfigure xorg nel kernel funzionante.
hai gia reinstallato quel kernel(non funzionante) in synaptic avra' un'estensione simile
linux-image-(versione kernel)
:bai

ginalfa
13-12-10, 12: 14
se non hai più l'avviso della modalità grafica ridotta il problema dei driver video dovrebbe essere risolto.

Se non ho capito male con l'ultimo kernel ti dà il problema, se scegli un kernel precedente parte regolarmente.

per il kernel sballato proviamo a rimuovere i pacchetti linux-image- e linux-header- della versione del kernel capriccioso.
@cydonia
dalla prima immagine io capisco che non viene trovato il filesystem radice perchè non viene identificato l'UUID del disco e quindi intitramfs sgancia alla shell ridotta.

cydonia
13-12-10, 15: 24
dalla prima immagine io capisco che non viene trovato il filesystem radice perchè non viene identificato l'UUID del disco e quindi intitramfs sgancia alla shell ridotta.giusta osservazione:hap ma secondo me e' una correlazione di fattori ,ok verifichiamo il tutto (UUID)
posta il file grub.txt creato da questo comando

Only registered members can view code.e' nella tua home
e l'output di questo questo

Only registered members can view code.poi prova a rigenerare il grub :

Only registered members can view code.e riavvia con il kernel (non funzionante)


:bai

poniboy
13-12-10, 15: 48
scusa cydonia prima di fare ciò che mi hai scritto ho voluto provare a riavviare con un altro kernel
ho il 2.6.32-26 chè è il famoso che mi da quella schermata
2.6.32-25 provato adesso, stessa schermata, ma dopo che scrivo exit e do invio mi appare la pagina della modalità grafica ridotta.do ok e:

969

che faccio?

poniboy
14-12-10, 07: 36
ragazzi, che fine avete fatto?:bgg2

mentre vi aspettavo, ho deciso di avviare in modalità grafica ridotta solo per una sessione. questo è successo con il kernel 2.6.32-25 e 2.6.32-24 mentre con il 2.6.28-18 appare la schermata di modalità grafica ridotta e poi si pianta, devo riavviare a mano.
in sostanza, con tutti i kernel appare la schermata "initramfs" , con tutti, digito exit, ma se con il primo kernel (26) poi parte normalmente, con gli altri kernel parte quella schermata della modalità ridotta.
a sto punto?:triste

poniboy
14-12-10, 09: 47
Only registered members can view code.

nella home c'è ma se lo apro è vuoto.


Only registered members can view code.

ginalfa
14-12-10, 10: 02
Ho la sensazione che initramfs si sia incasinato
puoi provare ad avviare con il kernel che ti parte rimuovere l'ultimo kernel e reinstallarlo in modo da rigenerare initramfs e grub2

altra possibilità è
Only registered members can view code.

di più non saprei.

poniboy
14-12-10, 10: 10
i kernel partono tutti. solo che il 18-24 e 25 solo in modalità ridotta
possopartire con il 26 ma non ho capito come fare a " rimuovere l'ultimo kernel e reinstallarlo in modo da rigenerare initramfs e grub2"

mi spieghi i passaggi?

ginalfa
14-12-10, 10: 23
Lo elimini da synaptic scegliendo la disinstallazione compresi i file di configurazione.
poi lo reinstalli


Se non dovesse andare
in fstab puoi provare a sostituire la riga
UUID=3dad6898-c17a-43cb-8bbd-4d7993d11824 / ext3 defaults,errors=remount-ro,relatime 0 1

Only registered members can view code.

la selezioni tutta la riga e fai un copia
metti un # all'inizio della riga e poi fai incolla nella riga successiva
sostituisci
UUID=3dad6898-c17a-43cb-8bbd-4d7993d11824
con
/dev/sda3
salvi ed incroci le dita

comunque aspetta eventualmente qualche dritta di cydonia che è più esperto di me.

poniboy
14-12-10, 10: 41
Lo elimini da synaptic scegliendo la disinstallazione compresi i file di configurazione.
poi lo reinstalli



scusa che voce devo cercare su synap. "kernel"?

cydonia
14-12-10, 11: 49
nella home c'è ma se lo apro è vuoto.questo perche' e' un'aggiornamento alla 10.04,pensavo fosse un'installazione pulita,dunque hai ancora il grub-legacy

sistema fstab come e stato detto,praticamente cosi'

Only registered members can view code.ma devi anche sistemarlo nel grub posta

Only registered members can view code.poi fai come ha detto ginalfa rigenera initrams:

Only registered members can view code.lo rigenera su tutti i kernel
:bai

poniboy
14-12-10, 14: 26
Only registered members can view code.

fstab deve essere cosi'?

Only registered members can view code.

cydonia
14-12-10, 17: 59
si l'fstab deve essere cosi',la parte del kernel del menu.lst


Only registered members can view code.
ho aggiunto anche rootdelay
:bai

poniboy
14-12-10, 18: 12
fatto tutto. sempre stessa cosa:triste

cydonia
14-12-10, 18: 36
hai rigenerato initrams? togli dal grub rootdelay,splash,quiet vediamo di ricavare qualche info in piu'
al limite cancella quel kernel e poi lo reinstalli
cosi:

Only registered members can view code.poi lo installi

Only registered members can view code.probabilmente dopo la reinstallazione sono da risistemare le voci nell'fstab e grub
:bai

poniboy
15-12-10, 07: 49
ciao. stamane ho paerto il menu.lst e quella stringa non era piu' come l'ho modificata, ma era dinuovo come prima "# kernel /vmlinuz root=/dev/hda2 ro"
come mai?
lo cancello comunque il kernel?

intanto una curiosità, anche perchè mi sto spazientando:bgg2
adesso il mio pc è partizionato come vedi qui sotto
972

ma se io formattassi la partizione di ext 3 e di swap, le unisco e le lascio non allocate, poi mi sacrico ubuntu 10.04 o 10.10 e faccio l'installazione ex novo? non dovrebbe andare tutto a posto?
le altre 2 partizioni non le tocca se io in fase di installazione gli faccio prendere il piu' ampio spazio contiguo.
sbaglio?

cydonia
15-12-10, 08: 02
ciao poniboy che stringa hai modificato?:ohohperche' qella che iniziano con il #"cancelletto" sono commentate e dunque ignorate nella lettura del grub in fase di avvio e quella in particolare e' un'esempio',di posto il menu.lst modificato ,dovrai copia incollarlo al posto del tuo

Only registered members can view code.avvia il kernel
2.6.32-26-generic
:bai

poniboy
15-12-10, 09: 15
copia incollato e salvato, ma al riavvio sempre uguale :bgg2:triste

devo toglier e poi reinstallare il kernel come mi hai detto prima?

ho notato adesso che nel menu.lst la riga che hai modificato è di nuovo come prima!
??

cydonia
15-12-10, 09: 50
per salvare le modifiche devi editarla da root :

Only registered members can view code.
stessa cosa per l'fstab

.....................

ma se io formattassi la partizione di ext 3 e di swap, le unisco e le
lascio non allocate, poi mi sacrico ubuntu 10.04 o 10.10 e faccio
l'installazione ex novo? non dovrebbe andare tutto a posto?

le altre 2 partizioni non le tocca se io in fase di installazione gli faccio prendere il piu' ampio spazio contiguo.

sbaglio?

senza fare tutto questo ,puoi benissimo in fase di installazione dirgli di formattare quelle partizioni e poi installarci sopra

:bai

poniboy
15-12-10, 10: 19
adesso all'avvio appare una schermata infinita di righe, e alla fine di tutto devo di nuovo dare exit e invio in quanto c'è di nuovo il solito initramfs
mah! ho mal di testa!:ghgh

facciamo cosi' se hai ancora voglia di darmi una mano io proverei a installare ex novo
mi devi solo dare una mano a capire bene come fare senza rovinare le altre partizioni. io ero tranquillo, formattando da gparted e lasciando non allocato, ma se tu mi dici che in fase di installazione posso formattare e installare x me va bene, non ricordo bene ciò che chiede in fase di installazione!
l'unica cosa che vorrei salvare è la posta di thunderbird in toto.se sai come fare x salvarla tutta e poi rimetterla? basta che copio la cartella .thunderbird da "poniboy"? o no è cosi' semplice?

quale versione? 10.04 o 10.10? se hai ancora voglia di seguirmi:bgg2

ginalfa
15-12-10, 11: 34
se non hai programmi particolari da tenere forse si fa prima a reinstallare.
i dati della home li puoi copiare e salvare da qualche parte che non sia la partizione ext3
la posta di thunderbird sta netta tua home, ma è una cartella nascosta, che comincia con un punto
dovrebbe essere .mozilla-thunderbird
nella fiestra di nautilus con ctrl-h vedrai le cartelle nascoste.
click (http://linux.billera.eu/?p=416)
da terminale

Only registered members can view code.

comunque i pacchetti del kernel in synaptic si chiamano linux-image-xxxx (xxxx=versione del kernel)

poniboy
15-12-10, 11: 49
ma io sarei quasi dell'idea di formattare.
ora vedo di salvarmi thund e poi mi date una mano? io volevo usare gparted, cyd mi ha detto di farlo in fase di installazione, non vorrei incasinarmi.
quale versione uso?

cydonia
15-12-10, 11: 58
facciamo cosi' se hai ancora voglia di darmi una mano io proverei a installare ex novo
.......
quale versione? 10.04 o 10.10? se hai ancora voglia di seguirmi:bgg2 chiaro,siamo qua':eye
dal canto mio avrei preferito cercare di risolvere il problema,pero' e' chiaro che se uno deve essere subito produttivo non aspetta,fai conto che sono anni che non reinstallo
comunque mi sembra che hai sempre avuto problemi con l'istallazione?sbaglio?
credo che sia una concatenazione di fattori per questo problema initrams,UUID e perche' no anche una corruzione del filesystem.
per la scelta ti consiglio la LTS
il comando per la reistallazione del kernel lo avevo scritto post indietro per linux-image-2.6.32-26-generic
da eseguire anche negli altri kernel ,potresti provare prima su questo

io ero tranquillo, formattando da gparted e lasciando non allocato
fai come ti senti piu' sicuro:hap non cambia nulla e solo un passaggio in piu'
:bai

poniboy
15-12-10, 11: 59
al tempo. prima mi consigli di provare ancora a reinstallare il kernel? prima di formattare?
rientro in ufficio dolpo le 15.30, vi rileggo dopo:bai

poniboy
15-12-10, 18: 20
rieccomi! chefo? formatto?

--- Post unito in modo automatico ---

disinstallato e reinstallato il kernel, ma sempre uguale.se non hai piu' idee procedo con la formattazione :bgg2

cydonia
16-12-10, 01: 27
fai questa prova poi se non va reistalla,perche' andremo avanti per tentativi ,dai uno sguardo all'fstab ,se c'e' la stringa dell'UUID sisteme come abbiamo fatto
precedentemente con /dev/sda3 (ricorda di editarlo da root)
poi nel grub inserisci questa:

Only registered members can view code.
avvia il primo kernel 2.6.32-26-generic

poniboy
16-12-10, 08: 10
sei davvero bravissimo! è andata! unico difetto è che ci mette un minuto da quando parte dopo il menu' di boot, ma almeno funziona!:ghgh
secondo te si riesce anche ad accorciare il tempo? poi magari se reinstallo, lo pulisco un pò:ghgh
che dici?
anzi, mi sai dire come fare una bella pulizia?
devo sistemare anche gli altri kernel? come?:bgg2:bai

cydonia
16-12-10, 11: 56
secondo te si riesce anche ad accorciare il tempo? poi magari se reinstallo, lo pulisco un pò:ghgh
che dici?diminuisci il rootdelay fino a trovare un compromesso tra stabilita'/avvio

anzi, mi sai dire come fare una bella pulizia?
devo sistemare anche gli altri kernel? come?:bgg2http://www.collectiontricks.it/forum/images/smilies/ciao%20%29.gifse parli dei kernel magari tieni i primi tre e l'ultimo lo rimuovi,poi sistema il grub con i primi tre cosi':

Only registered members can view code.ho diminuito il rootdelay a 40 vedi se cosi' tiene,se si diminuisci ulteriormente, per gradi.
35 ,30 e cosi' via fino a trovare un compromesso
:bai

poniboy
16-12-10, 14: 22
ho messo prima 40 e poi 30 ma siamo sempre a 50 secondi, abbiamo guadagnato 10 secondi meglio di nulla:ghgh
con gli altri kernel però ho la modalità grafica ridotta. me li tengo cosi'?
devo cambiare qualcosa nei driver?

cydonia
16-12-10, 14: 50
vedi le modifice che ho fatto io al grub ,diminuisci ulteriormente il rootdelay e togli anche il paramentro
locale=it_IT
:bai

poniboy
16-12-10, 15: 09
ho messo 30 ma il tempo cmq è di 50 secondi. l'ho fatto in tutte le righe dei vari kernel.ma non fa nulla, va bene lo stesso. x quanto riguarda il discorso della modalità grafica ridotta sugli altri 3 kernel,si può risolvere o lascio cosi'?
discorso driver?:bai

cydonia
16-12-10, 18: 38
Only registered members can view code.
con il solito errore di initrams o solo grafico?,comunque ora puoi provare ad installare i driver nvidia come spiegato precedentemente da @ginalfa
:bai

poniboy
17-12-10, 08: 09
disattiva i driver ristretti e riavvia
poi da terminale
Codice:
sudo apt-get purge nvidia-173 nvidia-currentriavvia ancora in modo da favorire l'dentificazione del driver giusto da parte di jokey-gtk

se la gpu è della serie 6 o superiore dovrebbero andare bene i current

per il kernel vediamo in seguito

a suo tempo mi disse di fare cosi' e già lo feci :bgg2


con il solito errore di initrams o solo grafico?,

solo grafico

cydonia
17-12-10, 09: 21
posta gli output di :

Only registered members can view code.

Only registered members can view code.
:bai

poniboy
17-12-10, 09: 29
Only registered members can view code.


Only registered members can view code.

:bai

cydonia
17-12-10, 12: 42
ho visto in un'altra discussione che hai la 9500gt,in un computer ho la 9800gt i driver che devi aver installato sono:
nvidia-current nello specifico nvidia-current (195.36.15-0ubuntu2)
nvidia-current-modaliases.....nvidia-current-modaliases (195.36.15-0ubuntu2)
nvidia-settings..... nvidia-settings (195.36.08-0ubuntu2)
se ci sono i nouveau toglili e anche altre versioni di driver
:bai

poniboy
17-12-10, 14: 12
nvidia-current (195.36.24-0ubuntu1)
nvidia-current-modaliases.....nvidia-current-modaliases (195.36.24-0ubuntu1)
nvidia-settings..... nvidia-settings (195.36.08-0ubuntu2)

questi sono quelli che ho! tutto il resto l'ho tolto
solo che gli altri kernel continuano ad essere in modalità grafica ridotta:bgg2
fa nulla dai, me li tengo cosi', tanto non dovrei usarli :bgg2
la chiudiamo qui? che dici?:bgg2

cydonia
17-12-10, 15: 28
la chiudiamo qui? che dici?:bgg2

che sei sfinito?:bgg2,una cosa ma lsmod lo hai dato con i kernel i modalita' grafica ridotta o quello funzionante?
:bai

poniboy
17-12-10, 15: 41
che sei sfinito?
boia chi molla!:ghgh lo dicevo per te, magari ti sei rotto lepelotas:glu


ma lsmod lo hai dato con i kernel i modalita' grafica ridotta o quello funzionante?


funzionante! ho sbagliato?

--- Post unito in modo automatico ---


Only registered members can view code.

questo da modalità ridotta:bai

cydonia
17-12-10, 16: 05
non e' caricato il modulo nvidia per il kernel a g.ridotta,prova cosi' :

Only registered members can view code.
e scegli:

Only registered members can view code.
aggiora la cache

Only registered members can view code.
questo fallo in uno dei kernel a g.ridotta
:bai

poniboy
17-12-10, 16: 33
:bgg2 yes, ma..... ora c'è sta schermata

978

è normale che non mi faccia abilitare gli effetti visivi?

cydonia
17-12-10, 17: 08
è normale che non mi faccia abilitare gli effetti visivi? in modalita grafica ridotta e senza il modulo nvidia.vuoi anche il 3d?:ghgh
prova,edita /etc/modprobe.d/blacklist.conf:

Only registered members can view code.a fine file inserisci

Only registered members can view code.poi prova a reinstallare i vari nvidia-current etc etc

poniboy
17-12-10, 17: 13
vuoi anche il 3d?

non sarebbe male :ghgh


poi prova a reinstallare i vari nvidia-current etc etc

ma sono già installati :shock

cmq, al riavvio di nuovo la schermata di prima. solo che con la modifica che mi hai fatto fare prima, lo schermo era ok, adesso è dinuovo tutto piu' grande.:ohoh

cydonia
17-12-10, 22: 12
infatti o detto reinstallare perche' per qualche motivo non compila il modulo nel kernel in uso,prova cosi' controlla la versione di nvidia-current da synaptic e se diverso, modifica di conseguenza il valore finale di questo comando:

Only registered members can view code.

il tutto ovviamente nei kernel a g.ridotta
:bai

poniboy
18-12-10, 08: 51
il valore è quello. ho reinstallato i driver nvidia comunque e al riavvio mi sono trovato addirittura il primo kernel in modalità grafica ridotta :ghgh
:triste
ho voglia di prendere un martello!

cydonia
18-12-10, 09: 00
nel primo dai

Only registered members can view code.posta l'output
e puoi postare il risultato del comando(dkms) sopra scritto con il primo kernel e uno degli altri
:bai

poniboy
18-12-10, 09: 16
ecco ma mi sa che qualcosa non quadra


poniboy@poniboy-desktop:~$ sudo nvidia-xconfig
[sudo] password for poniboy:
sudo: nvidia-xconfig: command not found
poniboy@poniboy-desktop:~$




poniboy@poniboy-desktop:~$ sudo dkms install -m nvidia-current -v 195.36.24

Error! This module/version combo is already installed
for kernel: 2.6.32-26-generic (i686)
poniboy@poniboy-desktop:~$

cydonia
18-12-10, 15: 12
nvidia-xconfig fa parte di nvidia-current,reinstalla cosi':

Only registered members can view code.e posta l'output ,per dkms se pioi postare anche per gli altri kernel
:bai

poniboy
20-12-10, 08: 08
scusa il ritardo ma il pc è al lavoro e al sabato e domenica non posso fare nulla :bgg2


Only registered members can view code.

dal secondo kernel ecco:

Only registered members can view code.

:bai

cydonia
20-12-10, 10: 10
nel secondo kernel cioe' questo
2.6.32-25-generic

installa gli header :

Only registered members can view code.e dovrebbe compilare il modulo,per esserne sicuri dai:

Only registered members can view code.l'output dovrebbe essere:



Only registered members can view code.poi riedita blacklist.conf

Only registered members can view code.e togli

Only registered members can view code.poi:

Only registered members can view code.:bai

poniboy
20-12-10, 10: 46
e togli
Codice:
blacklist vga16fb


non c'è


sudo nvidia-xconfig

mi da command not found


tagliamo la testa al toro, se reinstallo risolvo? anche perchè comincia a servirmi. :ghgh

che dici? io non sono stanco, ma dopo un problema ne viene fuori unaltro:ghgh

cydonia
20-12-10, 11: 03
tagliamo la testa al toro, se reinstallo risolvo? anche perchè comincia a servirmi. :ghgh
immagino.se la live cd ti funziona senza problemi..si con i nvidia gia' caricati e nessun blocco del kernel
comunque a parte il modulo e nvidia-xconfig basta che nell'xorg.conf ci sia questo:

Only registered members can view code.
e se con il comando dato nei post precedenti che verifica che il modulo sia gia' installato
nel 2.6.32-25-generic.questo blacklist vga16fb dal primo kernel
:bai

poniboy
20-12-10, 11: 28
:bai adesso sono dentro con il live cd,

.se la live cd ti funziona senza problemi..si con i nvidia gia' caricati e nessun blocco del kernel


come faccio a sapere se funziona bene? :bgg2

poniboy
20-12-10, 11: 35
mentre ti aspetto sonoarrivato qua:
984

clicco su elimina sda3?
sda4 la lascio stare?
dopo cosa mi chiederà?

aspetto x non fare vaccate :bgg2

ginalfa
20-12-10, 13: 07
potresti anche non eliminare la sda3, ma semplicemente formattarla (in ext3 o ext4) assumendo / come punto di mount.
In fondo fa lo stesso
la swap sda4 la lasci com'è

poniboy
20-12-10, 14: 02
non mi da la possibilità di formattare, mi dice elimina modifica o ripristina
che fo?

poniboy
20-12-10, 17: 43
dove siete? :bgg2

poniboy
21-12-10, 07: 37
:bai ragazzi sono sempre fermo a quella schermata....non dimenticatemi:ghgh

cydonia
21-12-10, 09: 41
come ho gia' detto e' da un po che non reinstallo,comunque un backup preventivo di windows e la fat32 e' d'obbligo in questi casi, onde evitare...:eye:sisi.ora potresti tamite gparted eliminare ext3 e la swap cosi' da creare un'unica partizione,poi o formattando in ext4 o l'asciarla non partizionata che poi in fase di installazione indichi quella
:bai

ginalfa
21-12-10, 09: 48
come sarebbe non ti permette di formattare?
nello screenshot che mi hai postato c'è proprio la casella di spunta per la formattazione
se vai in modifica potrai disporre la formattazione, indicare il titpo di filesystem ed il punto di mount.
in ogni caso fino a che non applichi le modfiche non verrà effettuato nessun cambiamento ad disco e quindi potrai sempre tornare indietro
oh, se la elimini brutalmente male non fa, ma dovrai comunque ricreare la partizione e poi formattare ed indicare / come punto di mount. Era solo per essere un tantino più raffinati:tong2

poniboy
21-12-10, 10: 45
non ho resistito e ho fatto da cavia:ghgh
ho selezionato la sda3 e poi modifica, da li me l'ha fatta formattare scegliendo poi ext4 e / come mount
da li sono partito e ora sono arrivato:ghgh
non mi ha rovinato nulla delle altre partizioni:sisi
ho installato i driver raccomandati che mi ha chiesto all'inizio, ho fatto gli aggiornamenti richiesti dal sistema, e ho riavviato.
volete ridere?
al riavvio riecco la schermata initramfs
per fortuna dopo aver digitato exit, poi ci mette poco a partire :ghgh
evidentemente c'è qualche problema con sta scheda! boh!

poniboy
21-12-10, 18: 13
mentre vi aspetto:
dopo avere reinstallato ubuntu 10.04 se inserisco un cd o dvd nel masterizzatore non succede nulla! che devo fare?

cydonia
22-12-10, 08: 43
al riavvio riecco la schermata initramfs
ripeti i passi precedenti cioe' editare il grub,in questo caso il grub2 inserendo per prima cosa il rootdelay
:bai

poniboy
22-12-10, 09: 06
/boot/grub/menu.lst
è vuoto adesso.:triste

cydonia
22-12-10, 09: 24
infatti ho detto grub2:hap

Only registered members can view code.es:

Only registered members can view code.
poi

Only registered members can view code.
:bai

poniboy
22-12-10, 10: 23
sempre la solita schermata


Only registered members can view code.

cydonia
22-12-10, 18: 04
devi ripercorrere cosa hai fatto precedentemente,ora tocca all'UUID
nel grub2,edita sempre lo stesso file /etc/default/grub e decommenta cioe' togli il cancelletto "#" che lo precede a questa striga ,come da esempio:

Only registered members can view code.
poi aggiorna il grub con sudo update-grub
lo stesso con l'fstab togli l'UUID e indica direttamente la periferica
:bai

poniboy
23-12-10, 07: 57
devi ripercorrere cosa hai fatto precedentemente,ora tocca all'UUID
nel grub2,edita sempre lo stesso file /etc/default/grub e decommenta cioe' togli il cancelletto "#" che lo precede a questa striga ,come da esempio:

Only registered members can view code.
poi aggiorna il grub con sudo update-grub
:bai

se ho ben capito tolgo solo il cancelletto dalla stringa che mi dici! giusto?

però scusami ma non ho capito come devo fare x fstab :triste
so decoccio :bgg2

--- Post unito in modo automatico ---

questo è il mio fstab


Only registered members can view code.

cydonia
23-12-10, 08: 41
non serve perche' e' gia' sistemata:

Only registered members can view code.

poniboy
23-12-10, 08: 56
sempre sto cacchio di nitramfs :triste
ho tolto il # ho updatato il grub, ma sempre uguale! ma porca mucca!:shock

cydonia
23-12-10, 09: 04
devi provre per trovare un compromesso ,aumenta il rootdelay a 70 e posta l'output del file(grub.txt) creato da questo comando lo trovi nella home

Only registered members can view code.

poniboy
23-12-10, 11: 17
Only registered members can view code.

--- Post unito in modo automatico ---

sembra che ci siamo! :bgg2

poniboy
23-12-10, 17: 32
mi sembrava troppo bello.......:triste
al secondoriavvio ecco che siamo daccapo

cydonia
24-12-10, 08: 41
ora quant'e' il rootdelay?

poniboy
24-12-10, 17: 51
ma l'avevo messo a 70, poi ho riavviato e funzionava, dopo averti postato il grub.txt ho ancora riavviato ed avevo la solita schermata! non capisco:triste
in ogni caso ci "sentiamo" lunedi :bgg2
auguri di buone feste a tutti quanti

poniboy
27-12-10, 09: 38
rieccomi! che mal di testa..... adesso funziona di nuovo, e non ho toccato nulla, ho riavviato piu' volte e continua a funzionare! mah! mistero della fede:bgg2
che faccio chiudiamo qui? che dici cyd?

cydonia
27-12-10, 18: 49
se non ci sono altri problemi,direi di si:sisi

poniboy
28-12-10, 07: 56
a dire la verità un altro problemino c'è :ghgh
si tratta di riuscire a configurare e far funzionare la chiavetta tim olicard 100 se sei esperto anche in questo apro un altro topic e cominciamo, altrimenti dovrò rinunciare a navigare con linux:triste


secondo me hoi fantasmi nel pc adesso al riavvio ecco di nuovo la schermata con initramfs :cry3

cydonia
28-12-10, 08: 56
il discorso e' che devi trovare un punto di equilibrio,aumenta il rootdelay a 80 o 90 ,altra cosa che devi fare attenzione quando c'e' un'aggiornamento del kernel o del grub dovrai rifare il procedimento.
:bai

poniboy
28-12-10, 09: 54
sia a 80 che a 90 sempre uguale.:triste

cydonia
30-12-10, 08: 51
che devi provare metti 120,una curiosita' al grub,con i soliti comandi aggiungi l'opzione debug insieme a splash e rootdelay
1) cancella il ring buffer

Only registered members can view code.2) aggiungi al grub debug e aggiorna il grub e riavvia
3) al riavvio posta il dmesg

Only registered members can view code.
:bai

poniboy
30-12-10, 14: 02
ciao! mentre ti aspettavo ho provato a riavviare alcune volte ed ora sembra che vada! è a 90
mai dire mai però! x ora lascio stare e non tocco nulla! vediamo in seguito! provo

x il discorso della chiavetta che dici? sei esperto anche li? apro un topic?:bgg2

poniboy
28-01-11, 11: 55
rieccomi ragazzi! sempre io e mi sa che sono martellato dalla sfiga. ho fatto un lavoro con gparted, ridimensionando la partizione che avevo in fat32, dove mettevo delle cose, e l'ho poi unita, con la partizione di xp
al riavvio tutto funzionante, sia xp che ubuntu
adesso, stamane hoacceso ubuntu, in tutti e tre i kernel 2.6.32-28/27 e 24 e mi sono trovato sta sorpresa

http://d3.myfreefilehosting.com/d1/Foto0226.jpg

help!

sono entrato con la live di 10.04 e questa è la schermata di gparted
http://d3.myfreefilehosting.com/d2/Foto0227.jpg

cydonia
30-01-11, 08: 40
scusa il ritardo,ma sono stato impegnato.:hap.apparte che in questi giorni ci sonoo stati aggiornamenti del kernel,ora dai uno sguardo ai parametri del grub/kernel controlla che ci siano ancora ,aggiungili all'ultimo kernel se non ci fossero e gioca come al solito con il delay poi ti ho chiesto post sopra il debug..
:bai

poniboy
30-01-11, 15: 22
ciao cyd salvatore del mio ubuntu :bgg2
è una cosa davvero stana, se io uso xp e riavvio, ecco che mi appare quella schermata e non riesco a far altro che spegnere dal tasto del pc. se io invece avvio il pc, scegliendo al boot ubuntu ( che daltronde è la prima scelta) ecco che funziona! non capisco il motivo. davvero astrale! :ghgh

cydonia
08-02-11, 12: 36
piu' che astrale chiama l'esorciccio per il tuo computer:ghgh,apparte gli scherzi bisogna avere un minimo di log il debuggggg
:bai

poniboy
08-02-11, 13: 21
piu' che astrale chiama l'esorciccio per il tuo computer:ghgh,apparte gli scherzi bisogna avere un minimo di log il debuggggg
:bai

perdonami, come è già che lo devo fare?

cydonia
08-02-11, 21: 03
dai uno sguardo al post 101 qui' sopra:hap
:bai

poniboy
09-02-11, 08: 16
scusa, ma non capisco come devo fare x aggiungere sto debug


# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="rootdelay=90 quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_LINUX_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

cydonia
09-02-11, 09: 38
Only registered members can view code.
:bai

poniboy
09-02-11, 19: 50
Only registered members can view code.
:bai

ora ho capito :bgg2
poi che devo fare?

cydonia
09-02-11, 22: 05
1) cancella il ring buffer e riavvia
Codice:

Only registered members can view code.2) al riavvio posta il file creato con il dmesg..
Codice:

Only registered members can view code.:bai

poniboy
17-02-11, 08: 07
scusa il ritardo cyd sono stato via. appena riesco ti posto l'ciò che mi hai detto di fare :bgg2
:bai