PDA

Visualizza versione completa : Linux Mint 10 si blocca



Brujo
03-12-10, 15: 18
Salve a tutti, inizio nel dire che ho 3 HD; 1 Slave e 2 IDE. Nel'HD slave ho il SO xp e qui vorrei installarci anche mint 10 in dual boot. Inserisco il cd di linux, vado nel bios e metto come prima opzione il lettore dvd. Parte il cd di linux fino ad arrivare ad una schermata tutta nero con il logo di linux al centro e 4 pallini verdi sotto (:ehmm giusto per farmi capire) e da qua non va più avanti, ho aspettato anche un'ora ma niente. Sapete dirmi cosa fare?
Ho provato a masterizzare due cd con due masterizzatori e pc diversi ma il risultato non cambia

Ho provato il live cd di linux su un altro pc e funziona tutto regolarmente.:boh

pierino_89
03-12-10, 16: 44
Evidentemente non gli aggrada per qualche motivo. C'è qualche opzione per partire in modalità testuale?

Brujo
03-12-10, 18: 33
Evidentemente non gli aggrada per qualche motivo. C'è qualche opzione per partire in modalità testuale?

:ehmm in che senso? quando inserisco il cd dove ancora sono su windows xp ci sono le solite opzioni.
1 - prova e installa
2 - installa dentro windows
3 - ulteriori informazioni

Brujo
04-12-10, 23: 56
:ehmm Non vi viene in mente niente?

djdedo
05-12-10, 01: 07
Hai una scheda video ati per caso?

pierino_89
05-12-10, 01: 51
No, dico quando accendi il pc e lo fai salire da cd. Dovresti avere almeno 3 o 4 opzioni.

Brujo
06-12-10, 08: 23
Hai una scheda video ati per caso?

Si, ati radeon 9250

---Post unito in modo automatico ---


No, dico quando accendi il pc e lo fai salire da cd. Dovresti avere almeno 3 o 4 opzioni.

No, parte subito a caricare il cd. Alcune scritte in alto (con sfondo nero) poi c'è lo sfondo grigio con il logo di linux mint 10 e il conto alla rovescia per il boot e subito dopo, come dicevo, la scritta linux mint al centro con sfondo nero e 4 o 5 puntini sotto. Praticamente dove mi si blocca.

cydonia
06-12-10, 10: 30
prima della fine del conto alla rovescia premi un tasto :
controlla il disco:
check integrity disk
e se e' apposto:
avvia in modalita' compatibile

se non va
avvia normalmente e quando ci sono i pallini verdi premi ALT-F2 cosi' vediamo dove si blocca,anche se dovresti vederlo nella modalita' compatibile nel caso di blocco
:bai

djdedo
06-12-10, 15: 20
Io sono quasi convinto che sia colpa della scheda ati, mi han sempre dato problemi con le live. Se non hai ancora risolto io fare questa prova



When Ubuntu starts:

F6 then Esc to see the boot:

file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash --

Remove quiet splash and add xforcevesa so it looks like this


file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz xforcevesa --

Then Enter to boot.

Brujo
06-12-10, 17: 26
prima della fine del conto alla rovescia premi un tasto :
controlla il disco:
check integrity disk
e se e' apposto:
avvia in modalita' compatibile

se non va
avvia normalmente e quando ci sono i pallini verdi premi ALT-F2 cosi' vediamo dove si blocca,anche se dovresti vederlo nella modalita' compatibile nel caso di blocco
:bai

Ho fatto come hai detto, scelto check integrity disk
risultato: check finished: no errors found
poi ho avviato in modalità compatibile, ad un certo punto mi compare, su sfondo nero, una serie di scritte e un disegno di un cervo(credo), alcune scritte erano: your cpu appears to be locking expected security protections. Please check your BIOS settings, or for more information, run: /usr/bin/check-bios-nx --verbose.
E poi una scritta verde:
mintç(non era proprio questo il simbolo ma non so come si riproduce)mint ~ $
alchè ho spento per non fare casini


@djdedo: appena posso farò anche quella prova.

cydonia
06-12-10, 19: 31
poi ho avviato in modalità compatibile, ad un certo punto mi compare, su sfondo nero, una serie di scritte e un disegno di un cervo(credo), alcune scritte erano: your cpu appears to be locking expected security protections. Please check your BIOS settings, or for more information, run: /usr/bin/check-bios-nx --verbose.

posta l'output comando suggerito :

Only registered members can view code.
dopo la scritta verde

mint ~ $

Brujo
08-12-10, 11: 53
posta l'output comando suggerito :

Only registered members can view code.
dopo la scritta verde

Dopo la scritta verde

Only registered members can view code.
Ho riportato la seguente dicitura

Only registered members can view code.

Il risultato è stato il seguente


Only registered members can view code.

Sono andato a vedere nel sito indicato, ma non ci ho capito nulla. Per paura di combinare casini aspetto le vostre notizie:sisi

cydonia
08-12-10, 12: 22
in parole povere ti dice che la nuova feature(flag)(Non-eXecute) per la protezione della memoria(buffer overflow)adottata nelle nuove cpu amd e intel e' disabilitata e la devi abilitare,questo "avvertimento" e' stato introdotto dalla 10.04 in poi ora :
devi abilitarlo da bios,se non e' presente questa opzione dovrai fare l'upgrade del bios
:bai

Brujo
09-12-10, 13: 03
in parole povere ti dice che la nuova feature(flag)(Non-eXecute) per la protezione della memoria(buffer overflow)adottata nelle nuove cpu amd e intel e' disabilitata e la devi abilitare,questo "avvertimento" e' stato introdotto dalla 10.04 in poi ora :
devi abilitarlo da bios,se non e' presente questa opzione dovrai fare l'upgrade del bios
:bai

In parole povere come dovrei fare?:ehmm

cydonia
09-12-10, 21: 48
all'avvio del sistema entrare nel bios con del o f2 dipende dal modello, trovare una voce in sicurezza o feature(qualcosa del genere) ,che assomiglia a protezione della memoria o NX.

posta marca modello del computer.

Brujo
10-12-10, 08: 16
all'avvio del sistema entrare nel bios con del o f2 dipende dal modello, trovare una voce in sicurezza o feature(qualcosa del genere) ,che assomiglia a protezione della memoria o NX.

posta marca modello del computer.

Motherboard: Asus P4S800D
Processore: Pentium 4 CPU 3.00 GHz

Entrando nel BIOS ho queste soluzioni:
Main - Advanced - Power - Boot - Exit

cydonia
10-12-10, 18: 01
dovresti aggiornare il bios,ma secondo me la strada piu' sensata da percorrere se vuoi installare la live di mint e' partire dalla karmic(helena) e poi aggiornare,sicuramente quando aggiorni alla 10.04 avrai quell'avviso ma in tal caso essendo installata puoi eliminare il check

Only registered members can view code.
fino alla 10.10.
se no ,installare la 10.10 alternate di ubuntu e poi togliere il check
:bai

Brujo
16-12-10, 09: 12
Buongiorno carissimi amici, ho fatto una scelta. Alla fine ho installato linux mint 9. Fatto le partizioni con gparted e installato. Ma purtroppo mi è sorto un altro problema. Dopo il bootloader mi compare una finestra con scritto: Ubuntu is running in low-graphics mode the following error was encountered. You may need to update your configuration to salve this. L'unico problema è che poi si blocca il pc. Quindi dovrei fare qualche cosa prima del bootloader tra xp e linux
Grazie, aspetto fiducioso

cydonia
16-12-10, 11: 59
low-graphics mode the following error was encountered. You may need to update your configuration to salve this
solitamente e' specificata anche la causa,risoluzione non supportata,refresh non supportato,vedi se dopo quella frase e specificato..
:bai

Brujo
16-12-10, 12: 16
solitamente e' specificata anche la causa,risoluzione non supportata,refresh non supportato,vedi se dopo quella frase e specificato..
:bai

(EE) VESA: Kernel modesetting driver in use, refusing to load
(EE) No devices detected
:boh:bai

cydonia
16-12-10, 13: 26
hai installato mint9 e dunque lucid,giusto'? perche' questo andra' ad influire le modifiche al grub se hai il grub-legacy e' una cosa se il grub2 e' un'altra.

comunque prima il boot.
il tuo sistema ha bisogno del parametro nomodeset nel kernel per partire ,tamponiamo momentaneamente il boot ,cosi' a sistema avviato potrai rendere le modifiche permanenti ora fai attenzione:
all'avvio del sistema quando ti si presentera' la scelta del sistema operativo da avviare ,sposta i tasti cursore su mint/ubuntu e premi la lettera "e" cosi' da mettere in editor mode il grub.ora spostati con i tasti cursore alla voce:


Only registered members can view code.sicuramente il tu kernel sara' diverso ma non farci caso devi solo inserire il parametro nomodeset dopo lo splash, l'asciando invariati gli altri parametri sia prima che dopo lo splash
fatto questo premi control + x e avvia il kernel.
questa modifica non e' permanente(fino al prossimo riavvio) ma serve per rendere stabile il sistema fin tanto che modifichiamo il grub:
se usi grub2

Only registered members can view code.e alla voce

Only registered members can view code.come prima dopo lo splash aggiungi nomodeset l'asciando invariato il resto, salva.
ora aggiorna il grub

Only registered members can view code.
:bai

Brujo
16-12-10, 14: 36
Intanto dico che sei mitico :eye
dopo aver aggiunto al primo codice nomodeset sono entrato senza problemi, cioè qualche problema l'ho avuto perchè non riesco a connettermi, mentre prima in live cd non ho avuto nessuna difficoltà, ma questo è un altro problema.
In alto, sempre nel bootloader ho riportato questo:
GNU GRUB versione 1.98-1ubuntu5-1mint2
Quindi io non ho il grub2, devo attuare sempre lo stesso procedimento che mi hai scritto?
E non ho lucid, ma isadora.

cydonia
16-12-10, 14: 52
E non ho lucid, ma isadora.e' basata sulla lucid lynx vedi qui', (http://www.linuxmint.com/oldreleases.php)
procedi con le modifiche al grub,poi vediamo il resto(connessione)
:bai

Brujo
16-12-10, 16: 19
Ancora una volta devo farti i miei complimenti, ora se riesci ad aiutarmi anche con internet, almeno non devo fare avanti e indietro tra linux e windows.
Allora appena entro in basso a dx ho i due schermi con scritto:wired network connection 'auto eth0' active, ma non riesco a navigare, poi a fianco compare uno scudo e se passo sopra con il mouse dice:gestione aggiornamenti impossibile connettersi ad internet.
Come provider ho infostrada e come router un netgear dg834g.
Se da terminale scrivo: sudo dhcpcd eth0 mi da errore

cydonia
16-12-10, 18: 33
Se da terminale scrivo: sudo dhcpcd eth0 mi da errore

posta l'errore:hap ,comunque il netgear e' impostato come server dhcp (se mi ricordo si chiama cosi')
posta gli output di :

Only registered members can view code.

Only registered members can view code.
e anche il router

Only registered members can view code.
:bai

Brujo
17-12-10, 09: 10
Purtroppo non posso postarti nulla, non so il perchè ma questa mattina linux si blocca :furious:wall:furious:wall l'unica cosa che riesco a fare è spegnere il pc fisicamente. Se hai qualche soluzione soso tutto orecchie

cydonia
17-12-10, 09: 17
messaggi di errore?

Brujo
17-12-10, 09: 31
Nessuno, si blocca solamente. La prima volta inserisco account e password iniziali e si blocca poi, la seconda volta non riesco neanche ad inserire account e psw.

cydonia
17-12-10, 12: 55
vediamo se riusciamo a ricavarci qualcosa,nel grub edita come avevi fatto inizialmente per inserire temporaneamente nomodeset,questa volta togli splash e quiet e dai control+x.vedrai scorrere le periferiche rilevate e altre info tra cui se siamo fortunati,se si blocca prima del login il motivo.se al login si blocca prova a dare ctrl+alt+f1 cosi' da entrare i TTY con il login testuale
e dai per ritornare a quello grafico:

Only registered members can view code.

Only registered members can view code.
e riprova.
:bai

Brujo
17-12-10, 14: 47
vediamo se riusciamo a ricavarci qualcosa,nel grub edita come avevi fatto inizialmente per inserire temporaneamente nomodeset,questa volta togli splash e quiet e dai control+x.vedrai scorrere le periferiche rilevate e altre info tra cui se siamo fortunati,se si blocca prima del login il motivo.se al login si blocca prova a dare ctrl+alt+f1 cosi' da entrare i TTY con il login testuale
e dai per ritornare a quello grafico:

Only registered members can view code.

Only registered members can view code.
e riprova.
:bai

:furious niente da fare , tolgo splash e quiet, scorre la sequenza, mi parte linux con sfondo verde che mi chiede l'account e subito si blocca. Gli do ctrl+alt+f1 ma non succede niente. Qualsiasi combinazione di tasti gli do non ne vuole sapere. Mi conviene reinstallarlo?

cydonia
17-12-10, 15: 21
mmmh vediamo se e' gnome, al grub dovresti avere mint kernel in recovery mode,se non c'e' puoi usare la live di mint e rinomina gnome2,in recovery mode


Only registered members can view code.in rosso devi inserire il nome che hai dato,ricorda una directory che inizia con il punto come .gnome2 e' nascosa, se agisci dalla live per rinominare la directory come abbiamo fatto. premi ctrl+h per visualizzarla
tuttalpiu' se non va anche cosi' proviamo a creare un'altro utente,in recoveriy mode

Only registered members can view code.e la pass

Only registered members can view code.cosi' provi a loggarti con questo nuovo utente
:bai

Brujo
17-12-10, 15: 58
:ehmm Con il live cd devo entrare o mi devo fermare prima ( al bootloader) per dare questi comandi.
Se ho capito bene inserisco il cd di linux, entro e poi da terminale faccio il tutto?

cydonia
17-12-10, 16: 15
se al boot quando scegli il sistema operativo da avviare dove abbiamo fatto le modifiche
temporanee hai una cosa di questo tipo.

Only registered members can view code.
ma riferito a mint scegli questo kernel
se non hai questa modalita' al boot, dovrai usare la live cd di mint quella che ti e' servita per
per installarla.
con la live ti fermi al punto di rinominare la directory ma in questo caso lo fai graficamente
la partizione di mint(quella installata la trovi in /media)insieme a quella di windows,entri dentro
vai nella /home/tuo_utente e rinomini quella directory,la live non abilita di default la visualizzazione dei file nascosti cosi' premi ctrl+h per vederli

Brujo
17-12-10, 16: 58
Only registered members can view code.

Purtroppo devi avere pazienza con me:confused:
sono andato in recocery mod e mi è uscito questo menu
resume resume normal boot
clean try to make free space
dpkg repair broken packages
failsafex run in failsafe graphic mode
grub update grub boot loader
netroot drop to root shell prompt with networking
root drop to root shell prompt

Nel mentre che stavo scrivendo questo menu mi si è oscurato il monitor e per riavviarlo involontariamente ho dato il comando grub update grub boot loader:ehmm
poi sono andato su cancel per uscire e mi si è bloccato di nuovo
mi sa che ho ancora molto da :leg1:

cydonia
17-12-10, 17: 11
scegli una di queste due modalita'

Only registered members can view code.
:bai

Brujo
20-12-10, 08: 55
:cry3:cry3 niente da fare, continua a bloccarsi.
Non so se te ne avevo parlato, ma io ho installato linux da un cd riscrivibile. Potrebbe essere quella la causa? se volessi reinstallarlo con un cd normale come mi dovrei comportare, devo formattare linux che c'è ora e reinstallarlo normalmente o devo seguire qualche altra via?

cydonia
21-12-10, 09: 32
Non so se te ne avevo parlato, ma io ho installato linux da un cd riscrivibile. Potrebbe essere quella la causa?
se fosse colpa del cd non si sarebbe neanche installata,ora non so cosa ha portato al malfunzionamento,hai messo mano da qualche parte oltre al grub?
un backup preventivo di windows e' d'obbligo,ora e' un po di anni che non reinstallo ma dovrebbe bastare eliminare la partizione di linux tramite gparted della mint poi formattarla in ext4 (o l'asciarla non partizionata),e indicare in fase di installazione quella patizione.
:bai

Brujo
21-12-10, 20: 34
Otre al grub niente, domani riprovo a formattare e reinstallare, speriamo.
Devo formattare anche lo swap?
Ora mi è venuto in mente una cosa non so se questo può dare qualche problema, nel partizionare l'HD mi è uscito fuori questo:
8 mbit ( cioè il minimo)
200 GB XP
96 GB Mint
4 GB swap
Non sono riuscito a togliere quei 8 mbit non allocato, può dare problemi?

cydonia
22-12-10, 08: 38
Ora mi è venuto in mente una cosa non so se questo può dare qualche problema, nel partizionare l'HD mi è uscito fuori questo:
8 mbit ( cioè il minimo)
........
Non sono riuscito a togliere quei 8 mbit non allocato, può dare problemi?
questo perche' di default e' abilitata l'opzione"arrotondare ai cilindri" che fa in modo di allineare i limiti della partizione con i cilindri del device,questo incrementa anche se di poco le prestazioni,non crea nessun problema,si puo' sistemare in un secondo momento
:bai

Brujo
23-12-10, 13: 43
Purtroppo mi sa che c'è qualche cosa al livello di cpu. Anche con la live mi si blocca appena compare la schermata iniziale del desktop.

cydonia
24-12-10, 08: 40
hai provato in compatibilty mode all'avvio della live?.
oppure aggiungendo nomodeset ,per aggiungerlo nel menu di scelta quando hai premuto un tasto prima della fine del conto alla rovescia premi il TAB e a fine file inserisci il parametro.:bai

Brujo
22-04-11, 15: 22
Sono di nuovo quà a disturbare la vostra vita tranquilla:sisi

Purtroppo dopo vari tentativi non ho risolto nulla, linux continua a bloccarsi. Ho riformattato e reinstallato, ma non è cambiato nulla


Io sono quasi convinto che sia colpa della scheda ati, mi han sempre dato problemi con le live. Se non hai ancora risolto io fare questa prova

Fatta anche questa prova, sia in modalità live-cd che non mi da sempre questo errore:
(EE) VESA: Kernel modesetting driver in use, refusing to load
(EE) No devices detected

Vado avanti e mi si presenta un menù con queste opzioni:
1 Run ubuntu in low-graphics mode for just one session
2 Reconfigure graphics
3 Troubleshoot the error
4 Exit to console login
5 Restart x

Le prime volte mi si bloccava dopo aver dato l'opzione n.1, poi anche alla comparsa del sopraindicato menù

Non so più che pesci pigliare. Chiedo ancora un vostro aiuto:triste:triste:triste

Brujo
03-05-11, 16: 44
Niente??:oo2

cydonia
04-05-11, 06: 11
Only registered members can view code.
ripercorri i passi iniziali,quelli di inserire il nomodeset
:bai

Brujo
05-05-11, 17: 35
Non me ne volete :tong2, ho deciso di installare ubuntu 11 che sembra non darmi nessun problema. Però ora ho una curiosità. All'interno del HD ho sia xp che linux mint, quest'ultimo lo vorrei togliere per mettere ubuntu. Avevo fatto le partizioni con gparted, ma molto probabilmente ho fatto un gran casino e chiedo a voi come poter rimediare. Questo è come si presenta l'HD:

/dev/sdc1 ntfs 99325 MB
/dev/sdc5 ext4 86442 MB
/dev/sdc6 swap 3074 MB
/dev/sdc2 swap 4194 MB
/dev/sdc3 ext4 127022 MB

Vorrei aggiustarlo con xp - ubuntu e swap, ma se cerco di eliminare qualche partizione, non avendo gparted su ubuntu, mi rimane uno spazio vuoto. Chiedo lumi.
Già che ci siamo il punto di mount devo mettere " / " ?:bai