PDA

Visualizza versione completa : Riquadro nero su finestra spegnimento



DeST
28-11-10, 12: 32
Salve a tutti,
nuovo giorno nuovo problema...
Nel mio sistema (Lubuntu 10.10) non veniva visualizzato lo splash boot così ho seguito una guida sul forum (questa (http://forum.ubuntu-it.org/index.php/topic,398532.msg3103114.html#msg3103114)) per ripristinarlo...

seguita la procedura la schermata è riapparsa... però su alcune finestre (per ora quella per lo spegnimento) si presenta un fastidiosissimo rettangolo nero che copre quasi totalmente la finestra!!!

A questo punto preferisco tornare indietro! :cry3
ma non vorrei riperdere la schermata... cosa posso fare?

aggiungo screen
893

pierino_89
28-11-10, 13: 08
Beh, per tornare indietro basta che segui la guida esattamente al contrario. Ma quei rettangoli a me sembrano tanto gli scleri di compiz. Non è che lo stai usando?

DeST
28-11-10, 14: 43
OK
ho disinstallato v86d
ho ripristinato le stringhe in gksu gedit /etc/default/grub e in gksu gedit /etc/initramfs-tools/modules
come di default
Il problema del rettangolo nero è sparito
adesso però come splash boot ho un'orribile schermata nera con una scritta spartana al centro dello schermo (non quella ufficiale per intenderci)
meglio niente allora! ma adesso come la levo o meglio posso ripristinare quella di default
gli unici comandi in più che ho eseguito sono

Only registered members can view code.

come devo fare?

compiz è installato ma non attivo. Ho il problema che non funziona, infatti sto anche cercando un modo per farlo avviare!
questo Lubuntu è una vera e propria gatta da pelare!

pierino_89
28-11-10, 14: 46
Eh vabbè, ma se metti lubuntu e poi pretendi di avviare compiz e tutto...
È come andare da mc donald e prendere la coca cola zero per non ingrassare :tong2

Comunque, il contrario di FRAMEBUFFER=y è sicuramente FRAMEBUFFER=n

DeST
28-11-10, 21: 25
Ho provato compiz su una live con Ubuntu e girava bene il problema era ubuntu che risultava piuttosto pesante (anche senza compiz)
Per questo motivo ho provato Lubuntu, del quale (in termini di prestazioni) sono mooooolto soddisfatto.
Pensavo che in fondo compiz avrebbe funzionato ancora meglio con un sistema più leggero (il portatile monta una ATI Mobility Radeon Xpress x200 64mb)

Il punto è che non avendo mai usato linux non avevo idea che con un DE diverso da gnome avrei affrontato tutti questi problemi... in fondo è meglio così... credo che solo facendosi le ossa sui problemi di un S.O. si possa imparare realmente ad usarlo! ::bgg2

pierino_89
28-11-10, 21: 45
Beh, la live per forza che va piano, gira tutta su ram... Se la installi sicuramente va molto più veloce.

DeST
28-11-10, 22: 27
Prtroppo il problema non è della live,
sulla live ho provato compiz...
sul pc ho provato ubuntu senza compiz...
E' il pc che non ha proprio delle buone caratteristiche... però compiz funzionava!
Spero che almeno nella prossima release di Lubuntu le cose vadano a migliorare
:eye

K.a.o.s.
28-11-10, 23: 42
Installa il ccsm (sudo apt-get install compizconfig-settings-manager ), disattiva quasi tutti i plugin (lascia i più leggeri) e poi posta che ti dice se lanci da terminale:

Only registered members can view code.

DeST
29-11-10, 11: 01
Il terminale non dice assolutamente nulla come se compiz fosse partito correttamente...
Ma sul sistema ho sempre i stessi problemi (spariscono panello superiore e inferiore, non risponde ai comandi)

Potrebbe essere un problema di driver video? Non ho capito dove verificare se ho tutto installato e in regola... :ehmm

DeST
04-12-10, 10: 44
dopo un aggiornamento adesso quando do da terminale

Only registered members can view code.
i comandi di compiz funzionano, i pannelli (sopra e in basso) si vedono, ma... le finestre non hanno decorazioni... e quindi nemmeno tasto chiudi!

il terminale mi dice

Only registered members can view code.

pierino_89
04-12-10, 13: 19
Installa emerald, sennò non sa a che programma far mettere i bordi finestra

DeST
04-12-10, 16: 18
ho installato emerald ma il risultato non cambia...
ho provato a dare da terminale emerald --replace ma non succede nulla
allora nell'opzione configurazione di compiz alla voce decorazione ho inserito quel comando nell'apposito campo..
non è cambiato nulla soliti problemi...

pierino_89
04-12-10, 16: 59
compiz --replace && emerald --replace

DeST
04-12-10, 19: 54
compiz --replace && emerald --replace

niente da fare, solti problemi
questo è quello che dice il terminale

Only registered members can view code.

pierino_89
05-12-10, 01: 52
Evidentemente dipendono da qualche pezzo di gnome che non si sono portati dietro. Non saprei cosa dirti.

DeST
05-12-10, 14: 50
uff... almeno qualcuno conosce il nome di qualche applicazione alternativa per linux che permetta di ricreare il cubo desktop...
Per gli effetti di trasparenza e dissolvenza sto ripiegando su Xcompmgr