PDA

Visualizza versione completa : Gimp non si avvia sotto Lubuntu



DeST
22-11-10, 15: 20
Salve a tutti ho un problema sotto Lubuntu
Gimp non si avvia... su internet ho trovato una discussione dove viene chiesto di installare una patch per x11 rilasciata a questo link (http://xquartz.macosforge.org/trac/wiki/X112.1.3)
Ho scaricato la patch ma un file .pkg e non so come fare ad installarlo..
hepl :cry3

:bai

pierino_89
22-11-10, 16: 55
Leggi bene, una patch per mac os...

DeST
22-11-10, 17: 00
Ops... ho visto che parlavano di x11 e dato che x11 anche lxde ho fatto un po di confusione..
allora come risolvo il mio problema sotto linux Lubuntu?
Chiedo cortesemente ai moderatori di cambiarmi il titolo della discussione! :ehmm

pierino_89
22-11-10, 17: 06
Avvia gimp da riga di comando e guarda cosa scrive.

K.a.o.s.
22-11-10, 17: 39
Ops... ho visto che parlavano di x11 e dato che x11 anche lxde ho fatto un po di confusione..

PS: x11 il server grafico X.org che lo strato sottostante a Lxde come per Gnome, Kde, Enlightment e i vari Wm come Compiz, BlackBox ecc.
Insomma tutta la parte video passa da lui.

DeST
22-11-10, 17: 46
Avvia gimp da riga di comando e guarda cosa scrive.

ehmm... :ehmm come si fa?

pierino_89
22-11-10, 17: 50
scrivi "gimp" sul terminale

DeST
22-11-10, 18: 07
allora quando ho scritto gimp da terminale si avviata una finestra che guidava nell'installazione di gimp, completata l'installazione si aperto...
chiuso il programma non si apre ne dal menu ne dal launcher sul desktop, allora lo faccio partire dal terminale e parte senza apparenti problemi... per la versione 2.2 io ricordavo di avere la 2.6! ???
Quindi ora parte solo da terminale!? cosa devo fare?

gimp
/usr/local/lib/gimp/2.0/plug-ins/print: error while loading shared libraries: libgimpprint.so.1: cannot open shared object file: No such file or directory

(gimp:1818): LibGimpBase-WARNING **: gimp: wire_read(): error
/usr/local/lib/gimp/2.0/plug-ins/helpbrowser: error while loading shared libraries: libgtkhtml-2.so.0: cannot open shared object file: No such file or directory

(gimp:1818): LibGimpBase-WARNING **: gimp: wire_read(): error

pierino_89
22-11-10, 18: 16
lancia gimp-2.6

DeST
22-11-10, 18: 28
con gimp-2.6 mi da undefined symbol...
nella cartella home presente solo gimp-2.2
forse perch ho provato a reinstallarlo un paio di volte, ma... la versione non vecchia??
comunque i launcher non funzionano e da terminale parte... bho?
dove la trovo la versione aggiornata?
ho provato ad installarla sia con sudo apt-get install gimp che dal software ceter ed esce fuori sempre la 2.2
nelle propriet del launcher il comand o
Only registered members can view code.

DeST
22-11-10, 20: 36
Sto andando letteralmente in crisi...
provo a riepilogare il tutto per dare maggior chiarezza

Allora ho avviato gimp da terminale e si aperta una finestra che guida all'installazione di gimp 2.2 (mentre io ho installato la 2.6), se completo l'installazione alla fine si apre, ma solo dal terminale.
Se provo ad avviare gimp da un launcher del desktop o del menu non succede niente.
Quello che si avvia da terminale per sempre la versione 2.2!!
Quindi ora parte solo da terminale, ed la versione sbagliata!

Questo quello che mi da il terminale quando avvio gimp
gimp
/usr/local/lib/gimp/2.0/plug-ins/print: error while loading shared libraries: libgimpprint.so.1: cannot open shared object file: No such file or directory

(gimp:1818): LibGimpBase-WARNING **: gimp: wire_read(): error
/usr/local/lib/gimp/2.0/plug-ins/helpbrowser: error while loading shared libraries: libgtkhtml-2.so.0: cannot open shared object file: No such file or directory

(gimp:1818): LibGimpBase-WARNING **: gimp: wire_read(): error

adesso nella cartella home presente solo gimp-2.2 (dato che ho cercato di eliminare tutti i file cancellando la 2.6)

ho provato ad installare sia con

Only registered members can view code.
che dal software ceter ed esce fuori sempre la 2.2

ho provato a dare nel terminale

Only registered members can view code.
ma non cambiato nulla

ho rimosso gimp con

Only registered members can view code.
provando a reinstallare non cambia nulla

ho anche usato ubuntu tweaker per fare pulizia nei pacchetti nella cache e nelle configurazioni

nelle propriet del launcher il comando riportato

Only registered members can view code.

Help... :wall

pierino_89
22-11-10, 20: 56
Se nei repo c' la 2.2 puoi fare upgrade quanto vuoi ma non va su di certo. Sei sicuro di avere l'ultima versione di lubuntu? E di non avere pasticciato i repo?

PS: se fai prima remove e poi purge, va a termine solo il remove. Inoltre clean, autoclean e autoremove non mi sembra prendano un pacchetto come argomento. Inoltre apt-get update si fa prima, perch aggiorna la lista. Farlo dopo assolutamente inutile.

K.a.o.s.
22-11-10, 21: 19
adesso nella cartella home presente solo gimp-2.2 (dato che ho cercato di eliminare tutti i file cancellando la 2.6)
Nella home? Che ci fanno l?

Allora ho avviato gimp da terminale e si aperta una finestra che guida all'installazione di gimp 2.2 (mentre io ho installato la 2.6), se completo l'installazione alla fine si apre, ma solo dal terminale.Come li hai installati?

Io controllerei prima i repo che siano attivi e a posto. Su Ubuntu c' "sorgenti software", su Lubuntu ci sar qualcosa di simile. Abilita i vari update nella seconda tab.

Dopo quello (non prima perch senn non serve ad un tubo):

Only registered members can view code.


ho anche usato ubuntu tweaker per fare pulizia nei pacchetti nella cache e nelle configurazioni
Occhio che c' chi ha fatto casino con quel programma. Se vuoi fare pulizia/manutenzione meglio se la fai "a mano".

DeST
22-11-10, 22: 35
Sei sicuro di avere l'ultima versione di lubuntu?
Ho installato una settimana fa Lubuntu 10.10


PS: se fai prima remove e poi purge, va a termine solo il remove. Inoltre clean, autoclean e autoremove non mi sembra prendano un pacchetto come argomento. Inoltre apt-get update si fa prima, perch aggiorna la lista. Farlo dopo assolutamente inutile
Forse avrei dovuto scriverli nell'ordine in cui li ho eseguiti :ehmmm


adesso nella cartella home presente solo gimp-2.2 (dato che ho cercato di eliminare tutti i file cancellando la 2.6)

Nella home? Che ci fanno l?
ho abilitato la visualizzazione dei file nascosti si trova esattamente in home/user/.gimp-2.2


Allora ho avviato gimp da terminale e si aperta una finestra che guida all'installazione di gimp 2.2 (mentre io ho installato la 2.6), se completo l'installazione alla fine si apre, ma solo dal terminale.

Come li hai installati?

Come gi detto ho provato sia da terminale che dal software center ad installare la versione 2.6, ma quando avvio da terminale (dato che il launcher non va) parte una procedura di installazione della versione 2.2
so di aver installato la 2.6 perch il comando del launcher gimp-2.6 %U e perch nel software center viene indicata la versione


ho anche usato ubuntu tweaker per fare pulizia nei pacchetti nella cache e nelle configurazioni

Occhio che c' chi ha fatto casino con quel programma.
Mi sa che troppo tardi... :wall

Mi potete guidare passo passo nel controllo dei repo?

K.a.o.s.
22-11-10, 22: 53
ho abilitato la visualizzazione dei file nascosti si trova esattamente in home/user/.gimp-2.2
Quelle sono le impostazioni, il programma sparpagliato in /usr/local/

Mi potete guidare passo passo nel controllo dei repo?
Se sei sicuro di avere la 2.6 allora non serve, in ogni caso: ho scoperto ora che hanno tolto la voce "sorgenti software" dal menu di Ubuntu per semplificare l'uso. Puoi raggiungere la stessa schermata dal software center oppure da Synaptic. Praticamente dal software center vai nel menu modifica->sorgenti software (in base a quello che leggo sul web). Da l puoi controllare i repo con una gui.

Comunque fai pulizia da Synaptic di tutte le versioni di Gimp installate e reinstallalo in maniera pulita. Almeno vediamo di partire da una base.
Dopo quello prova a lanciare il comando del launcher da terminale (anche senza il %U) e posta gli errori che d.

DeST
22-11-10, 23: 53
Comunque fai pulizia da Synaptic di tutte le versioni di Gimp installate e reinstallalo in maniera pulita.
Bh dopo averlo rimosso con sudo apt-get remove gimp l'unica voce in synaptic legata gimp gimpshop.
Come mi consigli di procede per per l'installazione? da terminale o da software center?

K.a.o.s.
23-11-10, 00: 34
Come mi consigli di procede per per l'installazione? da terminale o da software center?
Sono la stessa cosa tecnicamente, anche perch il software center non fa altro che eseguire apt per mostrando una interfaccia.
Vai con un normalissimo:

Only registered members can view code.
Poi lancialo e posta gli errori.

DeST
23-11-10, 18: 58
Adesso si avvia!!!
Credo che il problema era da attribuire ad un pacchetto di gimpshop (gimp con la grafica di photoshop) che non era stato rimosso dall'ultima disinstallazione
e che ho rimosso manualmente da synaptic

Grazie a tutti dell'aiuto

PS. non che conoscete un modo per trasformare l'aspetto di gimp in uno pi simile a photoshop? :lol: