PDA

Visualizza versione completa : Non si imposta la tastiera italiana.



lupass93
02-11-10, 17: 59
Ciao a tutti, ho effettuato un aggiornamente (comprendente anche Xorg naturalmente) che mi ha impostato la tastiera americana. Io allora come solitamente faccio ogni volta che c'e' un aggiornamento di questo genere reimposto la tastiera italiana modificando il file /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi settando it al posto di us: ecco il mio /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi

Only registered members can view code.
Ora fatto questo e riavviato non e' cambiato nulla allora ho modificato anche lo Xorg.conf aggiungendo la riga
Only registered members can view code. :
E lo Xorg.conf eccolo

Only registered members can view code.

Ma niente da fare... allora provo a toccare la configurazione di Gnome, andando in Sistema > Preferenze > Tastiera. Da qui passo su Disposizioni ed imposto Italia e rimuovo USA. Riavviando non cambia nulla.
Grazie in anticipo, Ciao!

pierino_89
02-11-10, 18: 02
Xorg non usa pi hal dalla versione 1.8.
Inoltre, dovresti usare evdev come driver per la tastiera. L'altro solo un fallback.


Only registered members can view code.

lupass93
02-11-10, 18: 05
Xorg non usa pi hal dalla versione 1.8.
Ok, quindi cosa devo toccare per impostare la tastiera italiana?

pierino_89
02-11-10, 18: 07
Beh, lo xorg.conf un passo, poi controllerei che non faccia cose strane gnome.

lupass93
02-11-10, 18: 17
Beh, lo xorg.conf un passo, poi controllerei che non faccia cose strane gnome.
[/CODE]
Gia' e' proprio Gnome che da problemi, infatti se vado su un'altra tty la tastiera e' italiana, e' con Gnome che non e' italiana. Provo, allora, a toccare qualche configurazione in Gnome.

pierino_89
02-11-10, 18: 33
la tty non segue le regole di x. Prova con un wm leggero.

lupass93
03-11-10, 13: 47
Ho risolto reimpostando in Sistema > Preferenze > Tastiera e poi Disposizioni.
Grazie. Ciao!