PDA

Visualizza versione completa : Firefox e ThunderBird non possono accedere a partizione in FAT.



Andy86
28-10-10, 18: 14
:bai

Si continua il problema alla fine di questa discussione (http://www.collectiontricks.it/forum/gnu-linux/Ct2453-dopo-pulizia-con-ubuntu-tweak-ubuntu-non-parte-piu-che-cavolo-ho-combinato/index2.html). Lascio ai mod decidere se spostare qui ciò che non c'entra di là.

In sostanza i programmi con FF e TB non riescono ad accedere ai file del profilo condivisi con win (sotto il quale tutto bene) presenti in una partizione FAT creata per l'occasione.

Con natilus è possibile vedere correttamente tutti i file presenti, ma FF e TB li danno per occupati.

Come già detto:



Non so se c'entra, ma natilus indica come root il proprietario di tutti i file e le cartelle nella protezione. :ohoh

Provando a dare 'chown -R', dice "funzione non permessa" su tutti i file. Il che mi sembra normale, visto che il fat non dovrebbe avere gestione di permessi.

Il file fs-tab attuale:


Only registered members can view code.-------------------------------------------------------------------------------------------------------------------------


comunque dai uno sguardo qui' (http://linux.collectiontricks.it/wiki/Lettura_e_scrittura_partizioni_NTFS) l' avevo scritto nel wiki di linux su p2pforum

Quell'articolo parla di ntfs. Vale lo stesso anche per FAT? cioè devo seguirla sostituendo il filesystem nei comandi? :m:

:thx

cydonia
28-10-10, 19: 07
va bene anche per il fat anzi teoricamente dovrebbe bastare umask=000
ogni comando al il suo man page,se vedi:

Only registered members can view code.la parte che interessa su il fs fat
..........................




(Note: fat is not a separate filesystem, but a common part of the msdos, umsdos and vfat filesystems.)
blocksize=512 / blocksize=1024 / blocksize=2048
Set blocksize (default 512).
uid=value and gid=value
Set the owner and group of all files. (Default: the uid and gid of the current process.)
umask=value
Set the umask (the bitmask of the permissions that are not present). The default is the umask of the current process. The value is given in octal.
dmask=value
Set the umask applied to directories only. The default is the umask of the current process. The value is given in octal.
fmask=value
Set the umask applied to regular files only. The default is the umask of the current process. The value is given in octal.
check=value
Three different levels of pickyness can be chosen:
r[elaxed]
Upper and lower case are accepted and equivalent, long name parts are truncated (e.g. verylongname.foobar becomes verylong.foo), leading and embedded spaces are accepted in each name part (name and extension).
n[ormal]
Like "relaxed", but many special characters (*, ?, <, spaces, etc.) are rejected. This is the default.
s[trict]
Like "normal", but names may not contain long parts and special characters that are sometimes used on Linux, but are not accepted by MS-DOS are rejected. (+, =, spaces, etc.)
codepage=value
Sets the codepage for converting to shortname characters on FAT and VFAT filesystems. By default, codepage 437 is used.
conv=b[inary] / conv=t[ext] / conv=a[uto]
The fat file system can perform CRLF<-->NL (MS-DOS text format to UNIX text format) conversion in the kernel. The following conversion modes are available:
binary
no translation is performed. This is the default.
text
CRLF<-->NL translation is performed on all files.
auto
CRLF<-->NL translation is performed on all files that don't have a "well-known binary" extension. The list of known extensions can be found at the beginning of fs/fat/misc.c (as of 2.0, the list is: exe, com, bin, app, sys, drv, ovl, ovr, obj, lib, dll, pif, arc, zip, lha, lzh, zoo, tar, z, arj, tz, taz, tzp, tpz, gz, tgz, deb, gif, bmp, tif, gl, jpg, pcx, tfm, vf, gf, pk, pxl, dvi).
Programs that do computed lseeks won't like in-kernel text conversion. Several people have had their data ruined by this translation. Beware!
For file systems mounted in binary mode, a conversion tool (fromdos/todos) is available.
cvf_format=module
Forces the driver to use the CVF (Compressed Volume File) module cvf_module instead of auto-detection. If the kernel supports kmod, the cvf_format=xxx option also controls on-demand CVF module loading.
cvf_option=option
Option passed to the CVF module.
debug
Turn on the debug flag. A version string and a list of file system parameters will be printed (these data are also printed if the parameters appear to be inconsistent).
fat=12 / fat=16 / fat=32
Specify a 12, 16 or 32 bit fat. This overrides the automatic FAT type detection routine. Use with caution!
iocharset=value
Character set to use for converting between 8 bit characters and 16 bit Unicode characters. The default is iso8859-1. Long filenames are stored on disk in Unicode format.
quiet
Turn on the quiet flag. Attempts to chown or chmod files do not return errors, although they fail. Use with caution!
sys_immutable, showexec, dots, nodots, dotsOK=[yes|no]



Various misguided attempts to force Unix or DOS conventions onto a FAT file system.

.................................................. ..........
scusa ho dovuto inserirlo cosi' seno' partiva la formattazione del testo
potresti anche inserire come parametri il gid e uid del tuo utente


Con natilus è possibile vedere correttamente tutti i file presenti, ma FF e TB li danno per occupati.

in che senso li da occupati?,che non ha i permessi di lettura e scrittura?
:bai:bai

Andy86
28-10-10, 19: 34
:bai

Sarebbe un elenco di opzioni da provare a mettere nel fstab? :ohoh

Ora il 'man mount' non te lo posso postare, perché devo restare sotto win.


in che senso li da occupati?,che non ha i permessi di lettura e scrittura?Penso di sì. In pratica fa come quando sono usati da un'altra istanza che non risponde:

http://support.mozilla.com/img/wiki_up/3b6ebd901b4ee9dc11be7fbb9ce4511a-1284479498-822-1.png

(immagine dal wiki di mozzilla, in ubuntu mi esce in inglese nonostante la localizzazione.)

Ho verificato per il file parent.lock, all'avvio di ubuntu non è presente.
E comunque il profilo viene caricato correttamente da win.
Non è un problema della condivisione, perché prima del blocco dell'altra discussione andava. :boh

:thx

cydonia
28-10-10, 20: 12
Sarebbe un elenco di opzioni da provare a mettere nel fstab?
sarebbe un'elenco di parametri che si possono inserire all'occorrenza nell'fstab o con il comando mount


Penso di sì. In pratica fa come quando sono usati da un'altra istanza che non risponde:
questo significa che c'e' un'altra istanza di firefox e che il profilo e' gia' in uso da quella
il file .parentlock che inizia con il punto e un file nascosto se c'e' e nella directory di .mozilla o .mozilla/firefox/nome.default(anche questa nascosta) nella tua home
con nautilus visualizza - (mostra file nascosti) o piu' semplicemente ctrl + h
prova anche a killare non da root firefox , ma se c'e' il parentlock questo non ha effetto

Only registered members can view code.:bai:bai

Andy86
28-10-10, 21: 04
:bai

È vero. Ora sono su windows e vedo la presenza del .parentlock nella dir del profilo di firefox (che nel mio caso è "part-fat/firefox/profiles/nome.default", in quanto, se non si è capito, condivisa tra i due sistemi. Il percorso si può settare con il comando "firefox -profilemanager" su linux o "firefox -p" su win), non sapevo che su ubuntu si chiamasse così... :ehmm

Ora lo elimino, poi quando accedo a ubuntu vedo se va. :sisi

Per la cronaca, dicendo:


fa come quando sono usati da un'altra istanza che non rispondeSottointendevo che istanze attive in questo caso non ce ne sono. :hap

:thx


AGGIORNAMENTO:

:bai

Dopo rimozione file .parentlock da entrambi i profili, firefox e tb, ancora lo stesso errore.

Però c'è un'altra cosa, non è più possibile usare il cestino sulla partizione 'fat': prima funzionava correttamente, ora dice "impossibile spostare il file pinco pallino nel cestino. Eliminare immediatamente?".

Devo continuare a cercare la soluzione in un problema di mozilla o mi metto a far prove con i mount elencati sopra?

:thx

NUOVO AGGIORNAMENTO:

In effetti la partizione fat non c'entrava nulla. FF e TB avevano semplicemente dimenticato il percorso associato al profilo (quando ho eliminato il vecchio non è apparsa la richiesta di eliminazione dei file, come se non ci fossero più). È bastato creare un profilo nuovo associando il giusto percorso e sono ripartiti.

:thx lo stesso.

cydonia
31-10-10, 12: 06
ma anvedi:bgg2 ,meglio cosi' vedo che incominci a districarti in questo nuovo mondo http://www.collectiontricks.it/forum/attachment.php?attachmentid=850&d=1288523066