PDA

Visualizza versione completa : Dopo pulizia con ubuntu-tweak, ubuntu non parte più. Che cavolo ho combinato?



Andy86
16-10-10, 14: 35
:bai

Sarà che ubuntu devo ancora imparare a conoscerlo bene, ma, pur potendolo usare poco, causa problema nat (http://www.collectiontricks.it/forum/gnu-linux/Ct2305-configurare-bridge-su-ubuntu-per-usare-il-pc-come-router.html), sono riuscito a combinarla davvero grossa... :ehmm

Dopo aggiornamento del kernel (penso collettivo :ohoh), volevo togliere le voci vecchie dal grub, ma il grub.cfg non mi offriva più la possibilità di farlo (altro aggiornamento? :boh), così mi sono messo alla ricerca di un programma, ed ho trovato ubuntu-tweak.

Con esso ho fatto un po' di pulizie ed ho personalizzato un po' di roba (anche se non ricordo esattamente cosa... :triste).

Risultato? All'avvio niente più ubuntu. :ops:

Il grub è ancora lì con le sue belle 7 voci, anche se ero convinto di aver usato bene la modalità "pulizia kernel", ma ubuntu non parte (con nessuno dei due kernel e nemmeno in safe-boot) rimane lo schermo nero col trattino bianco (come quando si blocca una sessione dos di windows) e il disco non lavora più (lo si vede dalla lucina rossa sul case). :wall

Se riavvio a forza fa il controllo, si riavvia, e sono ancora da capo.

Il mio timore è di aver messo qualche impostazione alla http://www.fruttasnack.eu/it/images/cale/cavolo.jpg in UT, ma ora come faccio (visto che non posso nemmeno accedere all'installazione)?

Ditemi che non devo "reinstallare"... :forgive (anche perché nel cd di Ubuntu non c'è il ripristino :cry3).

:thx

K.a.o.s.
16-10-10, 15: 11
Se riavvio a forza fa il controllo, si riavvia, e sono ancora da capo.
Grub lancia semplicemente il kernel e carica l'initrd se c'è (ovvero se non hai compilato un kernel tu rimuovendo questa opzione). Se dici che fa il controllo, allora grub non dovrebbe c'entrare, anche perché lo fa fsck dopo il lancio di init.

Prova però lo stesso a ripristinare grub: AmministrazioneSistema/Grub/Ripristino - Wiki di ubuntu-it (http://wiki.ubuntu-it.org/AmministrazioneSistema/Grub/Ripristino)

Ditemi che non devo "reinstallare"... (anche perché nel cd di Ubuntu non c'è il ripristino ).
Tecnicamente quasi se non sempre si può evitare, anche se non si avvia. Basta entrare in chroot nel sistema da una live e sistemarlo da lì :eye.

Andy86
16-10-10, 15: 26
Se dici che fa il controllo, allora grub non dovrebbe c'entrare, anche perché lo fa fsck dopo il lancio di init.Penso che il grub sia a posto, anche perché windows, la cui voce è nel grub parte e quando faccio il safeboot mi mostra a schermo una serie di linee, che scorrono talmente veloci da non riuscire a leggerle (prima di arrivare al trattino bianco o al controllo). Provo il ripristino lo stesso? :ohoh


Basta entrare in chroot nel sistema da una live e sistemarlo da lì :eye.Sapendo cosa sistemare... :ehmm

K.a.o.s.
16-10-10, 15: 46
Il ripristino era solo per escludere un problema con grub, comunque non dovrebbe essere necessario. Anche se lo fai non dovrebbe impedire Win 7 di avviarsi :eye.

In ogni caso, avvia una live e prova così:
sudo -s
mkdir /mnt/ubuntu
mount /dev/sdaX /mnt/ubuntu # monta insomma la tua partizione con ubuntu e nel caso anche la /boot se è separata
cd /mnt/ubuntu
mount -t proc none proc
mount -o bind /dev dev
mount -o bind /sys sys
chroot /mnt/ubuntu
aptitude reinstall linux-image-2.6.32-21-generic

Dovrebbe anche riaggiornare Grub. Nel caso non funzioni... hai per caso una scheda video Intel?

ginalfa
16-10-10, 17: 57
Penso anch'io che tu abbia sballato il kernel.
Per il futuro usa startup-manager per ripulire le voci del grub, anche se con grub2 le sue funzioni sono limitate.
Se si tratta solo di eliminare vecchi kernel che non ti servono basta rimovere i rispettivi pacchetti linux-image e linux-header da synaptic e recuperi anche un bel po' di spazio.
buon chroot....:bgg2
Qunto alle sk video se hai la 10.10 sappi che con le sk nvidia ci possono essere problemi con i driver proprietari. In particolari la 96 e la 173. La common funzia.

Andy86
16-10-10, 18: 17
Win 7

Veramente ho win xp. :boh


linux-image-2.6.32-21-generic
A questa parte dovevo sostituire il mio kernel, vero?

Comunque ora esce l'immagine con la scritta ubuntu e si blocca sui pallini scorrevoli.

Se faccio il safeboot si blocca con questi messaggi:

http://img26.imageshack.us/img26/2481/16102010014.jpg


hai per caso una scheda video Intel?

NO. Nvidia Geforce 9600gt.

------------------------------

Un'altra cosa, ho visto che update-grub trova i kernel da alcuni file chiamati con il nome della versione, perciò ho momentaneamente spostato quelli della vecchia versione nel cestino per sfoltire la lista. Ho fatto bene?

:thx

ginalfa
16-10-10, 18: 21
Quanto alle sk video se hai la 10.10 sappi che con le sk nvidia ci possono essere problemi con i driver proprietari. In particolari la 96 e la 173. La common funzia.
Se usi il 173 non ti partirà mai e si fermerà sui pallini. Cmq se non sbaglio quella sk usa la common.
Il punto è che il modulo del kernel deve essere compilato per quella versione di kernel che hai in uso.
Quello delle sk video sulla 10.10 è un problema che si risolve facendo partire in modalità grafica ridotta e disattivando i driver restricted, ma vedo che non ci arrivi nemmeno.

Andy86
16-10-10, 19: 03
:bai

Scusa gino, il tuo post #5 non lo avevo proprio visto. Comunque i driver proprietari nvidia li ho sempre usati per abilitare gli effetti ed hanno sempre funzionato (ne abbiamo anche parlato in un'altra discussione, per un mancato riconoscimento del monitor dovuto ad un problema hardware).


pacchetti linux-image e linux-header da synaptic e recuperi anche un bel po' di spazio.Saperlo prima avrei fatto così. Sta' cosa non l'ho trovata da nessuna parte.
Pensi che ora possa far partire il synaptic dal chroot col sistema detto da Kaos e reinstallare il kernel che non va? :ohoh


Il punto è che il modulo del kernel deve essere compilato per quella versione di kernel che hai in uso.E come faccio? :ehmm

pierino_89
16-10-10, 23: 34
Quell'errore non parla di moduli nvidia, kernel o grub. Parla di filesystem scassato. Proporrei di fare un bel fsck da live.

K.a.o.s.
17-10-10, 01: 19
O è il filesystem scassato, o qualche problema di permessi :shock
In genere il filesystem scassato dovrebbe però dire I/O error...

Il fsck ovviamente ci sta :eye

pierino_89
17-10-10, 02: 12
O è il filesystem scassato, o qualche problema di permessi :shock
Attento: il permission denied dovrebbe essere dato dal fatto che al fallimento di fsck la root viene rimontata in read-only (opzione di fstab).


In genere il filesystem scassato dovrebbe però dire I/O error...
No, I/O error è in caso di disco spanato, per il file system da solo non mi pare.

K.a.o.s.
17-10-10, 11: 00
No, I/O error è in caso di disco spanato, per il file system da solo non mi pare.
No no di questo sono sicuro :hap. Avevo avuto questi errori quando avevo scassato il filesystem e poi successivamente ho fatto un controllo per vedere se c'erano settori danneggiati.

Andy86
17-10-10, 11: 40
:bai


Only registered members can view code.Sembra pulito.

Ora all'avvio (dopo fsck automatico e riavvio) esce così:

804

ubuntu-tweak da chroot non parte:


Only registered members can view code.


:thx

K.a.o.s.
17-10-10, 12: 16
Eh no, con chroot non fai partire applicazioni grafiche, per quello devi usare e configurare schroot.

Prova a fargli reinstallare gli initscripts, plymouth e a passare a vesa per l'avvio. Non so se basta ancora modificare lo xorg.conf.

Andy86
17-10-10, 12: 24
Proverò. Ora sono costretto a restare su win per nattare il portatile. :triste

Comunque nel frattempo ho provato a eseguire synaptic da chroot (è grafica ed è partita :m:) e reinstallare il kernel da lì. L'errore appare mutato, ma sinceramente mi sembra lo stesso espresso diversamente:

805

:boh

pierino_89
17-10-10, 13: 34
Ho paura che tu abbia fatto qualche casino con udev. In ogni caso, cerca di lavorare da riga di comando perché è più sicuro. Le apps grafiche dipendono quasi tutte dalla sessione di dbus, e potrebbero crashare senza preavviso lasciandoti magari con dei pacchetti semiconfigurati o danneggiati.

cydonia
17-10-10, 22: 58
Ho paura che tu abbia fatto qualche casino con udev

lo credo anchio,visto anche l'errore nell'immagine del primo post
prova una cosa con una live cd o in chroot apri l'fstab che sta in /etc/fstab,togli gli UUID esempio
da cosi':

Only registered members can view code.a cosi':

Only registered members can view code.
:bai:bai

pierino_89
17-10-10, 23: 02
Io toglierei anche errors=remount-ro, che è relativamente poco utile e fa più casino che altro.

ginalfa
18-10-10, 10: 01
Sì, per ora i driver nvidia li lascerei stare. Infatti:

ma vedo che non ci arrivi nemmeno

Andy86
18-10-10, 21: 16
:bai

Allora, reinstallati initscripts e plymouth, vesa non ho capito cos'è e non so cosa devo fare.

Quando ho provato ad aprire gedit per modificare fstab mi è apparsa una sfilza interminabile di errori tutti uguali:

Only registered members can view code.

Alla fine si è aperto, ma non è esattamente ciò che mi aspettavo:


Only registered members can view code.

:boh

:thx

pierino_89
18-10-10, 22: 09
:bai

Allora, reinstallati initscripts e plymouth, vesa non ho capito cos'è e non so cosa devo fare.
Veramente avevamo detto udev... :tong2



Quando ho provato ad aprire gedit per modificare fstab mi è apparsa una sfilza interminabile di errori tutti uguali:
E come te lo dobbiamo dire che le app grafiche da chroot non funzionano o funzionano male, e che dunque non bisognerebbe usarle? :tong2



Alla fine si è aperto, ma non è esattamente ciò che mi aspettavo:


Only registered members can view code.

:boh

:thx
Beh, tanto per cominciare bisognerebbe capire che ci fa la root in ext2 e perché monta con opzione users, dopodiché dovresti fare
Only registered members can view code. per capire i dev corrispondenti ai rispettivi uuid.
A parte tutto, quel fstab è veramente strambo. Forse salvarsi le config modificate in etc, la home e la lista dei pacchetti installati esplicitamente non sarebbe male ripartire da capo, una volta capito il problema...

Andy86
18-10-10, 22: 37
Veramente avevamo detto udev...Kaos aveva detto:


Prova a fargli reinstallare gli initscripts, plymouth e a passare a vesa per l'avvio.



E come te lo dobbiamo direAh, già. :ehmm Ma allora come lo modifico quel file? schroot non si installa... :boh


Beh, tanto per cominciare bisognerebbe capire che ci fa la root in ext2 e perché monta con opzione users, dopodiché dovresti fare
Only registered members can view code. per capire i dev corrispondenti ai rispettivi uuid.
Only registered members can view code.In effetti una volta non era così. Potrebbe essere stato un programma che ho usato un po' di tempo fa per settare il motaggio delle partizioni all'avvio? (non ricordo come si chiama però...).

:thx

K.a.o.s.
18-10-10, 22: 44
Kaos aveva detto:
Mi assumo la responsabilità :ghgh, comunque c'è da dire che era riferito al primo screen (dove udev compare solo dopo).

Ah, già. Ma allora come lo modifico quel file? schroot non si installa...
Usa nano oppure, più avanzato e complesso, vim.
sudo nano /etc/fstab

pierino_89
18-10-10, 22: 46
Beh, vi e nano sono degli ottimi editor. Ti consiglio vivamente il secondo, anche perché è già installato.
Dopodiché, avendo appurato che la root sta su sda1, direi che come opzioni mettiamo un bel "defaults,relatime" invece che users e magari controlliamo se invece che ext2 è per caso una ext4, il che spiegherebbe molte cose.

Consiglio vivissimo: diffida di tutti i simpatici tools automatici. I file di configurazione hanno tutti una sintassi relativamente semplice, per quel poco che c'è da farci sopra in un sistema desktop non vale la pena andare a spanarli con qualche aggeggino di dubbia affidabilità.

Andy86
19-10-10, 13: 43
:bai

Modificato il file fstab secondo vostre istruzioni:

Only registered members can view code. Ma non lo digerisce:

813

:ohoh :boh

pierino_89
19-10-10, 14: 20
eh magari però devi dirlo che monti / su /dev/sda1 :tong2

/dev/sda1 / ext2 default,relatime 0 1

cydonia
19-10-10, 18: 34
sei sicuro che sia in ext2?
se sei in chroot
posta:

Only registered members can view code.( l come livorno)
oppure

Only registered members can view code.
Only registered members can view code.:bai

Andy86
19-10-10, 21: 46
:bai

Quando posso provo. Comunque se non sbaglio quando l'ho installato ho messo ext2 perché risultava l'unico stabile. :ohoh

Oggi ho provato ad aggiungere il punto di mount come detto da ginalfa. Nuova configurazione, nuovo errore:

815

Il disco è a posto. Avevo fatto il test ufficiale samsung appena due mesi fa, e lasciato l'unico badblock solo soletto in mezzo ad un spazietto non partizionato.

:thx

cydonia
19-10-10, 22: 35
Comunque se non sbaglio quando l'ho installato ho messo ext2 perché risultava l'unico stabile??, in che senso?
quando puoi posta l'output di quel comando
e anche di questo:

Only registered members can view code.ma prima prova a riavviare il sistema decommentando questa stringa dalla configurazione del grub2 (se lo utilizzi)

Only registered members can view code.
Only registered members can view code.togli il cancelletto e salva
poi:

Only registered members can view code.poi riavvia
:bai

Andy86
19-10-10, 23: 08
parted -l:


Only registered members can view code.ls -la /etc/udev/rules.d:


Only registered members can view code.
??, in che senso?Cercando su google per vedere la differenza e quello che era meglio ho letto che ext4 è ancora troppo giovane e pieno di bug. Perché invece scelsi ext2 invece che ext3 non lo ricordo, forse lessi qualcosa, ma non so... :ehmm

Grub modificato come sopra, riavvio e vedo (ora sto scrivendo dalla live).

:thx

EDIT 23.28:
Rieccomi... ...sotto windows.
Anche dopo la modifica a grub nulla di fatto, è ritornato l'errore di prima (l'ultimo postato) ed in coda si sono aggiunti quelli di udev (impossibile leggere bla... /udev/ bla... bla... bla...).

buona :notte:

pierino_89
19-10-10, 23: 33
Ext3 è stabilissimo, c'è da anni e anni... Praticamente è ext2 con l'aggiunta del journaling (tant'è che puoi montare ext3 come ext2 e viceversa)

cydonia
20-10-10, 01: 07
premesso,quelle due regole in udev non dovrebbero esserci
z80_user.rules
40-permissions.rules
e comunque non dovrebbero precludere l'avvio
1) edita con nano z80_user.rules se e' vuoto aggiungi un # al suo interno e salva
2) edita 40-permissions.rules e sostituisci tutte le occorrenze SYSFS con ATTR e BUS con SUBSYSTEM,dovrebbero essere risolti gli errori di udev
3) nell'fstab commenta tutti i device, meno l'ext2
posta anche l'output di dmesg
:bai:bai

Andy86
21-10-10, 17: 22
:bai

Ma se non ci devono essere perché non rimuoverle? :boh

Comunque tutto fatto.

Ecco l'output di dmesg direttamente dalla live:


Only registered members can view code.Ora riavvio e vedo se parte... http://www.ieson.com/immagini/dita_incrociate.gif

----------------------------------------------
Niente da fare. :cry3
Nuovo errore:
822
:thx

cydonia
21-10-10, 18: 44
riposta come e' adesso il dmesg
vediamo se devi dare:

Only registered members can view code.ma prima togli dall'fstab defaults(non default) e relatime e rimetti users e riprova
e' solo quello l'errore?

:bai

Andy86
21-10-10, 19: 16
:bai

il dmesg l'ho eseguito dopo aver fatto tutte le modifiche. L'averlo fatto prima di tentare il riavvio cambia qualcosa?

Il "e2fsck" ho già provato a darlo più di una volta, anche senza "e2", restituisce sempre "clean".

Per il resto adesso non posso provare. Quando provo faccio sapere.

:thx

cydonia
21-10-10, 20: 59
risposta queste domande:

Ma se non ci devono essere perché non rimuoverle? :boh
il dmesg l'ho eseguito dopo aver fatto tutte le modifiche. L'averlo fatto prima di tentare il riavvio cambia qualcosa?rules:
quelle due regole in un'installazione pulita di lucid non esistono,z80_user.rules viene creato con l'installazione di un programma (pysdm) serve per creare i punti di mount senza mettere mano all'fstab,permettendo di creare delle regole in udev,40-permissions.rules non e' piu' usato dalla versione di ubuntu (hardy)(udev),come hai potuto notare ti ho fatto modificare delle funzioni non piu' usate dalla versione attuale di udev.
dmesg:
cambia perche' il dmesg in parole povere non fa altro che farti visualizzare le periferiche (ed eventuali problemi) caricate all'avvio dal kernel
:bai

Andy86
21-10-10, 21: 06
pysdm

Ecco come si chiamava... è il programma che volevo dire prima e non mi veniva il nome.


non e' piu' usato dalla versione di ubuntu (hardy)

:m: Allora è per questo che è letteralmente sparito dal menù avvio? E successo in seguito all'aggiornamento?

E quindi forse il problema non è stato UT ma un'incompatibilità con l'aggiornamento?
Perché con pysdm sono andato avanti parecchio senza problemi. :sisi

:thx

cydonia
21-10-10, 21: 29
Allora è per questo che è letteralmente sparito dal menù avvio? E successo in seguito all'aggiornamento?
probabilmente,hai fatto l'aggiornamento da hardy a lucid senza passare prima con le versione intermedie?
comunque sconsiglio di usare programmi automatici che mettono mano all'fstab,puoi comunque reinstallarlo ma devi comunque mettere mano a quel file anche se ,come ho gia' detto non pregiudica l'avvio del sistema.i problemi al filesystem possono essere di varia natura,corrotto, fstab ,comunque non e' stat una buona scelta l'ext2
:bai

Andy86
21-10-10, 21: 52
hai fatto l'aggiornamento da hardy a lucid senza passare prima con le versione intermedie?

E che ne so. Lascio fare tutto a gestore aggiornamenti. :sisi

Ecco il nuovo dmesg:


Only registered members can view code.

Ora riavvio e vedo col nuovo fstab.

cydonia
21-10-10, 22: 01
gli upgrade del sistema non li fa in automatico,devi sceglierlo esplicitamente:hap

Andy86
21-10-10, 22: 44
No, Niente aggiornamenti manuali. Nuovo errore:

826

cydonia
21-10-10, 23: 01
si va a tentativi,togli users e metti defaults

Andy86
22-10-10, 15: 49
:bai

Neanche. :triste

830

Il risultato di fsck è sempre lo stesso: "clean".
Errore identico in avvio dopo averlo eseguito.

cydonia
23-10-10, 08: 22
utilizza non in chroot,ma con la live o in recovery mode a partizione smontata

Only registered members can view code. calcola anche di usare badbocks
:bai

Andy86
24-10-10, 10: 58
:bai


calcola anche di usare badbocksSarebbe ciò che fa quel comando, o è un'altra operazione che devo fare io?

Questo è l'output col -y:


Only registered members can view code.ps: alla recovery mode non ci arrivo, i messaggi che posto li prendo appunto da lì, altrimenti in modalità normale vedrei solo lo splash che carica all'infinito. :triste

:thx

EDIT:

Fatto il controllo col -c (era questo che intendevi?)


Only registered members can view code.

Ora provo a riavviare.

cydonia
24-10-10, 11: 31
con la live cd dai:
sudo e2fsck -pf /dev/sda1
e poi
sudo e2fsck -y /dev/sda1



altrimenti in modalità normale vedrei solo lo splash che carica all'infinito
quando arrivi allo splash premi f2 per abilitare il text mode ,per vedere cosa dice

Andy86
24-10-10, 11: 42
:bai

Dopo riavvio appena menzionato un post fa, accesso al sistema eseguito correttamente. :gogo

Ho provveduto subito a rimuovere ubuntu-tweak. :bsh

Ora devo eseguire lo stesso i comandi che dici? :ohoh

Nell'fstab ora posso rimuovere i commenti in modo che mi rimonti le altri partizioni all'avvio?
O devo effettuare altre modifiche?

:thx

cydonia
24-10-10, 11: 49
1)comandi:no,non servono piu'.
2) non credo sia colpa di quel programma
3) togli i commenti all'fstab
4) cambia fs in favore di ext3

Andy86
24-10-10, 11: 56
4) come si fa?

:thx

cydonia
24-10-10, 12: 02
ad es.dai uno sguardo qui' (http://ubuntrucchi.wordpress.com/2009/01/05/convertire-una-partizione-da-ext2-a-ext3/),ma prima di fare questo,con eventualmente backup del caso.
credo devi commentare anche il parametro al grub che ti ho detto di modificare

Andy86
24-10-10, 12: 44
l'fstab de-commentato non va bene:

834

:triste

----------------------------------------------------------
Prima di riavviare ho provato la guida che mi hai linkato, ma dice che mount è occupato.
(Ovviamente proverò dalla live intanto che sistemo l'fstab).

cydonia
24-10-10, 12: 57
fammi vedere l'fstab


ma dice che mount è occupato.

devi farlo a partizione smontata,con una live,ma prima fstab

Andy86
24-10-10, 13: 42
L'fstab è in sostanza quello che ho già postato con le modifiche suggerite, quindi:


Only registered members can view code.

cydonia
24-10-10, 14: 24
Only registered members can view code.l'UUID lo sistemiamo dopo aver fatto il tutto,se hai il floppy disk (fd0) e lo utilizzi decommenta
:bai

Andy86
24-10-10, 19: 40
:bai

Conversione FS e aggiornamento FsTab fatti.

Ubuntu ora parte, solo dev'esserci qualche problema a comunicare con la partizione condivisa con win, quella in FAT, firefox infatti non riesce ad usare il profilo salvato in tale partizione. :boh

:thx

cydonia
24-10-10, 19: 59
gioca un po con l'fstab:hap

Only registered members can view code.con:

Only registered members can view code.
Only registered members can view code.
Only registered members can view code.:bai:bai

Andy86
27-10-10, 19: 33
:bai

Niente neache così. Natilus vede correttamente tutta sda3, FF e TB no. :boh

Non so se c'entra, ma natilus indica come root il proprietario di tutti i file e le cartelle nella protezione. :ohoh

Provando a dare 'chown -R', dice "funzione non permessa" su tutti i file. Il che mi sembra normale, visto che il fat non dovrebbe avere gestione di permessi.

:thx

pierino_89
27-10-10, 20: 27
Propongo di aprire un nuovo thread per la discussione, visto che l'argomento sta un po' divagando...

cydonia
28-10-10, 08: 40
Provando a dare 'chown -R', dice "funzione non permessa" su tutti i file. Il che mi sembra normale, visto che il fat non dovrebbe avere gestione di permessi.

il discorso e' che non segue lo standard Posix,microsoft doveva sopperire a questo problema con il Fs ntfs ma e' stato un fallimento visto la costanza a seguire gli standard (suoi):ghgh.Quoto @pierino_89 nell'aprire un'altra discussione ,perche' si e' esaurita la problematica iniziale,comunque dai uno sguardo qui' (http://linux.collectiontricks.it/wiki/Lettura_e_scrittura_partizioni_NTFS) l' avevo scritto nel wiki di linux su p2pforum.se continui ad avere problemi apri una nuova discussione.
:bai