PDA

Visualizza versione completa : Configurare bridge su ubuntu, per usare il pc come router.



Andy86
19-09-10, 14: 13
Sempre io, coi miei soliti problemi da semi-profano.
Questa è la mia configurazione lan in breve:
679
Ok, avete capito che non sono disegnatore... :triste
Ovviamente vuole essere una soluzione economico-alternativa all'acquisto di un router. :sisi

Configurazione ovviamente funzionante su windows, ma lui lo conosco abbastanza bene da piegarlo al mio volere; però, purtroppo, questa affermazione non vale per ubuntu.

Poiché ubuntu non mi permette di avviare due connessioni contemporaneamente, quindi a nulla vale la configurazione fatta a mano da gestione connessioni, connetti una cade l'altra... :triste

Ho provato quindi a seguire questa guida (http://wiki.ubuntu-it.org/Router), che mi fa creare una terza connessione che le comprende tute e due, ma eseguendo l'ultimo test indicato mi ritorna l'errore:

Only registered members can view code.

Ho letto che la pendrive potrebbe non supportare la mastermode, in effetti provando a commentare la riga:


Only registered members can view code.

L'errore sparisce. Ma la connessione ancora non va, non solo, non va neanche la connessione normale (eth1).

Non so più che fare. :ehmm

:thx

pierino_89
19-09-10, 14: 55
Allora, mi sembra di aver capito che hai pc1 con una ethernet collegata al router e una wireless in master che natta il portatile sul router.
Onestamente non ho idea di come si faccia a creare una rete wireless, né se il gestore delle connessioni lo faccia. Ma sicuramente posso dirti che non è in grado di gestire i bridge, quindi probabilmente ti conviene disattivarlo e gestire a mano la questione (come nella guida).

Conta poi che nella guida si parla di 3 interfacce, mentre tu ne hai solo due. Quindi devi fare una cosa tipo:


Only registered members can view code.

Però prima voglio vedere ifconfig -a per capire a che punto stiamo.

Andy86
19-09-10, 16: 10
Sì, hai capito bene, ecco l'output di ifconfig:


Only registered members can view code.

NB: è fatto dopo aver ripristinato il backup effettuato all'inizio della guida, altrimenti non potevo connettermi.

NB2: La scheda a cui è collegato l'hag fw è eth1; la prima, che fisicamente si trova più in basso, è attualmente inutilizzata.




nella guida si parla di 3 interfacce

A me sembra che sia semplicemente divisa per casi, quindi al punto 4.4 ho seguito solo il sottopunto 3; forse per quello che non andava più nulla.. :ohoh




probabilmente ti conviene disattivarlo

E come si fa? :ehmm


:thx & :bai

pierino_89
20-09-10, 00: 57
NB: è fatto dopo aver ripristinato il backup effettuato all'inizio della guida, altrimenti non potevo connettermi.
Ok, allora vediamo di andare per gradi in modo da non ripetere la cosa.




A me sembra che sia semplicemente divisa per casi, quindi al punto 4.4 ho seguito solo il sottopunto 3; forse per quello che non andava più nulla.. :ohoh

Eh no, la guida ne usa vistosamente 3 :tong2 una eth e una wlan per la intranet e l'altra eth praticamente corrisponde al cavo telefonico.



E come si fa? :ehmm

:thx & :bai
Beh, puoi disinstallarlo, disattivare il servizio (mi pare che bum te lo faccia fare graficamente) oppure dirgli di farsi gli affaracci suoi e non gestire quelle due interfacce. Comunque ci pensiamo dopo.

Adesso facciamo (da root):
- un bridge: brctl addbr br0
- scegliamo le interfacce da collegare con il bridge: brctl addif br0 eth1; brctl addif br0 wlan0
- tiriamo giù la connessione ethernet: ifdown eth1 , oppure ifconfig eth1 down se l'altro dà errore
- connettiamo il bridge: dhclient br0
A questo punto dovresti essere in grado di navigare, e dovresti vedere con ifconfig che eth1 non ha un ip ma trasmette/riceve e che l'ip della rete locale ce l'ha br0.
Dopodiché cercheremo di far andare la wlan in master mode.

Andy86
20-09-10, 14: 12
:bai, dopo aver effettuato tutte le operazioni da te descritte (alla seconda riga ho fatto la seconda cosa, la prima dava "ignored unknow eth1") mi sono ritrovato ancora senza connessione, ho provato anche a rialzarla con "ifconfig eth1 up", ma non c'era verso di connettersi.

Questo è l'output dell'ultimo comando:


Only registered members can view code.

E questo è ifconfig:

Only registered members can view code.

Un'altra cosa: poi come setto l'ip giusto per poter vedere pc1 da pc2?

Su pc2 c'è XP, l'ip è settato a mano su 192.168.0.2, mentre il gateway su 192.168.0.1 (che sarebbe l'ip della pendrive wireless sul pc1) e il nome rete su "casa".

Su windows devo connettere entrambe (il primo che lo fa si mette in attesa, l'altro si connette) su ubuntu come faccio a dire "cercalo e connettiti"?

Da "gestione connessioni" lo vedeva e bastava cliccarci sopra, ma non supportando il bridge si staccava eth1...

:boh

:thx & :bai

pierino_89
20-09-10, 15: 00
Devi tirare giù eth1 per poterla aggiungere al bridge, e se non aggiungi eth1 al bridge non può prendere l'indirizzo da dhcp.
L'ip non devi settarlo, con il bridge dovremmo riuscire a far passare il dhcp direttamente.

Andy86
20-09-10, 19: 22
Devi tirare giù eth1 per poterla aggiungere al bridge

l'ho fatto, ho fatto tutti i comandi che mi hai messo prima. il comando up l'ho fatto dopo, perché non funzionava.


L'ip non devi settarlo, con il bridge dovremmo riuscire a far passare il dhcp direttamente.

Vuol dire che poi devo settare la wireless sul portatile come "ottieni indirizzo ip automaticamente"?

Non va poi così bene, perché potrebbe capitare di essere connessi una volta sotto ubuntu e una volta sotto windows. :sisi

:bai

pierino_89
20-09-10, 20: 14
l'ho fatto, ho fatto tutti i comandi che mi hai messo prima. il comando up l'ho fatto dopo, perché non funzionava.
Ok, allora inizia con un service NetworkManager stop e poi ifdown eth1 e ifconfig eth1 down in sequenza. Poi riprova ad aggiungere eth1 a br0.



Vuol dire che poi devo settare la wireless sul portatile come "ottieni indirizzo ip automaticamente"?

Non va poi così bene, perché potrebbe capitare di essere connessi una volta sotto ubuntu e una volta sotto windows. :sisi

:bai
Non ho detto che tu debba per forza usare il dhcp, ho detto che puoi usarlo :tong2

In ogni caso, deve essere il portatile a collegarsi al fisso (tu facevi il viceversa?)

Andy86
23-09-10, 14: 47
:bai

se do service NetworkManager stop ottengo:


Only registered members can view code.Per ragionamento ho guardato nel system-monitor, non c'è alcun processo con quel nome.



tu facevi il viceversa?No. Faccio da entrambe. Se connetto solo il portatile (da win), questo si mette in attesa di connessione (dicendo che il fisso non è connesso), viceversa se connetto prima il fisso.

Non so se ubuntu "ragiona" in modo un po' diverso. :ehmm

Comunque la mia domanda era perché mi hai detto di non settare l'ip. A me serve avere un ip uguale sia sotto win che sotto ubuntu, in modo da non dover continuamente modificare le impostazioni del portatile (che, ricordo, ha solo win xp).

:thx


AGGIORNAMENTO:

Ho trovato un alternativa al network manager che dovrebbe permettere il bridge, tal wcid, ma quando da "reti" scelgo "crea rete ad hoc" imposto l'ssid, ip, attivo la condivisione della rete internet e premo OK, la connessione non viene creata (cioè nell'elenco non la vedo...).

Ma che è?!?! Una congiura?!?! :wall

:bai

Andy86
27-10-10, 20: 19
:bai

Tu e la tua wireless in master. :furious

Ho risolto il problema di wicd dando:


Only registered members can view code.

:hap

Andy86
29-10-10, 23: 56
:bai

Ancora nulla da fare con la condivisione della rete. Penso sia un problema di compatibilità di "zero wireless configuration", perché ora, nonostante veda e agganci la rete creata da ubuntu, non riconosce la cifratura, cioè vede la rete come sprotetta anche se ho messo la wep. (Comunque non esce su internet neanche se non metto la protezione).

Che dite? Mi consigliate un'alternativa a 'zero' o abbandono wicd? :boh

:thx

pierino_89
30-10-10, 00: 29
Te l'ho già detto: è una cosa che dovresti gestire a mano, non con un tool bello pronto. Quello che vuoi fare esula dai loro compiti.
Sotto con iptables e ifconfig :tong2

Andy86
30-10-10, 13: 59
:bai

Quello che vuoi fare esula dai loro compiti.

Quello che dici mi lascia basito. Perché fanno i tool se poi non funzionano neanche sulle cose base? :boh

Comunque OK, mi studio un po' i comandi di "interfaces", tanto dimestichezza con l'informatica ne ho e credo che alla fine me la caverò. Anzi, potrebbe anche essere divertente... :ohoh :ehmm

Tornando seri:

1. Non mi è chiaro che cosa cambia tra dare i comandi con if/iwconfig e scriverli nel file "interfaces". Forse un modo per fare prove? :m:

2. Poiché la penna wireless non è sempre attaccata al pc (quando non serve la stacco, altrimenti scalda per niente), devo rifare tutta la connessione a mano ogni volta?

3. Provando i comandi che hai messo sopra non navigo più finché non do dhclient eth1. Cosa sbaglio?

4. Quella bozza di interfaces che hai messo all'inizio è una prova che devo fare? :ohoh

5. Una volta modificato interfaces, c'è un comando da dare, bisogna riavviare o va da solo?

pierino_89
30-10-10, 14: 23
:bai
Quello che dici mi lascia basito. Perché fanno i tool se poi non funzionano neanche sulle cose base? :bohBeh no, su quel che devono fare funzionano benissimo, ma non puoi pretendere che gestiscano quello che vuoi fare. Per loro natura quando qualcosa va a turbare il comportamento dell'interfaccia che stanno gestendo, o cercano di riportarla allo status da loro definito, o la tirano giù, o smettono di gestirla. O tutte le cose assieme :ghgh



Comunque OK, mi studio un po' i comandi di "interfaces", tanto dimestichezza con l'informatica ne ho e credo che alla fine me la caverò. Anzi, potrebbe anche essere divertente... :ohoh :ehmm

Ma si, alla fine il file di interfaces sono 4 comandi in croce... Se non vuoi smattare con i bridge puoi fare in modo che salgano le due interfacce e poi nattare il traffico con iptables.
Dipende cosa poi devi fare, ovviamente.



Tornando seri:

1. Non mi è chiaro che cosa cambia tra dare i comandi con if/iwconfig e scriverli nel file "interfaces". Forse un modo per fare prove? :m:

Il file "interfaces" usa un linguaggio più chiaro per l'utente, ma poi di fatto quando viene letto viene ritradotto in direttive per ifconfig/route/iwconfig/wpa_supplicant o anche iproute2 se c'è. È una cosa solo delle debian based, e viene applicata ad ogni riavvio (servizio networking).
Usando i comandi direttamente invece le modifiche sono temporanee, perché al riavvio le interfacce sono non configurate, poi viene letto il file di interfaces e allora te le trovi settate.



2. Poiché la penna wireless non è sempre attaccata al pc (quando non serve la stacco, altrimenti scalda per niente), devo rifare tutta la connessione a mano ogni volta?

Se usi ifconfig e compari, ogni volta che la periferica va offline (a mano o per altri motivi) deve essere riconfigurata da capo. Per mantenere i settaggi devi dichiararla nell'interfaces, poi nello stesso abiliti l'hotplug oppure dai ifup nomeinterfaccia quando vuoi configurarla.



3. Provando i comandi che hai messo sopra non navigo più finché non do dhclient eth1. Cosa sbaglio?

4. Quella bozza di interfaces che hai messo all'inizio è una prova che devo fare? :ohoh

Non mi ricordo manco più cosa abbiamo detto ormai :triste
Se non hai bisogno di aprire porte in ascolto all'esterno, che ne diresti di ripartire con il NAT al posto del bridge?



5. Una volta modificato interfaces, c'è un comando da dare, bisogna riavviare o va da solo?
Molti modi.
Riavviare il servizio networking
ifdown -a && ifup -a
ifdown nomeinterfaccia && ifup nomeinterfaccia
Riavviare :bgg2

Andy86
30-10-10, 14: 54
che ne diresti di ripartire con il NAT al posto del bridge?Che cosa cambia? Comunque per nattare il portatile sull'hag devo creare un ponte tra la wlan0 ed eth1, no? :m:


Non mi ricordo manco più cosa abbiamo detto ormai :tristeÈ ancora tutto scritto. :bgg2


Dipende cosa poi devi fare, ovviamente.Lo scopo non è cambiato: condivisione della connessione internet con il portatile in wireless (e magari anche della stampante e di qualche cartella).


:thx

pierino_89
30-10-10, 15: 26
Che cosa cambia? Comunque per nattare il portatile sull'hag devo creare un ponte tra la wlan0 ed eth1, no? :m:

No. È come avere un router con la porta internet che entra su un altro router, diciamo.



È ancora tutto scritto. :bgg2

Lo so, ma se ti va bene l'approccio nat lasciamo stare il bridge che per qualche motivo non mi esce mai bene :tong2



Lo scopo non è cambiato: condivisione della connessione internet con il portatile in wireless (e magari anche della stampante e di qualche cartella).
:thx

Probabilmente col nat la condivisione della stampante e delle cartelle non funzionerà...

Andy86
30-10-10, 15: 37
Ma(s)sì dai, Basta che funziona la condivisione internet e per adesso mi va bene... :bgg2 :ghgh

Poi una volta che ho imparato a masticare ifconfig qualche prova ce la tiro fuori anch'io. :sisi

pierino_89
30-10-10, 15: 43
Più che altro devi masticare un po' di networking avanzato, che non è così banale.
L'unica cosa che devi fare è configurare le due interfacce di rete in modo che funzionino nel loro ramo.
Dopodiché leggi la parte di condivisione della connessione qui:
Script di base per configurare il firewall Netfilter - Linux@P2P Forum Italia (http://linux.collectiontricks.it/wiki/Script_di_base_per_configurare_il_firewall_Netfilt er)

Andy86
30-10-10, 20: 31
Pure il firewall devo configurare? :shock

Comunque fatto qualche prova con il bridge:


Only registered members can view code.



Only registered members can view code.

Il portatile vede la connessione e si aggancia (però!! :hap), ma su internet non ci entra... :boh

:thx

pierino_89
31-10-10, 01: 23
Il portatile che indirizzo ottiene?

Andy86
31-10-10, 10: 42
:bai

Allora, il portatile è configurato a mano sul gateway 192.168.0.1, poiché sul pc fisso gira anche xp, e non è in grado di fare da dhcp, perciò deve andare in modo statico.

Se lo metto per prendere l'indirizzo da dhcp vede correttamente l'indirizzo del bridge, ma la connessione non va lo stesso. :boh

Potrebbe essere un problema di permessi? :ohoh

:thx

(comunque credo che farò qualche esperimento per un bridge statico, poiché non sarebbe comodo settare continuamente il portatile tra manuale e automatico :sisi).

pierino_89
31-10-10, 12: 58
Nein. Ti avevo detto che il fisso non deve fare da dhcp, deve riuscire a far passare sopra il bridge il dhcp dell'hag o quel che era. Se hai due classi di indirizzi differenti sulle due interfacce, il portatile non andrà mai su internet senza essere nattato dal fisso (e a quel punto il bridge serve solo per far figura).

Andy86
31-10-10, 13: 12
Probabilmente ho fatto un po' di confusione. Pensavo che il bridge fosse già un tipo di nat, anche tra ip diversi.

Ok, comunque ho smanettato un po' senza risultato, e ora forse ho capito perché... :ehmm

Poi ho provato quella cosa del nat, ed ho messo interfaces così:


Only registered members can view code.

Mentre nello script preso dalla guida ho sostituito "ppp0" con "eth1" e "eth0" con "wlan0".
Proporzione corretta?

Comunque il risultato è stato che non è andato più nulla, neanche il fisso su internet. Uff...

:thx

pierino_89
31-10-10, 13: 24
Diciamo che i comandi rilevanti nel tuo caso sono solo

Only registered members can view code.
Se metti wlan0 in output (l'opzione -o) ottieni il contrario, ovvero natti il router sul portatile :tong2

Il bridge tra due interfacce vuol dire grossomodo che quelle due interfacce sono come uno switch ethernet a due porte. Di conseguenza a una c'è attaccato l'hag col dhcp, dall'altra il portatile. Il fisso fai finta che non esista per comodità. Il problema è che essendo wireless il concetto è più complesso, perché devi effettuare la connessione ma senza assegnare l'indirizzo, perché altrimenti è come se il bridge smettesse di funzionare, perché se assegni un indirizzo di classe diversa alle due porte del bridge queste non possono più parlarsi.

Ricordati di mettere al fisso se stesso come gateway sulla wlan0, altrimenti poi non sa come uscire su quell'interfaccia (se usi il nat).

Andy86
31-10-10, 14: 26
:ops:

Ok, allora il bridge non va bene. Effettivamente avevo frainteso il significato di bridge. Allora si parla di nat, come quella che ho tra Xp e Xp (che, :ehmm, ho pensato fosse una sorta di bridge... :bgg2).


i comandi rilevanti nel tuo caso sono soloNel senso che sono gli unici che vengono sbagliati con la proporzione che ho fatto io?
Oppure intendi che basta mettere quelli nello script?


Ricordati di mettere al fisso se stesso come gateway sulla wlan0:m: e come faccio? eth1 è in dhcp, non ha ip fisso, cosa metto davanti alla voce "gateway" sotto "iface wlan0 ..."?

:thx

pierino_89
31-10-10, 14: 46
Nel senso che sono gli unici che vengono sbagliati con la proporzione che ho fatto io?
Oppure intendi che basta mettere quelli nello script?Bastano quelli (prima però devi riportare al default le regole)



:m: e come faccio? eth1 è in dhcp, non ha ip fisso, cosa metto davanti alla voce "gateway" sotto "iface wlan0 ..."?

:thx
Ho detto wlan0, non eth1 :bgg2 quella la lasci così com'è. Dato che wlan0 ha ip statico, le dai quell'ip anche come gateway.

Andy86
31-10-10, 15: 03
Sicuro che in quel modo non si crea una ridondanza ciclica? su XP il gateway della connessione wi-fi sul fisso deve essere lasciato vuoto per funzionare. :m: (mentre sul portatile metto l'ip del fisso)


devi riportare al default le regole:leg: :ohoh ... Non trovo come si fa ... :ehmm

EDIT, Trovato:


Only registered members can view code.Ora provo. :sisi

EDIT2:

Lo script non funziona. :boh
La rete "casa 2" non viene vista dal portatile se lo script viene eseguito.
Se commento lo script tutto torna a posto (ovviamente niente internet sul portatile...)

:thx

EDIT3:

Tra una cosa e l'altra ancora prove ed ancora niente. uffff.....Ora win vede la connessione generata anchea script attivo, che ho modificato così:


Only registered members can view code.

Ma nulla.

A proposito, se metto l'ip ricorisivo a wlan0 come hai detto tu non si connette più neanche il fisso. :bgg2

:thx

pierino_89
01-11-10, 01: 26
Beh, ok, lasciamo vuoto il gateway. Dunque, in che maniera verifichi la connessione a internet? Riesci ad arrivare a vedere almeno il pc?

Andy86
01-11-10, 10: 09
:bai


in che maniera verifichi la connessione a internet?

Semplicemente aprendo firefox. :bgg2



Riesci ad arrivare a vedere almeno il pc?

:ehmm Non mi è proprio saltato in mente di provare il ping...

Comunque l'ssid che creo da ubuntu viene visto automaticamente da windows, anche se lo cancello dalle connessioni preferite.

pierino_89
01-11-10, 13: 26
potrebbe essere un banale problema di dns... prova

Andy86
01-11-10, 13: 53
:bai

Ho provato sia con open-dns che con l'ip di pc1. Cambia nulla.

pierino_89
01-11-10, 13: 55
beh l'ip di pc1 sicuramente non funziona. Come hai settato i dns?

Andy86
01-11-10, 13: 57
Come ho appena detto un post fa... :m:

pierino_89
01-11-10, 13: 59
Intendevo, resolv.conf?

Andy86
01-11-10, 14: 02
Su pc2 (quello che deve essere nattato) c'è win XP. Quindi niente resolv.conf. :ghgh

Su pc1 neanche lo mai guardato. Lui si connette e non vedo che centrano i dns con le connessioni in entrata.

pierino_89
01-11-10, 14: 09
Ah giusto, me n'ero dimenticato.
Boh, prova a pingare l'indirizzo di pc1 assegnato dal dhcp, così vediamo se è un problema di nat o cosa.

Andy86
01-11-10, 15: 17
All'occasione ecco i risultati dei ping, cioè nulla, pc2 non pinga proprio nulla.

Da solo richiesta scaduta, sia sull'ip dhcp che sullo statico di wlan0. :boh

Eppure la connessione viene stabilita... :triste e Da pc1 a pc2: (non so perché, ad un certo punto cambia da sola l'ultima cifra... :boh)


Only registered members can view code.

Sembra lo vede.

Il firewall su xp è giù, quindi è innocente.

Io continuo a temere l'incompatibilità. :ohoh

pierino_89
01-11-10, 18: 33
Only registered members can view code.

Sembra lo vede.
100% packet loss significa che non lo vede.



Il firewall su xp è giù, quindi è innocente.
Beh, nella situazione corrente è difficile che il firewall crei problemi di sorta. Comunque un problema in meno.



Io continuo a temere l'incompatibilità. :ohoh
Questo è fuori discussione. Molti router e access point sono basati su linux, dopotutto.

La diagnosi è che la connessione wireless non è stabilita proprio per niente, "Destination Host Unreachable" indica che il so non ha modo di raggiungere l'host, o perlomeno non gli sono state date le informazioni necessarie per farlo.

Andy86
01-11-10, 22: 50
:bai


100% packet loss

Pensavo fosse per l'ultima cifra che cambia. Ovviamente non potendo pingare se stesso andava in lost, però la prima riga, col 2 finale, dice un numero di byte. Pensavo fossero i trasmessi. :sisi


la connessione wireless non è stabilita proprio per niente,

Proprio per niente no. Quasi per niente. Quando attivo la wlan0 windows comincia a vedere la connessione disponibile con l'ssid che ho assegnato e quando mi aggancio dice 'connesso'.
Per escludere false informazioni ho eliminato l'impostazione memorizzata da xp, esso rivede comunque l'ssid che ho messo in ubuntu. :sisi

-----------------------------------------------------

Comunque ora che faccio?!?!? Le idee le ho finite... :cry3:cry3:cry3

:thx

pierino_89
02-11-10, 10: 08
Pensavo fosse per l'ultima cifra che cambia. Ovviamente non potendo pingare se stesso andava in lost, però la prima riga, col 2 finale, dice un numero di byte. Pensavo fossero i trasmessi. :sisi
Aspetta... non ho bene capito questo passaggio. Pingare se stesso??

Andy86
02-11-10, 12: 40
:bai

Allora, se guardi bene il testo del ping che ho postato:


Only registered members can view code.Io do istruzione di pingare 192.168.0.2, che è l'indirizzo ip statico assegnato al portatile (pc2), ma il comando lo fa solo per la prima riga, espressa infatti in modo diverso. Poi cambia automaticamente l'indirizzo in 192.168.0.1, che è l'indirizzo statico assegnato a wlan0, e comincia a non vedersi più. :boh

Ma se fa il ping ad un indirizzo, perché aspetta risposta da un altro? :boh

Poi non so se ho preso un granchio io, ma non mi sembra una cosa normale.

pierino_89
02-11-10, 12: 52
Io do istruzione di pingare 192.168.0.2, che è l'indirizzo ip statico assegnato al portatile (pc2), ma il comando lo fa solo per la prima riga

No, la prima riga è solo di intestazione.


Poi cambia automaticamente l'indirizzo in 192.168.0.1, che è l'indirizzo statico assegnato a wlan0, e comincia a non vedersi più. :boh
Ma neanche per sogno, c'è scritto From (= da), ovvero ti specifica da che indirizzo sta mandando i dati. Altrimenti se avessi 4 interfacce sulla stessa rete non sapresti quale va e quale no.
Inoltre, se la prima riga fosse stato un ping positivo nelle statistiche avresti avuto 80% packet loss e non 100%.



Ma se fa il ping ad un indirizzo, perché aspetta risposta da un altro? :boh
No, la risposta deve arrivare dallo stesso, altrimenti verrebbe droppata dal kernel apprescindere.


Poi non so se ho preso un granchio io, ma non mi sembra una cosa normale.Hai assolutamente preso un granchio :tong2

Andy86
02-11-10, 13: 16
Ah, be, Ok. Fregato dall'abitudine con windows.Pensavo che il "da" fosse inteso come "risposta da", in questo senso:


Only registered members can view code.------------------------------------------------------------------------------------

Comunque, ora che faccio per capire perché non si vedono?

:thx

pierino_89
02-11-10, 13: 29
Beh, è chiaramente legato al wifi, ma non saprei dirti in che modo.

In ogni caso sembra che ad-hoc non faccia al tuo caso:
"Ad-hoc networks cannot bridge to wired LANs or to the Internet without installing a special-purpose gateway."
Ad-Hoc Wireless - What is Wireless Ad-Hoc Mode? (http://compnetworking.about.com/cs/wirelessfaqs/f/adhocwireless.htm)

Andy86
06-11-10, 12: 12
:bai Rieccomi a fare prove.


sembra che ad-hoc non faccia al tuo caso:

Eppure su win ce l'ho impostata ad hoc e funziona benissimo. E poi win non permette altri modi per la connessione tra pc e pc. :boh

Comunque leggendo in giro ho visto che la connessione nat generata da iptables dovrebbe apparire in questo comando:


Only registered members can view code.

Ma, come vedi, non c'è... Che ci sia qualcosa che non va nello script??


Only registered members can view code.

A proposito, facendo prove con iptables -L e iptables -F mi sono reso conto che lo script inserito nell'interfaces non viene chiamato. (Però anche chiamandolo manualmente "./sbin/fw_nat.sh", non cambia nulla. :boh

:thx

pierino_89
06-11-10, 17: 29
Eppure su win ce l'ho impostata ad hoc e funziona benissimo.
Che ti devo dire, lì c'è scritto così :ehmm


E poi win non permette altri modi per la connessione tra pc e pc. :boh
E io lo dico sempre che windows fa male... Un router cosa credi che sia? Eppure non usa ad-hoc :tong2



Comunque leggendo in giro ho visto che la connessione nat generata da iptables dovrebbe apparire in questo comando:

netstat -nat

Dal manuale di netstat:
-n = numeric, ovvero non fa la risoluzione dns sugli ip;
-a = tutte le interfacce;
-t = traffico tcp
In pratica ti mostra tutte le connessioni tcp in ingresso sul tuo pc. Che è ben diverso.
Probabilmente netstat -M sarebbe più appropriato, ma generalmente le cose di iptables si controllano con iptables.



A proposito, facendo prove con iptables -L e iptables -F mi sono reso conto che lo script inserito nell'interfaces non viene chiamato. (Però anche chiamandolo manualmente "./sbin/fw_nat.sh", non cambia nulla. :boh

:thx
Devi specificare la tabella:
iptables -t nat -L

altrimenti ti mostra solo i filtri in ingresso/uscita

Andy86
26-11-10, 17: 03
:bai

Problema risolto alla radice. Il vecchio hag telsey si è bruciato e fastweb me lo ha sostituito con il nuovo pirelli (no, non è un pneumatico... :bgg2) che ha anche il wi-fi. Per cui la nat ora è storia.

Al massimo dovrei capire come condividere alcune cartelle da ubuntu, ma se non ce la faccio da solo apro un'altra discussione, che questa è già un poema. :ohoh

:thx lo stesso di essermi stato dietro.