PDA

Visualizza versione completa : Problema connessione LAN



white_hot_ice
16-09-10, 16: 43
Buongiorno a tutti.Gentilmente aiutatemi con il problemino.....Ho installato la Ubuntu su mio portatile e sto cercando di stabilire la connessione via cavo,una volta collegato il modem al pc sul pannello di controllo compare la connessione,ma quando lancio il browser nn si apre nessuna pagina.con windows nn ci sono problemi.provider - tiscali

chrix
16-09-10, 17: 04
devi semplicemente impostare gli indirizzi manualmente...

white_hot_ice
17-09-10, 02: 27
Mi puoi aiutare,gentilmente...NN so cosa e dove impostare...grazie

ginalfa
17-09-10, 11: 45
usi un router o un modem usb?

white_hot_ice
17-09-10, 12: 32
Modem usb:hap

chrix
17-09-10, 13: 53
ah allora è un altra storia, prima devi accertarti che ubuntu supporti il dispositivo usb...

white_hot_ice
17-09-10, 14: 10
Beh,scusa,nn lo so se mi sono spiegato bene....il modem che sto usando supporta la connessione sia tramite la porta USB,sia tramite cavo Ethernet.Infatti sto cercando di collegarmi tramite cavo Ethernet

chrix
17-09-10, 17: 11
ah allora non è un modem ma un router... per configurare gli ip fissi vai sul simbolo della connessione e clicca configura quindi portati nella scheda "eth" e clicca modifica, li vai nella sezione tcp/ip v4 e imposti gli ip fissi.

ginalfa
17-09-10, 18: 13
marca e modello del modem?

Kirk78
18-09-10, 12: 21
Magari basta solamente inserire, a mano, i DNS. Perché pare si sia collegato visto che
sul pannello di controllo compare la connessione ma bisogna anche vedere se è sotto DHCP oppure no. Quindi i preziosi consigli di mettere anche l'IP della scheda a mano è correttissimo. Rispondi alla domanda di ginalfa, per vedere quale è anche l'IP del router, visto che il default dipende dal router. :bai

white_hot_ice
18-09-10, 13: 29
Modem Tiscali Voce Pirelli

---Post unito in modo automatico ---


ah allora non è un modem ma un router... per configurare gli ip fissi vai sul simbolo della connessione e clicca configura quindi portati nella scheda "eth" e clicca modifica, li vai nella sezione tcp/ip v4 e imposti gli ip fissi.

E dove gli trovo IP fissi?

---Post unito in modo automatico ---


Magari basta solamente inserire, a mano, i DNS. Perché pare si sia collegato visto che ma bisogna anche vedere se è sotto DHCP oppure no. :bai
Infatti,nella sezione tcp/ip v4,ore impostato proprio DHCP

Kirk78
18-09-10, 15: 13
Quindi sei in DHCP. Diciamo che è il contrario degli IP fissi, perchè è il router che assegna gli IP dei PC. I DNS (che dovrebbero spesso essere inseriti nel router) come ce li hai settati?
Visto che hai detto

con windows nn ci sono problemi lì come è settato IP e DNS?

white_hot_ice
18-09-10, 15: 31
Connessione ADSL:

VPI 8
VCI 35
Protocollo PPP over ATM (RCF 2364)
Encapsulation VC-Multiplexing (VC-MUX)
Indirizzo DNS Primario Assegnato dal server
Indirizzo DNS Secondario Assegnato dal server

---Post unito in modo automatico ---

Tiscali Assistenza - Parametri di configurazione (http://assistenza.tiscali.it/tecnica/parametri/)

---Post unito in modo automatico ---

Tiscali Assistenza - Modem Tiscali Voce Pirelli (http://assistenza.tiscali.it/tecnica/telefono/configurazioni/pirelli_voce/)

---Post unito in modo automatico ---

Ho provato ancha a fare ping(nn so quanto può essere utile)....google.com.....il tempo di risposta ma da 34 msec,cioe quindi riesce a mandare segnali in rete......boh

---Post unito in modo automatico ---

Infatti,ora sto navigando con lo stesso modem pero in ambiente windows che nn mi da nessun problema

Kirk78
18-09-10, 16: 06
Parlo dei settaggo del TCP/IP della tua scheda ethernet da Windows (se XP Proprietà connessione LAN -> Generale -> Protocollo TCP/IP -> Proprietà) e lo Stato connessione (se XP tasto destro sulla connessione -> Status -> Supporto -> Dettagli).
P.S. se vuoi aggiungere dati ad un messaggio fatto da poco fai "Modifica messaggio" :eye

ginalfa
18-09-10, 17: 49
La configurazione su ubuntu praticamente non è necessaria in modalità ethernet....click (http://assistenza.tiscali.it/tecnica/telefono/configurazioni/pirelli_wireless/verifica_rete/linux/)

Quindi il problema forse sta altrove
da terminale dai
Only registered members can view code. e posta il risultato

pierino_89
19-09-10, 02: 28
Potrebbe essere uno di quei router finti che fanno finta di essere dei router e poi invece usano pppoe, tipo i router di alice.
Prima di pensare a ip statici e andare a settare impostazioni che potrebbe essere complesso ripristinare, vediamo di capire bene la situazione globale.
Quindi sarebbe opportuno vedere gli output di:

Only registered members can view code.
che dicono rispettivamente la configurazione delle interfacce di rete, i gateway attivi e i dns in uso.

white_hot_ice
19-09-10, 13: 50
Parlo dei settaggo del TCP/IP della tua scheda ethernet da Windows (se XP Proprietà connessione LAN -> Generale -> Protocollo TCP/IP -> Proprietà)

Allora,qui è tutto impostato su automatico..Ottieni indirizzo IP automaticamente,ottieni indirizzo server DSN automaticamente,otteni IP privato automaticamente


e lo Stato connessione (se XP tasto destro sulla connessione -> Status -> Supporto -> Dettagli).

tipo indirizzo: assegnato da DHCP
indirizzo IP: 192.168.1.3
Subnet mask: 255.255.255.0
gateway: 192.168.1.1
indirizzo fisico: 00-16-D4-60-90-43
server DHCP: 192.168.1.1
server DNS: 192.168.1.1



La configurazione su ubuntu praticamente non è necessaria in modalità ethernet....click (http://assistenza.tiscali.it/tecnica/telefono/configurazioni/pirelli_wireless/verifica_rete/linux/)
Ok,qui mi dice di "seleziona Amministrazione dal menu Sistema e clicca su Rete",ma nel mio caso la voce Rete non appare nel menu........


Only registered members can view code.

ginalfa
20-09-10, 10: 40
l'output di ifconfig e di route mi sembrano a posto
manca uno spazio (dopo "cat") nell'ultimo comando


Only registered members can view code.

white_hot_ice
20-09-10, 13: 51
Eccolo:

Only registered members can view code.

pierino_89
20-09-10, 14: 10
nameserver, intendi? :tong2

Kirk78
20-09-10, 17: 28
Sembra a posto... per prova fai partire il PC dalla live di Ubuntu. Non mi chiedere il perché ma su una macchina, forse perché non digeriva bene la scheda, la live funzionava e l'installato no. :boh

ginalfa
20-09-10, 17: 33
Ed anche questo sembra a posto (vocale a parte :P).
ma non è che il browser è semplicemente offline?

Mi dici che in win tutto funziona e quindi devo supporre che il server DNS è impostato correttamente sul router.

Se da terminale dai

Only registered members can view code.
ti scarica in home un file "index.htm" o no?

white_hot_ice
21-09-10, 15: 18
Buongiorno,signori.
ginalfa,quando provo a digitare wget mi da questo:

Only registered members can view code.
nella cartella home nn appare nessun file index.html

pierino_89
21-09-10, 23: 58
Vediamo se è il dns che fa problemi:

Only registered members can view code.
Poi ritenta.

Kirk78
22-09-10, 09: 04
Hai poi provato con la live?

white_hot_ice
22-09-10, 13: 30
Vediamo se è il dns che fa problemi:

Only registered members can view code.
Poi ritenta.


Only registered members can view code.
entro come Administratore.
Con la live la stessa cosa:(

Kirk78
22-09-10, 15: 21
Prova a modificare /etc/sysctl.conf togli il # a

Only registered members can view code.
e aggiungi

Only registered members can view code.
Salva e riavvia. Qualcuno con Alice aveva risolto così. Non l'ho provato personalmente. Quindi prendilo con le pinze (backup dati, copia del vecchio sysctl.conf etc etc).

Edit: Insomma protegge dagli attacchi "syn flood (http://it.wikipedia.org/wiki/SYN_flood)", non si possono settare valori di buffer più alti di quelli di default e viene disabilitato l'Explicit Congestion Notification (su Win è di default disabilitato)

K.a.o.s.
22-09-10, 16: 27
entro come Administratore.
Se intendi root spero proprio di no...
Comunque sarebbe:

Only registered members can view code.

ginalfa
22-09-10, 19: 18
Con la live la stessa cosa:(
E se fosse il router ad andare in blocco?
I filtri p2p più aggressivi (quelli di tele2-tu) generano una serie di syn_flood
che provocano il blocco del traffico da parte del firewall di diversi router. Si risolve solo abbasando il livello di protezione del firewall.

Kirk78
22-09-10, 19: 27
I filtri p2p più aggressivi (quelli di tele2-tu) generano una serie di syn_flood
Uno dei comandi che ho messo prima è per evitare appunto i syn_flood.

ginalfa
22-09-10, 19: 32
Si, l'ho visto, è prorio quella parte del tuo post che mi ha ha fatto pensare ai filtri p2p.
Ma se è il firewall del router a bloccare il traffico i syn_flood al pc non ci arrivano nemmeno.

pierino_89
22-09-10, 22: 27
Se intendi root spero proprio di no...
Comunque sarebbe:

Only registered members can view code.
Potrebbe avere l'attributo immutabile sul file, anche se mi sembra strano. Se continua a dare errore, prova a dare un
Only registered members can view code.

K.a.o.s.
22-09-10, 23: 20
Potrebbe avere l'attributo immutabile sul file, anche se mi sembra strano.Potrebbe, ma in quel caso è sudo che esegue solo l'echo come root e non la redirezione dell'output. Ci avevo sbattuto un po' la testa anche io. :hap

pierino_89
22-09-10, 23: 30
jah, avrei dovuto virgolettarlo.
stupido sudo :tong2

white_hot_ice
25-09-10, 13: 05
Prova a modificare /etc/sysctl.conf togli il # a

Only registered members can view code.
e aggiungi

Only registered members can view code.
Salva e riavvia. Qualcuno con Alice aveva risolto così. Non l'ho provato personalmente. Quindi prendilo con le pinze (backup dati, copia del vecchio sysctl.conf etc etc).

Edit: Insomma protegge dagli attacchi "syn flood (http://it.wikipedia.org/wiki/SYN_flood)", non si possono settare valori di buffer più alti di quelli di default e viene disabilitato l'Explicit Congestion Notification (su Win è di default disabilitato)

Scusami,ora ti faccio una domanda un'pò stupida.......nn riesco a trovare questo file che dovrei modificare

---Post unito in modo automatico ---



Only registered members can view code.

Si entro proprio come root......Ma ora ho un''altro problema......quanto provo a digitare il codice,tipo sudo -s.....il sistema mi chiede la password di root,dopodichè la tastiera nn risponde più,nn mi fa digitare la password

pierino_89
25-09-10, 13: 06
La tastiera funziona benissimo, semplicemente il testo della password non viene mai mostrato.

Kirk78
25-09-10, 13: 07
/etc/sysctl.conf si trova ... su /etc :bgg2. Fai

Only registered members can view code.
così vedi se magari è di sola lettura. :bai

K.a.o.s.
25-09-10, 13: 41
così vedi se magari è di sola lettura.
Piuttosto ci vorrà root per modificarlo:

Only registered members can view code.

Al posto di gedit ovviamente si può usare l'editor che si vuole: nano, vim ecc.

Si entro proprio come root......
:shock se intendi che metti come utente root alla schermata di login, ti crea più problemi che altro... e abbassa tantissimo la sicurezza. Alcuni programmi giustamente non vorranno avviarsi come root (vlc è un esempio). Usa l'utente creato durante l'installazione.

pierino_89
25-09-10, 13: 54
Che io sappia GDM non lascia entrare root, oltre al fatto che l'utente di root è disabilitato di predefinito.

Kirk78
25-09-10, 14: 01
Piuttosto ci vorrà root per modificarlo:

Only registered members can view code.
Certo, però se fa ls vede se deve prima modificare l'attributo di sola lettura (e vede se c'è). Alle volte non si può modificare. Tu che edit preferisci per modificare i conf? :bai

K.a.o.s.
25-09-10, 15: 08
Tu che edit preferisci per modificare i conf?
Dipende, nano se devo fare una modifica veloce (ma proprio veloce), altrimenti uso vim.
Gedit mi aveva creato in passato qualche problema con dei caratteri speciali (non li mostrava) e lo uso solo su Linux.

però se fa ls vede se deve prima modificare l'attributo di sola lettura (e vede se c'è)È difficile in genere che sysctl.conf sia immutabile. Non avrebbe nemmeno particolarmente senso, tanto l'utente non riesce a modificarlo lo stesso :eye.

white_hot_ice
25-09-10, 15: 18
:shock se intendi che metti come utente root alla schermata di login, ti crea più problemi che altro... e abbassa tantissimo la sicurezza. Alcuni programmi giustamente non vorranno avviarsi come root (vlc è un esempio). Usa l'utente creato durante l'installazione.

Infatti,durante instalazione ho creato utente root e lo sto usando solo quello.anche perchè è unico:)

ginalfa
26-09-10, 11: 10
Infatti,durante instalazione ho creato utente root e lo sto usando solo quello.anche perchè è unico:)

Non vorrei che il problema sia proprio questo.
In Ubuntu creare un utente "root" può dare problemi ed in ogni caso anche se ha il nome "root" non si dovrebbe automaticamente comportare da root cioè con tutti i permessi.
Infatti, anche se l'utente root in ubuntu di norma non esite, con sudo su la console passa al prompt root@nomeutente
nel tuo caso quindi avresti


root@root/home/root

ma nel filesystem c'è già una cartella "root" in radice, alla quale fa riferimento lo pseudo-utente root

e la cosa non mi quadra per niente

ma se avvii con la live di ubuntu hai gli stessi problemi?
Io credo di no, altrimenti non avresti le localizzazioni.

white_hot_ice
26-09-10, 15: 29
Only registered members can view code.
Cmq per il root intendevo l'administratore(nn il nome "root")......
Cmq ho riuscito a risolvere il problema digitando il codice proposto da K.a.o.s,nn so di che modifica si trattava ma il fatto sta che finalmente sono connesso ad internet e ora posso passare a linux,completamente:)))
Grazie a voi,signori,del vostro tempo perso

K.a.o.s.
26-09-10, 15: 50
Se al riavvio dovesse crearti problemi (ovvero devi ridare il comando):


Only registered members can view code.
e non darà più problemi.

Kirk78
26-09-10, 19: 23
del vostro tempo perso Non è mai tempo perso, se si può risolvere un problema :oo2! Il motto di CT ricorda è "Difficile non è sapere, ma condividere ciò che si sa" e se oltre a condividere si può anche aiutare... che vuoi di più? Quindi direi - Risolto - :bai