PDA

Visualizza versione completa : Impostazione tastiera su ubuntu



Asterix
07-08-10, 09: 40
Ciao ragazzi

solo oggi ho notato una cosa :oo2

due giorni addietro ho installato per la prima volta ubuntu 10.04 nel mio portatile Asus F3S, ho selezionato tastiera italiana e fin qui tutto bene.

Oggi stavo sistemando alcuni plugin che avevo fatto in passato e ho scoperto che i caratteri del maggiore e del minore non sono vicino alla z come da tastiera, se premo il pulsante mi escono § ù. Il resto dei pulsanti sono Ok, mancano solo quei due li.

Aiutatemi sono vitali per il linguaggio html e php.

:bai

pierino_89
07-08-10, 11: 44
Hai settato tastiera italiana normale no?

Asterix
07-08-10, 13: 24
Si ho la tastiera italiana, la cosa strana è che tutti sono ok escluso quello.

http://img833.imageshack.us/img833/6471/schermatal.png
:bai

K.a.o.s.
07-08-10, 14: 11
Provando a modificare ~/.Xmodmap e usare xmodmap?
Prova a guardare qui (http://wiki.archlinux.org/index.php/Extra_Keyboard_Keys_in_Xorg) se ti aiuta.

Asterix
07-08-10, 15: 07
Cavoli li ho trovati

ALT GR+SHIFT+Z = <
ALT GR+SHIFT+X = >

il problema è che nel layout della tastiera quel tasto non esiste.

:bai

pierino_89
07-08-10, 15: 19
Prova un banalissimo "setxkbmap it" e dimmi come va.

Asterix
07-08-10, 16: 11
Non cambia nulla

Forse con il mio portatile ci sono dei problemi di mappatura tastiera.

:bai

pierino_89
08-08-10, 02: 00
Se hai un file xorg.conf, postalo. Io alla fine sul mio avevo installato kde perché aveva un tool di pastrocchio tastiera decisamente superiore. Ma teoricamente dovrebbero comunque andare tutti i tasti a parte quelli multimediali. Hai una tastiera 104 o 105 tasti?

Asterix
09-08-10, 08: 39
Il file contiene


Only registered members can view code.

Keyboard 19mm full size 88 Key with MS Windows function keys 2.5mm travel

:bai

Kirk78
09-08-10, 09: 17
Prova a mettere modello di tastiera "Generic". Magari è per un "Portatile Asus" diverso....

mi escono § ù
E premendo quei 2 tasti che cosa ti esce? Non è che ti esce < > ?
:bai
EDIT potresti anche provare a far partire la macchina dalla live di ubuntu 10.4 e vedere, se funzionano i tasti, che tipo di settaggi ci sono. poi riportarli nella versione installata

Asterix
09-08-10, 13: 41
Ho provato il generic e non è cambiato nulla


E premendo quei 2 tasti che cosa ti esce? Non è che ti esce < > ?


si ok che non sono pratico di linux ma di pc forse qualcosa ne capisco ed è una delle prime prove fatte :lol:

per la modalità live provo appena possibile.

:bai

Kirk78
09-08-10, 14: 07
Ok lo supponevo che l'hai fatta come prova: ma cosa ti esce? Se ti escono i caratteri corretti allora è strano perché nel caso fosse settato un'altro tipo di tastiera dovrebbe darti dei caratteri diversi per ogni tasto. Altrimenti sembra che siano abbinati 2 coppie di tasti a solo 2 caratteri. Quando fai la prova della live dicci. Ma su questo Notebook c'è solo linux o anche win? Se c'è un dual boot vedi su Win cosa danno tutti e 4 i tasti. :bai

EDIT: a quanto ne so l'unico layout che ha al posto del < ha ù è la Canadian Multilingual Standard però è abbinato al pipe....
EDIT 2: potresti anche rimappare quel tasto (o tutti se vuoi), però è strano quantomeno...

Asterix
09-08-10, 18: 03
I tasti sono tutti corretti tranne quello, a questo punto presumo sia un problema hw o di bios, ho visto che sulla foto della scheda prodotto quel tasto non c'è mah

ok non ci voglio perdere ulteriore tempo e utilizzo la combinazione.
:bai

Edit: risolto era un problema legato al bios.

Kirk78
09-08-10, 19: 48
Edit: risolto era un problema legato al bios.
Ok perfetto :bgg2: per i lettori di CT cosa hai cambiato? Così se c'è un problema simile hanno già la risposta!
:bai

Asterix
09-08-10, 20: 16
Semplicemente aggiornato.

:bai