PDA

Visualizza versione completa : Problema all'avvio di sidux



mich
02-08-10, 20: 47
Dopo aver aggiornato (e neanche il kernel, aggiornamenti normalissimi) mi sono trovato all'avvio successivo questo messaggio:

Only registered members can view code.

Al posto delle xx vari numeri che ho cancellato perché ho copiato da un altro forum e i miei erano diversi;
il numero di secondi di no response tende all'infinito: è come se tentasse qualcosa che ignoro ogni 3 secondi e non trovando niente ripete il tentativo (anziché abortire e avviarsi)
Ho provato a eliminare ogni riferimento di eth0 dal file /etc/network/interfaces ma niente.
Potrei disattivare la scheda ethernet dal bios (visto che tanto non la uso, visto che o mi connetto wifi o con la chiavetta tim/3) ma non è detto che risolva il problema e sono certo che basti andare ad agire su qualche file di configurazione, il problema è sapere quale...

K.a.o.s.
02-08-10, 22: 25
A occhio sembra che cerchi il cavo collegato e, non trovandolo, protesta. Quindi disattivando dal bios la ethernet dovrebbe andare... è la strada più semplice aspettando magari che un ennesimo aggiornamenti sistemi il problema. Prova al massimo :hap.

Essendo Sidux una Debian unstable non dovrebbe essere difficile beccare un update buggato.

pierino_89
03-08-10, 00: 52
Mi sembra a occhio che stia aspettando una risposta dal dhcp server, teoricamente prima o poi dovrebbe stufarsi :lol:. A me il sistema si incastra al boot quando sono sconnesso e il client ntp cerca di aggiornare l'ora. Probabilmente devi dare un timeout più basso al client dhcp nella configurazione, o disabilitare la configurazione in /etc/network/interfaces e gestirla a runtime.

mich
03-08-10, 10: 03
Probabilmente devi dare un timeout più basso al client dhcp nella configurazione
Per me potrebbe non esserci proprio, se sapessi esattamente dove andare a toccare lo avrei fatto subito


disabilitare la configurazione in /etc/network/interfaces e gestirla a runtime.
ho lasciato sia il file vuoto che con una roba grosso modo di questo genere
auto eth0
allow-hotplug eth0

ma continuava a fare così...


Essendo Sidux una Debian unstable non dovrebbe essere difficile beccare un update buggato.
Infatti sono certo che stia qu.i solitamente aggiorno via synaptic in modo da vedere una cronologia, ma l'ultimo lo avevo fatto da shell in runlevel3 come consiglia il manuale di sidux con dist-upgrade e non ho guardato i pacchetti installati quel giorno..


Quindi disattivando dal bios la ethernet dovrebbe andare..
Se me lo fa anche su questo kernel la disattivo, ho eliminato l'ultimo kernel e uso la revisione precedente


la strada più semplice aspettando magari che un ennesimo aggiornamenti sistemi il problema. Prova al massimo .
infatti prima o poi... quello che ha di buono sid(ux) è che gli aggiornamenti sono frequenti...

K.a.o.s.
03-08-10, 12: 56
Non usando Debian non conosco dove mette i log apt, però in genere sotto /var o /var/log ci sono.
(guardando ora su internet dicono /var/log/apt/term.log )

Se me lo fa anche su questo kernel la disattivo, ho eliminato l'ultimo kernel e uso la revisione precedente
Alcuni appunto consigliavano di ricreare l'immagine initrd.

infatti prima o poi... quello che ha di buono sid(ux) è che gli aggiornamenti sono frequenti...In teoria, per esperienza, bug del genere sono corretti quasi subito :shock, massimo 1 giorno. Non so però su Sidux come sia.

mich
08-08-10, 21: 31
Ho risolto il "problema"
era dovuto a qualche impostazione errata del client nbd (qualcuno mi spieghi a cosa serve)
risolto con apt-get purge nbd-client e ricreando l'immagine initrd (e già che c'ero ho rimesso l'ultima revisione del kernel)

Non sapendo cosa sia il client nbd presumo di non averne bisogno...

pierino_89
08-08-10, 22: 02
Network block device. Non so se possa avere a che fare con nfs, ma non mi sembra. In ogni caso, dubito fortemente ti serva.