PDA

Visualizza versione completa : Problema grub con gentoo



lupass93
11-07-10, 15: 43
Ciao a tutti, ho installato gentoo su un computer ma ho avuto problemi per l'installazione di grub.
Esattamente il primo problema della lista http://www.gentoo.org/doc/it/grub-error-guide.xml
Dopo aver compilato grub, ho proceduto con l'installazione:

Only registered members can view code.

Only registered members can view code. (boot si trova in /dev/sda1)

Only registered members can view code.

Only registered members can view code.
e l'output riportati diceva che era andato tutto bene, nessun problema, nessun errore.
Ho configurato menu.lst correttamente, ed ho riavviato.
All'avvio grub dice
Only registered members can view code. e resta così per sempre. Va in crash.
allora ho provato a reinstallando diversamente, ossia:

Only registered members can view code.
ma questo mi riporta alcuni errori come ad esempio

Only registered members can view code.
o alcuni errori riguardanti fd0 e quindi il floppy.
Ma comunque alla fine quando ho riavviato non è partito.
Allora ho pensato che il problema fosse che la live di gentoo caricasse le librerie deprecate vedendo quindi l'hd come hda e non come sda, ho provato quindi con la live di ubuntu che caricava le librerie non-deprecate e che quindi vedeva l'hd come sda, ma il problema persiste.
Non sò più cosa fare...
Grazie in anticipo. Ciao! :bai

K.a.o.s.
11-07-10, 17: 18
Ciao,
prova con questo :hap

Only registered members can view code.

lupass93
11-07-10, 23: 04
Ho provato sia con:

Only registered members can view code.
e sia con:

Only registered members can view code.
nel primo caso settava il device.map sia con fd0(prima) che con hd0(dopo fd0).
E non ha funzionato.
Nel secondo caso settava il device.map solo con hd0 /dev/hda che io ho modificato in hd0 /dev/sda.
Ma neanche in questo caso va...
In entrambi i casi nulla da fare.
Ho provato anche a rimanere normalmente in device.map ma niente da fare...

K.a.o.s.
11-07-10, 23: 18
La partizione di avvio ha la flag di boot?
Prova a guardare anche questo topic (http://www.linuxquestions.org/questions/linux-software-2/solved-grub-install-dev-hdx-does-not-have-any-corresponding-bios-drive-error-401582/).

lupass93
12-07-10, 10: 49
Le mie partizioni sono 3

/dev/sda3 /
/dev/sda2 swap
/dev/sda1 /boot

Quindi se ho capito bene, devo impostare direttamente il device.map con la live di ubuntu(perchè solo con essa mi da il problema does not have any corresponding BIOS drive) così:

Only registered members can view code. ?

K.a.o.s.
12-07-10, 11: 14
Le mie partizioni sono 3

Sì ma sda1 ha la flag di boot? Non intendo il punto di mount, proprio la flag. La puoi vedere e impostare sia da gparted che da fdisk (come da manuale di Gentoo (http://www.gentoo.org/doc/en/handbook/handbook-amd64.xml?part=1&chap=4#doc_chap2))
Quindi se ho capito bene, devo impostare direttamente il device.map con la live di ubuntu(perchè solo con essa mi da il problema does not have any corresponding BIOS drive) così:Direi di sì, per quanto sia mattina e non connetto troppo :hap

lupass93
12-07-10, 12: 49
Sì ma sda1 ha la flag di boot? Non intendo il punto di mount, proprio la flag. La puoi vedere e impostare sia da gparted che da fdisk (come da manuale di Gentoo (http://www.gentoo.org/doc/en/handbook/handbook-amd64.xml?part=1&chap=4#doc_chap2))
No, non era impostata la flag boot, ora l'ho impostata con grub :)


Direi di sì, per quanto sia mattina e non connetto troppo :hap
Si dopo aver impostato la flag boot ho riprovato con grub-install ma l'errore è sempre lo stesso (does not have any corresponding BIOS drive)
allora ho modificato device.map, ed ora il file è così:

Only registered members can view code.
Ora ti faccio sapere come va al riavvio... :D

EDIT:

Niente da fare.... non vuole proprio partire.

pierino_89
12-07-10, 14: 12
Tanto per cominciare, la sintassi di grub-install prende come parametro hd0 e non /dev/sda :lol:
Seconda cosa, se non specifichi --root-directory non verrà granché bene da live. Per root-directory intende la radice dell'installazione corrente, non boot, quindi o gli passi il path del drive root con tanto di boot montata, oppure prima di farlo devi fare alla partizione di boot un symlink boot che punti alla cartella stessa.

K.a.o.s.
12-07-10, 14: 20
Tanto per cominciare, la sintassi di grub-install prende come parametro hd0 e non /dev/sda
Mica vero :shock
Pure nel manuale di Gentoo è /dev/sda, anche qui (http://natonelbronx.wordpress.com/2008/03/03/ripristinare-grub-da-livecd-con-grub-install-e-altre-amenita/) e qui (http://orgs.man.ac.uk/documentation/grub/grub_3.html) (prima cosa trovata su Google).

pierino_89
12-07-10, 14: 22
Sì, ma se stai lavorando da live la mappatura dei device può essere incompleta o errata e fai prima a usare hd0. A me dandogli il dev non ha mai funzionato.

K.a.o.s.
12-07-10, 14: 28
Sì, ma se stai lavorando da live la mappatura dei device può essere incompleta o errata e fai prima a usare hd0. A me dandogli il dev non ha mai funzionato.
Per me è sempre stato il contrario :bgg2, poi non so con la nuova Ubuntu come vada... :hap

lupass93
12-07-10, 14: 32
Quindi se ho capito bene non posso dare grub-install /dev/sda, ma grub-install hd0.
Inoltre devo specificare con --root-directory la directory /mn/gentoo (in cui è montato /dev/hda3 e cioè / )
In conclusione devo dare:

Only registered members can view code.
Ho sbagliato qualcosa??

EDIT:

Con la live di Gentoo (e quindi con le librerie deprecate che vedono l'hd come hdx) in chroot, ho dato
Only registered members can view code.
il risultato dice che non c'è stato nessuun errore ed installazione finita.
il device.map ora è (hd0) /dev/hda.
Ora in fstab è tutto impostato secondo sdx
ed anche in menu.lst la riga root è root=/dev/sda3, ma il problema permane lo stesso!

pierino_89
12-07-10, 16: 29
Ma grub sale o no? Ai kernel panic ci pensiamo dopo.

lupass93
12-07-10, 16: 52
Nono... grub non vuole proprio avviarsi!
Troppo strano, mi è sempre bastato un semplice grub-install /dev/sda.
Incomincio a credere che il problema sia il pc...
Ho provato anche con grub-static ma non cambia nulla!

pierino_89
12-07-10, 16: 54
fai una roba, prova a installare tutto nella root e poi a traslocare boot nell'altra partizione ci pensi dopo.

lupass93
12-07-10, 16: 58
Quindi dici di reinstallare tutto in / senza fare una partizione apposita per la dir /boot/ ?

pierino_89
12-07-10, 17: 01
Reinstallare tutto??? Ma và, solo grub.

lupass93
12-07-10, 17: 05
Okokkk.....quindi monto tutto escluso /dev/hda1 (/boot), vado in chroot, riemergo grub e installo grub su /dev/hda3 ossia hd0,2. Giusto?

pierino_89
12-07-10, 17: 07
sì, ma sposta anche l'immagine del kernel.

lupass93
12-07-10, 17: 25
Niente. Non parte lo stesso.
Ora provo ad installarlo con grub-install --no-floppy hd0,2, ma non penso cambi molto da grub -> root (hd0,2) -> setup (hd0,2) -> quit.

EDIT:

Anche così non va....

pierino_89
12-07-10, 17: 30
se fai setup (hd0,2) non funzionerà mai, il bootloader va messo nel mbr, non nella partizione.

lupass93
12-07-10, 17: 45
Funziona!!!! Grazie mille a tutti!!!! :)
Finalmente parte grub ed anche il kernel non da problemi!! :)
Per la partizione di boot non fa niente tanto erano 64 mb, quindi non mi interessa più di tanto di recuperarla.
Grazie ancora, alla prossima Ciao!! :)