PDA

Visualizza versione completa : Windows XP xp non si avvia più!



leys89
16-03-10, 12: 36
salve ragazzi..

stamane accendo il pc, carica il bios, e quando terminano le operazioni del bios, lo schermo rimane nero! e nn fà nessuna operazione..

ho usato la consolle di ripristino di windows, i comandi utilizzati sono: CHKDSK /R - FIXBOOT - FIXMBR
ma non ha risolto nulla..
ho fatto anche il ripristino di windows sempre da cd, ma nulla!

ho staccato l'hd, l'ho montato soto un'altro pc, e ho provato lo scandisk ma ancora nulla!

SOLUZIONI??

danystreet
16-03-10, 13: 31
hai verificato che l'so di quell'hardisk non sia infetto?
in provvisoria nada?

usa un so live fai una scansione magari ti va bene!:bai

leys89
16-03-10, 17: 01
purtroppo non posso accedere in provvisoria.. dat che nn apre proprio l'so, cioè n pratica non appare nemmeno il logo di windows! ho provato a fare una scansione con "kav-secure 2008" ma nienete...

danystreet
16-03-10, 17: 16
be ma in provvisoria ci accedi prima del logo windows magari ti ho frainteso io
quando vedi il trattino bianco lampeggiate in alto a sinistra appena la schermata del bios sparisce e diventa nera da li hai modo di accedere alle modalita provvisorie di windows tenendo premuto f8

per caso hai bartpe?

con lui (windows live)
hai modo di eseguire applicazioni tipo combofix che è un toccasana per sistemi infetti


ma tutto ciò come ti è accaduto, da un momento all'altro? hai riavviato dopo aver installato qualcosa?

io disco fisso è vecchio?:bai

leys89
17-03-10, 09: 37
provo ad accedere in modalità provvisoria, ma mentre mi mostra i driver che sta caricando, si blocca sul driver "PCI.sys"

ho googolato un pò, mi hanno detto di staccare tutte le periferiche PCI, l'ho fatto, ma niente! ma sembra che il problema sia a livello SW

danystreet
17-03-10, 12: 01
quindi arrivi alla pagina di selezione delle modalita provvisorie giusto?
ha gia provato con ultima configurazione sicuramente fiunzionante

ma non hai detto come tutto cio sia accaduto
hai installato qualcosa prima che accadesse? magari propio driver di qualche periferica pci?:bai

auri54
17-03-10, 13: 32
provo ad accedere in modalità provvisoria, ma mentre mi mostra i driver che sta caricando, si blocca sul driver "PCI.sys"

Forse non ci combinerà niente, ma un problema di ram, no ? Se ne hai due, proverei con una sola, alternativamente, e vedi se persiste...Se fosse un problema SW, come credi, bastava un bel file di Acronis, tutto si risolveva in 20 minuti...
Aureliano :bai

danystreet
17-03-10, 14: 23
auri tu ci metti solo 20 minuti con acornis? beato te:bgg2 io con 4 gb di ram per scrivere il bakup del mio sistema 180gb ci metto 2ore e un quarto!!!:bai

leys89
17-03-10, 20: 47
ho provato a staccare le ram, a scambiarle di posizione ma nulla... adesso in provvisoria con prompot dei comandi mi si blocca sul driver ISAPNP.SYS

se nn sbaglio, mio fratello stava scaricando la nuova versione di messenger...! purtoppo questo non è il mio pc personale, e quindi non conosco tutte la faccende di tale makkina!

auri54
17-03-10, 21: 02
ho provato a staccare le ram, a scambiarle di posizione ma nulla... adesso in provvisoria con prompot dei comandi mi si blocca sul driver ISAPNP.SYS

Ma hai provato con una ram sola ? Prima con una e poi con l'altra ? Perchè quando si blocca in quel modo, cambiando posizione dei driver, sono sempre
più convinto che potrebbe dipendere da loro...
Aureliano :bai

---Post unito in modo automatico ---


auri tu ci metti solo 20 minuti con acornis? beato te:bgg2 io con 4 gb di ram per scrivere il bakup del mio sistema 180gb ci metto 2ore e un quarto!!!:bai

Diamine, ma il file immagine lo faccio solo della partizione "C" che con sistema operativo e programmi arriva sui 20 GB; le altre 3 partizioni non ho bisogno di Acronis, ho le eventuali copie su hard disk esterno, è il sistema operativo che mi si incasina in media ogni 15-20 gg. circa...:bgg2
Aureliano :bai

danystreet
17-03-10, 22: 08
e il problema diamine è che il mio pc solo s.o con programmi è 180gb :bgg2:bgg2:bgg2
per i dati altro disco da un tb se addio bakup ci mettevo un giorno:bgg2

leys...ma senza staccare i banchi... con un sistema live ti gira sto pc o no?
giusto per capire se son loro o è il s.o instllato:bai

leys89
18-03-10, 12: 14
si si... con sistema live funziona! per questo dico, sembra un problema SW

auri54
18-03-10, 15: 19
leys...ma senza staccare i banchi... con un sistema live ti gira sto pc o no?
giusto per capire se son loro o è il s.o instllato:bai


si si... con sistema live funziona! per questo dico, sembra un problema SW


Si e no :m: Il PC prima di partire fa il controllo ram, e qui potrebbe trovare l'inghippo...Comunque se togli l'hard disk e salvi i dati come esterno su un altro PC potresti formattare; ma se le ram hanno problemi, non finisci l'installazione perchè per eseguirla il sistema operativo si deve appunto appoggiare su di loro...
Aureliano :bai

danystreet
18-03-10, 16: 42
usi bartpe come sistema operativo live ?


comunque mi sa che auri là azzeccata in giro ho letto sta discussione... http://www.hwupgrade.it/forum/showthread.php?t=1417690

il tipo dice che i banchi di memoria erano ossidati una volta ripuliti l'errore è sparito :bai

Armandillo
18-03-10, 17: 06
:bai
mi intrometto nella discussione poiche' mi accingo ad installare Seven e per fare questo mi e' stato consigliato l'uso di GParted.

Leggendo in rete ho capito che questo software (immagine iso autoavviabile) e' in grado di risolvere i problemi di partizione e qui (http://www.ilsoftware.it/stampa_articolo.asp?id=5531) vi sono particolari che riguardano l'uso di una suite adatta a risolvere problemi simili ai tuoi.

Prima di formattare forse potresti tentare con GParted per correggere eventuali problemi di file system che credo siano all'origine del mancato avvio.

:bai

danystreet
18-03-10, 17: 13
ciao arma è appunto però io gli avevo chiesto se il disco era vecchio e lui non ha risposto ...tu dici che sia un errore del filesystem del disco ?
ma in fine dei conti gpartd fa le stesse cose del chkdsk della console di ripristino mi pare che lui le abbia gia tentate!!!

Armandillo
18-03-10, 17: 26
ma in fine dei conti gpartd fa le stesse cose del chkdsk della console di ripristino mi pare che lui le abbia gia tentate!!!

Credo che GParted faccia molto di piu'.
Secondo quanto ho letto, ma e' da confermare, quel programma potrebbe ridimensionare la partizione dov'e' il SO che non s'avvia.
Potrebbe quindi creare altra partizione primaria dove installare un altro SO.
Di conseguenza forse si potrebbe esaminare il SO con problemi o in caso negativo cercare di recuperare dati importanti.

E' un'idea...forse peregrina...ma io tenterei ogni strada prima di formattare !

:bai

leys89
18-03-10, 18: 06
ho provato a staccare l'hd, e montarlo su un'altra macchina, ma mi fa lo stesso errore... skermo nero!

le ram, le ho provate pure una per volta, ma non và!

l'hd e vecchiotto!

Andy86
18-03-10, 18: 54
Per non lasciare nulla di intentato,
hai provato con il ripristino dell'installazione di windows? scegli di installare windows e quando sei a ▼questa▼ schermata premi 'r'.
http://www.netforyou.it/wp-content/uploads/2009/03/windows-xp-professional-corp-2009-03-17-14-14-18.png

Verranno sostituiti tutti i file di sistema, compresi i ISAPNP.SYS e PCI.SYS che ti danno problemi, ma non verranno toccate le impostazioni utente e i file creati (o messi sul disco) dall'utente.

:bai

leys89
18-03-10, 19: 07
gia provato col ripristino ma niente! non si avvia...

Andy86
18-03-10, 19: 19
Montando il disco su un'altra macchina hai provato a montarlo in coppia con uno funzionante e vedere se il disco si apre in esplora risorse con l'altro sistema attivato? (prova che puoi fare anche con un sistema live).

danystreet
18-03-10, 19: 21
ummmm.....le ram le hai pulite come dice il tipo ? ma attaccando il disco ad un'altro pc non puoi pretendere che il sistema si avvii!! ha installati i drive per l'altra scheda madre...
a meno che l'altro pc non sia identico a quello da dove hai tolto l'hardisk

dovresti provare invece a metterlo sotto un'altro pc con gia installato l's.o su un'altro disco avviarlo da questultimo, e fare il controllo approfondito del filesystem con l'appsita funzione di windows
sempre che il problema sia quello
perche se è propio il disco fisso ad avere problemi fisici allora un format fatto come si deve è l'unica soluzione!


gparted sarebbe un valido programma per tentare il ripristino del filesystem con la sua funzione per il controllo del medesiomo da "iso avviabile cd"
ci mette un decimo del tempo che impiega la console di emergenza di windows....certo che se ce qualche errore grave quello non te lo risolve però!!!!


piuttosto o provi come to detto piu su
o con il sistema operativo live "spero tu abbia bartpe" perche con ubunto nun so se po!
avvii programmi appositi tipo parition magic ,paragon pariton magic, hardisk regenarator e cosi via...:bai

---Post unito in modo automatico ---

ops ho inviato la risposta medesima di andy prima che la riuscissi a leggere scusate...

Armandillo
18-03-10, 19: 31
Come detto in precedenza, dovro' adoperare GParted con altro harddisk sata proprio perche' il precedente vecchio harddisk ide mi aveva dato quella famosa schermata nera ma avevo risolto col sistema proposto da Andy.
Una volta risolto, pero', sono risultati danneggiati vari settori.

Credo che una formattazione risolva solo in parte poiche' la vetusta' del disco, forse, potrebbe in seguito riproporre problemi analoghi.

Se i dati in esso contenuti sono importanti credo che la priorita' sia recuperarli e per farlo non vedo altre strade se non quelle usando un programma di partizioni (non per forza GParted)

:bai

Andy86
18-03-10, 19: 31
ha installati i drive per l'altra scheda madre...

Non centra, tali driver servono solo al riconoscimento delle varie schede integrate e degli slot pci.
Il boot da disco, se ne era in grado, lo faceva comunque.
È la scheda madre che riconosce il disco avviabile, non il contrario.


per farlo non vedo altre strade se non quelle usando un programma di partizioni

Veramente sarebbe meglio farlo da un sistema live o da un altro disco, se il disco in questione è danneggiato potrebbe non essere possibile modificarlo o aggiungere una certa quantità di dati, e comunque si rischierebbe di "ucciderlo" del tutto.

:bai

danystreet
18-03-10, 20: 09
no andy se monti un'hardisk con s.o installato su macchina differente senza aver eseguito il sysprep
quel s.o non paritrà !!!

deve motare il disco come dici tu su una macchina che abbia gia il s.o installato ed eseguire il controllo del disco con windows o con programmi appositi ,se gparted non lo avesse o non fosse in grado di risolvere la problematica...

o al limte salvare i dati per poi fromattare a baso livello e ovviare alle problematiche del disco:bai

auri54
18-03-10, 20: 55
...Comunque se togli l'hard disk e salvi i dati come esterno su un altro PC potresti formattare...

Come già detto da altri, è chiaro che non può funzionare se lo monti, come sistema operativo primario, in un altro computer, non c'è possibilità.
Io intendevo metterlo come un hard disk esterno o in un box usb, oppure ancora meglio con un kit universale per leggere tutti i tipi di hard disk, io per esempio ho questo:
http://www.lindy.it/adattatore-da-usb-a-sata-ide/42868.html
Poi proverei a formattare, e vedi se riesci con l'installazione...se dipende dalle ram, non ci riesci...
Aureliano :bai

Andy86
18-03-10, 21: 14
Mai letta sta cosa. Il sysprep, che sapevo io, cambia solo il codice univoco (sid) quando duplichi (pirati) un sistema operativo, poiché, se ti ritrovi due sistemi operativi con lo stesso codice (fiscale), questi hanno problemi a funzionare in rete.
Se poi windows dovesse andare in schermata blu perché non in grado di riconoscere periferiche che vengono installate in fase di installazione di windows (ho letto che a volte può succedere), allora basta fare il ripristino, come detto due risposte fa, e verranno installati tutti i driver necessari (verrà anche ricreato il sid, ma è un'altra storia...).


se dipende dalle ram, non ci riesci

Anche se è rotto il disco...

:bai

auri54
18-03-10, 21: 27
Anche se è rotto il disco...
:bai

Quello forse dovresti riuscire a vederlo prima, al momento che lo colleghi da porta USB e probabilmente non inizia a girare, e non ti fa ricuperare niente...
Aureliano :bai

Andy86
18-03-10, 21: 42
Ovvio, ma se dovesse essere solo danneggiato qualche cluster (a proposito, una volta collegato in qualche modo potresti testarlo con hdtune (http://www.hdtune.com/files/hdtune_255.exe) o simili) potresti riuscire a recuperare qualcosa e poi riscontrare blocchi in fase di re-installazione.

:bai

danystreet
18-03-10, 21: 46
si scusami andy non ho specificato per bene la cose
allora il sysprep deve essere eseguito dopo aver estratto nella sua cartella il file Deploy.cab....
a quel punto non fa altro che preparare il disco rigido per lo spostamento sotto un'altra macchina
per una volta avviata essa con il cd di win inserito configuralo all'utilizzo sulla medesima....
senza reinstallare tutto mantendo tutti i programmi e i dati gia installati

spostadolo semplicemente non avrebbe modo di partire il sistema se la modo è diffferente da quella usata in fase di installazione :bai

Andy86
18-03-10, 22: 37
Sysprep è uno strumento progettato per gli amministratori di sistema, gli OEM (Original Equipment Manufacturer) e gli altri utenti che devono distribuire automaticamente il sistema operativo Windows XP su più computer. Dopo che si è eseguita la procedura di installazione iniziale su un computer, è possibile eseguire lo strumento Sysprep per predisporre il computer di riferimento alla duplicazione.
Fonte originale (http://support.microsoft.com/kb/302577/it).


Cioè con sysprep porti il sistema su più macchine diverse senza installarlo tutte le volte.
Quello che conosci tu è il sistema che usa chi non ha windows originale, quindi non credo che si possa suggerire qui.

Per sistemi originali basta un ripristino dell'installazione -> click (http://www.lidweb.it/ind_topic.asp?topic_id=640).
In fondo è solo uno dei tanti problemucci di driver che come li sa inventare windows non li sa inventare nessuno.

:bai

danystreet
18-03-10, 22: 48
io win ce l'ho originale e quella procedura la uso senza violare alcuna norma
ti dirò penso che sia anche piu comoda da attuare...in fondo fanno le stesse cose queste due procedure solo in maniere piu sbrigativa:bgg2

leys89
19-03-10, 09: 06
ragazzi ERGO!

ho provato a formattare l'hd, ma mi si blocca al 22% chiedendomi di inserire il cd di windows con l'etichetta "service pack 2" O_O

ma questo che utilizzo è il cd windows sp2

Armandillo
19-03-10, 09: 14
Se utilizzi il cd di Xp ti consiglio alla prima schermata di eliminare la partizione (se e' la sola, altrimenti elimina prima le altre) col tasto "L"
Poi la ricrei, tasto "C"
Quindi s'avviera' la formattazione NTSF e poi l'installazione del SO

:bai

danystreet
19-03-10, 11: 01
prima di reinstallare formatta il disco come si deve non con il cd di windows.... se puoi usa il software della casa produttrice dell'hardisk e falla a basso livello :bai

o in alternativa attacca il disco a un pc con il sistema operativo gia installato magari in slave...e utilizza la funzione formatta apposita da dentro windows in esplora risorse perchè è piu efficace di quella del cd di isatllazione



comuque io certe beghe le ho avute con degli aggirnamenti di windows sulla versione tarocca...
se non sbaglio tu hai detto che stava installlando dei componeti di msn il tipo giusto...
non vorrei che se beccato uno di quegl'aggirnamenti malevoli...
se cosi fosse il cd di windows non è in grado di formattare il disco in alcuni casi
quindi ti ripeto se riesci formattalo in altri modi...
nemmeno gparted ti sarebbe di aiuto in questi casi nemmeno cancellando la tabella delle partizioni !!!

good luck:bai

umberto
14-09-10, 10: 37
Ciao,
si tratta di un virus.
Qui la soluzione data in un forum di Microsoft: My Windows XP not booting up including safe mode (http://social.answers.microsoft.com/Forums/en-US/xprepair/thread/1bb2ac51-8b5c-4058-b835-408524ace776)
Se riuscite a postare in italiano passo per passo quello che dobbiamo fare Vi ringrazio a nome di tutti gli utilizzatori.
Ciao
Umberto

LadyHawke
14-09-10, 14: 13
Ciao umberto e benvenuto :hap,

Questa discussione risale a marzo, quindi presumo che leys89 anche se non l'ha fatto sapere, abbia in qualche modo risolto, ma per dovere di cronaca lasciamo chiara anche questa possibile soluzione che magari potrà essere comunque utile

Se si trattasse di quel virus le istruzioni sono di accedere al sistema tramite un CD live (Linux, BartPE oppure queste (http://www.collectiontricks.it/forum/guide-sistemi-operativi-e-software/Ct562-windows-non-si-avvia-piu-salviamo-il-salvabile.html) che abbiamo qui) e ricercare nella cartella \windows\system32\drivers un file _.sys di 0 Kb dal nome "strano" (e ovviamente cancellarlo o meglio rinominarlo ad esempio in .old)

A quel punto windows dovrebbe già riavviarsi regolarmente; se ciò non avvenisse si dovrebbe andare a verificare la presenza di qualche file "strano" in avvio automatico alla chiave HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Run del Registro di Sistema: occhio magari ad esportare prima la chiave che si andrà a modificare per sicurezza.

Ovviamente una volta ripartito windows ci sarebbero da fare altri controlli perchè il virus viene bloccato ma non è detto affatto che sia tutto ripulito: questo naturalmente se di quel virus si tratta.



:bai